externes USB Farbdisplay an allen Boxen mit USB für 2,90 bzw. 6,90 Euro excl. Versand


  • Lass die Doppelpostings bitte ...

  • Man könnte auch versuchen zu helfen, aber es ist einfacher den Oberlehrer zu spielen nicht wahr? ;-)

  • Quote

    Original von benn1
    Man könnte auch versuchen zu helfen, aber es ist einfacher den Oberlehrer zu spielen nicht wahr? ;-)


    Man könnte auch einfach akzeptieren, dass ein Doppelpost kacke ist. Und wie man das Display an der Dream aktiviert, ist in beiden Threads bis zum Erbrechen aufgeführt. Soll man dir das hier nochmal abtippen?

  • Du darfst auch gerne mal annehmen, dass man den Thread schon weitgehend gelesen hat und den üblichen Weg das Display zu aktivieren auch schon versucht hat. Nicht alle hier sind unwissend und so unterbelichtet wie du sie immer verkaufst :rolleyes:


    Und im Zweifel antworte ich, falls ich die Lösung kenne lieber nochmal, als pampig zu werden. Eine Community lebt doch von User-hilft-User oder nicht?


    PS: Full ack was das Doppelposting angeht. Kam bisher nicht vor - wird auch nicht mehr vorkommen.

  • Hi bennl,


    die Fehlermeldung


    >>ich hab das Display mit dem SPI Programmer unter Windows geflasht und das
    >>Plugin läuft auch auf meiner DM800 SE. Allerdings passiert im Display gar nichts...


    ist ungefähr so genau, wie wenn du dein Auto bei der Werkstatt vorbei bringst und sagt: Irgendwas stimmt nicht. Bitte reparieren.


    Also, was genau geht schief? Haste mal den Daemon manuell gestartet, um die Debug-Ausgaben zu prüfen?

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

    Edited once, last by mamba0815 ().

  • Hi mamba,


    habe es mittlerweile sogar mal hinbekommen. Und zwar genau über das stoppen und starten des Plugins ueber telnet.
    Ich befürchte aber fast, dass das Display einen Wackler hat, da es bei kleinsten Bewegungen ausgeht... oder der Akku hat ne Macke.
    Anschließend geht startet es wieder normal und ich muss entweder 3s M drücken oder 10min warten.


    Beim Stoppen/Starten über Telnet passiert dann folgendes:


    root@dm800se:~# /etc/init.d/lcd4linux stop
    Stopping lcd4linux
    Error: No matching USB device found!
    dpf: cannot open dpf device usb0
    Error initializing driver DPF: Exit!
    root@dm800se:~#

  • Ich habe exakt das selbe Problem.
    Schon mehr als drei mal unter Windows geflasht.
    Da kam auch keine Fehlermeldung.
    Das Plugin ist ebenfalls installiert und auf "ein" gestellt, aber auf dem lcd wird nichts angezeigt ausser die Bilder (mit Delphin ...) ---> Ist das normal, dass die nach dem Flashen noch drauf sind oder ist das Flashen fehlgeschlagen?


    In Telnet die gleiche Meldung wie bei benn1 ...

  • Quote

    Original von redskyfox
    Ich habe exakt das selbe Problem.
    Schon mehr als drei mal unter Windows geflasht.
    Da kam auch keine Fehlermeldung.
    Das Plugin ist ebenfalls installiert und auf "ein" gestellt, aber auf dem lcd wird nichts angezeigt ausser die Bilder (mit Delphin ...) ---> Ist das normal, dass die nach dem Flashen noch drauf sind oder ist das Flashen fehlgeschlagen?


    In Telnet die gleiche Meldung wie bei benn1 ...


    Bei mir klappt es, wenn ich manuell per telnet starte mit:
    root@dm800se:~# /etc/init.d/lcd4linux stop
    und anschließend
    root@dm800se:~# /etc/init.d/lcd4linux start


    Das Display vorher natürlich an die Box anschließen und mit etwa 2 Sekunden auf M drücken -> Modus wechseln -> blaues Display


    Grüße benn1

  • root@dm8000:~/dpf/fw# python hackit.py /dev/sr0
    Opening generic SCSI device '/dev/sr0'
    Reading flash...
    Segmentation fault


    bei mir ists dasselbe mit aktuellem ICVS, mit welchem Image hast Du es geflasht Mamba?

  • Quote

    Originally posted by benn1
    Hi mamba,


    habe es mittlerweile sogar mal hinbekommen. Und zwar genau über das stoppen und starten des Plugins ueber telnet.
    Ich befürchte aber fast, dass das Display einen Wackler hat, da es bei kleinsten Bewegungen ausgeht... oder der Akku hat ne Macke.
    Anschließend geht startet es wieder normal und ich muss entweder 3s M drücken oder 10min warten.


    Ein User hat mir genau das gleiche berichtet und meinte, dass er das gefixt hat, indem er seinen defekten Akku entfernt hat.

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

    Edited once, last by mamba0815 ().

  • was kann man tun wenn sich die Helligkeit nicht regeln lässt?
    Anzeige geht alles wunderbar, aber Helligkeit ändert sich nicht, egal was ich einstelle :(

    Ich antworte mit einem entschiedenen Vielleicht!!

  • Quote

    Original von redskyfox
    Ich habe exakt das selbe Problem.
    Schon mehr als drei mal unter Windows geflasht.
    Da kam auch keine Fehlermeldung.
    Das Plugin ist ebenfalls installiert und auf "ein" gestellt, aber auf dem lcd wird nichts angezeigt ausser die Bilder (mit Delphin ...) ---> Ist das normal, dass die nach dem Flashen noch drauf sind oder ist das Flashen fehlgeschlagen?


    In Telnet die gleiche Meldung wie bei benn1 ...


    du musst das LCD in den BSOH Modus bringen... Halte mal die Menü Taste länger gedrückt... Wenn es nicht am USB hängt sollte ein blauer Bildschirm kommen. Dann kannst dus dran stecken und es wird von der Dream neu erkannt. Danach das Plugin neu starten und et voila... sie haben Bild ;) vorher passiert da gar nichts

    Ich antworte mit einem entschiedenen Vielleicht!!

  • Quote

    Originally posted by magura
    root@dm8000:~/dpf/fw# python hackit.py /dev/sr0
    Opening generic SCSI device '/dev/sr0'
    Reading flash...
    Segmentation fault


    bei mir ists dasselbe mit aktuellem ICVS, mit welchem Image hast Du es geflasht Mamba?


    Ich habe das mit dem mipsel-gcc aus dem aktuellsten OE (build für dm8000) gebaut. Geflasht habe ich auf einer DUO.


    Im tar.gz File ist alles drin, dass man sich das selbst wieder bauen kann. Man muss nur den python-include Pfad anpassen und schon geht das "make all" auf dem eigenen OE.


    Mamba

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

  • Moin,
    ich habe es min Win-XP versucht, laut Tool ist alles ok.
    Allerdings friert das Display nach 3 Sekunden ein, ein Bluescreen kommt nicht!
    Unter der Dream mit einem ca. 1/2 Jahr altem Image bekomme ich auch nur:


    root@dm8000:~/dpf/fw# python hackit.py /dev/sr0
    Opening generic SCSI device '/dev/sr0'
    Reading flash...
    Segmentation fault

    Gruß
    kenwood



    1 x DM 8000
    1 x DM 7000 S
    1 x DM 500 HD
    1 x DM 500 S


  • kannst du dazu nochmal eine step by step how to schreiben BITTE :)

  • nachdem ich schon ewigkeiten probleme mit den flashen des bilderrahmens habe, hab ichs nun mal von der dream aus probiert via telnet.


    bekomme diese fehlermeldung?(bild im anhang) kann es sein das mein rahmen einfach nur für den mülleimer ist?


    edit: habe nun das /sg0 durch /sr0 ersetzt und erhalte wie einige hier den fehler
    Segmentation fault

    Files

    • error.jpg

      (95.43 kB, downloaded 1,246 times, last: )

    Edited once, last by Micharrr ().

  • ´so habe mir jetzt ubuntu runtergeladen und gestartet was muss ich jetzt öffnen oder starten ?
    ubuntu ist komplett neuland
    2.) Ein Linux (Ubuntu 11.10 in meinem Fall) und hier kommen mehrere Schritte


    oder geht das auch über windows habe das diaplay jetzt geflasht

  • So, ich hab heute meine 2 Displays bekommen und wollte die an der Box flashen, was aber nicht funktioniert hat (Segmentation fault..)


    Dann unter Windows gemacht.
    1. Display funktionierte auf anhieb einwandfrei.
    2. Display hat zwar fertig geflashed, hängt sich aber bei 3 Sekunden drücken komplett auf.


    Beide Displays sind komplett identisch vom Aussehen und auch die Verpackung ist die selbe.
    Bin bei beiden Exakt gleich vorgegangen ?(

  • Ein frohes neues Jahr an Alle.
    Für diejenigen so wie ich, die mit dem flashen über windows u. Dreambox nicht weiterkommen hier ein Tipp:


    1. Solltet Ihr über windows geflasht haben, flasht wieder die Originalfirm über windows zurück.
    Erfolgreich seid Ihr gewesen, wenn Ihr das Display über die Menütaste wieder problemlos ausschalten könnt.
    2. Ladet Euch Ubuntu 10.4 als iso runter und brennt die iso auf CD.
    3. Geht auf folgenden link: http://www.ipcop-forum.de/foru….php?f=57&t=28865&start=0
    4. Ladet Euch zu Ubuntu 10.4. die richtige Hack-Datei von der in 3. genannten Seite und ladet diese auf einen USB-Stick
    5. Bootet Eure Ubuntu-CD (nicht installieren, sondern von CD starten) und zieht die in 4. genannte Datei vom USB-stick auf den Desktop.
    6. Geht ins Terminal und wechselt dann in cd /Desktop.
    7. Alles weitere ist auf dem link unter 3. perfekt beschrieben


    Hiermit war ich nach allen anderen Versuchen auf Anhieb erfolgreich und kam sofort in den BSOH.
    Das Display war eine von den Zicken, die mit windoofs nicht wollen. Das Kabel war in Ordnung.
    Ich hoffe das hilft allen, die noch immer am Flashen sind weiter.
    Guten Start ins neue Jahr.

    Edited once, last by F2Air ().