(e2 plugin) MediaTomb (UPnP Server) [discontinued]

  • na dann versuch doch mal ob du die drei von deren feed installieren kannst
    wie schon im ersten posting geschrieben hab ich das nur mit einem orig. dmm image getestet bzw. in benützung

    dau bleibt dau, daran kann der beste dev nichts ändern<br><br>

  • reicht das nicht wenn ich nochmal bei dreamboxupdate schau ?
    aber die mediatomb werde ich da wohl nicht finden oder?


    das wären dann die:


    libiconv
    libexpat1


    oder?

    2x Dm 8000, Ds409, Qnap TS-459 Pro II, SPF-107H,Onkyo TX NR-509,Teufel Consono 35,PS3,Fritzbox 7270,7390,Wii,XboX1,Down 50 Mbits, Up 10 Mbits

  • die libiconv gibt es dort nicht, die libexpat1 gibt es nun aber am dmm feed hab ich gerade gesehen
    aber du solltest die auch vom feed deines images installieren (das sagt dir doch die fehlermeldung)

    dau bleibt dau, daran kann der beste dev nichts ändern<br><br>

  • hmmm und wo bekomme ich die libiconv her?


    ich schau heute abend nochmal.. bin gerade nicht daheim.. und versuch die dateien vom merlinfeed zu bekommen..

    2x Dm 8000, Ds409, Qnap TS-459 Pro II, SPF-107H,Onkyo TX NR-509,Teufel Consono 35,PS3,Fritzbox 7270,7390,Wii,XboX1,Down 50 Mbits, Up 10 Mbits

  • na einfach ipkg install libiconv unter root im telnet, oder du suchst es dir im packetmanager

    dau bleibt dau, daran kann der beste dev nichts ändern<br><br>

  • Das ist es Danke!

    Viele Grüße :danke:


    1X DM 900UHD
    1X DM 900UHD
    1X DM one OE2.6
    Gemini 4, Zombi
    WLan, Lan, Fritz!Box 6890LTE
    TV 4x Samsung

  • hallo jackdaniel


    soweit sogut.. läuft auch soweit..
    wif geht auch.. nur stört mich noch der eine eintrag mit warning..


    Copyright 2005-2010 Gena Batsyan, Sergey Bostandzhyan, Leonhard Wimmer.
    MediaTomb is free software, covered by the GNU General Public License version 2


    2011-11-10 14:19:29 INFO: Loading configuration from: /home/root/.mediatomb/config.xml
    2011-11-10 14:19:29 INFO: Checking configuration...
    2011-11-10 14:19:29 INFO: Setting filesystem import charset to ANSI_X3.4-1968
    2011-11-10 14:19:29 INFO: Setting metadata import charset to ANSI_X3.4-1968
    2011-11-10 14:19:29 INFO: Setting playlist charset to ANSI_X3.4-1968
    2011-11-10 14:19:29 INFO: Configuration check succeeded.
    2011-11-10 14:19:29 INFO: Initialized port: 49155
    2011-11-10 14:19:29 INFO: Server bound to: 192.168.1.145
    /etc/magic, 0: Warning: using regular magic file `/usr/share/file/magic'
    2011-11-10 14:19:30 WARNING: magic_load: could not find any magic files!
    2011-11-10 14:19:30 INFO: MediaTomb Web UI can be reached by following this link:
    2011-11-10 14:19:30 INFO: http://192.168.1.145:49155/

    2x Dm 8000, Ds409, Qnap TS-459 Pro II, SPF-107H,Onkyo TX NR-509,Teufel Consono 35,PS3,Fritzbox 7270,7390,Wii,XboX1,Down 50 Mbits, Up 10 Mbits

    Edited once, last by reiter0303 ().

  • schei.. auf die warnings, gibt es bei e2 auch bei jedem start wenn keine skin_user.xml vorhanden ist ;)

    dau bleibt dau, daran kann der beste dev nichts ändern<br><br>

  • ok danke..
    werde mal bischen probieren... :hurra:

    2x Dm 8000, Ds409, Qnap TS-459 Pro II, SPF-107H,Onkyo TX NR-509,Teufel Consono 35,PS3,Fritzbox 7270,7390,Wii,XboX1,Down 50 Mbits, Up 10 Mbits

  • Ich hab testweise mal eine Festplatte mit 300 GB Daten (Fotos, Videos) via USB an die DM800se gehängt.


    MediaTomb indexiert nun bereits seit knapp 10 Stunden (Basic). Der MediaPlayer der Fritzbox 7390 braucht dafür keine 3 Minuten. Dabei halte ich die CPU der DM für erheblich leistungsfähiger...


    Gäbe es eine Möglichkeit der Optimierung des Datenbankcodes oder wäre der Aufwand zu hoch dafür?

  • Hallo,


    bei mir läuft der mediatomb mitlerweile auch. Aber irgendetwas scheint immer noch nicht zu stimmen. In der Weboberfläche habe ich Freigaben hinzugefügt und dort werden auch alle Files angezeigt.
    Wenn ich dann auf der PS3 mit den UPnP Server anschaue werden ebenfalls alle Verzeichnisse angezeigt, aber keine Dateien aus den Verzeichnissen.
    kein .ts, kein .vob, kein .mpeg. Nur jpegs unterhalb fotos sehe ich.


    Gehe ich über den webbrowser der ps3 kann ich mir sogar filme anschauen. Aber das muesste doch eigentlich auch ueber den UPnP Server gehen ?
    Muss man noch etwas zusätzlich konfigurieren ?


    ich habe auch versucht im mediatomb eine externe url auf eine Streaming-url der Dreambox zu erstellen um live tv zu schauen. Der neu erstellte eintrag wird ebenfalls nicht im UPNP Server angezeigt, wohl aber das übergeordnete verzeichnis.


    Die Idee dahinter war, den Sky-3D Channel über die Dreambox an meine PS3 zu streamen an der ein 3d Projektor hängt.

  • Hallo,
    ich versuch es nochmal.


    Es sieht bei mir soweit alles prima aus: Sie bild 1 vor streaming


    Wenn ich aber von meinem Samy via Mediatomb auf die Videos der Dream zugreife, bekomme ich immer noch vom Samy die Rückmeldung "nicht unterstütztes Dateiformat" und in der Log von Mediatomb: ERROR;: ActionRequest:: ..... siehe Bild 2 nach streaming.


    Kann mir jemand bitte weiterhelfen?

  • Hallo JackDaniel,
    ich habe vermutlich bei der Installation das gleiche Problem wie bereits vorgetragen (gleiche Fehlermeldungen). Leider habe ich von Linux wenig Ahnung und bräuchte deshalb Hilfe. Habe auch schon im Forum und im Wiki gesucht.


    Kann es sein, dass ich bei der Eingabe omkg update im Telnet einen Fehler gemacht habe. Meine Eingabe war war "omkg update [Enter] ipkg install *.ipk [Enter] . Die Eingaben wurdem mit telnet im tmp-Verzechnis vorgenommen (ipk im tmp Verzeichnis).


    Im Paketmanager habe ich die libiconv nicht gefunden. Wo müßte sie denn stehen? Kann ich alternativ den Befehl ipkg install libiconv mit telenet einfach eingeben oder muss ich vorher noch etwas eingeben. Kann der Befehl auch mit telent ausgeführt werden, wenn ich im tmp Verzeichnis stehe oder wo muss ich den Befel ausführen?
    Vielen Dank für die Hilfe!!!!!


    Erledigt! Ich konnte jetzt das Problem zumindest bei mir selbst lösen. Ich habe die libiconf vom Paketmanager geladen. Nachdem ich dann die ipk`s von JackDaniel ohne die libiconf installiert habe hat es funktioniert. War mir halt so nicht bekannt. Jetzt konnte ich zumindest das Plugin installieren. Hoffentlich klappt der Rest auch noch. Schlönen Abend an alle.

  • Jetzt bräuchte ich nochmals Hilfe. Nach langem Kampf konnte ich ja MediaTomb installieren. Ich möchte hiermit zu meinem SamsungTV streamen.


    Zwischenzeitlich habe ich vom Samsung TV eine Verbindung zu MediaTomb und kann alle Aufnahme sehen. Die Config von MediaTomb habe ich auch unter etc.enigam2.mediatomb gefunden. Nur konnte ich bisher keine Änderung vornehmen, damit der Samsung das Dateiformat Ts kennt und diese Filme abspielt. Hat noch jemand einen Typ für mich wie die config zu ändern ist? Muss evtl. noch etwas geändert werden?


    Danke für die Hilfe!!!!!!

  • Also eine ".ts" von der DM800se frisst mein Samsung mit der Einstellung "video/mpeg" jedenfalls nicht. Ebenso keine Chance bei Wiedergabe von einem USB Stick.


    Insofern dürfte wohl das Format der TS-Dateien dem Samsung nicht passen. Allerdings sehe ich auch keinen Bedarf bei TS-Dateien, denn dafür hab ich ja ne Dreambox rumstehen...

  • Ja, wenn die Dreambox am TV hängt braucht man dies nicht. Wenn man aber von anderen TV ohne direkte Verbindung zur Dreambox streamen will, dann wäre es schon super. Vielleicht muss man eine andere Umwandlung als video/mpeg in MediaTomb einbinden. Hat jemand Erfahrungen hiermit. Danke.

  • dazu gibt es kein "patentrezept", was eure endgeräte können und was nicht .....
    aber beschäftigt euch mal mit den mappings in der mediatombconfig.xml in /etc/enigma2

    dau bleibt dau, daran kann der beste dev nichts ändern<br><br>

  • Ja, da bin ich gerade dran. Habe nur lange gebraucht um die Config zu finden. Will mal noch andere mappings einbauen. Muss evtl. sonst noch etwas an der Config geändert werden? Oder hat es jemand schon mit einem Samsung TV geschafft?

  • Ich habe jetzt unzählige Änderung in der config vorgenommen. Leider keine Änderung. Der Samsung will die Filme wegen dem Dateiformat nicht abspielen.


    Mir fehlt hier leider auch das nötige Fachwissen. Aus meiner Sicht werden die TS Dateien aber nicht in ein anderes Format trotz Eingabe in der Config umgewandelt.


    Ich habe auch bei Eingabe von MediaTomb auf folgende Meldung mit dem Fehlerhinweis erhalten (mit den X wurde Ziffern von mir geändert):
    2011-11-19 21:27:58 INFO: MediaTomb configuration was created in: /home/root
    .mediatomb/config.xml
    2011-11-19 21:27:58 INFO: Loading configuration from: /home/root/.mediatomb/
    onfig.xml
    2011-11-19 21:27:58 INFO: UUID generated: d8e8dbce-aa5d-4e7e-867b-63b4XXXXXX
    f
    2011-11-19 21:27:58 INFO: Checking configuration...
    2011-11-19 21:27:58 INFO: Setting filesystem import charset to ANSI_X3.4-196
    2011-11-19 21:27:58 INFO: Setting metadata import charset to ANSI_X3.4-1968
    2011-11-19 21:27:58 INFO: Setting playlist charset to ANSI_X3.4-1968
    2011-11-19 21:27:58 INFO: Configuration check succeeded.
    2011-11-19 21:27:58 WARNING: Sqlite3 database seems to be corrupt or doesn't ex
    st yet.
    2011-11-19 21:27:58 INFO: no sqlite3 backup is available or backup is corrup
    . automatically creating database...
    2011-11-19 21:27:58 INFO: database created successfully.
    2011-11-19 21:27:58 INFO: Initialized port: 49153
    2011-11-19 21:27:58 INFO: Server bound to: 192.168.XXX.XX
    /etc/magic, 0: Warning: using regular magic file `/usr/share/file/magic'
    2011-11-19 21:27:59 WARNING: magic_load: could not find any magic files!
    2011-11-19 21:27:59 INFO: MediaTomb Web UI can be reached by following this
    ink:
    2011-11-19 21:27:59 INFO: http://192.168.XXXXX:49XXX/


    Was kann ich noch probieren? Hat jemand eine Idee? Danke !!!!!