Enigma2 Image for PowerPC Dreamboxes - Howto

  • Re bitbake :


    Both these methods are ok :-


    cd $HOME/tuxbox-bb/build


    source ./env.source


    bitbake -cclean enigma2


    bitbake enigma2


    . env.source && bitbake -Db ../openembedded/packages/dreambox/dreambox-bootlogo.bb -c clean && bitbake -Db ../openembedded/packages/dreambox/dreambox-bootlogo.bb


    The second gives more debug output.


    Cheers.

  • Just a quick update, I've not stopped tinkering, I have some real work to deal with n my head needed to digest what I've done so far.


    I'm much more confident with what's going on n what's required to sort my little issues, I've wriiten up some rough notes which has helped and I will be applying my changes n testing my assumptions a little later.


    Will report back.


    Many Thanks again




    Hej

  • I don't want to get to carried away but :hurra: I think I have a working base image :)


    I obviously need to do some testing but I'm well chuffed.


    I know I keep saying this but Many Many Many Thanks for all files, info n help, I feel my understanding has taken a massive leap forward.


    So what next?


  • First of all - well done ! :hurra:


    When can we try out your image ?


    For the future - if you go through the e2 image threads for 500plus, 600pvr and 7020 - you will see many issues and requests which have not been resolved. Those will keep you busy ! :)


    Cheers, pcd.

    Edited once, last by pcd ().

  • Quote

    Originally posted by pcd


    When can we try out your image ?


    I didn't think anyone would be interested, after all it's really your image :)


    I will gladly make my image available if you want it. I haven't tried it in flash as yet and I want to add in some things that I commented out to get the build, I'm just working on the EPGImport at the mo taking into consideration the problems noted in the v7 thread.


    Did you see my comments re 4:3 letterbox, It was how my TV reacted on first boot of new image that makes me think this.

  • You will have to tell me exactly what I need to do for subtitles I've never used them.


    I don't know if it has anything to do with skin_user.xml in /etc that has some ref's to subtitles, but I don't have that in my image infact I have only installed the default skin so I have a clean base.

  • Quote

    I have only installed the default skin so I have a clean base.


    Great! That's why I asked you this.
    I know pcd used some patches for images to be displayed so I wonder if some of these patches actually changed something in the display of the DVB subtitles. As you can see from the screenshot, subtitles have some strange blue colour and they are jagged whereas enigma1 DVB subtitles are nice and clean. Can you tune in any of the channels that broadcast DVB subtitles, not teletext ones? Which satellites do you receive?

  • You will really hate me for this but, the only dish I'm connected to is not even lined up properly, I've access to a limited number of channels @ 28.2.


    my image as yet is prob not really ready for testing subtitles, I'm not convinced I've all libs installed as yet, I did have to comment out a few bits to get my build, but I will have a go.


    Do I have to install the subtitle plugin? How do I turn subtiles on?




    Edit: from your pic it look's like it's the text shadow settings, what skin n have you tried another?

  • If the subtitles are put in as pixmaps - it may be a pixmap problem. The e2 patches have some pixmap correction (e.g /Plugins/plugin.py).

  • No, you don't have to install anything.
    Just press audio button followed by green button on a channel that broadcasts subtitles, either txt or dvb.
    Choose a subtitle and press OK but I'm afraid no channel on 28.2 uses DVB subtitles, just txt ones.
    Settings in skins are just for txt subtitles and their position on the screen.

  • I know I do tend to make assumption's but, skin_user.xml in /etc is not right from what I've read it should be in /etc/enigma2 and will take priority.


    it contains:

    Code
    <skin>
    <subtitles>
    <sub name="Subtitle_TTX" font="Regular;34" foregroundColor="#ffffff" shadowColor="#40101010" shadowOffset="-3,-3" />
    <sub name="Subtitle_Regular" font="Regular;34" foregroundColor="#ffffff" shadowColor="#40101010" shadowOffset="-3,-3" />
    <sub name="Subtitle_Bold" font="Replacement;34" foregroundColor="#ffffff" shadowColor="#40101010" shadowOffset="-3,-3" />
    <sub name="Subtitle_Italic" font="Regular;34" foregroundColor="#ffffff" shadowColor="#40101010" shadowOffset="-3,-3" />
    </subtitles>
    </skin>


    Is this just a red herring?


    I still haven't seen a subtitle, even using v7 am I being dim?



    Edit: ok I'm sure this is related, I can see subs now configs seem tobe written to etc/enigma2 skin_user.xml


    Edit: forget that, sorry I couldn't be more help

  • This is "Subtitle_TTX". These subtitles are supplied by the teletext page for the channel. BBC 1 etc have them - not all the time.


    But kalehrl's picture shows the dvb subtitles. They are supplied with the tv picture. I don't know if some uk channels have them. You have to ask around.

  • Not wishing to sound selfish given all the help I've had but Subtitles isn't something hi on my list to look at. However I have now used it on my build, was missing the skin.user in the right folder! but seemed to work quite well on sly news, looks pretty crappy but hey function over form at the mo :)


    also the 4:3 issue is still eating at me a little, i'm sure AVSwitch needs a closer look as the diff applied changes 4:3 aspects I think.


    I personally would like the streaming to my pc to work as well as the openpli e1 image does, but i don't know where to start there yet.


    This is a mine field, I only wanted to build myself a light weight image just for me and learn a little more. lol.


    Most things in my image seem to be behaving, I just need another recap of files n folders added n those I comented out that are still missing like nfsserver and i'll try another build.



    Edit: 4:3 I'm now convinced is todo with diff:
    [php]@@ -179,7 +183,7 @@
    6-16:9 forced ("letterbox")
    */
    const char *aspect[] = {"4:3", "4:3", "any", "16:9", "16:10", "16:10", "16:9", "16:9"};
    - const char *policy[] = {"letterbox", "panscan", "bestfit", "panscan", "letterbox", "panscan", "letterbox"};
    + char *policy[] = {"panscan", "letterbox", "bestfit", "panscan", "letterbox", "panscan", "letterbox"};
    [/php]
    would that not be const char

  • Some of these diffs are quite old. I cannot remember the details of this one. You are on your own here ! :)


    Nfsserver files are (probably !) included in this image. But the files are listed (attached) in one of the threads. Many plugin items like these are same as in enigma1.


    I have patched the webif to change the streaming url from the e2 format to the e1 format.

    Edited 2 times, last by pcd ().

  • I'm happy to have a test I've just gotta get my head around diffs again :rolleyes:


    Yes I'm grabbing files from v7 as I need them, will I not be able to get source for the stuff I had to comment out?


    I would really like to get streaming sorted, your Cli image was the best at streaming until openpli, I like the way the openpli stream will follow zap so when using the tuxbox client on xbmc I can use controloid app to change channel via dm. DreamDriod seems to work very well with v7 and my image by the way.

  • Quote

    I have patched the webif to change the streaming url from the e2 format to the e1 format.


    The url format doesn't seem to be quite the same:
    v7 = http://192.168.1.x:31339/0,101,201,281
    E1 = http://192.168.1.x:31339/0,0104,0205,0285,0021
    These are obviously not the same channels, E1 format is from some older notes but I'm sure it was from the Cli image.


    E1 OpenPli = http://192.168.1.x:31344
    This follows channels on Zap


    It's really frustrating because v7 appears to follow zap in vlc it's just not decodeing the stream.


    I keep getting diverted from trying to make a complete image by the smaller elements in the image that I would like to understand and get right.


    I have managed as an exercise to recreate an E2 basic build using the openpli build enviroment so I do feel my building skills n error resolution is getting better :), I just need to get it to boot straight into E2 instead of via telnet, Still don't quite understand the boot process.


    Are any of the files from the Openpli Build of any interest to you?

  • Hi all,


    I have been reading alot, trying to get a dm7020hd image compiled.
    I have now succeeded, Ubuntu 11.04, Makefile-opendreambox-1.6, dm7020hd
    gets the rootfs, and deploy/images and the nfi has been tested in box
    I have also succeeded in compiling my own hello world in /deploy/addons


    But now i want to make changes, and get them into rootfs and nfi.
    I failed in this part, hope its ok i write here..


    Can someone give me a hit in, getting the hello would program into nfi image?
    Can someone give me a hit in, getting a new skin into image, just to understand how it works?


    I know the following files, but dont understand


    dreambox-image.bb, (this file seems very diffrent from OE 1.5)
    enigma2.bb
    enigma2-plugins.bb
    enigma2-skins.bb


    dm7020hd/build/tmp/work/dm7020hd-oe-linux/enigma2-3.2git20120327-r1/package/usr/share/enigma2/skin_default


    dm7020hd/build/tmp/work/dm7020hd-oe-linux/enigma2-3.2git20120327-r1/image/usr/share/enigma2/skin_default


    dm7020hd/build/tmp/work/dm7020hd-oe-linux/enigma2-3.2git20120327-r1/packages-split/enigma2/usr/share/enigma2/skin_default


    dm7020hd/build/tmp/work/dm7020hd-oe-linux/enigma2-3.2git20120327-r1/staging-pkg/staging/mipsel-oe-linux/usr/share/enigma2


    Following paths have been found and i tryed to put a new skin into these paths,
    But new skin do not arrive in rootfs or NFI.


    Thanks in advance

  • Hi StevieRV,


    Regarding putting stuff into the image - these are easy. There is a how-to in the Database.


    But this thread is for the powerpc boxes and OE-1.5 build.


    Cheers, pcd.

    Edited 3 times, last by pcd ().