dreamDroid - Open-Source Enigma2 Client für Android

  • Nachdem ich den Router neu gestartet habe, funktionierts jetzt auch mit "SSL". Manchmal kommt die Verbindung aber einfach nicht zustande. Ohne dass ich irgendetwas an den Einstellungen verändert habe, klappts irgendwann aber doch. Allerdings schleppend langsam. Jetzt habe ich in meiner Verzweiflung auch mal das Smartphone neugestartet ... bis jetzt funzt es einwandfrei ! Die Verbindung steht mit beiden Dreamboxen sofort. Mal sehen, ob es so bleibt.


    Ich habe zwei Dreamboxen. Ich habe mal am Beispiel einer der beiden Dreamboxen Bilder von meinen Einstellungen gemacht. Vielleicht ist ja doch noch ein Fehler drin. Werft doch mal bitte einen Blick drauf.


    [Blocked Image: http://s1.directupload.net/images/120915/temp/upxen4a4.jpg]


    [Blocked Image: http://s7.directupload.net/images/120915/temp/c5p8umhp.jpg]


    [Blocked Image: http://s1.directupload.net/images/120915/temp/fyvqe864.jpg]


    [Blocked Image: http://s1.directupload.net/images/120915/temp/6kwd826v.jpg]



    Vielen Dank nochmal für eure Hilfe.

  • Quote

    Original von zodiac65
    Einen Haken hat die Sache noch. Wenn ich in Dreamdroid "SSL" aktiviere wird wieder keine Verbindung aufgebaut. Woran kann das liegen ?


    Im Router solltest Du als Zielport der Weiterleitung den 443 Port der Dreambox angeben. Auf der Dreambox musst Du HTTPS auf Port 443 aktivieren (evtl. Enigma2 neustarten).

  • Bitte häng die Bilder doch direkt hier im Beitrag an (Buton Dateianhänge). Ich habe wenig Lust, auf irgendwelche Uploadseiten zu gehen und mit Werbefenster zugekleistert zu werden, nur um Dir zu helfen.


    Deine Regeln im Router sind IMO suboptimal, da Du als öffentlicher Port Zahlen nimmst, die für andere Dienste gerne genommen werden. Ändere das mal wie folgt zB ab, aber ändere dann auch den Port in Dreamdroid entsprechend:


    4433 443 DM7020HD-WAN DM7020HD
    4434 443 DM8000HD-WAN DM8000HD


    Die Ports 110 und 443 solltest Du nicht verwenden!

  • Sorry wegen der Bilder. Werde es das nächste Mal übers Forum hochladen. (hatte ich übersehen).


    Jetzt funktioniert es über WLAN nicht mehr. So ein Mist. :kaffee:


    Edit:
    So jetzt nochmal Bilder mit den Einstellungen einer Box. Mit den Einstellungen funktioniert es. Wenn ich aber auf WLAN umstelle, geht nix mehr. Irgendwie habe ich das Gefühl etwas grundsätzlich falsch zu machen.


    PS: das 3. Bild (Webinterface gemacht um 16:42) gehört hier nicht dazu. Bitte nicht beachten.

    Files

    • 001.jpg

      (4.71 MB, downloaded 730 times, last: )
    • 002.jpg

      (4.88 MB, downloaded 732 times, last: )
    • 004.jpg

      (3.25 MB, downloaded 736 times, last: )
    • 005.jpg

      (2.19 MB, downloaded 749 times, last: )
    • 006.jpg

      (3.61 MB, downloaded 720 times, last: )
    • 007.jpg

      (4.68 MB, downloaded 717 times, last: )
    • 008.jpg

      (4.46 MB, downloaded 726 times, last: )

    Edited 4 times, last by zodiac65 ().

  • Ja, ist richtig. Wenn ich am Handy 443 eingebe, gehts nicht.


    Oje, ich glaub ich muss aufhören. Das war zuviel heute. ^^
    Das 2. Bild von links gehört auch nicht hier rein. bitte auch nicht beachten.


    Also, das 2. u. 3. Bild von links nicht beachten. Die gehören hier nicht dazu.

  • Quote

    Original von mfgeg
    Hast du der Box ein Passwort vergeben?


    Ja, habe ich. Ich komme von aussen mit diesen Einstellungen auf die beiden Boxen. Über WLAN allerdings nicht mehr.

  • Deine Portweiterleitungen sind falsch. So sollte es sein. Der interne Port sollte jeweils 443 sein, nur Öffentlicher Port ist 4433 oder 4434:


    4433 443 DM7020HD-WAN DM7020HD
    4434 443 DM8000HD-WAN DM8000HD


    Für die Verbindung via WLAN solltest Du im Dreamdroid ein eigenes Profil anlegen. Mach davon mal nen Screenshot und stell den ein. Im Wlan kannst Du Port 80 nehmen und SSL sowie Login deaktivieren.


    Du hast auch an den Webinterface Settings gedreht! Das solltest Du lassen! Im Webinterface wie auf meinem Screenshot bitte HTTP Port 80 und HTTPS Port 443 einstellen. Bitte nicht an x Stellen einfach wild Dinge einstellen. Ich hab doch 3 Bilder mit allen Settings hochgeladen. Orientiere Dich daran...

  • @ QT
    Gestern habe ich meinen Fehler dann doch noch gefunden !
    Ich hatte ja verweifelt versucht deine Einstellungen so zu übernehmen. Es funktionierte aber nicht, deshalb meine "abgewandelten" Versuche es doch irgendwie zum Laufen zu bringen. Der Fehler lag letztlich nur an einem kleinen Detail.


    Beim Speedport kann man für Portregeln mehrere Arten auswählen. Portweiterleitung/Portumleitung/Porttriggering.
    Ich hatte "Portweiterleitung" ausgewählt, von dem hier auch immer die Rede war. Ich bekam damit aber bei der Einstellung der zweiten Box immer die Fehlermeldung, dass der Port schon vergeben wurde ...


    Erst als ich "Portumleitung" ausgewählt hatte, konnte ich die Einstellungen so vornehmen, wie du mir vorgeschlagen hast. Dann wurde es, selbst für mich als Netzwerk-Laien, offensichtlich wie das funktioniert. :hurra:


    Für WLan habe ich, wie von dir empfohlen, extra Profile angelegt. Das war dann auch das geringste Problem.


    Vielen Dank für deine Hilfe. Immerhin hat mich die ganze Aktion in Sachen Netzwerk Einrichten einen Schritt weitergebracht. ;)
    Abschliessend noch die Fotos meiner aktuellen Einstellungen. Bin mir jetzt ziemlich sicher, dass das so passt. Die Verbindung, egal ob von ausserhalb oder über Wlan, steht sofort.

    Files

    • hl1.jpg

      (4.89 MB, downloaded 670 times, last: )
    • hl2.jpg

      (4.07 MB, downloaded 662 times, last: )
    • hl3.jpg

      (2.15 MB, downloaded 664 times, last: )
    • hl4.jpg

      (2.48 MB, downloaded 668 times, last: )
    • hl5.jpg

      (2.71 MB, downloaded 665 times, last: )

    Edited once, last by zodiac65 ().

  • Sehr gut, wenn es nun intern und extern geklappt hat! Die Begrifflichkeiten in den Routern sind nicht immer eindeutig. Aber Du weisst ja nun, dass Du eine Portumleitung einrichten musst, wenn öffentlicher und interner Port unterschiedlich sein sollen. Eine Weiterleitung scheint den Port nur durchzureichen an ne andere interne IP.


    Ein Tipp noch: Du kannst mit diesen Portumleitungen nun nicht nur mit Dreamdroid zugreifen, sondern natürlich auch von extern mit jedem Browser. Als Adresse musst Du dann sowas eingeben:


    7020HD: https://<dynDNS-name>:4433/
    8000HD: https://<dynDNS-name>:4434/


    In beiden Fällen sollte dann Abfrage von User/Passwort kommen und danach das Webinterface laden.

  • und der player zum streamen ist bestimmt der vlc-player app.für android.
    denke mal der?


    VLC Direct Pro Free
    Video & Streaming


    frage nur weil ich seit 14 tagen auch sonn telefon habe.weil der player der drauf ist kann den stream nicht

  • gute und super schnelle antwort.dank dir


    muss da noch was eingestellt werden ,beim player?

    Mfg dofler! :P

    Edited once, last by dofler ().

  • glaube habe einen kleinen bug entdeckt-wenn man auf power control geht und neustarten will kommt dox geht in den standbay

  • Reichi


    kannst du bei der Fernbedienung bei jedem Tastendruck das aktuelle Bild der Box hinterlegen? Damit man sich das ewige hin und her zappen zwischen Fewrnbedienung und screenshot erspart.


    Danke

    DM600s Dm600c Gemini 4.7 600er Sattuner DM800se ICVS und DM8000 ICVS ALLES ORIGINAL Clones keine Chance :rot:

  • Hallo.


    Reichi


    Habe jetzt versucht die https://github.com/downloads/sreichholf/...d_1.0beta10.apk


    zu laden.


    Leider bleibt der Download bei ca. 50% bis zum Nimmerleinstag stehen. :rolleyes:


    Ich habe bei mir noch die erste Version der 1.0beta10 mit den bekannten Abstürzen drauf (Gerät wird gedreht > DreamDroid wurde beendet).


    Fehlt da auf dem Server etwas?


    gruß doctore6

  • doctore6: das Problem muss bei Dir liegen. Ich kann das APK ganz normal runterladen und da hängt auch nix oder ist unvollständig:


    Code
    # ls -l dreamDroid_1.0beta10.apk
    -rwxr--r-- 1 root root 1750751 Oct 21 19:09 dreamDroid_1.0beta10.apk
    # md5sum dreamDroid_1.0beta10.apk
    04aab42b01982580e7122aa72faa17a2 dreamDroid_1.0beta10.apk
  • Hallo.


    __QT__
    o.k. Das Laden ging nun. Warum auch immer vorhin nicht.


    Reichi


    Ich habe mit der Version 1.0beta10 ein Problem.
    Starte ich das Programm (Das Handy halte ich hochkant) ist alles i.o.
    Drehe ich das Handy nun quer kommt die Meldung "Leider wurde DreamDroid bendet". ;(


    DreamDroid geht in der Version bei mir nur hochkant (vertikal).
    Ist nun kein Drama, wäre aber schön wenn es dann nicht abstürzt.


    Mein Handy ist ein HTC-EVO3D mit Android 4.0.3 ICS!


    Gruß doctore6