[erledigt] Greenscreen bei lange "Power"

  • Hallo zusammen,


    mir ist gerade aufgefallen, dass wenn ich die DM800 per Fernbedienung runter fahren will (lange auf Power), crasht sie mir weg. Am Gerät selbst lange Power funktioniert problemlos. Und auch über das Menü läufts.


    Oder kann es sein, dass die Taste irgendwie anders belegt ist? In den QuickButton Settings finde ich die Taste nicht...


    Hier mal das CrashLog:

  • Lässt es sich Reproduzieren, dass der Green immer nur beim Shutdown über die FB auftritt? Das sieht mir eher nach einem Problem beim Zurückschreiben des EPG Caches auf deinen USB Stick aus:


    [eEPGCache] remove channel 0x1b90750
    [EPGC] abort caching events !!
    stop release channel timer
    [EPGC] store epg to realpath '/media/Stick1/epg-cache/epg.dat'
    [EPGC] 3607 events written to /media/Stick1/epg-cache/epg.dat
    thread joined 0
    FATAL: LINE 162 descriptor not found in descriptor cache ff4d27d4!!!!!!
    main thread is non-idle! display spinner!
    ]]>
    </enigma2crashlog>
    <pythonMD5sum>
    <![CDATA[


    Wäre interessant ob das Problem auch auftriit, wenn du den EPG Cache mal auf ein anderes Medium legst (Blue Panel -> Einst. -> Allg.)

  • Quote

    Original von kashmir


    [EPGC] store epg to realpath '/media/Stick1/epg-cache/epg.dat'
    [EPGC] 3607 events written to /media/Stick1/epg-cache/epg.dat


    das glaube ich nicht, dass es ein epg-problem ist,
    epg wurde laut log doch geschrieben

    Gruß Jammy


    _________________________


    Eine Leben ohne Dreambox ist möglich, aber sinnlos! ;)

    Edited once, last by Jammy ().

  • Als ich den Greenscreen zuerst hatte, hab ich mich dran gemacht, es noch einmal nach zu vollziehen. Passiert reproduzierbar beim PowerOff per FB.


    Der EPG Cache wird korrekt geschrieben und auch wieder her gestellt beim hochfahren. Ich hatte wohl zuvor den Cache mal gelöscht, um dem Problem mit den leeren Texten (bei RTL und Co) nach zu gehen, aber dazu gibt's ja hier schon nen eigenen Thread - kann damit eigentlich nicht zusammen hängen.


    Ich hatte später allerdings einen weiteren Green beim zappen. Hatte erst einen Sendersuchlauf gemacht und hab dann verschiedene Sender angezappt aus der "Provider" Liste (siehe log). Ob es wohl irgendwie zusammen hängt?


    Das mit dem Auslagern auf ein anderes Medium kann ich heute Abend nochmal versuchen.

  • Quote

    Original von Jammy
    das glaube ich nicht, dass es ein epg-problem ist,
    epg wurde laut log doch geschrieben


    Ja vermutich hast du Recht. Diesmal kam der Green nicht nach dem EPG Cache schreiben:


    [IDLE] 220.999737024 60 True
    action -> InfobarChannelSelection switchChannelDown
    allocating new converter!
    reused converter!
    allocating new converter!
    FATAL: LINE 131 descriptor not found in descriptor cache ff4f5af2!!!!!!
    ]]>
    </enigma2crashlog>
    <pythonMD5sum>
    <![CDATA[


    Problem ist die Zeile 131 im descriptor cache:
    FATAL: LINE 131 descriptor not found in descriptor cache ff4f5af2!!!!!!


    Nur sagt mir descriptor cache nix, vielleicht kann jemand anderes helfen?

  • irgendwas ist im Cache vom EPG versaut bei dir
    Nutzt du irgendwelche Programme die auf den Cache zugreifen könnten.
    Wenn du eine epg.dat in /media/Stick1/epg-cache/ liegen hast.
    Kill mal enigma lösch die und starte Enigma neu.

    Meine Todesursache wird wahrscheinlich Sarkasmus im falschen Moment sein!


    Boxen:
    1. One
    2. DM820HDse
    3. DM920


    Satellit:
    Astra 19,2°

  • epg-cache Verzeichnis war leer. Nach kill von enigma und neustart war EPG erstmal wieder jungfräulich. Danach klappte das PowerOff per FB.


    Ich muss aber dazu sagen, dass ich vorher nochmal ein update gemacht hatte (heute sollte ja der "RTL" EPG Patch kommen), da kamen wieder reichlich neue Pakete (31 oder so).


    Hab jetzt nochmal meine Sender durch geschaltet um den EPG zu füllen und es klappt immer noch :hurra:


    Alles etwas seltsam - ich hatte das EPG ja vorher schon mal zurück gesetzt. Na egal.


    :350: Vielen lieben Dank euch allen!

  • evtl. liegts auch daran, daß RTL seine Änderungen am EPG wieder rückgängig gemacht hat.