direkt zu einem TV streamen

  • Hi,


    ich fasse mich kurz, weil ich noch schaffen muss:


    1. Also Openelec auf SD Karte installieren und dann in der SD Karte die Config.txt suchen.


    Aber Vorsicht !!!: Öffne nicht die Config einfach mit Windows, sondern benutze zum Besispiel DCC (Dreambox Control Center) und öffne die Datei über FTP.
    http://kenntwas.de/2012/linux/…-jetzt-in-bootconfig-txt/


    Dann an der Stelle entsprechend wie im Overclocking beschrieben verändern. Nicht vergessen das '#' zu entfernen, sonst bleibt es ein Kommentar.
    Bei unsicherheit Tante Google oder hier fragen :-)
    Alles auf eigene Gefahr !!!


    2. Habe das hier im Einsatz: http://www.amazon.de/Hama-MCE-…TF8&qid=1354890024&sr=8-1 und damit läuft alles super.


    3. Ich habe Mediatomb auf der Dreambox drauf, doch mit dieser Lösung werde ich Meditomb nicht mehr brauchen !!! Mit der Raspberry Pi ist es egal, ob man Mediatomb drauf hat oder nicht.

  • Quote

    3. Ich habe Mediatomb auf der Dreambox drauf, doch mit dieser Lösung werde ich Meditomb nicht mehr brauchen !!! Mit der Raspberry Pi ist es egal, ob man Mediatomb drauf hat oder nicht.


    Wie geil ist das denn....:-)


    Genau deswegen suche ich pausenlos nach einer Lösung! Heisst ich kann mir die Installation von MediaTomb (geplant für heute Abend) ersparen?
    Mit was "zapfst" du den TV Lifestream der Dreambox den an? XBMC oder mittels Browser??


    Das ist dann defintiv die Lösung sie ich suche...bin gespannt auf Deine Anwort...und dann hoffentlich am Ziel meiner Reise angelangt.

  • Genau,


    Mediatomb brauchst du für XBMC nicht. bei Openelec ist LIVE TV als Extraoption dabei.


    Also Openelec auf die SD installieren. P.S: Openelec sieht genauso aus wie XBMC :-)


    In den deaktivierten Add Ons gibt ein ein VU+ Add on.


    Einfach ins Add on reingehen, die IP Adresse von der Dreambox eintragen und Aktivieren. DANACH in den Openelec einstellungen LIVE TV aktivieren.
    Wenn du es davor aktivierst kommt es zur einer Fehlermeldung, das kein PVR Add on aktiv ist.


    Schlussendlich wird es dann möglich sein Live Tv zu streamen.
    Es werden alle deine Favoriten Kanäle automatisch angezeigt.


    Gruß und bis Sonntag.

  • Es ist egal welche version. Ich habe wohl auch diese version genommen. Alle versionen haben das add on drauf.

  • :-) bin nun auch soweit...


    Was ich leider (noch) nicht geschafft habe ist die Sache mit dem Übertakten.


    Die config.txt ist read only (abgesehen davon gibt es sie an 2 Orten). Die eine habe ich hinbekommen, ist aber vermutlich nicht die, welche "angezogen" wird. Die andere lässt sich einfach nicht ändern.


    Welche der beiden config.txt (bootloader oder Flash Verzeichnis) muss editiert werden und wie genau hast du das hinbekommen?


    Gruss
    Paraxenos (der dich offensichtlich immer bei der Arbeit stört)

  • Wenn du die SD Karte in deinen PC einsteckst und rein gehst, begrüßt dich die config.txt :-)


    Dann musst du die Stelle suchen wo das hier steht:


    # arm_freq=700
    # core_freq=250
    # sdram_freq=400
    # over_voltage=0


    du änderst es dann so z.B ab:


    arm_freq=900
    core_freq=333
    sdram_freq=450
    over_voltage=2


    aber bitte mit DCC über ftp öffnen. nicht direkt über Windows.

  • Irgendwie geht das nicht :-(


    Habe genau wie beschrieben die config.txt unter Windows mit DCC editiert und gesichert. Dann Karte wieder ins Rasp und gestartet.


    Eine Überprüfung der Taktrate (CPU) zeigt aber keine Veränderung. Auch wenn die config.txt auf der Rasp nochmals überprüft wird, scheinen die Änderungen verloren oder ignoriert zu sein?


    Siehe Anhang.


    Was läuft das bloss schief?

  • Mit

    Code
    cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq


    kannst du dir die aktuelle CPU-Frequenz anzeigen.


    Bei mir zeigt /proc/cpuinfo nur 561.33 BogoMIPS, die aktuelle CPU-Frequenz ist 800 MHz.

    Files

    • cpuinfo.png

      (15.08 kB, downloaded 505 times, last: )

    Grüße
    apostrophe

  • Hhmmm


    Entsprächen dann meine 697.95 BogoMIPS den 900MHz die ich eingestellt habe?


    Das Ergebnis Deines Befehls habe ich angehängt.


    Ev. könnte coolboymant auch mal noch seine Werte posten?

  • Das sieht doch sehr gut aus.


    Ich habe mal meine drei Raspberry Pis mit Debian Wheezy getestet und schaffe es nicht, diese zu übertakten (rasp1.png + rasp2.png). Der Raspberry der mir unter RASPBMC nur 531.66 BogusMIPS anzeigt (sich hier aber übertakten lässt), hat bei Debian Wheezy 697.95 BogoMIPS; lässt sich aber nicht übertakten(rasp0.png).


    Wie ist denn deine XBMC-Performance?

    Files

    • rasp0.png

      (55.15 kB, downloaded 450 times, last: )
    • rasp1.png

      (56.49 kB, downloaded 443 times, last: )
    • rasp2.png

      (17.49 kB, downloaded 443 times, last: )

    Grüße
    apostrophe

    Edited once, last by apostrophe ().

  • Tja im Prinzip läuft es soweit gut. Stream ab NAS Full HD Movie lief ruckelfrei ab.
    Wo ich noch etwas Mühe habe ist der Live-Stream. Da hatte ich bei FULL-HD Sendern nur Ton?! Könnte aber auch an etwas anderem liegen.


    Werde mal noch etwas testen und mich wieder melden.


    Wäre schon nicht schlecht man wüsste ob die CPU nun mit 900 MHz läuft oder nicht. Keine Ahnung was es mit diesen BogoMIPS genau auf sich hat.....

  • So da bin ich wieder ;-)


    Also in diesem BogoMIPS habe auch diese 697,95 stehen. Auch wenn ich die Raspberry PI übertacktet habe.


    An folgenden 3 Sachen stelle ich fest, das die veränderungen trotzdem greifen:


    1. Wenn du im Punkt Systeminfo bist, kannst du die Framerate sehen. Ist die Raspberry Pi nicht übertacktet, pendelt sich dieser bei ca 30 Frames. Übertacktet ca 60 Frames.


    2. Die Temparatur wird heißer, diese steht ebenfalls unter Systeminfo. Ich habe eine Temparatur von ca 55 Grad. Normal wird die Raspberry Pi nicht so heiss.


    3. Nicht übertacktet kommen die Ruckler und das nicht mehr syncrone laufen vom Bild und Ton. Übertacktet sind diese weg :-)


    Du schreibst, dass du bei Live HD Stream nur Ton hast? Live SD Stream funktioniert?


    Wie ist di Pi im Netz angeschlossen? Lan ? WLan?


    P.S: So ich ich es bei der Pi verstanden habe, tacktet sich Sie selber runter, wenn die Leistung nicht gebraucht wird. Vielleicht bleibt dieses BogoMIPS auch deswegen immer auf dieser Zahl.

  • Welcome back :-)


    Gut, das werde ich heute gleich mal probieren (einsehen in den Einstellungen).


    Hast Du ev. auch noch eine Erklärung, weshalb meine config.txt nicht "greift"?


    Habe eigentlich alles so gemacht wie von Dir beschrieben.


    Mal sehen heute Abend was die Werte ergeben....


    Gruss
    Paraxenos


    PS: Habe meine "Pi" in einem Gehäuse. Wäre es ev. ratsam, da noch einige Löcher in den Deckel zu bohren (Hitzestau?)

  • Die '#' Zeichen sind davor auch weg ?


    900 Mhz langen für HD Live Stream. Wenn die Framerate so um die 60 ist, sollte deine Übertacktung geklückt sein.


    Funktioniert den der SD Live Stream bei dir ?

  • So, da bin ich wieder


    Ich war wohl etwas zu euphorisch :-(


    Folgende Probleme bestehen noch:


    1. LiveStream
    a) Da liest er immer erst alle Sender ein (muss das nach jedem Neustart sein, dauert extrem lange)? Bild 3
    b) Habe nur Ton und kein Bild (siehe Anhang)? Bild 1 & 2


    2. CPU Speed
    bekomme nur die geposteten Default Werte (frames ca. 25 - 30 / Temp ca. 50°). Da kann also auch etwas nicht stimmen


    3. Auflösung
    Da ich das Teil an einem der ersten Flachbidschirm TVs habe (SCART und DVI) versuche ich über HDMI zum TV zu gelangen. Da nehme ich den DVI Eingang mit einem DVI to HDMI Adapter => KEIN Bild. Eigenartigerweise kann ich im Menu wenn ich den Analog TV Ausgang der Rasp nehme die Auflösung nicht ändern (720x480 bei 60Hz). Dachte das sei ev das Problem. Die Auflösung über FBAS (gelber Ausgang) geht, ist aber schon ziemlich schlecht.


    Könnt Ihr mir zu den Punkten ev. behilflich sein? Denke das Wichtigste wäre mal der Live Stream MIT Bild, dann CPU Clock und schliesslich ein noch etwas besseres Bild...


    Danke & Gruss
    Paraxenos

    Files

    • 1.jpg

      (71.22 kB, downloaded 419 times, last: )
    • 2.jpg

      (59.3 kB, downloaded 402 times, last: )
    • 3.jpg

      (49.04 kB, downloaded 403 times, last: )
  • Also, dass diese epg's beim Neustart eingelesen werden, ist immer so. Vielleicht lässt sich das bei den Einstellungen im openelec deaktivieren.


    Zumindest ist es ein gutes Zeichen, dass alles verbunden ist. Was nicht ok ist, wenn das Laden so lange dauert. Nach ca 30 Sekunden sollte er durch sein.


    Hast du die Möglichkeit deine pi mit einen Monitor direkt über hdmi anzuschließen? Kannst du die pi auch direkt über LAN zum testen anschließen?

  • Pi ist per LAN angeschlossen und ja, kann sie auch an einen HDMI Monitor anschliessen.


    Wenn ich auf Live-TV gehe vergeht mir der Spass, da dann jeweils 10Min. lang ALLE Sender inkl. EPG von der DM8000 eingelesen werden.
    Ist das endlich geschafft, ist die Auswahl eines Sender wieder ein Geduldspiel (als ob die über tausend Sender die halt nun mal auf der DM8000 vorhanden sind jedesmal einzeln gescannt werden...)


    Ich glaube ich "ziehe" mir mal die letzte 3.0 Version des Image Files und starte nochmals von Beginn an.


    Nur mal so zu meinem Verständnis:


    Ist bei Dir (Euch) Live TV einwandfrei benutzbar? Ich meine starten von Live TV, Programmwechsel, EPG etc. läuft "flüssig"? Lässt sich die Rasp mit der MCE Ferbendienung ein.- und Ausschalten? Aus geht mei mir, ein jedoch nicht mehr

  • Pass auf. Damit du das ganze mal sehen kannst, nehme ich heute Abend ein kurzes Video mit Kommentar auf. ;-)


    Da ich heute beim Kunden bin, weiss ich nur nicht genau wann. Wir bekommen das schon hin ;-)