(e2 plugin) Erweiterte Filmauswahl (AdvancedMovieSelection)

  • Hallo,


    okay ich muss mich mal wieder als DAU outen :rolleyes:


    Also ich kann eine Film selektieren und dann nach den Infos suchen lassen, das ist kein problem.
    Aber eine "automatische" Suche habe ich noch nicht gefunden, wo ich ganze Verzeichnisse durchsuchen
    lassen kann, da bin ich wohl zu doof dazu ;(


    Wenn ich auf ein Verzeichnis gehe wie Sci-Fi und übers Menü auf suchen gehe sucht er mir nur nach diesen Wort und nur für dieses Verzeichnis aber nicht für die Filme die da drinn liegen...


    Und wenn ich übers Menü gehe und ein Suchverzeichnis auswähle und dann den grünnen Button drücke für TMDb bekomme ich nur ein Error angezeigt :rolleyes:

    MfG EgLe :]

    Linux will Benutzer, die Linux wollen. Linux ist nicht Windows


    Kernel : 5.4.2-1-MANJARO LTS
    GUI : KDE 5.64.0 / Plasma 5.17.4
    Machine : Intel NUC8i7HVK
    Graphics : Radeon RX Vega M GH
    CPU : Intel Core i7-8809G @ 8x 4.2GHz
    RAM : Gskill F4-3000C16S-16GRS Speicherkarte so D4 3000 16GB C16 Rip

  • Hier (e2 plugin) Erweiterte Filmauswahl (AdvancedMovieSelection) hab ich dir doch den Punkt gezeigt (zweites Bild)


    Und wenn der nicht da ist dann musste es im setup einschalten (was auch im setup als hilfe steht siehe hier blauen Text ) ;)


    Die Hilfe im Plugin ist für alle da und unser Programmierer hat sich die Arbeit da nicht nur für sich gemacht ;)


    PS. und man muss sich in dem Ordner befinden oder halt die Sachen in der Bibliothek freigeben ,dann werden alle Fillme (auch die in den Unterordnern sind aufgeführt und dann kann man die gesammte Bibliothk automatisch scannen lassen ;)

  • Hallo zombi,


    hmm, dann ist meine Box kaputt oder ich bin zu doof :rolleyes:



    Ich habe die Einstellung wie du beschreiben hast.
    Gehe in ein Verzeichnis und klicke über Menü - Alle Infos Herunterladen....
    Dann kommt der Screen vom automatischen suchen aber da passiert einfach nichts.. :rolleyes:

    Files

    MfG EgLe :]

    Linux will Benutzer, die Linux wollen. Linux ist nicht Windows


    Kernel : 5.4.2-1-MANJARO LTS
    GUI : KDE 5.64.0 / Plasma 5.17.4
    Machine : Intel NUC8i7HVK
    Graphics : Radeon RX Vega M GH
    CPU : Intel Core i7-8809G @ 8x 4.2GHz
    RAM : Gskill F4-3000C16S-16GRS Speicherkarte so D4 3000 16GB C16 Rip

  • Du sollst ja auch nicht den Ordner markieren mit dem Cursor ,sondern in den Ornder gehen dann wird der Inhalt des Ordners gescannt)


    Ich glaub aber das es da e ne kleine Macke hat weil das geht nicht imm er .
    Besser ist es dein media/nas/... in die Bibliothek aufzunehmen und dann scannt er die gesammte Bibliothek mit einmal ;)

  • Hallo zombi,


    also dann gebe ich zu das ich für dieses Plugin zu Dumm bin.


    Habe mal eine Bibliothek erstellt sind nun auch mal 139 Filme drinn (alles Sci-Fi)


    Aber egal was ich mache es funktioniert bei mir nicht....


    Ob von der Bibliothek aus, in der Bibliothek, oder auf einem film, nichts geht mit automatischer Suche bei mir ;(



    Das einzigste was geht ist es Filme einzeln suchen zu lassen,
    wobei er dann immer sagt er findet nichts und ich muss manuell den Namen eingeben.


    Naja, an drei Tagen nur an dieser einen Funktion ausprobiert ohne Erfolg zeigt mir das ich es evtl. bleiben
    lassen sollte mich mit den Plugins die ich nicht kenne zu beschäftigen solange das nicht DAU sicher ist :rolleyes:

    Files

    MfG EgLe :]

    Linux will Benutzer, die Linux wollen. Linux ist nicht Windows


    Kernel : 5.4.2-1-MANJARO LTS
    GUI : KDE 5.64.0 / Plasma 5.17.4
    Machine : Intel NUC8i7HVK
    Graphics : Radeon RX Vega M GH
    CPU : Intel Core i7-8809G @ 8x 4.2GHz
    RAM : Gskill F4-3000C16S-16GRS Speicherkarte so D4 3000 16GB C16 Rip

  • Was geanu funktioniert denn nicht? zeigt er dann wieder an das 0/0 gescannt wurden?
    oder zeigt er an das er was gescannt hat?
    Und wenn du schon Cover hast werden die nicht überschrieben bei einer automatischen suche ,das ist damit man sich nicht ausversehen was löscht .
    Und es kann echt sein das AMS da Probleme hat die Sachen bei TMDB zu finden so wie du manche Filme benannt hast .

  • Nein das ist nicht kaputt hab das gerdae getestet und es ging genau wie es soll.

  • Hallo,


    Quote

    Original von cmikula
    Kann sein, dass die Suche für alle Film in der Bibliothek nicht funktioniert?!
    Eventuell mit markieren und grün (tmdb) probieren...


    Das funktioniert auch nicht.. sie Anhang screenshot.


    Quote

    Original von zombi
    Was geanu funktioniert denn nicht? zeigt er dann wieder an das 0/0 gescannt wurden?


    Jep das ist es genau er scannt gar nicht danach.....
    bleibt bei das 0/0 gescannt stehen und wenn ich stunden warte..
    Man sieht nicht einen einzigen Film an das er gescannt wurde.


    Naja für heute habe ich aber erstmal genug von dem Plugin, und brauche Pause davon.....

    Files

    • screenshot.jpg

      (88.68 kB, downloaded 532 times, last: )

    MfG EgLe :]

    Linux will Benutzer, die Linux wollen. Linux ist nicht Windows


    Kernel : 5.4.2-1-MANJARO LTS
    GUI : KDE 5.64.0 / Plasma 5.17.4
    Machine : Intel NUC8i7HVK
    Graphics : Radeon RX Vega M GH
    CPU : Intel Core i7-8809G @ 8x 4.2GHz
    RAM : Gskill F4-3000C16S-16GRS Speicherkarte so D4 3000 16GB C16 Rip

  • Na ja, bei der Filmnamenbenennung wird das sowieso nix mit der Suche ;)
    Da musst du erstmal die Namen deiner Filme überarbeiten.
    Am besten die .meta Datei mit Notepad++ bearbeiten - geht am schnellsten.

  • Also wenn ich deinen Screenshot sehe dann ist doch klar das es nicht geht (du versuchst bei TMDB nach einem film "Bibliothek .... " zu suchen.
    Wenn du den inhalt der Bibliothek scannen möchtest musst du dich in dieser befinden wie hier zb.auf dem Foto.
    Bist du dann da drin dann erst kannst du ins menü und Herunterladen für alle drücken und dann scannt er das auch.
    Und wie gesagt du hast ja allte cover usw. schon ,die überschreibt AMS nicht (zumindest sollte es das nicht) nur bei manuell kannst du das dann überschreiben.


    JA genau die Filmbeschreibung ist ja auch nicht umbedingt das ware mit den ganzen Punkten und was weiß ich alles (so sind die Filme da mit sicherheit nicht gelistet und dann soll dafür noch ein Parser angepasst werden? )
    Sorry aber benennt sie doch einfach mal richtig dann findet es die Sachen auch sehr gut und schnell.


    cmikula eventuell kannste noch einbauen das die Punkte durch leerzeichen ersetzt werden beim suchen ,eventuell hilft das .
    Aber nur wenn sowas überhaupt geht im parser.


    Ich habs mal gegen getestet und mit den ganzen punkten findet er natürlich nix ,sind die Punkte leerzeichen dann findet er es sofort.

  • Hallo,


    Quote

    Original von cmikula
    Na ja, bei der Filmnamenbenennung wird das sowieso nix mit der Suche ;)
    Da musst du erstmal die Namen deiner Filme überarbeiten.
    Am besten die .meta Datei mit Notepad++ bearbeiten - geht am schnellsten.


    Okay, dann bin ich beruhigt ;)


    Sagte ja das ich mich damit nicht auskenne und solche Plugin nie benutzte die ganze Zeit.


    Bin erst vor Kurzem auf die VideoDB gestoßen, und wollte eben auch dann dieses Plugin mal genauer betrachten.


    Daher auch meine erste Frage wegen dem Parser:


    Weil in der VideoDB ist ja so ein Parser mit drinn,
    der die Punkte usw. ignoriert, der erkennt bis auf wenige alle Filme soweit richtig...


    Und sagte ja sorry, das ich so ein DAU bin, dachte halt das sowas mit drin wäre.
    Dann weiß ich ja nun Bescheid, das es für mich so nicht zu gebrauchen ist. :rolleyes:


    Aber trotzdem ist ein gutes Plugin, aber meiner Meinung nach eben noch Verbesserungsfähig ;)

    MfG EgLe :]

    Linux will Benutzer, die Linux wollen. Linux ist nicht Windows


    Kernel : 5.4.2-1-MANJARO LTS
    GUI : KDE 5.64.0 / Plasma 5.17.4
    Machine : Intel NUC8i7HVK
    Graphics : Radeon RX Vega M GH
    CPU : Intel Core i7-8809G @ 8x 4.2GHz
    RAM : Gskill F4-3000C16S-16GRS Speicherkarte so D4 3000 16GB C16 Rip

  • Hi...
    Ich wollte auf meiner 7080 in meinem Newnigma2 mit OE 2.5 das AMS installieren. Telnet sagt 2 Module fehlen. Einmal isofs und udfs(?). Kann man das Lösen? Nachinstallieren von beiden geht nicht!

    1. = DM920HD
    2. = DM7080HD
    3. = DM8000HD
    4. = 2 x 3 TB WDmycloud
    5. = 1 x 3 TB Externe HDD
    6. = 1 x 2 TB WD Mybook

  • Hallo,


    ich bin mal wieder ins Thema eingestiegen und es war mir aufgefallen, dass die Seekbar (cursor) bei Full HD Skins nicht vernünftig skinbar ist.


    Deshalb wär´s ganz nett, wenn man in die seekbar.py noch folgenden Eintrag hinzufügen könnte (rot).


    def updateCursor(self):
    if self.length:
    try:
    sz_w = getDesktop(0).size().width()
    except:
    sz_w = 720
    if sz_w == 1280:
    x = 60 + int(11.5 * self.percent)
    elif sz_w == 1024:
    x = 60 + int(9.0 * self.percent)
    elif sz_w == 1920: x = 100 + int(17.2 * self.percent)
    else:
    x = 5 + int(6.8 * self.percent)
    self["cursor"].moveTo(x, 100, 1)
    self["cursor"].startMoving()
    pts = int(float(self.length[1]) / 100.0 * self.percent)
    self["time"].setText(_("Manual jump to:") + ' ' + ("%d:%02d" % ((pts/60/90000), ((pts/90000)%60))))


    Dann klappts dann auch bei den FullHD Skins.
    Mit den Werten ist die Position der Progressbar x=100, y=100, Länge=1720px


    Wäre prima, wenn man das ändern könnte.
    Dann muss ich das bei einem Update nich immer händisch tun......

    2x DM 900 UHD
    1x DM 800 HDse V2
    4x DM 500 HD V2
    Merlin OE2.x/GP3.x/Eigener Skin
    Sky Welt/Film HD, HD+, V13

    :429:

    Edited once, last by aslan2006 ().

  • Hallo bekomme ab und zu eine green screen wenn ich AMS starte.
    dm7080 Merlin OE 2.5


    File "/usr/lib/enigma2/python/Plugins/Extensions/AdvancedMovieSelection/Source/ServiceProvider.py", line 173, in getPercentSeen
    IOError: [Errno 5] Input/output error

  • So! Ich habe es installiert bekommen. Aber wo ist es? Nicht unter Erweiterungen oder in den Menues ist es zu finden! Wo isses hin?

    1. = DM920HD
    2. = DM7080HD
    3. = DM8000HD
    4. = 2 x 3 TB WDmycloud
    5. = 1 x 3 TB Externe HDD
    6. = 1 x 2 TB WD Mybook

    Edited once, last by spatz69 ().