(e2 plugin) Erweiterte Filmauswahl (AdvancedMovieSelection)

  • Quote

    Original von cmikula
    Tut mir leid, dass wir ein Privatleben haben!!!


    na zum glück haben wir das ;)

    TunerA: Multifeed
    13°O, 19,2°O, 23,5°O, 28,2°O
    TunerB: LAMINAS OFC-1200
    45°O, 42°O, 40,0°O, 39°O, 36,0O, 33,0°O, 31,0°O, 28.2°O, 26,0°O, 23.5°O, 21,6°O, 19.2°O
    , 16,0°O, 13°O, 10,0°O, 9°O, 7°O, 5°O, 4,8°O, 0,8°W, 4°W, 5°W, 7°W, 8°W, 11,0°W, 12.5°W
    , 15°W, 18,0°W, 22,0°W, 24,5°W, 30°W
    TunerA/B: In Gebrauch
    0,8°W, 9°O, 13°O, 19.2°O, 23.5°O, 28.2°O
    Dreambox: 7000, 7020SI, 7020HD
    Telekom-Entertain

  • cmikula
    So war das nicht gemeint...
    Hoerte sich von zombie aber so an, dass ihr nur auf OE2.0 arbeitet und testet. Kann verstehen, dass man dann fuer OE1.6 nichts machen wuerde (waer aber schade)
    Dann sollte man die V2.9 nur als final OE1.6 bezeichnen. und in der Database ist sie ja auch noch ( danke fuer den Hinweis an lizard-king).


    Also: das Wochenende gehört der Familie.....

    DM8000 mit RGB-Display Skin=infinityHD/image=exp2011-09-06/GP3,DM7020HD, OE2.0 mit karatelight, DM7080HD

  • für die 1.6 user


    probier mal das neue paket im anhang



    Achtung:
    ist ein schneller fixversuch


    nicht getestet auf 1.6


    wenns noch nicht klappt müssen wir länger warten

  • wart nen momment, gibt sicherlich gleich was zum testen


    ups da isses schon :D

    TunerA: Multifeed
    13°O, 19,2°O, 23,5°O, 28,2°O
    TunerB: LAMINAS OFC-1200
    45°O, 42°O, 40,0°O, 39°O, 36,0O, 33,0°O, 31,0°O, 28.2°O, 26,0°O, 23.5°O, 21,6°O, 19.2°O
    , 16,0°O, 13°O, 10,0°O, 9°O, 7°O, 5°O, 4,8°O, 0,8°W, 4°W, 5°W, 7°W, 8°W, 11,0°W, 12.5°W
    , 15°W, 18,0°W, 22,0°W, 24,5°W, 30°W
    TunerA/B: In Gebrauch
    0,8°W, 9°O, 13°O, 19.2°O, 23.5°O, 28.2°O
    Dreambox: 7000, 7020SI, 7020HD
    Telekom-Entertain

  • Charly2mal2
    wenn eine version für OE1.6 angeboten wird dann arbeiten die beiden auch weiterhin an einer OE1.6 variante ;)
    ich schrieb das WIR Betatester dies nicht richtig getestet haben mit dem OE1.6 weil das fast keiner mehr von uns hat ,das bedeutet aber noch lange nicht das die beiden nicht an der OE1.6 version weiterarbeiten ;)

  • Moin und dankeschön für´s 3.0 er Update !!


    Irgendwie habe ich das Datenbank-Prinzip noch nicht ganz verstanden.


    1.) Wo wird denn die Datenbank abgegelegt bzw. wo ist sie zu finden ?
    Ein Datenbanksymbol wird bei mir nirgends angezeigt (wie im Screen zum Updatepost), obwohl in den Einstellungen alles auf an...
    Als Suchverzeichnis ist hdd/movie gewählt.


    Ich habe keine eingebaute HDD. Ist alles per fsatb gemountet, sollte doch aber kein Problem sein ?


    2.) Wird sie regelmäßig aktualisiert oder muss ich das manuell selbst immer durchführen ?


    3.) Wie sieht ein Marker aus bzw. wo ist der zu finden (kann auf den Screenshots auch nichts erkennen) ?


    4.) Bei "DB aktualisieren" passiert nichts. Muss da was passieren (Bildschirmanzeige ?) ?


    Gibts eigentlich sowas wie ein "AMS Wiki", wohl alles mal etwas ausführlicher erklärt wird ;) ;)?

    3x DM 900 UHD
    1x DM 800 HDse V2
    4x DM 500 HD V2
    Merlin OE2.x/GP3.x/Eigener Skin
    Sky Welt/Film HD, HD+, V13

    :429:

    Edited 2 times, last by aslan2006 ().

  • so da wollen wir mal deine fragen beantworten :D


    1. Die Datenbank ist nicht so wie du eventuell denkst ;)
    es wird alles so wie immer gehandhabt ,also deine sachen befinden sich immernoch so wie immer in den jeweiligen ordnern ,die datenbank erfast das nur alles wenn du es freigibst und zeigt dir dann alles auf.
    also musst deine HDD ,nas oder was auch immer freigeben wo die filme /serien drauf sind ;)


    zu erstens
    schau dir mal das Menü der AMS an dort findest auch die einstellung für die datenbank (bild 2) und dort musst du deine verzeichnisse freigeben die durchsucht werden sollen ;)


    2.aktualliesiert wird immer wenn du in die AMS gehst oder manuell


    3.marker ist wie hier auf dem foto


    4.kann nicht gehen weil du nix für die datenbank freigegeben hast und ja es wird dir dann angezeigt das die datenbank aktuallisiert wird


    und nein ein richtiges Wiki für die AMS gbt es nicht

  • Quote

    Originally posted by Heiquito
    Ist es denn bei dir auch so, dass der komlette movie Ordner (inkl. movie Verzeichnis) gelöscht wird?


    Das Verhalten ist aus Sicht des Unix-Filesystems völlig normal und insofern kein Fehler. Der Verzeichniseintrag "." ist ein weiterer Name (kein Symlink, ein richtiger (Hard)Link) für das Verzeichnis selbst, der Name ".." ein weiterer Name für das übergeordnete Verzeichnis. Beide funktionieren in jeder Hinsicht so, wie andere Namen (Links) auf ein Verzeichnis auch, nur mit der Besonderheit, dass Hardlinks auf Verzeichnisse normalerweise nicht zulässig sind - sie führen ja zu unauflösbarer Verknäuelung des ursprünglichen Baums, in der man dann endlos rekursieren könnte. Generell stellt Unix also sicher, dass Verzeichnisse - im Gegensatz zu regulären Files - nur genau einen Namen haben. Die zusätzlichen Namen "." und ".." sind ein Sonderfall, sie werden automatisch erzeugt und sind immun gegen Umbenennung und andere Manipulationen. Insofern sind sie durchaus eine Tretmine, aber eine mit bestens bekanntem Erscheinungsbild. Ein forciertes rekursives Löschen (z.B. "rm -rf ..") funktioniert daher und macht genau das, was es soll: Es löscht rekursiv das gesamte übergeordnete Verzeichnis von dem Verzeichnis, wo man grad drin steht (cwd).


    Das ist übrigens nicht nur auf Unix so, als der Herr Gates Anfang der 80er das QDOS für IBM ein wenig aufpeppen musste, hat er seine Xenix-Erfahrungen für ein vernünftiges hierarchisches Dateisystem einfließen lassen und daher geht die selbe Versenkung ganzer Platteninhalte auch unter (Win)DOS. Ich kann mich noch an einen Leserbrief in der c't erinnern, wo jemand genau das beschrieb - er wollte ein Verzeichnis "leer machen", ihn störten die "hässlichen" Einträge "." und ".." und er hat alles versucht, auch die loszuwerden. Mit durchschlagendem Erfolg...


    Wir sind uns einig, dass das ein Feature ist, das man in GUIs abfangen muss, und das ist in der AMS ja nun auch passiert. Generell ist das Löschen von ganzen Verzeichnisbäumen immer äußerst heikel und daher geht das unter Unix ja auch gar nicht - rmdir(2) löscht ausschließlich leere Verzeichnisse (also welche, die außer den Links "." und ".." keine weiteren Einträge haben), unlink(2) löscht nur andere i-node-Typen, aber keine Verzeichnisse. Rekursives Versenken eines ganzen Baums ist eine konzertierte Aktion eines Userspace-Tools, das den Baum depth-first traversieren, alle non-directories mit unlink(2) entfernen und dann die entleerten Directories mit rmdir(2) vernichten muss, schön von den Blättern aufwärts zur Wurzel und u.U. noch garniert mit Anpassungen der Zugriffsrechte (Löschen hängt bekanntlich am Schreibrecht auf Verzeichnisse) - passiert also nicht aus Versehen. So eine mächtige Waffe will gut gesichert sein ;)


    Man muss jetzt nicht gleich auf jegliche Löschfunktion für Verzeichnisse verzichten. Wenn sie ausschließlich rmdir(2) aufruft, kann sie nur auf leere Verzeichnisse wirken und ist insofern sicher gegen jede relevante Fehlbedienung. Kann dann bedeuten, dass Trümmer in dem Directory (z.B. verwaiste Metadaten-Files, zu denen die .ts schon nicht mehr existieren) dessen Löschen verhindern, aber letztlich ist das Auch Gut So(tm).


    HTH,
    Andre.

  • O.K., das Problem war, wie beschrieben, das Auswählen der Verzeichnisse.
    Allerdings zeigte sich da ein seltsames Verhalten.


    In der Verzeichnisauswahl klappt das Zuweisen zur Datenbank nur, wenn ich dafür ein Lesezeichen auswähle !?
    Bei mir stand vorher keins drin (auch komisch, weil ich habe ja Lesezeichen) und ich wollte die Verzeichnisse direkt über die obere Spalte zuweisen.
    Das wurde auch ohne Murren akzeptiert aber es wurde keine Datenbank angelegt.


    Ich musste also erst ein Lesezeichen hdd/movie anlegen und dann klappte die Auswahl bzw. Zuweisung.
    Ist das so gewollt ? Wenn ja, sollte man das aber mal noch generell zu Besten geben...

    3x DM 900 UHD
    1x DM 800 HDse V2
    4x DM 500 HD V2
    Merlin OE2.x/GP3.x/Eigener Skin
    Sky Welt/Film HD, HD+, V13

    :429:

  • danke für deinen text aber das wusten die Programmierer schon ;)
    nur sollte und wollen sie das löschen (auch von leeren ordneren) in der AMS nicht haben und daher ist das so ,das war schon immer so ,daher war das doch ein BUG ;)
    wer ordner löschen möchte (auch in der AMS ) kann das über die lesezeichenfunktion machen (dort kann man leere ordenr nämlich auch löschen ;) )
    und ansonsten gibt es genügend andere Plugins die dies ermöglichen ,in der AMS Movieliste direkt verzeichnisse löschen wird es daher nicht geben.

  • DANKE an Bschaar, Zombie und alle Entwickler und Tester !!!!
    mit der version von Bschaar klappt es auch auf OE 1.6 und auch wir können weitertesten und nutzen
    (dauerte etwas länger, weil ich war gearde dabei, die 2.9 zu restaurieren und die Box blieb hängen, musste Box ganz durchstarten :gutenmorgen: :rolleyes:)


    SUPER !!!


    Charly2mal2

    DM8000 mit RGB-Display Skin=infinityHD/image=exp2011-09-06/GP3,DM7020HD, OE2.0 mit karatelight, DM7080HD

  • Quote

    Original von Bschaar
    für die 1.6 user
    probier mal das neue paket im anhang


    Danke!


    Der Fehler beim Speichern der Einstellungen unter OE 1.6 ist jetzt weg. Außerdem werden die Einstellungen auch wieder wie früher übernommen.

  • super


    auch auf meiner 800 mitOE1.6 läuft es wieder


    ist denn auch der Fehler mit dem "Timer umschalten" gefixt?

    Gruß
    banyba


    920 S2 FBC+Triple, 4tb WDblue
    900 S2 FBC
    525HD S+C
    520HD bei allen DMM, GP4 + notgedrungen HD+
    Nas Synology DS220+

  • die gefixte version für OE1.6 sollte jetzt auch auf dem Addon sein. ;)

    TunerA: Multifeed
    13°O, 19,2°O, 23,5°O, 28,2°O
    TunerB: LAMINAS OFC-1200
    45°O, 42°O, 40,0°O, 39°O, 36,0O, 33,0°O, 31,0°O, 28.2°O, 26,0°O, 23.5°O, 21,6°O, 19.2°O
    , 16,0°O, 13°O, 10,0°O, 9°O, 7°O, 5°O, 4,8°O, 0,8°W, 4°W, 5°W, 7°W, 8°W, 11,0°W, 12.5°W
    , 15°W, 18,0°W, 22,0°W, 24,5°W, 30°W
    TunerA/B: In Gebrauch
    0,8°W, 9°O, 13°O, 19.2°O, 23.5°O, 28.2°O
    Dreambox: 7000, 7020SI, 7020HD
    Telekom-Entertain

  • und ich hab ja nur hochgeladen ;)


    es war cmikula der den fix schnell gemacht hat :top:

  • Quote

    Originally posted by zombi
    danke für deinen text aber das wusten die Programmierer schon ;)


    Das will ich hoffen ;)
    Nur lesen hier auch Anwender mit, und ich vermute mehr als einem davon haben die ersten Reports von Heiquito hier im August etwas Bange gemacht. Insofern kann ein kurzer Abriss über weniger bekannte Marotten unserer Betriebssystembasis sicher nicht schaden.

    Quote

    nur sollte und wollen sie das löschen (auch von leeren ordneren) in der AMS nicht haben und daher ist das so ,das war schon immer so ,daher war das doch ein BUG ;)


    Ok, wenn es per definitionem nicht gehen soll, klar.


    Ich benutze sowieso den Papierkorb. Und den lösche ich manuell, primär weil das automatische Löschen bei mir nicht funktioniert (Note to self: mit 3.0 mal wieder testen). Und da wären wir bei dem einen Feature, was mir "fehlt": Automatisches Löschen nach einer einstellbaren Liegezeit im Müll statt zu einem festen Zeitpunkt. Ich hatte gehofft, dass das bei irgendeinem Update mal auftaucht, aber da das bisher nicht passiert ist, wollt ich mal drüber reden ;)


    Ansonsten: Glückwunsch zur Release & Thanks,
    Andre.