VPS-Plugin 1.6

  • Ich hab´s jetzt nochmal überprüft:
    in CoolTV gibt es die Funktion "QuickRecord" (Rec-Taste) - und mit der werden Timer in CoolTV ohne direkte Editiermöglichkeit angelegt.
    Und dann wird VPS nicht aktiviert. Hoffentlich kann das noch geändert werden!? Abgesehen davon klappt VPS einwandfrei! :hurra:

  • Ich habe mich die letzte Woche einmal in PDC - Program Delivery Control vertieft wegen einige völlig erfolglosen Aufnahmen in Reaktion auf des Papstes Wahl. (Verschoben Programmierung, die nicht durch den EPG aber gut mit PDC in der Teletextsignal übergeben wurde)


    Ich habe festgestellt, dass PDC über Teletextsignal von dem Belgischen Sender VRT Eins, Canvas und Ketnet, auch über Satellit übertragen wird. (Ich habe mit dvbsnoop Teletext Packet 8/30 Format 2 http://pdc.ro.nu/packet30.html gefunden.)


    Ich habe auch den Quellcode des VPS-plugin (enigma2-plugin-system plugins-vps) studiert und festgestellt, dass dieses Plugin völlig PDC Informationen im Videotext-Signal ignoriert . Das VPS-plugin sieht offenbar ausschließlich auf die EIT-Tabelle in der DVB-SI-Signal.


    Dann ging ich auf der Suche nach Linux-Software, die Videotext-Informationen analysiert und ich kam bei http://packages.ubuntu.com/de/source/precise/zvbi
    Schließlich habe ich sogar eine fertige Aufnahme-Tool gefunden die PDC Informationen im Teletextsignal liest und so perfekte Aufnahmen macht.
    http://k5.sh.cvut.cz/~oskar/bl…&entry=entry100321-191554



    Ich habe es noch nicht geschafft vpsrecord-1.1 zu kompilieren für mipsel32 und zu testen ob PDC effektiv mit OpenPLi funktioniert.
    Vielleicht kann jemand mit mehr Erfahrung mit Linux und OpenPLi dieses Aufnahme-Tool einmal kompilieren?


    Vielleicht ist die VPS-plugin (vps.cc) über eine relativ kurze Zeit mit dem PDC-Funktionalität zu erweitern, so dass alle Sender mit einem klassischen PDC-signal (insbesondere die Belgische Sender VRT) perfekt von Anfang bis Ende aufgezeichnet werden.

  • Ich habe das Problem immer wieder mal, dass ich VPS auf Ja (Sicherheitsmodus) gestellt habe. Der Sender strahlt kein VPS aus und das Plugin bestimmt die Anfang/Endezeit aufgrund vom EPG. Manchmal läuft aber autoincrement 1 an und der Timer wird auf 1minuten Taktung umgestellt.


    Das Problem ist, dass somit der Nachlauf von x Minuten was man in enigma2 eingestellt hat verloren geht. Blöd ist es dann wenn der Sender 1-2min die Sendung überzieht und das Ende dadurch fehlt, da EPG Now/Next sich geändert hat.


    Gibts da einen Workaround, dass hier die x Minuten Nachlaufzeit bei autoincrement dennoch beibehalten wird?

    Best Enigma2 Plugins:
    TV Charts Plugin, EPGRefresh, AutoTimer, VPS Plugin, SeriesPlugin

  • Das Problem besteht weiterhin, dass bei einer Aufnahme sei es RTL oder ProSiebenSat.1 Familie VPS zwar aktiviert ist, aber nicht vom Sender gesteuert werden soll.


    Oft geht es gut, aber wie vorher wieder bekomme die Aufnahme aus welchem Grund auch immer acitivating state 3 und autoincrease recording 1 minute(s) läuft an und die Aufnahme läuft solange bis der EPG wechselt. Natürlich fehlen oft dann die letzten 10-30sek der Aufnahme, da der Nachlauf somit wegfällt.


    Seltsam finde ich, dass der Sender kein VPS oder running status sendet.


    Ich weiß auch nicht ob eine andere Aufnahme reinspuckt, denn dieser Sender sendet VPS bzw. den Running Status. Und genau zeitgleich welcheselte bei allen Aufnahmen activating state auf 3

    Best Enigma2 Plugins:
    TV Charts Plugin, EPGRefresh, AutoTimer, VPS Plugin, SeriesPlugin

  • Passiert das eventuell immer, wenn du einen Timer löschst, während die Aufnahme läuft?


    Das Plugin nutzt ja die Autoincrease-Funktion von Enigma2. Wenn bei laufender Aufnahme irgendein Timer gelöscht wird, so setzt E2 bei den Timern mit Autoincrease die Endzeit auf die aktuelle Uhrzeit.

  • Quote

    Original von sftg
    Passiert das eventuell immer, wenn du einen Timer löschst, während die Aufnahme läuft?


    Das Plugin nutzt ja die Autoincrease-Funktion von Enigma2. Wenn bei laufender Aufnahme irgendein Timer gelöscht wird, so setzt E2 bei den Timern mit Autoincrease die Endzeit auf die aktuelle Uhrzeit.


    In meinem Beispiel am Montag liefen 4 Aufnahmen, 1 Timer wurde von Hand gelöscht und bei den anderen 3 (stimmt) began schlagartig das Autoincrease.


    Bisschen blöd, das heißt das kann immer wieder passieren, wenn mehr als 1 Aufnahme läuft und ich sage VPS JA, aber nicht vom Sender steuern und Aufnahme 1 läuft aus und Aufnahme 2 läufter aber noch weiter.


    Ist somit VPS ja, vom Sender nicht steuern auch nicht 100% ne gute Lösung, gibt ja so Sender die strahlen mal ne Sendung 1-2min länger aus obwohl Now/Next EPG schon gewechselt ist. Die zusäötzliche Nachlaufzeit durch enigma2 würde dadurch ja ignoriert werden.

    Best Enigma2 Plugins:
    TV Charts Plugin, EPGRefresh, AutoTimer, VPS Plugin, SeriesPlugin

    Edited once, last by muelleimer321 ().

  • Quote

    Bisschen blöd, das heißt das kann immer wieder passieren, wenn mehr als 1 Aufnahme läuft und ich sage VPS JA, aber nicht vom Sender steuern und Aufnahme 1 läuft aus und Aufnahme 2 läufter aber noch weiter.


    In dem Fall tritt das nicht auf. E2 löscht ja automatisch keine Timer.

  • Quote

    Original von sftg


    In dem Fall tritt das nicht auf. E2 löscht ja automatisch keine Timer.


    Ok, kann man bei automatischen Aufnahmen keine Angst haben das die zusätzliche Endzeit verschwindet.


    Aber warum wird beim löschen einer manuellen Aufnahme/Stoppen einer Aufnahme? die andere Timer angefasst?

    Best Enigma2 Plugins:
    TV Charts Plugin, EPGRefresh, AutoTimer, VPS Plugin, SeriesPlugin

  • Hatte jetzt 2x die Woche das Problem, dass keine Timer manuell bearbeitet oder gelöscht wurden während einer Aufnahme und dennoch hat es autoincrease automatisch nachts bei den Timer eingeschaltet und die Nachlaufzeit somit ignoriert.


    Das Ergebnis war bei beiden Aufnahmen fehlte am Schluss das Ende, obwohl Ja (Sicherheitsmodus) ausgewählt war.

    Best Enigma2 Plugins:
    TV Charts Plugin, EPGRefresh, AutoTimer, VPS Plugin, SeriesPlugin

  • Hi.


    Bei mir läuft VPS ziemlich reibungslos und ich bin froh, dass es dieses Plugin gibt. Danke!
    Wird es eigentlich noch weiterentwickelt?
    Ein Problem gibt es nämlich dann doch noch:
    gestern konnte ich beobachten, dass die Box nach VPS-Aufnahmeende ungewollt in den Deep-Standby ging, obwohl das lt. Vorgaben von ElectricPowerSave nicht passieren dürfte.
    Da scheint VPS stärker zu sein ... ;)
    Gibt es eine Chance, das in den Griff zu bekommen?

  • was war im timer eingestellt?


    (was nach die aufnahme passieren soll)

  • und ist die box hochgefahren für die aufnahme?

  • Ja - sie war vorher im Standby und zu Beginn der 2. Aufnahme lief schon eine weitere Aufnahme. Nach Ende von Aufnahme 2 (Aufnahme 1 endete schon vorher) ging die Box dann in den Deep Standby.

  • jetzt wird es lustig :D


    dein profil sagt box und image: siehe signatur :D


    und hast du OE2.0? weil da ist Standby und Deep Standby jetzt Idle und standby :D



    und "ja": also ist hochgefahren
    dann ist es doch normal das die dann wieder im standby geht (also früher deep standby)



    hoffe das ist verständlich ;)

  • Nicht wirklich. ;)
    Die Box war vorher aus, aber nicht heruntergefahren. Und nach der VPS-Aufnahme ist sie dann komplett runtergefahren.
    Bei Nicht-VPS-Aufnahmen macht sie das nicht.

  • dann war die box vorher nicht aus ;)


    und welches image hast du jetzt im einsatz? auf welche Box?

  • Sie war halt nicht ganz aus ... ;)
    Zu Image und Box sage ich jetzt besser nichts, sonst gibt´s Stress. :518:
    Ich vermute halt, dass es ein generelles Problem sein könnte, sonst hätte ich hier auch nichts geschrieben.

  • Hallo,


    bei mir läuft das vps-Plugin seit ungefähr einer Woche nicht mehr rund, ein Drittel der Aufnahmen findet nicht statt, bzw. es wird kurz zuvor aufgenommen und dann nach einer Minute abgebrochen. Vorher konnte ich auf den Sicherheitsmodus verzichten und brauchte die Filme nicht zu schneiden, jetzt geht das kaum noch.


    Ich nehme Sendungen ohne Unterbrechungen bei den ÖR auf, heute abend hat z.B. die dritte Folge von "Top of the Lake" auf ARTE nicht funktioniert. Liegt das an den ÖR, kann das jemand bestätigen oder eventuell an meiner Zusammenstellung?


    DM 8000 mit OE1.6, Enigma2 2012-11-03-3.2, Image: Release 3.2.3 2012-07-07.


    Gruß Alaska