Enhanced Movie Center (EMC)

  • mrvica2
    So hab jetzt auch das Cover angepasst so das es im HD eine Größe hat und das passende no_poster.png aus dem img Ordner läd und bei Fullhd wird jetzt auch ein extra passendes no_poster.png aus dem img_fhd geladen .
    Somit sollte dann auch die Größe bei den nicht DreamOS Image passen.
    Und ich würde auch wenn ihr möchtet das alphatest="blend" wieder mit einbauen so das überall das mit den transparenten icons geht (ohne deine Farbhinterlegungen ;) )
    Wenn ihr mal testen möchtet würde ich das nochmal hochladen und ihr könnt es in einem nicht DreamOS Image mal testen .
    Wie gesagt im DreamOS Image muss das alles nicht sein und man merkt da jetzt auch keinen Unterschied ,es ist nur bei nicht DreamOS Image nötig sowas extra einzubauen daher wenn ihr das möchtet müsst ihr es auch dann selbst testen da ich so ein Image hier nicht habe.

  • Hier bitte teste mal ,wenn das mit den Datein so geht in den älteren Image dann kann ich die screens in den py Datein auch noch anpassen.


    Also hierbei sollten jetzt das Cover bei Fullhd und bei HD passend gehen weil es werden extra für die Skinauflösungen die passenden genommen und die icons und buttons im EMC Movieplayer screen und im EMC Movielisten screen sollten dann auch keine Löcher mehr bei euch erzeugen.
    Testet bitte und berichtet dann würde ich das wie gesagt in den anderen Datein auch noch bei den screens machen.


    Edit. Ist jetzt im emc enthalten ,danke dhwz

  • Zitat: Steht der Cursor auf einem Verzeichnis, werden alle Files in dem Verzeichnis abgespielt (mit Play oder lang Play für Shuffle)


    das habe ich schon erwähnt dass es nicht mehr funktioniert, konnte den Fehler einkreisen, es lag an dem Patch, hier der diff, tut man die alte Datei einspielen, funktioniert es wieder

  • sorry falsch ausgedrückt, ich meinte das Diff, war doch kein Patch, da wollte man bei PlayAll einen Titel zurückspringen können, das Feature ist zwar nett, jetzt geht aber kein PlayAll vom Verzeichnis, wir wollen klar beides, so wie es aussieht kommt das
    self.playlist = [ self.playall.next() ]
    gar nicht zum Zuge, nur wenn der Cursor im Verzeichnis auf einer Datei steht tut es dann, wenn ich die alte EMCMediaCenter.py vom Ende November 2016 zurückkopiere funktioniert dann alles, es liegt definitiv dran, fixen kann ich es nicht, nur Testen

  • Laufen die neuen versionen auch auf OE2.0 oder nur auf OE2.5?

    Viele Grüße vom verrückten Hund


    Sat-Receiver: DM800HD PVR (Merlin3 OE2.0 + Rambo + Gemini 3.2)
    TV: LG 42LW4500
    StreamingClient: PopcornHour A-200

  • natürlich

    DM920, DM8000
    Panasonic TX-43CXW754
    Panasonic SC-ALL30+2x SC-ALL2
    Wavefrontier t55
    8°w, 4/5°w, 0,8°w, 4,8°e, 9°/10°e, 13°e, 16°e, 19°e, 23°e, 28°e
    Standort Wien

  • hab die Änderung im git von betonme nun doch gefunden, hatte selbst diese aber noch nicht auf der Box
    War ja sogar schon am 24.08.2017


    Hab die ganzen letzten Änderungen nicht mitbekommen, da die Versionsnummer nicht verändert wurde. ;(
    https://github.com/betonme/e2o…nhancedMovieCenter.py#L68


    Bei weiteren Änderungen bitte die Version aktualisieren ;)
    Hab da so ein Script, was mir git-Änderungen anhand der Versionsnummer meldet.


    Danke

    Gruß
    Sven

    Edited once, last by Sven H ().

  • Quote

    Original von Sven H
    Bei weiteren Änderungen bitte die Version aktualisieren ;)


    Das hat Fischreiher leider vergessen.
    Aber diese Änderungen von ihm müsste man ja auch noch fixen. Weil dadurch ja das abspielen des ganzen Verzeichnis Inhalts nicht mehr geht.


    Und wenn die Änderungen von zombi soweit ok sind, werde ich wenn ich etwas Zeit habe die mal in's Git schieben.
    Bin selbst noch nicht mal dazu gekommen es aus zu probieren. ;(

  • Dann sollte mal einer der immer rumgeheult hat auch mal schreiben ob die letzten Änderungen so bleiben müssen für alle oe's ,weil dann muss ich nämlich noch die screens in den py Dateien anpassen so das auch die anderen oe's dann zB anständig transparente icons nutzen können.
    Keiner aber echt keiner hat hier was dazu geschrieben aber rumheulen und runterladen ,da soll es einem Spaß machen zu helfen ,nein er nicht.

  • Quote

    Original von Swiss-MAD
    Das hat Fischreiher leider vergessen.
    Aber diese Änderungen von ihm müsste man ja auch noch fixen. Weil dadurch ja das abspielen des ganzen Verzeichnis Inhalts nicht mehr geht. ...


    Also wenn ich bei mir mit dem Update von heute auf einem Ordner bin und dann die Play-Taste drücke, werden die Filme aus diesem Ordner abgespielt.


    Oder ist das Problem ein anderes ?

    Gruß
    Sven

    Edited once, last by Sven H ().

  • Quote

    Original von Sven H
    Also wenn ich bei mir mit dem Update von heute auf einem Ordner bin und dann die Play-Taste drücke, werden die Filme aus diesem Ordner abgespielt.


    Oder ist das Problem ein anderes ?


    Muss ich erst mal bei mir ausprobieren.
    Mach ich dann wenn ich zomis Änderungen ausprobiere.
    Ob es auf OE2.0 auch läuft kann ich dann auf der alten 800se gleich auch machen.
    Mal sehen ob ich heute Abend etwas Zeit finde. :rolleyes:

  • Quote

    Original von zombi
    Keiner aber echt keiner hat hier was dazu geschrieben aber rumheulen und runterladen ,da soll es einem Spaß machen zu helfen ,nein er nicht.


    ich habe es getestet, kann so bleiben, Hauptscreen OK, die Setup Screens (Haupt, Cover, Filelist..) nur kleines Problem mit den bunten Knöpfen (rot, grün, gelb), ist um die drum durchsichtig, ist mir ein Rätsel warum, auch wenn ich in den .py alphachannel="blend" mache, an den .py musst du demnach nichts machen, ist OK so, die anderen Icons werden richtig dargestellt.
    nur das eventuell weg, in CoolSkin/EMCSelection.xml
    shadowColor="black" shadowOffset="-2,-2", bei mir sieht dann der Text in den bunten Knöpfen verfranzt aus, ohne das OK, alles mit HD Skin getestet

  • Die letzten Änderungen wo ich das mit den buttons/icons gemacht habe als test waren ja nur im player und hauptscreen ( movieliste ) deshalb hab ich ja geschrieben das ihr bitte testen sollt und berichten.
    Alle anderen screens muss man in den py Dateien machen und daher wenn du schreibst im hauptscreen geht es und die buttons red ,blue usw. sind dann dort richtig dann muss ich das in den py Dateien auch anpassen und dann sind die in denn anderen emc screens dann auch richtig..
    Im dreamos muss man da halt nix machen das ist da alles ohne solche Einträge richtig daher schrieb ich ja das ich es hier immer richtig habe und nicht sehe ob es bei den anderen oe's halt nicht passt und deshalb brauch ich das feedback sonst habt ihr halt Pech und es kann sich jemand anderes drum kümmern.


    Ich würde dann am we. wenn ich wieder zu Hause bin alle screens so anpassen und dann nochmal alles einstellen wenn halt das im hauptscreen und player alles OK für alle oe's ist.

  • Hallo,


    wollte gerne den Enhanced Movie Center EMC weiter nutzen leider stürtzt dieser immer wieder ab in der dreambox siehe Crash Log


    Könnt Ihr mir weiter helfen?

  • Warst du mit diesem crash nicht auch schon im Newnigma2 Forum?
    Die InfoBarGenerics.py ruft timeshift auf während du in EMC die Taste gelb drückst.
    Das ist sehr komisch.
    Deinstalliere doch bitte mal Permanent Timeshift, und schau ob es immer noch so ist.
    Mit was für einer Funktion ist in EMC die Taste gelb belegt?
    Und was hast du auf Taste gelb im TV Betrieb?

  • Ich hab seit meinem Wechsel auf die aktuelle DM920 mit dem EMC das Problem, dass er den Fortschritt nicht mehr speichert.


    Habe per NFS mein NAS eingebunden, Aufnahmen funktionieren auch soweit 1A.
    Bei der Wiedergabe legt er entsprechende "Cuts" Datei auch an, aber diese bleibt leer. Normal hat die Datei immer ein paar Bytes...


    Habt ihr eine Ahnung woran das liegt?

    Dreambox 920 UHD - 2x Sat 19,2 ; GP4

  • Hi.
    First: thanks for a great plugin.
    Two questions:


    1: why does the blue IMDB button do not work ? (nothing happens)


    2: subtitles, in .srt file, formatted like:

    Code
    1
    00:01:03,040 --> 00:01:07,563
    string 1
    2
    00:01:15,520 --> 00:01:16,091
    string 2


    I can select them using sound and yellow button, but not see them.. any clue ?