Enhanced Movie Center (EMC)

  • Habe aber noch ein Frage,
    wenn ich Mp3´s mit EMC abspiele, wird kein Cover angezeigt, obwohl es im Tag gespeichert ist.

    Image: Newnigma2 V4.0.9

  • Quote

    Original von ebbe sand
    Habe aber noch ein Frage,
    wenn ich Mp3´s mit EMC abspiele, wird kein Cover angezeigt, obwohl es im Tag gespeichert ist.


    Cover aus der .mp3 in den ID3 Tags werden nicht ausgelesen.
    Nur Cover die als Bild vorliegen wie es im 1. Post steht:

  • Hallo,


    ich habe eine kurze Frage. Nachdem vor 2 Wochen die Dreambox nicht mehr starten wollte habe ich neu flashen müssen, seitdem habe ich ein Problem beim Verschieben von Filmen von der internen Festplatte auf eine externe, auch beim Löschen von Filmen aus dem Papierkorb habe ich Probleme. Das ist zuvor nicht aufgetreten...


    Folgendes passiert:
    Nachdem ich einen Verschiebevorgang / Löschvorgang gestartet habe kann ich das aktuell laufende Programm noch schauen, schalte ich nun um tritt eines der folgenden beiden Szenarios auf:
    Das Bild wird schwarz, das OSD wird angezeigt, der Ton wird wiedergegeben. Etwa eine Minute später setzt auch der Ton aus. Wenn ich nun umschalte wird das Bild wieder angezeigt, dann friert erneut etwa eine Minute später das Bild ein, der Ton setzt aus.
    Alternativ dazu tritt die Fehlermeldung auf dass das Tunen fehlgeschlagen ist und ich die Tunerkonfiguration überprüfen soll.


    Hat jemand eine Ahnung wodurch das ausgelöst wird? Wie geschrieben ist das vor dem Flashen nicht aufgetreten. Da ist nur die Steuerung etwas träge geworden aber Fernsehen war nebenbei noch möglich. Jetzt ist die Dreambox komplett unbrauchbar während sie per EMC löscht oder verschiebt.


    Danke im Voraus!

  • Tefrogg


    Welche EMC Version hast du installiert ? Und welche hattest du vorher ?
    Das löschen sollte die Box nie so ausbremsen, ich kann dabei sogar bei meiner alten DM7025 normal zappen.
    EMC löscht ja sogar seit einiger Zeit mit der E2 Löschroutine, die alles in Häppchen löscht um während einer laufenden Aufnahme keine Aussetzer zu produzieren.


    Hast du deine Platte schon mal auf Dateisystemfehler überprüft ?
    Welches Dateisystem verwendest du ?
    Ist der DMA für die Platte aktiviert ? (Müsste man soweit ich mich erinnern mag mit "hdparm" überprüfen können.)

  • Hallo Swiss-MAD,


    danke für deine Antwort!


    Installiert habe ich die aktuelle BETA Version 3.7.4 von der ersten Seite. Die gleiche Version war auch zuvor (als es noch funktioniert hat) in Verwendung.
    Dann musste ich wie gesagt vor zwei Wochen die Box neu flashen (mit dem aktuellen Experimental von DMM) und eine Woche später (also vor einer Woche) habe ich abermals geflasht da unter anderem dieses Problem aufgetreten ist. Da es aber auch jetzt noch auftritt und ich nicht weiß was jetzt anders ist als zuvor...
    Wie gesagt hatte ich nie Probleme damit, wenn ich aber jetzt 50-100GB von intern auf extern kopiere ist die Box für längere Zeit vollkommen unbrauchbar.


    Überprüft habe ich das Dateisystem jetzt über Nacht und es wurden keine Fehler gefunden, also alles okay.
    Das verwendete Dateisystem ist ext3, DMA ist aktiviert soweit ich das jetzt verstanden habe. Es ist eine SATA Platte die sich nicht im IDE Modus befindet, da soll das wohl Standard aktiv sein.


    Hier mal Daten der HDD:
    root@dm7020hd:~# hdparm -tT /dev/sda1


    /dev/sda1:
    Timing cached reads: 370 MB in 2.01 seconds = 184.45 MB/sec
    Timing buffered disk reads: 238 MB in 3.02 seconds = 78.83 MB/sec


    Die externe HDD hat folgende:
    root@dm7020hd:~# hdparm -tT /dev/sdc1


    /dev/sdc1:
    Timing cached reads: 418 MB in 2.00 seconds = 208.92 MB/sec
    Timing buffered disk reads: 240 MB in 3.02 seconds = 79.42 MB/sec


    Ich verstehe es einfach nicht...

  • Ich hab' jetzt mein altes Skin Projekt wieder ausgegraben, weil ich wieder etwas mehr Zeit habe.


    Ich bastle an einem schlanken Skin der ohne selectionPixmap's in div Menüs, Listen etc. auskommt. Aber leider stosse ich beim EMC auf Schwierigkeiten.


    Code
    CoolTitleColor="1" : "1" = damit ist der Filmitel in der selben Farbe wie der Status, "0" = immer in weiss.
    CoolDateColor="1" : "1" = damit ist das Datum in der selben Farbe wie der Status wenn CoolTitleColor="0" ist. "0" = auch in weiss wenn CoolTitleColor="0"
    CoolHighlightColor="1" : "1" = damit ist nur der Selektierte Eintrag in der selben Farbe wie der Status, wenn CoolTitleColor="0" ist


    1. kann man den Flmtitel auch in einer anderen Farbe als weiß und den Statusfarben darstellen?
    2. den selektierten Filmtel möchte ich auch gerne in einer anderen Farbe als weiß und den Statusfarben darstellen


    also etwa so (einfach ein paar Farben zur Veranschaulichung genommen)


    Titel in der Filmliste sollen gelb sein (standard Listen Farbe im Skin)
    die Titel selektiert sollen violett dargestellt werden (statt dem selectionPixmap, standard Farbe im Skin für "selected")


    Die Progressbar soll dann die Farben gelb (ungesehen, also die Farbe der Titel), blau (angespielt), grün (gesehen) und rot bei laufender Aufnahme dargestellt werden.


    mit foregroudColor="'yellow" im EMC widget "list" kann ich die Farbe der Verzeichnisnamen ändern. Durch die Globe Einstellung 'color name="ListboxSelectedBackground" ' wird dann der selektierte Eintrag (also in dem Fall die Verzeichnsise, Lesezeichen etc. im EMC) wie in allen Menüs, Listen etc. in der gewünschten Farbe dargestellt.


    Nur auf die Filmliste hat das leider keine Auswirking. Gibt es eine Lösung, dass so hinzugriegen oder brauchst man weitere Farbdefinitionen im EMC? Wie z.B. "CoolTitleListColor" und "CoolTitleSelectColor"


    Wobei es mir haupsächlich darum geht, einen selektieten Titel in einer anderen Farbe als weiß und den Statusfarben darzustellen.

    Gruß Fred


    Die Dreambox ist tot, es lebe die Dreambox

  • Quote

    Originally posted by Swiss-MAD


    Wie bschaar schon schrieb, oder ein immer aktuelles ipk gibt es auf dem Newnigma2 Feed, das aber mit der Versionsnummer nicht mit denen hier koresspondiert, das dort das ipkg automatisch jede Nacht generiert wird.
    Viel hat sich aber seit der V.3.7.4 nicht geändert.


    Ich habs vom Feed (enigma2-plugin-extensions-enhancedmoviecenter_1.0git20140505-r1_mips32el.ipk), aber wenn ich in das Setup gehe wird die Version als 3.7.4 (die es schon vor mehr als halben Jahr gab) angezeigt, deshalb meine Frage.


    In EnhancedMovieCenter.py steht drin: EMCVersion = "V3.7.4beta20131015"

  • Die Platten scheinen ja in Ordnung zu sein.


    Quote

    Original von Tefrogg
    Installiert habe ich die aktuelle BETA Version 3.7.4 von der ersten Seite. Die gleiche Version war auch zuvor (als es noch funktioniert hat) in Verwendung.


    Das bestätigt eigentlich das es nicht von EMC her führen sollte. :rolleyes:


    Quote

    Original von Tefrogg
    wenn ich aber jetzt 50-100GB von intern auf extern kopiere ist die Box für längere Zeit vollkommen unbrauchbar.


    Starte doch mal einen Kopiervorgang einer .ts Datei mit einem Dateimanager von der Dreambox aus, um zu sehen ob es da auch probleme gibt.
    Oder auch mal von der Console aus.


    Quote

    Original von Tefrogg
    Ich verstehe es einfach nicht...


    Ich wüsste im Moment auch nicht woher das kommt.

  • Quote

    Original von Fred Bogus Trumper
    1. kann man den Flmtitel auch in einer anderen Farbe als weiß und den Statusfarben darstellen?
    2. den selektierten Filmtel möchte ich auch gerne in einer anderen Farbe als weiß und den Statusfarben darstellen


    Ich meine mich zu erinnern, das dies schon mal angesprochen wurde.
    Soweit ich das noch in Erinnerung habe, wird hier die Farbe direkt von EMC bestimmt, und kann nicht über den Skin geändert werden.
    Weil man es so einstellen kann das die Schrift auch die Status-Farbe bekommt.


    Es wäre aber nicht verkehrt, EMC bei zu bringen das man die Farbe über den Skin "überschreiben" kann.
    Dann greift bei verwenden so eines Skin's einfach die Farbeinstellung für den Filmtitel im EMC Setup nicht, wenn man es aber weiss wäre das ja nichts schlimmes. ;)

  • Quote

    Original von Sharky444
    Ich habs vom Feed (enigma2-plugin-extensions-enhancedmoviecenter_1.0git20140505-r1_mips32el.ipk), aber wenn ich in das Setup gehe wird die Version als 3.7.4 (die es schon vor mehr als halben Jahr gab) angezeigt, deshalb meine Frage.


    In EnhancedMovieCenter.py steht drin: EMCVersion = "V3.7.4beta20131015"


    Im Code von EMC steht immer die Letzte Version von EMC die ich veröffentlicht habe.
    Die Versionsnummer erhöhe ich da auch nur dann, wenn ich eine Version hier veröffentliche.
    Da die ipkg's vom NN2 Feed automatisch jede Nacht generiert werden, wird das natürlich übernommen.
    Man kann ja schlecht jede Nacht die Version automatisch erhöhen nur weil ein neues ipkg gemacht wird.


    In dem Fall hast du ja aber im ipkg Dateinamen das Datum drin (in deinem Beispiel 2014.05.05) und so weist du das es auch aktuell ist.
    Auch wenn in EMC immer noch die letzte Versionsnummer von mit drin steht. ;)

  • Hi Leute.
    Ich wollte mal fragen ob es was neues bzgl. des EMC/PLI4 "FATAL: unbindAction with illegal python reference" GS gibt. Weis da jemand Rat oder gibts da schon ne Lösung?

  • Quote

    Original von fidelcastro54
    Hi Leute.
    Ich wollte mal fragen ob es was neues bzgl. des EMC/PLI4 "FATAL: unbindAction with illegal python reference" GS gibt. Weis da jemand Rat oder gibts da schon ne Lösung?


    Keine Ahnung was das für ein Problem mit dem PLI Image sein soll. Noch nie was davon gehört.
    Und solange alles auf dem DMM Image läuft und EMC soweit "sauber" ist, müssen die Image Ersteller nachsehen was sie verdreht haben.

  • Ich möchte einen bug melden, der ziemlich nervig ist ...


    EMC Version: 3.7.4beta20131015 von der 1. Seite


    Ich editiere hin und wieder die .eit und ts.meta von Aufnahmen und Serien und führe Staffel/Eipisode zum Titel hinzu und/oder editierte ich auch die Description.


    Leider stürzt danach EMC immer wieder mal ab, wenn man den Film nur mit dem Cursor in der Fillmliste anwählt, weil die .eit nicht eingelesen werden kann.


    Mit EMC 3.0.0 unter OE1.6 wird beim der selben Aufnahme einfach keine Info angezeigt, E2 crasht nicht und der Film kann abgespielt werden. Mit aktuellem OE2.0 wird hingegen die Film Info der scheinbar "korrupten" .eit im DMM Movieplayer angezeigt - und es crasht auch nichts.



    Mit EMC 3.7.4 ist das echt nervig! Es reicht schon, wenn man durch die Filmliste scrollt und versehentlich auf so einer Aufnahme mit editierter und scheinbar korrupter .eit stehen bleibt - Enigma2 crasht. Scheinbar hängt das mit der Länge der Description zusammen - dann muss man erst die Discription kürzen und die Aufnahme wieder mit EMC testen ...


    Ich häng' mal so eine scheinbar "korrupte" .eit und .ts.meta samt crashlog an. Die .eit und .ts.meta habe ich nur im Titel angepasst. Staffel und Episoden Nr. hinzugefügt (Titel - S10E12) sowie Serientitel und Staffel/Episoden Nr. Diese .eit bringt EMC 3.7.4 zum crashen, mit 3.0.0 wird einfach nichts angezeigt und der DMM Movieplayer kann die .eit korrekt auslesen.


    Ich hab' das auch mit dem default Skin ohne EMC-Screens getestet - crasht auch mit dem EMC default screen ...


    Edit: die .zip sollte ich auch hochladen ... :D

    Gruß Fred


    Die Dreambox ist tot, es lebe die Dreambox

    Edited 4 times, last by Fred Bogus Trumper ().

  • Fred Bogus Trumper


    Ja, dieser Bug ist leider schon lange bekannt, und auch seit 15.04.2012 als Bug-Report gelistet ---> https://github.com/betonme/e2o…ancedMovieCenter/issues/2
    Und wenn du dem Link da folgst, landest du auf dem alten EMC Issue-Tracker (da sollten glaube ich alle lesen können). Da wurde das Problem auch schon genauer unter die Lupe genommen.
    Leider ist das Problem immer noch nicht gefixt. Es ist aber so, das eigentlich der EITitor das .eit File nicht korrekt schreibt, nur sollte EMC wegen einer fehlerhaften .eit nicht gleich die grätsche machen. ;(
    Ich hatte auch schon mal LukaNoah wegen dem Problem in EITitor angeschrieben, und falls er mal ein Update machen sollte, würde er sich das mal ansehen.....sollte er das nicht schon lange wieder vergessen haben......ist schon laaange her. ;)

  • ok, danke fürs feedbach. Gibt es eine Alternative für den EITitdor?


    Ich hatte ja sehr lange - eigentlich bis vor kurzem - auf meinen "Produktiv Boxen" noch OE1.6 Images mit EMC 3.0.0 am Laufen gehabt. Mit EMC 3.0.0 crascte es nicht, wenn man "drüberscrollte", deshalb war mir das nie so aufgefallen, dass da einige leere Infos dabei waren.


    Die meisten fehlerhaften .eits habe ich gefunden, man muss ja nur langsam durch die Verzeichnisse scrollen und warten bis es crasht. Aber lästig und langwierig ist das schon.


    Aber nur an den .eit alleine kann es eigentlich auch nicht liegen. Wie gesagt, im DMM Movieplayer wird die Description, short Description und Sendername, Datum Uhrzeit korrekt auch bei den "faulen" .eit's angezeigt - ohne crash.

    Gruß Fred


    Die Dreambox ist tot, es lebe die Dreambox

    Edited 2 times, last by Fred Bogus Trumper ().

  • Quote

    Original von Fred Bogus Trumper
    ok, danke fürs feedbach. Gibt es eine Alternative für den EITitdor?


    Ich kenne den EdIT - Extensible EIT Editor , verwende aber im Moment nur noch DCC-E2 v1.50 .
    Da wird in der Videoliste (FTP / Recordings) aber NUR die .meta editiert, das reicht mir da ich nur den Titel anpasse.


    Es liegt schon an der .eit, nur darf deswegen EMC nicht gleich einen Crash verursachen.
    Schön wäre es natürlich wenn EMC den Fehler in der .eit ignorieren würde und die Infos dennoch auslesen.
    Das müsste halt wer umprogrammieren....freiwillige vor....ich kann das leider nicht.

  • Guten Morgen,


    sorry für die späte Rückmeldung. Zu meinem Problem kann ich mittlerweile etwas sagen.


    Das Problem wird verursacht durch volle Auslastung der CPU beim Verschieben einer Datei von der internen Festplatte auf eine externe. Beides SATA Festplatten. Die Externe ist dabei per eSATA mit der Dreambox verbunden. Wenn ich mir per "top" über Telnet anzeigen lasse was hier passiert so lastet der Befehl "mv" die CPU über den gesamten Verschiebevorgang vollkommen aus. Beide Dateisysteme sind ext3, der Geschwindigkeitstest ist jedoch auf beiden Festplatten gleich gut, wie ich bereits geschrieben habe. Das Problem tritt beidseitig auf, also sowohl beim Verschieben von der Externen, als auch beim Verschieben auf die Externe.


    Die Schreibgeschwindigkeit beider Festplatten liegt bei intern 40.X MB/s und extern 44.X MB/s weshalb ich hier irgendwelche Emulationen ausschließen möchte.


    Wenn ich die gleiche 10 GB Datei nun aber per Datei Browser vom BP verschiebe findet auch eine massive CPU Auslastung statt (von 90-135%), allerdings innerhalb von Enigma2 bei KEINERLEI Problemen beim Umschalten, Aufnahmen wiedergeben, ...


    Die Performance ist eingeschränkt, aber nur minimal, es kommt niemals zu Problemen bei der Wiedergabe, die Umschaltzeiten sind minimal verschlechtert.
    Das Problem tritt offenbar nur dann auf wenn ich EMC zum Verschieben auf die externe Festplatte verwende.


    Hast du eine Ahnung was es damit auf sich haben könnte? Eine Option für den Enigma2 Kopier-, Lösch- und Verschiebemodus gibt es innerhalb von EMC ja nicht, oder?


    Vielen Dank für die Hilfe!

  • Hallo,
    ich möchte meine EMC Einstellungen auf eine andere Box übetragen.
    Werden diese unter /etc/enigma2/settings abgespeichert oder
    gibt es weitere config Dateien?


    Vielen Dank im Voraus

  • Quote

    Original von detchaos
    Werden diese unter /etc/enigma2/settings abgespeichert oder
    gibt es weitere config Dateien?


    Ja, die Einstellungen werden in der E2 settings gespeichert, es gibt aber noch ein paar Sondersettings wie Bookmarks, Permanente Sortierung, etc. die alle /etc/enigma2/emc-*****.cfg lauten.