Anleitung für dFlash

  • Hier findet ihr immer die neueste Anleitung für dFlash.


    Wenn ihr Fehler findet, Anregungen habt, .. Immer her damit!;)


    Dank blu8 gibt's Le istruzioni dFlash auch in Italienisch


    viele Grüße
    wysiwyg




    Derzeit sind die Neuerungen bis zur Version 7.1.1 eingearbeitet.


    NEU: (6. Aug. 2012)
    - alle Neuerungen/Anpassungen von dFlash an OE 2.0
    Dies betrifft vor allem die Änderungen der Flash- und Backup-Tools
    NEU: (28. Mai 2012)
    - neueste Entwicklungen in dFlash 5.x für OE 2.0
    NEU: (15. Apr. 2012)
    - alte Zöpfe abgeschnitten.;)
    NEU: (22. Feb. 2012)
    - alles rund um das neue writenfi
    NEU: (16. Feb. 2012)
    - neues writenfi und die Konsequenzen + kleinere Änderungen
    NEU: (11. Jan. 2012)
    - Anleitung zum Erstellen von Bootlogs (auf der DM8000) ergänzt.
    NEU: (10. Dez. 2011)
    - alte, in der neuen Version nicht mehr gültige Textstellen überarbeitet.
    NEU: (8. Dez. 2011)
    - Überarbeitet: Die Beschreibung der Verwendung einer sog. RAM-Disk (ramfs), welche das Flashen von NAS-Ressourcen ermöglicht.
    - Neufassung des Abschnitts Nur überschreiben des Images

  • Na gut ,dann will ich mal was dazu beitragen in der PDF steht :


    Quote

    Für Images mit Loader #76 sollte dFlash 0.44 verwendet werden, für alle neueren Versionen ist eine dFlash Version > 0.44 erste Wahl.


    Es gibt aber nur die :


    Quote

    enigma2-plugin-extensions-dflash_0.61_mi psel.ipk


    ..und jetzt ,denke das das egal ist ,oder?

  • Was auch cool wäre, wenn die Anleitung im Wiki verfügbar wäre ;)


    Das habe ich auch noch gesehen.Bei der manuellen Installation
    hast du einen vetippsler drinnen (opk). Oder hast du mal den Namen geändert?


    Könntest es auch so machen das installieren, da ja das Ding in /tmp liegt nach dem kopieren,anhand der Anleitung. Auch spielt die Version keine Rolle bei der Installation.


    Code
    opkg install /tmp/enigma2-plugin-extensions-dFlash*



    Im Bildchen vom deinstallieren ist auch noch ein kleiner Fehler drinnen.
    Mit den ipkg Befehlen die doppelt sind.


  • nein, das ist nicht egal, die Versionen > 0.44 benötigen einen Loader #8X.

    Viele Grüße
    Jürgen


    "Kaum macht man es richtig, .... schon geht es!"


    "Machen ist wie wollen, nur krasser!"

  • Eigentlich für gutemine:)


    Flashing with this plugin completely with your own risk!!!!

  • siehste,das heisst mit der 0.61 könnte ich sichern mit einem SSL 76 ?


    Und über dem 76 SSL braucht man die 0.44 er Version..?

  • So stimmt das aber nicht :-)


    Für die neuen Loader solltest du das neue writenfi verwenden das nur im aktuellen dFlash drinnen ist. Damit kannst du aber AUCH alte Images/Loader flashen.


    Solange du also NUR alte images flashen willst mit Loader 76 reicht auch das alte dFlash, nur wenn du neue Images flashen willst solltest du das NICHT mehr verwenden.


    Daher biete ich auch die alten dFlash Versionen nicht mehr an und supporte auch nur mehr das aktuelle.


    Und mit dem sichern hat das erst recht nichts zu tun, dFlash verwendet immer den Loader der im Flash ist und packt Ihm ins nfi.

    Edited 3 times, last by gutemine ().

  • Quote

    Original von Benq2705
    Es gibt aber nur die : enigma2-plugin-extensions-dflash_0.61_mi psel.ipk
    ..und jetzt ,denke das das egal ist ,oder?


    Die Loaderabhängigkeit ist druchaus gegeben. Auf dem Feed gibt es daher immer noch die 0.44. Ich werde es in der nächsten Version der Anleitung ändern.


    vielen Dank auch an alle anderen für die Anregungen. Morgen Abend werde ich wohl die Zeit finden, die Anleitung zu überarbeiten.


    viele Grüße
    wysiwyg

    Kernenergie, die todsichere Garantie für eine strahlende Zukunft. :rot:

    Edited once, last by wysiwyg ().

  • Die Anleitung ist aktualisiert. Danke für eure Hinweise.


    viele Grüße
    wysiwyg

    Kernenergie, die todsichere Garantie für eine strahlende Zukunft. :rot:

    Edited once, last by wysiwyg ().

  • Hallo allerseits,


    an diesem Wochende war gutemine sehr erfolgreich: Die 7025 Besitzer können sich freuen, dFlash funktioniert nunmehr auch auf ihren Boxen. Alle übrigen finden ein weiter optimiertes dFlash vor.


    viele Grüße
    wysiwyg


    Die Anleitung für dFlash (Stand: 27. März 2011) findet ihr im ersten Beitrag.

    Kernenergie, die todsichere Garantie für eine strahlende Zukunft. :rot:

    Edited 2 times, last by wysiwyg ().

  • Danke - eine gute Idee.


    Den Text habe ich etwas überarbeitet in der Hoffnung, dass der Leser besser erkennt, was für eine tolles Plugin gutemine's dFlash ist.


    viele Grüße
    wysiwyg

    Kernenergie, die todsichere Garantie für eine strahlende Zukunft. :rot:

  • Es gibt eine neue Anleitung mit Tipps, wie man mit dFlash in Verbindung dem GP3 Settingsmanager Plugin seine Box in nur drei Schritten vollständig aktualisieren kann.


    viele Grüße
    wysiwyg

    Kernenergie, die todsichere Garantie für eine strahlende Zukunft. :rot:

  • Ich hab das Plugin gerade mal auf meiner 500hd mit aktuellem iCVS getestet. Egal, ob ich es über die Einstellungen aufrufe, oder über das Webinterface, es klappt nicht.


    Ich möchte mein Image auf ein NAS sichern, das gemountet ist. Beim Sicherungsversuch wird das Verzeichnis angelegt, dann dort ein swapfile und in der folge die einzelnen Files der Partitionen. Dann bootet die Box und hinterlässt folgende Files im Backup-Ordner:


    Code
    root@dm500hd:/media/net/STORAGE2/FlashBackup# ls -alh
    drwxrwxrwx 1 root root 0 Apr 8 20:40 .
    drwxrwxrwx 1 root root 0 Apr 8 20:37 ..
    -rwxrwSrwt 1 root root 2.4M Apr 8 20:40 boot.jffs2
    --wx---r-- 1 root root 48.0M Apr 8 20:42 root.jffs2
    -rwxrwSrwt 1 root root 138.9K Apr 8 20:40 secondstage.bin
    -rwxrwSrwt 1 root root 127.0M Apr 8 20:40 swapfile


    Es wird aber kein NFI erzeugt.


    Noch eine kleine Anmerkung, in der Anleitung steht, man erreicht das Webinterface über /dFlash was aber nicht geht, weil es /dflash heißen muss.

    Meine Boxen:
    [list=1][*]1 mal Dreambox 500hd
    [*]4 mal Dbox2 Sagem1i (davon 2 mit sonderbarem Defekt)
    [*]1 mal DVBS-Karte
    [/list=1]

  • dann soltlest du ENDLICH die aktuelle dFlash Version verwenden und Plugin Probleme im Plugin Thread posten

  • Quote

    Original von gutemine
    dann soltlest du ENDLICH die aktuelle dFlash Version verwenden und Plugin Probleme im Plugin Thread posten


    Sorry, ich hab das Plugin über BluePanel installiert und hier oben im ersten Post steht "Wenn ihr Fehler entdeckt, Ergänzungen möchtet oder Fragen habt, dann bitte hier in den Thread reinschreiben!"

    Meine Boxen:
    [list=1][*]1 mal Dreambox 500hd
    [*]4 mal Dbox2 Sagem1i (davon 2 mit sonderbarem Defekt)
    [*]1 mal DVBS-Karte
    [/list=1]

  • Übers BP kriegst duleider immer noch nur Version 0.44 - wir sind derzeit bei 0.91


    Und den Dokufehler darfst du hier ja reporten :-)

    Edited 2 times, last by gutemine ().