webradioFS 14.xx - Plugin für Radio (Internet, Sat, Kabel) und Audio, mit webinterface

  • m0rphU
    ich schau nochmal, bin nun aber wirklich recht ratlos



    Quote

    Lediglich das kleine Fenster bei FullHD-Skins stört


    also bitte :rolleyes: ich bin kein skinner und habe keine derartige Box, wie sollte ich das machen?


    edit:
    falls es als info was bringt, ich pack das auf mint 17 einfach mit dpkg-deb -b

    Edited once, last by shadowrider ().

  • FullHD geht doch auch auf alten Boxen. Außerdem habe ich ja nicht zwingend dich angesprochen ;)
    Ist das denn vom Code möglich, das zu skinnen? Im Plugin-Ordner finde ich nur Screens für SD, XD und HD.


    Zum deb-File: Kannst du mal eine Version ohne die postinst und postrm scripte erstellen? evtl. sind die ja schuld, dass das deb nicht korrekt entpackt wird.
    Interessanterweise wird beim Installieren des Pakets auch der von mir vorher manuell kopierte Ordner entfernt.

    so long
    m0rphU



    :aufsmaul: Kein Support per PN! :aufsmaul:

  • 1. danke für endlich mal fundierte Rückmeldung!


    hab ne Idee - könnte es sein, das es am Besitzer der dateien liegt? ich habe das ja nicht unter root gemacht gehabt


    der manuelle Ordner wird entfernt, weil die install-routine ja funktioniert - evtl ist der ganze kram woanders auf der Box??


    Quote

    Ist das denn vom Code möglich, das zu skinnen? Im Plugin-Ordner finde ich nur Screens für SD, XD und HD


    da bei euch ja wohl HD greift, muss erstmal dieser skin "vergewaltigt" werden, falls es etwas gibt baue ich es gerne mit ein (bräuchte dann die Höhe/Breite vom Full-Hd

  • hab das mal als root gebacken, evtl deshalb?


    edit, Datei entfernt

    Edited once, last by shadowrider ().

  • Top! Das wars :hurra: Also mit der als root gepackten deb klappt alles! Danke :)


    Edit: Oh verdammt, nicht genau hingeguckt. In der deb fehlen ja die Unterordner... Also läuft das Plugin so auch nicht. Aber, wenn alles im Paket enthalten wäre, gäbe es wohl kein Problem mehr :D

    so long
    m0rphU



    :aufsmaul: Kein Support per PN! :aufsmaul:

    Edited once, last by m0rphU ().

  • na dann weiß ich Bescheid - und ihr solltet mal auf der box schauen, ob da nicht die Dateien woanders gelandet sind und Platz verschwenden...


    edit:
    neue *.deb ist online verfügbar ;)

    Edited 3 times, last by shadowrider ().

  • Wunderbar, jetzt ist auch alles enthalten. Wurde installiert, bis auf die genannten Skin-Probleme (zIndex beim Löschen von Streams und ausstehende FullHD-Anpassung) konnte ich nix fehlerhaftes mehr finden :top:


    FullHD: Das ist die Auflösung 1920x1080. Beispielhaft kannst du dir ja mal meine Anpassungen im MEPGC ansehen: http://schwerkraft.elitedvb.ne…df800509e17e5fd6c40c79f21
    Ich werde mal vorübergehend gucken, dass ich den integrierten HD-Skin anpasse. Das Hauptproblem, das ich gerade habe ist dass das Fenster seltsamerweise nach oben verschoben ist (Overscan am TV ist deaktiviert). Werde das mal untersuchen, wenn ich nicht weiter komme, beschreibe ich das nochmal genau ;)


    Und Platz hab ich doch genug auf der 7080 :P Ich hatte aber schon kurz gesucht und keine Leichen gefunden:


    Code
    root@dm7080:/# find -name webradioFS.pyo
    ./usr/lib/enigma2/python/Plugins/Extensions/webradioFS/webradioFS.pyo
    root@dm7080:/#


    Evtl. hatte auch das "apt-get remove enigma2-plugin-extensions-webradiofs" geholfen...

    so long
    m0rphU



    :aufsmaul: Kein Support per PN! :aufsmaul:

    Edited once, last by m0rphU ().

  • klingt doch schon mal gut =)


    Quote

    zIndex beim Löschen von Streams


    wird das ganze meldefenster nicht angezeigt oder nur der Text nicht? kannst mal screenshot machen? andere meldungen werden richtig angezeigt?


    Quote

    Ich werde mal vorübergehend gucken, dass ich den integrierten HD-Skin anpasse

    wenn du mir das dann gibst, baue ich es mit ein - dann können wir gleich testen ob online-update nun auch funktioniert (sollte ab der 12.65, bin aber nicht sicher)


    Quote

    Und Platz hab ich doch genug

    habe ich auf keinem meiner Geräte ;)

  • Quote

    Original von shadowrider
    wird das ganze meldefenster nicht angezeigt oder nur der Text nicht? kannst mal screenshot machen? andere meldungen werden richtig angezeigt?


    Das ganze Fenster ist nicht zu sehen. Auf dem Screenshot im Anhang bearbeite ich einen Stream und habe dann nochmal blau gedrückt, aber das Abfrage-Popup bekomme ich garnicht zu Gesicht.
    Wo könnten noch andere Popups sein? Kenne das Plugin wie gesagt nicht ;) Mir ist aber noch nix aufgefallen außer der einen Abfrage, aber alle anderen Screens sind ja auch große Fenster.


    Quote

    Original von shadowrider
    wenn du mir das dann gibst, baue ich es mit ein - dann können wir gleich testen ob online-update nun auch funktioniert (sollte ab der 12.65, bin aber nicht sicher)


    Mal sehen, was ich da so hinbekomme. Im Moment irritiert mich nur, dass das Fenster nach oben verschoben ist, obwohl im HD-Skin eine positive y-Koordinate angegeben wird.

    Files

    • screenshot.png

      (78.21 kB, downloaded 236 times, last: )

    so long
    m0rphU



    :aufsmaul: Kein Support per PN! :aufsmaul:

  • gibt ne ganze Menge derartige Ansagen, Aufnahme aus der genre-Ansicht, rec beenden usw.


    da wird aber offensichtlich der Dialog nicht angezeigt :rolleyes:

  • So nu kann ich wieder mit testen, welche .deb muss ich den nun installieren? Irgendwie mag dies bei mir nicht funktionieren egal ob ich die .deb von hier oder die auf der HP verwende!

  • Quote

    Irgendwie mag dies bei mir nicht funktionieren


    bei irgendwie -Problemen kann ich leider nicht helfen

    Edited once, last by shadowrider ().

  • - Beide Versionen installiert
    - Fehlermeldung keine
    - unter Erweiterungen taucht es aber nicht auf
    - ja Box wurde neu gestartet


    "dpkg --install *.deb; echo ">>> DONE <<<";


    Preparing to unpack enigma2-plugin-extensions-webradiofs_12.65_all.deb ...


    Unpacking enigma2-plugin-extensions-webradiofs (12.65) over (12.65) ...


    Setting up enigma2-plugin-extensions-webradiofs (12.65) ...
    install webradioFS"

  • shadowrider nun irgendwie heißt nun mal irgendwie :hurra:
    So aber ich mach es kurz, den so wie bei pille war es bei mir auch!


    Deshalb ja auch meine Frage welche .deb sollte man verwenden, da mit beiden(Anhang hier & von deiner HP) dies nicht funktionierte.

  • da kann ich nichts dazu sagen - bei m0rphU hat es offenbar ordnungsgemäß funktioniert
    (die Version von meiner Seite - kann man aber nachlesen hier wenn man den Thread verfolgt, die andere nehme ich gleich raus)


    Quote

    irgendwie heißt nun mal irgendwie


    es gibt die Möglichkeit für aussagekräftige Infos, nach denen ich Änderungen versuchen kann - oder jemand stellt mir eine solche Box zur Verfügung und ich kann das selber austesten
    mit ohne gar nix kann ich auch nix ändern ;)

  • Ach shadowrider nicht immer alles so verbissen sehen :tongue:
    Wie gesagt habe es mit beiden getestet gehabt, aber trotzdem wollt es nicht. Keinerlei Fehlermeldungen beim installieren bekommen wo man hätte ansetzen können!


    Die .deb auf deiner Seite ist noch die vo gestern oder eine neue?

  • Quote

    nicht immer alles so verbissen sehen

    rein sachlich, nicht mehr und nicht weniger


    Quote

    Die .deb auf deiner Seite ist noch die vo gestern

    ja - schmeiß mal alles runter, auch die fav und conf, kompletter neustart und dann neu installieren

  • Och mönne immer alles so sachlich macht doch keinen Spaß :tongue:
    Ja kann dies aber erst später testen.

  • ob du es glaubst oder nicht - ich empfinde dabei auch sowas wie Verantwortungsgefühl, zumindest was crash betrifft
    würde es pers. nicht lustig finden wenn mir die Box z.B. bei einer Aufnahme wegcrasht - also möchte ich das möglichst auch niemand anderem zumuten
    (und wenn es Spaß macht, dann schreib mal schön beim nächsten mal soviel Details wie möglich, damit mir der meine daran nicht vergeht :aufsmaul:)
    .
    .

  • Habe es extra nochmal getestet.


    "apt-get remove enigma2-plugin-extensions-webradiofs" -> Alles weg, Reboot -> Kein WebRadioFS unter den Erweiterungen


    Paket von der Website per FTP nach /tmp/ und dann "debinstall" (das geht nur im Merlin4 ;) ) -> Alle Dateien da, Reboot -> Plugin lässt sich starten :hurra:


    träumer78: Hast du das Paket nochmal von der Website geladen und auch mal die alte Version deinstalliert? Die Versionsnr. wurde nicht geändert, aber das Paket wurde ja vorgestern ausgetauscht. Vllt. hast du noch die alte Version auf der Festplatte. Oder dpkg will nicht updaten, weil die Version nicht erhöht wurde (daher mal deinstallieren vor dem debinstall).

    so long
    m0rphU



    :aufsmaul: Kein Support per PN! :aufsmaul: