webradioFS 14.xx - Plugin für Radio (Internet, Sat, Kabel) und Audio, mit webinterface

  • nochmal.
    dein Image ist von 09/2014 = neu
    in dem Image, von welchem dein crashlog stammt, sind Änderungen drin welche im Plugin nicht berücksichtigt sind.
    Diese Änderungen können nicht berücksichtigt werden, weil mir die Informationen dazu nicht zugänglich sind.


    flashe ein Image von z.B. Anfang des Jahres und du wirst diesen Crash nicht haben!


    um das nochnmal klarzustellen: meine Projekte sind Freizeitarbeit, Hobby.
    Bedeutet, der Zeitaufwand muss in einem vertretbaren Rahmen bleiben, die Kosten dürfen die jetzigen laufenden nicht übersteigen (ich bekomme dafür von niemandem etwas), und ich werde mit absoluter Sicherheit keine Fremdprogramme decompilieren um z.B. an bestimmte Informationen zu kommen.
    Ich habe hier jahrelang immer wieder versucht, meine Plugins an die Besonderheiten so gut wie möglich anzupassen.
    Da aber derzeit dafür keine Möglichkeit für mich besteht, kann ich meine Plugins nicht auf diese Images anpassen.


    Potenzierend kommt dazu, das positives feedback allenfalls vereinzelt stattfindet - wenn es keine Probleme gibt dann ist's gut und ich darf es daran erkennen, das nichts gepostet wird - motiviert sowas von gar nicht da etwas zu machen. Da widme ich mich doch Aktivitäten, die mir Freude machen oder wo etwas dabei rauskommt.... ;)

  • Nichts für ungut. Hätte ja sein können, daß irgendwas mit meinem System nicht stimmt.
    Ich schätze jedermans Arbeit.

  • @shadowrider: Der Crash tritt auf einem OE 2.0 Image auf. Die von dir angesprochenen Änderungen beziehen sich aber nur auf OE 2.2.


    Der folgende Crash ist irgendwas anderes:

    Code
    Traceback (most recent call last):
    File "/usr/lib/enigma2/python/Components/ActionMap.py", line 46, in action
    res = self.actions[action]()
    File "/usr/lib/enigma2/python/Plugins/Extensions/webradioFS/webradioFS.py", line 935, in live_tv
    File "/usr/lib/enigma2/python/Plugins/Extensions/webradioFS/webradioFS.py", line 6928, in start
    AttributeError: 'eVideoWidget' object has no attribute 'setOverscan'
    (PyObject_CallObject(<bound method HelpableActionMap.action of <Components.ActionMap.HelpableActionMap instance at 0x262faf8>>,('wbrfsKeyActions', 'pvr')) failed)
    ]]>


    Und wenn dir Infos zum aktuellen E2 oder DreamOS fehlen, kannst du doch einfach im IRC vorbeigucken. Ich bin sicher, dass dir da jemand helfen kann :)

    so long
    m0rphU



    :aufsmaul: Kein Support per PN! :aufsmaul:

  • Hallo shadowrider


    Auch ich schätze Deine Arbeit, vor allem das webradioFS.
    Ich muss Dir leider sagen das ich zZ Vers. 12.46 nutze. Damit habe ich keine Prob.
    Kann zwar den Startstream und Bildschirmschoner auf 30s ncht speichern, aber ich kann es bediehnen.
    Die Meldung mit dem GStreamer kommt von den neueren Änderungen im Image. Da kannst Du nichts ändern und das akzeptiere ich ja auch.

    Files

    • FS.png

      (25.72 kB, downloaded 318 times, last: )

    Gruß Rabevater
    Merlin+GP3 zombi HD1R3 / Farbdisplay

    Edited 3 times, last by Rabevater ().

  • mehrere Punkte:


    nach wie vor, ".instance.setOverscan" ist bereits seit langer Zeit und vielen Versionen vorhanden - wie kann es sein das es nun plötzlich crasht?


    dieser crash kann definitiv nicht beim start ausgelöst werden, vom Posten also etwas merkwürdig (zumal er ja viele crash's hat und ich fröhlich raten könnte) - wenn aber derart schnell "ich nehme etwas anderes" kommt dann lohnt der Aufwand nicht


    Quote

    kannst du doch einfach im IRC vorbeigucken. Ich bin sicher, dass dir da jemand helfen kann

    wie stellst du dir das vor, weiter so wie bisher?
    ich bekomme meldung über crash, frage nach der entsprechenden Funktion, ändere diese ab, bekomme nächste crash-Meldung, usw... :rolleyes:


    ich hatte nach den Hinweisen die e* welche im Git erkennbar waren angepasst, aber offenbar gibt es da weitaus mehr,
    und weder mag ich auf eine derartige Art rumstückeln noch täglich x Meldungen mit "ist abgestürzt" haben bis nach der 500 Anpassung es evtl läuft


    Rabevater
    ich kann leider nichts beheben/anpassen, ohne eindeutige Informationen
    wenn ich auf meine (nach-)Fragen keine Antwort bekomme bin ich hilflos, dann muss es bleiben wie es ist (das was ich testen kann teste ich, das was ich nachstellen kann behebe ich - alles andere liegt beim geneigten User

    Edited once, last by shadowrider ().

  • Zum positiven Feedback: Ich habe auf der 8000HD Image von 11-2014 und aktuelles WebradioFS und es crashed nix. Die Meldung mit dem gstreamer kommt bei einigen Sendern. Ich teste aber auch zwischendurch nichts, wenn es nicht sein muss.
    Gruß, Renard

    Es ist Zeit, dass der Stein sich zu blühen bequemt... (Paul Celan)

  • Die Frage, wie nutzt du das radio?`Kannst Fav.anlegen , Streams in deinen Ordnern speichern? Welches Image nutzt Du wenn ich fragen darf?

    Gruß Rabevater
    Merlin+GP3 zombi HD1R3 / Farbdisplay

  • Image ist Original, und ich höre nur Radio, ich lege nichts an und speichere nichts.

    Es ist Zeit, dass der Stein sich zu blühen bequemt... (Paul Celan)

  • Quote

    Heizölpower Zitat: Welche GStreamer Variante ich denke nicht, dass du da so einfach austauschen kannst, denn viel wichtigere Funktionen im system benötigen den und sind auf die vorhandene Version abgestimmt __________________ .


    THX


    und bei dieser Gelegenheit " Vielen Dank" für das geniale Plugin. Bei mir crasht auch nichts, aber ich höre auch nur den stream und speichere nichts.
    Vielleicht bringst Du mal eine gaaanz einfache Version raus, die nur wenige Funktionen hat und bei allen läuft ?!


    LG

    Meine aktuellen Boxen: DM 7080 HD, DM 500 HD mit USB, 2x 820 HD, VU+ solo²;
    ausgemustert: DM 7020, DM 500s, DM 800 HD, Xtrend 4000

  • Quote

    Vielleicht bringst Du mal eine gaaanz einfache Version raus, die nur wenige Funktionen hat


    ohne dir zu nahe treten zu wollen - aber das ist doch totaler Blödsinn
    stelle deine Streams in favoriten rein und nutze das programm - nichts weiter braucht es und einfacher geht es nicht


    unkomplizierter und einfacher geht es nicht, wer hindert dich es so zu nutzen?
    wie kommst du darauf, irgendwelche Funktionen nutzen zu müssen - wo du doch gerade schreibst du würdest es nicht tun?



    Nachtrag:
    das es überall läuft? ich bin es nicht, der die Unterschiede schafft
    habe 0 Anteile an dem Auseinanderdriften der Plattformen und Images - also bitte an der richtigen Stelle ansetzen


    edit:
    mal nachgefragt, weil ich es absolut nicht verstehe:
    ihr hangelt euch bei jedem Start durch die genres um dann einen Sender abzuspielen?
    warum, wenn ich fragen darf, macht ihr es so kompliziert?

    Edited 3 times, last by shadowrider ().

  • auf meiner Seite habe ich mal ein deb-File zur Verfügung gestellt
    da ich es nicht testen kann, benötige ich feedback um dies künftig zu unterstützen




    zur Information:


    wer Hilfe/Support wünscht, möge mir eine anständige Fehlerbeschreibung geben und wenn möglich ein crashlog anhängen.


    Für User welche es nicht für sinnvoll halten, auf meine (Nach-) Fragen zu antworten, halte ich es nicht für sinnvoll mich in meiner Freizeit weiter damit zu beschäftigen.
    Weder erlaubt mein Budget den Kauf weiterer Modelle, noch erlaubt es meine Zeit, alle Arten von Images mit jeweils hunderten möglicher Einstellkombinationen (möglicher! nicht notwendiger!) zu testen.
    Wenn 5 min zuviel sind um eine ordentliche Fehlerbeschreibung zu posten - warum sollte ich mich stundenlang dransetzen?


    (und mal ehrlich: niemand hier würde im richtigen Leben immer wieder versuchen, Menschen zu helfen welche generell nicht antworten - oder denen gar laufend was schenken....)


    wer am Programm Änderungsvorschläge hat, möge es konstruktiv einbringen, seit Jahren habe ich immer wieder auf Userwünsche reagiert...
    (egoistische Kommentare, z.B. was alles aus dem Programm kann weil es jemand nicht benötigt, werden zukünftig ignoriert - ich selbst benötige etwa 70% der auf Userwunsch vorhandenen Funktionen nicht)


    ob und wie ich mich hier künftig weiter einsetze, liegt also beim geneigten user ;)

  • Quote

    Traceback (most recent call last): File "/usr/lib/enigma2/python/mytest.py", line 741, in <module> runScreenTest() File "/usr/lib/enigma2/python/mytest.py", line 636, in runScreenTest runReactor() File "/usr/lib/enigma2/python/mytest.py", line 178, in runReactor reactor.run(installSignalHandlers=False) File "/usr/lib/python2.7/site-packages/twisted/internet/base.py", line 1192, in run self.mainLoop() File "/usr/lib/enigma2/python/e2reactor.py", line 209, in mainLoop runMainloop() File "/usr/lib/enigma2/python/enigma.py", line 5489, in __call__ return ret(*args, **kwargs) File "/usr/lib/enigma2/python/Components/ActionMap.py", line 62, in action res = self.actions[action](int(action)) File "/usr/lib/enigma2/python/Plugins/Extensions/webradioFS/webradioFS.py", line 802, in keyNumberGlobal TypeError: 'NoneType' object has no attribute '__getitem__' (exit code 5)


    DB 7080
    - Update nicht möglich
    - Steuerkreuz und Zehnertastatur gibts einen grünen

  • Quote

    Update nicht möglich

    heißt was? gibt es Ausgaben im Telnet?


    ist eine Fav-Datei vorhanden? wo liegt die?

  • Quote

    ohne dir zu nahe treten zu wollen - aber das ist doch totaler Blödsinn stelle deine Streams in favoriten rein und nutze das programm - nichts weiter braucht es und einfacher geht es nicht unkomplizierter und einfacher geht es nicht, wer hindert dich es so zu nutzen? wie kommst du darauf, irgendwelche Funktionen nutzen zu müssen - wo du doch gerade schreibst du würdest es nicht tun?


    @shadowrider, da hast Du mich missverstanden oder mit einem anderen User verwechselt.


    Ich nutze das Programm gelegentlich und habe damit überhaupt keine Probleme. Lediglich die gstremer-Meldung tritt bei einigen Sendern auf. Für mich kein Grund zur "Beschwerde"; ich hatte auch nur nachgefragt, welche gstreamer-version die richtige ist.


    Mit dem Vorschlag einer einfachen Programmvariante wollte ich nun dir nicht zu nahe treten, sondern auf die user reagieren, die bei irgendwelchen Funktionen (die ich nicht nutze) Abstürze verzeichnen.
    Das war auch nicht im Entferntesten als Kritik zu verstehen.


    Bei dem Hinweis auf das Abspeichern der streams hast du mich möglicherweise verwechselt, denn ich hatte derartiges nicht angesprochen.
    Ich habe - wie gesagt - bei meiner 500HD keine Probleme mit deinem plugin.


    LG

    Meine aktuellen Boxen: DM 7080 HD, DM 500 HD mit USB, 2x 820 HD, VU+ solo²;
    ausgemustert: DM 7020, DM 500s, DM 800 HD, Xtrend 4000

  • Quote

    Mit dem Vorschlag einer einfachen Programmvariante wollte ich nun dir nicht zu nahe treten

    wieso mir? ich nutze das meiste davon auch nicht, ist auf Userwunsch eingebaut - und mehrere versionen kann ich zeitlich nicht bewältigen


    Quote

    Das war auch nicht im Entferntesten als Kritik zu verstehen

    selbst wenn, ich geb da meinen Senf dazu ;)


    Quote

    Ich habe - wie gesagt - bei meiner 500HD keine Probleme mit deinem plugin

    hoffe es gilt auch für 12.61 :)

  • Hallo shadowrider


    Ich jabe jetzt die aktuelle 12.63 installiert. Bis jetzt alles, so wie ich es nutze super.
    Vielen Dank.


    An wen muss ich mich direkt wenden wegen des GStreamer Prob. bei den Sendern?

    Gruß Rabevater
    Merlin+GP3 zombi HD1R3 / Farbdisplay

  • Quote

    Vielen Dank.


    der Dank gilt eher dem User maithai, von welchem ich gestern die notwendigen Fehlerbeschreibungen und Infos bekommen habe


    Quote

    An wen muss ich mich direkt wenden wegen des GStreamer Prob.


    Gstreamer ist in deinem Image enthalten und wird für viele weitere Funktionen genutzt - hat nichts mit den Sendern zu tun