Lost in Translation

  • Die muss auf Blau im Plugin aber dasein wenn du ein OoZoon image im Flash hast wo der initramfs Patch drinnen ist.

  • Schau ich mir morgen nochmal an...
    Im Moment habe ich gerade Newnigma im Flash zum Fernsehen...
    Danke erstmal...
    P.S. der log war aber mit Oozoon.

  • Zwei kurze Frage für ganz dumme wie mich:


    Welches Kabel benötige ich, um für die 800se einen Bootlog zu erstellen?
    Mein Nullmodem-USB-Kabel kann ich ja nicht verwenden, weil die 800se - anders als die 8000 - keinen seriellen Anschluss hat. Daher bin ich jetzt total überfragt, wie ich den Mini-USB-Anschluss nutzen soll. Ich habe es zwar mit einem normalen Mini-USB-Kabel versucht, aber das scheint nicht das richtige zu sein. Ich habe da weder mit dem HyperTerminal noch mit Putty einen Log hinbekommen. Aber das könnte auch an fehlerhafter Terminal-Config liegen.


    Was genau muss ich als Host angeben und welchen Port? Ich hab es mit der IP probiert und Port 22 und 23 probiert, aber nichts hat irgendwie funktioniert.
    Da ich im Hyperterminal nur TCP/IP als Verbindungsart auswählen kann und nicht COM1 o.ä. hat mir auch die im Wiki verlinkte Bootlog-Hilfe wenig weitergeholfen. :(

    DM 8000 HD SSS (mit 2 TB WD-CaviarGreen-HDD)
    DM 800se PVR S (mit 160GB WD-Caviar Blue)

    Edited 3 times, last by tesky ().

  • Ein Mini-USB Kabel ist schon richtig. Aber wie bei allen bei Windows benötigst du den
    UART Treiber für die Dreambox. Diesen bekommst du auf der Homepage von DMM.
    Dann funktioniert daß auch mit putty oder Hyperterminal.

  • Quote

    Original von gutemine
    Was für ein image hast du im Flash - wirklich das aktuelle OoZoon OE 2.0 ?
    Und Flashkernelcopy und labelmount auf ja stehen in den Einstellungen ?


    Oozon vom 14.7.2012 und beide Optionen ein. Trotzdem das gleiche Verhalten wie bei mdfine. Hier mein Dumbo.Log (hat sich nix geändert):


    ---------------------------
    root@dm500hd:~# [6n
    root@dm500hd:~# tail -f /tmp/dumbo.log[J
    Command (m for help): Partition number (1-4):
    Command (m for help): Command action
    e extended
    p primary partition (1-4)
    Partition number (1-4): First cylinder (6-487, default 6): Using default value 6
    Last cylinder or +size or +sizeM or +sizeK (6-487, default 487): Using default value 487


    Command (m for help): The partition table has been altered.
    Calling ioctl() to re-read partition table
    + partprobe /dev/sdb
    + fdisk -l /dev/sdb


    Disk /dev/sdb: 4009 MB, 4009754624 bytes
    255 heads, 63 sectors/track, 487 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes


    Device Boot Start End Blocks Id System
    /dev/sdb1 * 1 5 40131 6 FAT16
    /dev/sdb2 6 487 3871665 83 Linux
    + dd if=/dev/zero of=/dev/sdb1 bs=512 count=1
    1+0 records in
    1+0 records out
    512 bytes (512B) copied, 0.005132 seconds, 97.4KB/s
    + /var/tmp/Dumbo/bin/mkdosfs -F 16 -n TIMOTHY /dev/sdb1
    mkdosfs 3.0.11 (24 Dec 2010)
    + mkfs.ext4 -L DUMBO /dev/sdb2
    mke2fs 1.42.1 (17-Feb-2012)
    Filesystem label=DUMBO
    OS type: Linux
    Block size=4096 (log=2)
    Fragment size=4096 (log=2)
    Stride=0 blocks, Stripe width=0 blocks
    242400 inodes, 967916 blocks
    48395 blocks (5.00%) reserved for the super user
    First data block=0
    Maximum filesystem blocks=994050048
    30 block groups
    32768 blocks per group, 32768 fragments per group
    8080 inodes per group
    Superblock backups stored on blocks:
    32768, 98304, 163840, 229376, 294912, 819200, 884736


    Allocating group tables: 0/30 1/30 2/30 3/30 4/30 5/30 6/30 7/30 8/30 9/3010/3011/3012/3013/3014/3015/3016/3017/3018/3019/3020/3021/3022/3023/3024/3025/3026/3027/3028/3029/30 done
    Writing inode tables: 0/30 1/30 2/30 3/30 4/30 5/30 6/30 7/30 8/30 9/3010/3011/3012/3013/3014/3015/3016/3017/3018/3019/3020/3021/3022/3023/3024/3025/3026/3027/3028/3029/30 done
    Creating journal (16384 blocks): done
    Writing superblocks and filesystem accounting information: 0/30 1/30 2/30 3/30 4/30 5/30 6/30 7/30 8/30 9/3010/3011/3012/3013/3014/3015/3016/3017/3018/3019/3020/3021/3022/3023/3024/3025/3026/3027/3028/3029/30 done


    + fdisk /dev/sdb


    Command (m for help): Partition number (1-4): Hex code (type L to list codes):
    Command (m for help): The partition table has been altered.
    Calling ioctl() to re-read partition table
    + mkdir /var/tmp/dumbo
    mkdir: can't create directory '/var/tmp/dumbo': File exists
    + mount -t ext4 /dev/sdb2 /var/tmp/dumbo
    + mkdir /var/tmp/dumbo/boot
    + mount -t vfat /dev/sdb1 /var/tmp/dumbo/boot
    + rm -r /var/tmp/dumbo
    rm: can't remove '/var/tmp/dumbo/boot': Device or resource busy
    rm: can't remove '/var/tmp/dumbo': Device or resource busy
    + mkdir /var/tmp/dumbo/media
    + mkdir /var/tmp/dumbo/media/swap
    + dd if=/dev/zero of=/var/tmp/dumbo/media/swap/swapfile bs=1024 count=524288
    524288+0 records in
    524288+0 records out
    536870912 bytes (512.0MB) copied, 30.138536 seconds, 17.0MB/s
    + mkswap /var/tmp/dumbo/media/swap/swapfile
    Setting up swapspace version 1, size = 536866816 bytes
    UUID=74fdd6d0-2f98-403e-ab10-670435b71f50
    + swapon /var/tmp/dumbo/media/swap/swapfile
    + /var/tmp/Dumbo/bin/nfidump --o /media/hdd/backup/OE20DumboFullset.nfi /var/tmp/dumbo
    ----------------------------
    Danach reboot.


    Mit 3.0.5 alles ok, Fehler tritt nur bei 3.1.0 auf.


    Gruss - LERNI -


    P.S.: ist das vlt. der Fehler ?
    rm: can't remove '/var/tmp/dumbo/boot': Device or resource busy
    rm: can't remove '/var/tmp/dumbo': Device or resource busy

    ---------------------------------------------
    manchmal verliert man
    und manchmal gewinnen die Anderen
    ---------------------------------------------

  • dann pack halt das image aus und aktualisiere nachher auf 3.1


    Und nein das ist kein Fehler.


    Im Sommerloch wird man keine Images mit Dumbo auspacken können sondern nur booten bis ich neue Version mache, aber dafür ist es noch zu früh.


    Bei dir sieht das so aus wie wenn das nfidump crashed und dann einfach sofort der nächste Schritt kommt (das reboot).


    Wobei das seltsam ist weil das nfidump und das Image Auspacken geht bei mir anstandslos und du packst ja wohl kein OpenPLI 3.0 image auf was eigentlich das einzige ist was im nfidump set 5.* im 6.* dazu gekommen ist, plus das ich ein paar schlummernde Sachen aufgedreht habe die bis jetzt was anderes gemacht haben, um die Klone zu ärgern die nicht verstehen das man sich nur weil etwas funktioniert nicht so sicher fühlen sollte.


    Ausserdem ist es ein netter Test, um zu sehen ob sie es rauspatchen können - bis jetzt tauschen sie immer nur gegen ältere binaries aus wo sie sich sicher fühlen was aber ein Irrtum ist :-)


    Weil die PLi Images sind bei den Klonen recht beliebt (auch wenn dort im Moment immer noch 2.1 verwendet wird das man auch mit altem nfidump scheinbar problemlos auspacken kann) wird das nicht ewig so bleiben.

    Edited 3 times, last by gutemine ().

  • Flashcopy funktoiniert auch mit 3.1.0,
    aber das auspacken eines mit 3.0.5 gesicherten NFI-Images geht nicht.


    Update im ausgepackten Image, welches schon auf dem Stick liegt, geht auch nicht, wird ja nicht unterstützt (zumindest lt. Meldung im telnet).


    So, jetzt belasse ich das erst mal auf der 3.0.5 Version, habe ja schon mal erwähnt, dass ich damit keine Probleme habe. Wenn ich noch was für Dich testen soll, einfach melden.


    Gruss - LERNI -

    ---------------------------------------------
    manchmal verliert man
    und manchmal gewinnen die Anderen
    ---------------------------------------------

  • Dann hast du falsche Netzwerkeinstellungen, Dumbo Images kann man ziemlich problemlos ganz normal aktualisieren.


    Und ja das Flashcopy ist auch nicht vom Sommerloch betroffen, ich teste nur Sachen im mkfs.jffs2 (mit lzo support) und im nfidump 6.0 die halt beim Auspacken und Sichern benutzt werden.

    Edited once, last by gutemine ().

  • Dumbo geht bei mir mit Version 3.1.0 auch nicht

    Sagt der Walfisch zum Thunfisch... Was soll ich tun Fisch?
    Sagt der Thunfisch zum Walfisch... Du hast die Wahl Fisch!

    Edited 2 times, last by nino16000 ().

  • lerni


    Geht mir genauso. Beim extrahieren des Image schmiert Dumpo 3.1.0 sofort ab. In Version 3.0.8 rennt noch der kleine Elefant.
    Aber jetzt wissen wir woran es liegt... das Sommerloch.


    GuteMine


    Was soll das denn bringen mit Dumbo 3.0.8 ein Image Extrahieren und danach auf 3.1.0 upzudaten? Ist es eine Sommerloch-Beschäftigung :hurra:

    Ich bin Guybrush Threepwood, ein mächtiger Pirat!

    Edited once, last by Guybrush2012 ().

  • Das Problem ist dass das Loch eigentlich noch nicht engefangen hat, aber mal sehen, zuerst müssen wir die LowFAT Probleme in den Griff bringen.


    Wenn man kein OpenPLi 3.0 auspacken oder sichern will braucht man die Sachen vom 3.1 eh nicht.


    Elefanten fallen auch nicht so leicht in Löcher :-)

  • Vielen Dank an netman für den Hinweis mit dem uArt-Treiber.


    Vielleicht kann sich jemand mal den Bootlog ansehen. Ich vermiute, dass es am USB-Stick liegt, weiß es aber nicht und finde mich bei dem Log auch nicht wirklich raus-
    Fakt ist, er bootet nur ganz kurz und bricht dann ab.

    Files

    • Bootlog.txt

      (14.04 kB, downloaded 17 times, last: )

    DM 8000 HD SSS (mit 2 TB WD-CaviarGreen-HDD)
    DM 800se PVR S (mit 160GB WD-Caviar Blue)

  • Quote

    Original von lerni
    Update im ausgepackten Image, welches schon auf dem Stick liegt, geht auch nicht, wird ja nicht unterstützt (zumindest lt. Meldung im telnet).


    Mit Update meinte ich hier natürlich nur DUMBO Update von 3.0.5 auf 3.1.0.


    Das Systemupdate läuft natürlich.


    Gruss - LERNI -

    ---------------------------------------------
    manchmal verliert man
    und manchmal gewinnen die Anderen
    ---------------------------------------------

  • wenn du im Flash Dumbo updatest und dann wieder das Dumbo image botest hast du auch dort die neue Version von Dumbo

    Edited once, last by gutemine ().

  • So hatte schon an mir gezweifelt das is ich das 3.1.0 nich zum laufen bringe :)


    Aber das 3.0.8 geht einwandfrei...Allerdings hab ich eine Frage, müsste ich nicht auch Dumo als Plugin im Dumbo gebooteten Image sehen?


    Edit: Per Webif komme ich hin ;) und über Menü / Erweiterungen


    Sorry


    Gruß Gerry

    Gruß Gerry

    Edited 2 times, last by gerry6n ().

  • wenn du in den Einstellungen im Extensions Menu aufdrehst siehst du es auch auf Blau

  • Vielleicht kann damit einer was zu meinen Problem mit Dumbo und Gemini Plugins was anfangen. Hab die ganze Box nochmal neu gemacht aktuelles Oozoon im Flash Dumbo 3.08 installiert orginal DMM auf den Dumbo Stick und GP3.2 drüber. Dumbo danach auf die neuste Version upgedatet. Danach nur Gemini Jukebox übers BluePanel installiert um zu testen ob es dann gleich im BluePanel mit angezeigt wird, war aber leider nicht der Fall. Hab neu gestartet und zum testen danch mal ein Plugin übers Telnet installiert und da ist mir dieser Fehler aufgefallen.


    root@dm800se:~# opkg install /tmp/*.ipk
    Installing enigma2-plugin-extensions-bildonline (1.4) to root...
    Configuring enigma2-plugin-extensions-bildonline.
    ###################################################
    # #
    # Bild online installed successful! #
    # #
    ###################################################
    Configuring geminijukebox.
    //var/lib/opkg/info/geminijukebox.postinst: line 1: ginstall.py: not found
    Collected errors:
    * pkg_run_script: package "geminijukebox" postinst script returned status 127.
    * opkg_configure: geminijukebox.postinst returned 127.



    Hab danach zum testen mal das gleiche im Flash versucht und da gehts ohne Probleme.