usbTuner (multiple tuners on dm800) v0.7.3 ipk package (all new images) + GUI plugin

  • Maybe this helps you: http://www.dream-multimedia-tv…ad&postID=96294#post96294

    TV: Samsung LE40A656 -|- Dreambox: DM800se (Sat) -|- Image: Merlin²

  • i have a kworld 323u dvbt stick. its a em28xx device but icvs sees it as a 2883 usb device uknown. it works with sifteam but not here. what can been done?

  • Hat den schon jemand den Cinergy T RC MKII Stich ans laufen gebracht?

    wenn ich dir usbtuner_0.4.3b_dm800.ipk starte erkennt es den stick und will die module für den af9015 installieren.

    Jedoch nach dem Restart is der Tuner leider nicht verfügbar.

    @dm800:~# /usr/bin/lsusb
    Bus 001 Device 002: ID 0ccd:0097 TerraTec Electronic GmbH Cinergy T RC MKII
    Bus 001 Device 001: ID eb1a:51b2 eMPIA Technolo
    Bus 003 Device 000: ID 0000:0000 CD-R/RW Drive
    Bus 002 Device 000: ID 0000:0000 CD-R/RW Drive
    Bus 001 Device 000: ID 0000:0000 CD-R/RW Drive

    Bus 001 Device 001 is der Sundtek DVBC Stick.

    Kann/muss ich noch was anderes machen ausser die usbtuners.ipk installieren?

  • If you expect me to reply write in english.

  • Quote

    Originally posted by rouyi
    i have a kworld 323u dvbt stick. its a em28xx device but icvs sees it as a 2883 usb device uknown. it works with sifteam but not here. what can been done?

    Paste your lsusb from icvs and from sifteam. I'll see what I can do.

  • Hello,
    thanks a.key for your work.

    I have DMM original Image (release-dm800-3.1.0.nfi) and GP3 (g3wizard_0.14-r0_mipsel.ipk) installed on DM800. I installed usbtuner_0.4.3b_dm800.ipk, but the package does't work. I have a Kworld 399U DVB-T USB stick that works pretty fine with other images (GP2 5.1). With your package, the box hangs on booting and I must unplug from power supply. The DVB-T stick is reported as Afatech9015 (1b80:e399).
    Even box doesn't boot, i still can use telnet to make some tests. I replaced various files with the ones I have from other sources, but still no luck. I added manually in /usr/share/usb.ids the ID of this stick, but same result.
    If I replace /lib/firmware/dvb-usb-af9015.fw with the old one (that works on GP2 5.1) the box finishes booting but the remote control and front standby button are dead.
    BTW, with my old package, the box works fine, but the DVB-T stick is recognized as input device (as RC or keyboard), not as tuner B.
    Can you guite me to right direction?

  • for chooleen - i also have kworld 399u and it works with this files manually installed from here : usbTuner for all new images :

    but now i have experienced another problem on the new icvs image with gp3 :
    after the activation of usbtuner the pozitionersetup stop working and the image goes in to reboot.
    i have this crash file:
    File "/usr/lib/enigma2/python/Plugins/SystemPlugins/PositionerSetup/", line 358, in updateStatus
    transponderdata = ConvertToHumanReadable(self.tuner.getTransponderData(), "DVB-S")
    File "/usr/lib/enigma2/python/Tools/", line 25, in ConvertToHumanReadable
    eDVBFrontendParametersSatellite.FEC_9_10 : "9/10"}[tp["fec_inner"]]
    KeyError: 'fec_inner'
    any solution?

  • Well...
    You gonna have to clean your system before you can fully debug your issues here. By cleaning I mean get rid of all files you put there for the usb tuner to work.
    Assuming that the image you're using is using the kernel that the ipk I uploded is compatible with and that your tuner is supported (modules for it exist in the package) you can:
    unplug your usbtuner
    reinstall the ipk
    plug your usb tuner in
    try to autodetect the tuner: /usr/script/
    If your tunner is not autorecognized but is supported and you know your moduleset name do:
    /usr/script/ <your_moduleset_name>
    This will put the name of your moduleset into /etc/dtt.modules and the moduleloading/usbtuner starting script will pick it up and fire up what's needed.
    /etc/init.d/ should load all modules and start usbtuner is all went well.

    You can of course do the whole thing manually.
    Without using the scripts:
    load your modules: modprobe <your_usb_tuner_module> or insmod /path/to/your/module - but with insmod you will have to load up all the dependent modules before you can insert the one for your tuner.
    Once your module is loaded and USBTUNER conneted check if your have:
    /dev/dvb/adapter1 - if yes then all should be ok and your should be able to start usbtuner binary:
    /usr/bin/usbtuner 1
    that will create additional entry in /proc/bus/nim_sockets for your second tuner. If it did then restart enigma2:
    killall enigma2
    and once enigma2 starts up go to settings, tunner config and check if your second tuner is there.

  • Guys - please bear in mind that since I updated the ipk package there has been a new kernel released for the DB800.
    The ipk contains modules for kernel from DEC 2010 which will be incompatible with images running on kernel mentioned above.
    Once I find time to update the image on my DM800 and have a play with it I will try to further improve the package but for now this package wont automagically work for new images like it was working for the ones with older kernel.

  • Hi.
    I still haven't got time fully fix the package for new images but I've got some progress...
    I only tested it on new image from N ewnigma2 and I actually just tested the scripts not the package.
    At first glance: - it will break your image. On my dm800 with nova2 usb tuner makes the image unbootable. And it's not the dtt scripts that does it. It's the actual tuner module. I've not debugged it fully but while using modules installed by the opkg on enigma2 (opkg install v4l-dvb-module-...) and then following it with all the dependent modules after rebooting the box it stops during boot after the stage where there's DHCP on OLED. Basically oled goes black, red diode flashes and nothing else happens. As mentioned above I've not had time to actually check what's stopping it but clearly this image is not prepared for tuners connected over usb.
    I fixed by blacklisting the tuner module in /etc/modprobe.conf, modifying one of the /etc/init.d scripts ( - I've added -a -b switches to LOAD_MODULE= modprobe at the top which honors blacklist definitions.

    I'm gonna change n ewnigma2 to something else at some point cuz I feel that there are better images out there. I'll report back later - so watch this space.

  • did anyone post an answer to this yet?

    I'd like to use the tt3600 s as well since I have great experience with that tuner so far.


    Original von DaDare
    What about the TechnoTrend 3600S?

  • Hi!

    I tried Tevii S660 and it is recognized and supported by install script. I use the module dw2102 for it.

    After configuring the Tuner in Tuner panel I unfortunately get no picture on the usb tuner. Connecting via Telnet and running dmesg, I see that I get always those messages, when recording on Tuner1 and switching to antoher channel to force DM800 to use the Tevii:

    VTUNER ioctl 1
    VTUNER ioctl 2
    VTUNER ioctl 1
    VTUNER ioctl 2
    VTUNER ioctl 1
    VTUNER ioctl 2
    VTUNER ioctl 1
    VTUNER ioctl 2

    Someone knows where the problem is??


    EDIT, After some time I get those messages in telnet:
    ds3000_firmware_ondemand: Waiting for firmware upload (dvb-fe-ds3000.fw)...
    ds3000_firmware_ondemand: Waiting for firmware upload(2)...
    ds3000_firmware_ondemand: No firmware uploaded (timeout or file not found?)
    ds3000_tune: Unable initialise the firmware

  • Quote

    Original von thefirstbreath
    did anyone post an answer to this yet?

    I'd like to use the tt3600 s as well since I have great experience with that tuner so far.…oTrend_TT-connect_S2-3600…

    firmware > /lib/firmware (flash image)

    linux >driver>media>dvb >dvb-usb > pctv452e
    linux >dirver>media>dvb >fronteds > stb0899 + stb6100

    need compilation for 2.6.18... >


    "drivers" xxx.ko > /lib/module/dvbt (for path install like dvbt.. usbtuner, "modified with your .ko" )

    look here >usbTuner for all new images > usbtuner tar.gz.

    dm800 s 600s 500 s gemini

    Edited 2 times, last by thatave ().

  • Your firmware is not being loaded. Probably due to the fact that it's missing from the package.
    Google for: dvb-fe-ds3000.fw and once downloaded upload it to /lib/firmware. Then restart your box and it should work. If not check the logs. and post them so that we can help you further.

  • Hi.

    Since my last post about the progress of new version of the package I've changed to nemesis 2.2 image.
    It by default has support for usb tuners but since at the time I was installing it I could not get mdules from it's feeds server I applied my own scripts.
    It turns out that this image suffers the same effect on having dvb modules installed to default location /lib/modules/<kernel_version/kernel/drivers/media/... as N ewnigma2 had ( booting stops after loading the module during startup). In this image it's even worse because the default modprobe command is not a stand alone program which could support switches for honoring blacklisting of modules from /etc/modprobe.conf or /etc/modprobe.d. It's a busybox version.
    So creating a package that will work more universally will be quite challenging.

    I'm open for suggestions on how to work around the booting freeze issue especially when I haven't yet checked what's actually causing it to stop (I'd need to see boot messages probably through the serial console).

    I think the solution will be to check if the modprobe command supports blacklisting and if not replace it with a provided one. Then modify startup script for modules loading to add blacklisting switches.
    And of course at some point it will be necessary to somehow have all the usb-dvb modules installed. I was thinking for simply downloading all dvb-modules using opk/ipk right after installation. This would solve the problem of outdated modules included in the ipk package.

    If anyone has some suggestions please post them here and I'll be happy to review it and go ahead with the new version of the package.

  • I just bought an ATSC tuner which, at least on the information I could gather, might work.
    I will post updates I soon as I received it.

  • a.key is it possible to update the dvb-t drivers in u'r package with the newer ones (HP-nova dated from 05-05) from the ItalysatDTT Downloader 0.5..??

    Im also running Nemesis 2.2 and tried to update with ItalysatDTT but it downloads the drivers and when enabling they cannot access or smth so the old driver remains..

  • It identified correctly my tuner but at first it didn't work.

    After the reboot and looking at dmesg I found:

    I will try later with an USB extension cable, because tuner didn't fit connecting directly.
    Any other suggestion based on the output?


  • I'm making progress with the card, now I got more info. on dmesg but still failing to load some modules: