usbTuner (multiple tuners on dm800) v0.7.3 ipk package (all new images) + GUI plugin

  • könntest du mir bitte sagen, wie das genau geht und wo ich das eintragen muß? vielen Dank!

  • Morning Ladies and Gentlemen,
    I have a common problem with asus my cinema u3100mini ver2 on Merlin3 OE2. lsusb reports 1b80:d3a8 afatech but disn't find anything. After put manually dib0700 to conf the same. I found a lot of info concerning rtl2832u on ubuntu (eg…nput-infrastructure/58232). But how to force it to work on dream I really don't know because sudo, git etc don't work. Should I install everythin to compile firmware file? There is also info that it is dvb_usb_af9015. Is it true?
    Do you have any ideas?
    Thanks in advance,

  • I followed all the steps on page 1.
    Additionally, I also did the offline installation directly on the dream.
    In the program I downloaded again all drivers.
    Initiate. Reebooted twice and suddenly I had it there under tuner settings.

  • That´s strange. I did the same, but the tuner didn´t appear in the tuner settings. It only was listed in the vtuner Plugin, but was markes as disabled (or similar, I can´t remember the exact term).

    Just to be safe: You´re using a WinTV Nova-T USB Stick and it really works with OE 2.0, that is, you get a TV signal and can really watch TV with it?

  • Hello!
    I install plugin and drivers, but tuner didn´t appear in the tuner settings. It only was listed in the vtuner Plugin, and markes as enabled (green). What can I do? Tuner DM800PVR, USB stick AF9015.

  • Hello. I have the latest version of gemini image and a usb with A815 (volarX). I've tried everything I've seen, but I am unable to install it. Someone could help me? How could delete the wrong drivers installed too?

    Anybody can help me??

  • I got this error:

    Configuring usbtuner.
    System startup links for /etc/init.d/ already exist.
    Checking for -b support in modprobe... Failed.
    Error: modprobe -b returns error! Is module-init-tools package installed ?
    Collected errors:
    * pkg_run_script: package "usbtuner" postinst script returned status 1.
    * opkg_configure: usbtuner.postinst returned 1.

    What can I do?

  • Quote

    Original von jmaa009
    Hello. I have the latest version of gemini image and a usb with A815 (volarX). I've tried everything I've seen, but I am unable to install it. Someone could help me? How could delete the wrong drivers installed too?

    Anybody can help me??

  • I try to use my TevII S660 on my DM 500HD USB Mod.
    Yesterday I installed the Script and when I look in the DVB-USB-Tuner-Setup I can see the TevII S660 but the button is grey. I have installed the DW2102 Driver but when I run ...

    root@dm500hd:~# /usr/script/ extended_status
    Connected devices:
    9022:d660 TeVii S660 USB: <Driver error>

    Usbtuner service:

    Contents of /proc/bus/nim_sockets:
    NIM Socket 0:
    Type: DVB-S2
    Name: BCM4505
    Has_Outputs: no
    Frontend_Device: 0
    I2C_Device: 2

    ... there is still a driver error!!

    Anybody can help me?

    root@dm500hd:~# /etc/init.d/ start
    Loading module: dw2102...FATAL: Module dw2102 not found.

    But it is installed.

    Edited 2 times, last by bigfoot1313 ().

  • Hello

    In 7020hd and Gp3.2 image, how to activate pinnacle usb dvb-t tuner?

    already I did not have a problem with activate it on OE 1.6 images.


  • Checking for -b support in modprobe... Failed.
    Error: modprobe -b returns error! Is module-init-tools package installed ?

    module-init-tools already installed. did you know what can i do ?

    Mein Motto : et hätt noch immer jod jejange

    Edited once, last by ks646 ().

  • When you're trying to debug what's wrong with your setup be aware of:
    dmesg - will tell you kernel messages in regards to anything happening to devices and drivers etc.
    ls -al /dev/dvb/ - will list you DVB devices/frontends that the kernel presents to Linux userspace
    cat /proc/bus/nim_sockets - will show you what tuners are available for enigma2.

    In general you need:
    - The physical device (USB tuner)
    - drivers (kernel modules)
    - firmware for the drivers
    - usbtuner binary

    Once you connect the USB device to your box you run dmesg on the command line (through SSH or telent) to see what does the kernel say about the device. All the messages maybe rather cryptic but should give you enough idea. You will see some messages about connected USB devices and given USB IDs etc.

    To load the the necessary drivers into the kernel you basically do: modprobe <driver_name>
    Loading the driver will attempt to load the actual driver and all related drivers because you have to know that it's not just one driver that is required for supporting your device. Various pieces of the h/w in the USB tuner device require various drivers and loading the main driver should automatically load all related drivers for other components. This should be handled automatically by modprobe assuming that all drivers are available/installed and the program and kernel knows about them. As you can imagine there needs to be some kind of way to tell the kernel's module autoloader in what order to load all the drivers and this is where "depmod -a" comes handly. After installing new drivers (kernel modules) the OS (Linux userspace) should run depmod -a to update this database of module relationships. if it's not done automatically you need to run it manually. But you should only require run it once after all your drivers have been installed.
    A very important aspect of installing and loading drivers is the firmware. Firmware is a part device drivers that is not provided in an open source and provided as a binary blob (a file) instead. The firmware file needs to be of certain version and needs to be named exactly as the kernel module (driver) expects it. In addition to this the firmware file needs to be placed in /lib/firmware or some sub directory of it - once again this is dependent on what the driver (kernel module) expects.
    So once you have everything installed on your box (kernel modules and firmware) when you do "modprobe <kernel_module_name>" there will be some interesting messages produced by the kernel which you will be able to see when you run "dmesg". If you can't see anything interesting try unplugging the device and plugging it back in and right after this check "dmesg". In most of the cases the modules cannot be loaded because firmware file is missing, not in the right place or wrong version. Of course it may also be the case of not being able to load one or more of required drivers/modules. But kernel (through dmesg) should show you.
    Sometimes you need to unload all the related modules (modprobe -r <module_name>) and load the device module again (which should try loading all related modules automatically) and if there is any module missing you'll probably see it on the console or in dmesg. When unloading particular modules you will have to do it in a correct order because they depend on each other so if module "z" requires module "y" and module "y" requires module "x" as it's dependency you will not be able to do: modprobe -r "x" because linux will tell you that it's being used by module "y" or module "z" so you will have to first unload module "z" then module "y" and finally if nothing is using module "x" it will let you unload it.

    There seem to be a lot of confusion about "modprobe -b" and module-init-tools. There reason why my scripts even touch this subject is because at the time of me creating this whole thing my enigma2 image would freeze during boot when all my usb tuner device drivers were loaded. This had something to do with frontend ordering in /dev/dvb and how enigma2 was expecting it at bootup. The solution to the problem was to blacklist the usb tuner device driver (module) in /etc/modprobe.conf so that the driver doesn't get loaded automatically during boot. Then, once all normal services started and before enigma2 process is started, start the usbtuner service which manually loads the required module/driver, starts usbtuner binary to present the tuner in /proc/bus/nim_sockets and allow enigma2 process to see it as additional tuner.
    So the images I looked at by default were using "modprobe" command that did not support blacklist support. Installing module-init-tools rectified it because it was shipping a different version of modprobe program which did support the -b switch but -b is not executed by default so I had to "patch" the script that runs it to add the "-b" switch. After that my box would cleanly boot and not stall half way through. I honestly don't know why doing this on recent gemini or some other OE 2.0 images breaks the boot process. I didn't have time to look at it - and still don't. A way to find this out is to enable console redirection to serial port in the bios and observing the boot process through console (in eg. minicom or hyperterminal).

    I know that it's all rather technical and may not help average user who just wants to have an additional tuner in their enigma2 box but may help to understand how the whole process work for someone who decides to take it forward and has some more generic linux admin knowledge.

  • Hello, I'm looking for ipk patch for DM8000 or driver for Abilis AS102 usb tuner which have changed

    /* PCTV Systems: PCTV picoStick (74e) */
    #define AS102_PCTV_74E "PCTV Systems picoStick (74e)"
    #define PCTV_74E_USB_VID 0x2013
    #define PCTV_74E_USB_PID 0x0246

    /* PCTV Systems: PCTV picoStick (74e) */
    #define AS102_PCTV_74E "PCTV Systems picoStick (74e)"
    #define PCTV_74E_USB_VID 0x0b89
    #define PCTV_74E_USB_PID 0x0007

    "Italy SAt DTT downloader", "kernel-module-dvb-as102_3.2-r12.54-bsp0_dm8000.ipk" and "kernel-module-dvb-usb_3.2-r12.54-bsp0_dm8000.ipk" has 0x2013 and 0x0246. Please help me change inside ipk file on 0x0b89 and 0x0007:) I'm not so good :) Best regards.

  • I have DM520 with image based on kernel 3.4-3.9.
    I bought this
    I couldn't get it to work after installing drivers from their server. I'm not sure where the problem could be
    here is some of what I've done along with logs
    I appreciate any inputs, is it driver issue? or what exactly

    uname -a gives this

    Linux dm520 3.4-3.9-dm520 #1 SMP Thu Jul 21 07:15:20 CEST 2016 mips GNU/Linux

    downloaded dvb-usb-rtl2832 from the server then restarted the box but no dvb-t tuner seen

    dmesg gives me this

    disconnected the usb tuner then reinserting tuner then dmesg gives this

    lsusb gives this

    Bus 001 Device 003: ID 0bda:2838
    Bus 001 Device 001: ID 1d6b:0002
    Bus 002 Device 001: ID 1d6b:0001

    opkg list *rtl28* gives this

    enigma2-plugin-drivers-dvb-usb-rtl2832 - 1.0-r2 - USB DVB driver for Realtek RTL2832 chipset
    USB DVB driver for Realtek RTL2832 chipset.
    kernel-module-dvb-usb-rtl28xxu - 3.4-.1 - dvb-usb-rtl28xxu kernel module
    dvb-usb-rtl28xxu kernel module; Realtek RTL28xxU DVB USB driver
    kernel-module-rtl2830 - 3.4-.1 - rtl2830 kernel module
    rtl2830 kernel module; Realtek RTL2830 DVB-T demodulator driver
  • Quote

    Originally posted by eduardolino
    This plugin works in GP3 OE2.0 with usb dvb-t based in chips AF9015, SIANO, ITE9135. But only with default HD skin, which don't have frontend info. I think there are some kind problem on drivers, which not working correct with frontend infos. furthermore in case of SIANO or ITE9135 chipset you must replace the kernel module from oficial DM feed, with Pli team drivers.


    Where do I find the kernel module? (which directory?) (OE2.0 / DM 7020 HD / Exp+GP)

    Thanks by advance and greetings!