usbTuner (multiple tuners on dm800) v0.7.3 ipk package (all new images) + GUI plugin

  • Oh, sorry, I've mix up the T5 and H5.


    The T5 works but the H5 (I've got that) don't. Right?


    Is there anyother DVB-C stick that works or just the Sundtek?

  • Hello -
    I am failing to make this DVB-T stick work on my DM500HD and still getting the error:



    root@dm500hd:/usr/script# usbtuner
    open device /dev/dvb/adapter1/frontend0
    failed to open frontend: No such file or directory


    Although the drivers are installed and the stick seems to be recognized by the DM.



    root@dm500hd:/usr/script# usbtnrsetup.sh check_status
    Hauppauge Nova-TD Stick (52009): <OK>


    root@dm500hd:/usr/script# lsusb
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 002: ID 05e3:0736 Genesys Logic, Inc. microSD Reader/Writer
    Bus 001 Device 003: ID 2040:5200 Hauppauge Laser Printer


    I have a an usb-board card with an internal port on which I installed an SD card (with 2 partitions) one used for /usr (flash expander) and the second partition is used for recording when using timeshift.
    As you can see in the result of mount :
    ...
    none on /proc/bus/usb type usbfs (rw,nosuid,nodev,noexec,relatime)
    /dev/disk/by-uuid/4cafee57-8760-4653-bfbf-9ca7ce370826 on /media/hdd type ext3 (rw,relatime,errors=continue,barrier=1,data=writeback)
    /dev/disk/by-uuid/c32e0b34-8d30-476a-861f-dc1cc81b63a9 on /usr type ext3 (rw,relatime,errors=continue,barrier=1,data=writeback)
    /dev/sdb1 on /media/usb1 type ext3 (rw,relatime,errors=continue,barrier=1,data=writeback)


    I plugged the tuner stick on the external port.
    Any help please?


    Thanks.

  • Hello,
    please can anyone help on this?


    additional test I did:
    /dev/dvb/adapter1 doesn't seem to exist only adapter0 exists
    when running :
    usbtuner -a 0
    open device /dev/dvb/adapter0/frontend0
    failed to open frontend: Device or resource busy



    Thanks

  • Quote

    Originally posted by scipion
    Hello,
    please can anyone help on this?....


    Very simple but primitiv brute force solution:


    Delete usbtuner config file.


    Execute commands:



    Reboot and enjoy with USB tuner


    This metod is ony for dream with single internal tuner and one USB DVB-T stick. Can easily modify for other situations.

  • Hello,
    Since I was not making progress I used another image and suprisingly it worked without any additional configuration.


    I think you are right your suggestion should solve the isue. I'll have to restore a backup to see if it works.
    Thanks a lot

  • I have the above USB tuner.


    After installing usbtuner_0.7.3_all.ipk I discovered it was not recognised.


    However, some other Typhoon/Freecom devices were included in usbtnrsetup.sh.


    Therefore I ran


    lsusb
    to find the ID.


    It was
    ID 14aa:0160 WideView Technology Inc. Astra 5400U


    Next I patched usbtnrsetup.sh with this device ID (simply pasting "14aa:0160" over the USB ID in another "WideView" line.


    After a reboot the tuner was then recognised and I was able to install the drivers.


    All working :)


    I hope this can help someone else in the same situation.


    007.4

  • DM800SE
    Nemesis 2.6 110r0 OE1.6
    DVB-T stick: Sky Digital Key Green LED, Abilis AS-102


    If I insert USB DVB-T on Windows 7, property says PID/VID 2137:0001


    I telnet


    #opkg install module-init-tools


    #opkg install /tmp/usbtuner_0.7.3_all.ipk


    When I open DVB-T Setup Plugin I read:


    the "usbtuner" is running for (0) devices [this is written in RED font]
    Below I read
    Super Digi Key [with a green dot]


    I restarted Enigma several times, installed firmwares, rebuild configuration and restarted usb tuner, but I can NOT see the DVB-T tuner listed in Menù->Configuration->Service Searching->Tuner Config.


    I see only DVB-S tuner


    I telnet also:
    #/usr/script/usbtnrsetup.sh download_drivers


    #/usr/script/usbtnrsetup.sh auto_setup


    #/usr/script/usbtnrsetup.sh enable


    #/usr/script/usbtnrsetup.sh check_status -> with response OK


    Any HELP?


    lsusb

    Code
    Bus 002 Device 002: ID 0bda:8172 Realtek Semiconductor Corp.
    Bus 001 Device 003: ID 2137:0001
    Bus 001 Device 002: ID 08ec:0008 M-Systems Flash Disk Pioneers SmartCard Reader


    dmesg
    attached


    lsmod


    /etc/init.d/usbtuner.sh start

    Code
    Usbtuner service is already running for /dev/dvb/adapter1 (pid 2374).


    /usr/script/usbtnrsetup.sh extended_status


    /etc/init.d/usbtuner.sh start

    Code
    Usbtuner service is already running for /dev/dvb/adapter1 (pid 2374).


    /etc/init.d/usbtuner.sh download_drivers

    Code
    This procedure will try to download and install module: dvb-as102 and it's dependent modules from your ipk/opk repositories.
    Installing [00/000]:
    [1/2]: v4l-dvb-module-dvb-usb...
    [2/2]: v4l-dvb-module-dvb-as102...
    Done.
    All v4l modules installed.


    /etc/init.d/usbtuner.sh auto_setup

    Code
    Checking for -b support in modprobe... OK.
    Checking for patched /etc/init.d/modutils.sh...OK.
    Searching for tuners...Done.
    Found: dvb-as102 !
    dvb-as102 already in the config (/etc/usbtuner.conf).
    dvb-as102 already blacklisted in /etc/modprobe.conf.
    Enigma already patched. All done.
    If new tuner has been found you'll need to restart Enigma2 for changes to take effect.

    Files

    • dmesg.txt

      (30.48 kB, downloaded 16 times, last: )
    • lsmod.txt

      (1.46 kB, downloaded 8 times, last: )

    Edited 2 times, last by CrasHBoneS ().

  • Only FYI...


    I have been trying hard to get usb DVB-T working on my clone DM800 with OpenPLI 2.1.
    Finally got it to work with "ItalysatDTT" plugin, but it slows down the box a lot, so i wanted to try your "usbTuner-v0.7.3".


    The plugin installs OK, downloads and setup drivers and works fine until first full reboot, when the box halts at loading kernel.


    Investigating, i found the cause to be the "-b" switch (use blacklist) you add in "modutils.sh".
    Removing it fixes everything...


    PS. This must be a "PLI family of images" only thing. Other images boot fine with the -b switch.

  • Maybe who have plugin ItalySatDtt-downloader for Dreambox , openpli 3.0 and O.E 2.0??? Or drivers for usb sticks AverMedia Volar Black HD a850: AF9015
    Thanks!

    not works like sports and sattv

  • Quote

    Original von wavelet
    Just wanted to let you guys know that I've got usbtuner working on a DM8000HD with the PCTV Systems nanoStick T2 290e, but DVB-T functionality only I'm afraid - no DVB-T2 yet! ;(


    Thank you! :) I was able to get the 290e running on my DM8000 with the same procedure.


    Quote

    Original von wavelet
    Unfortunately, as I said, I can't get the 290e to receive any DVB-T2 channels. The 1st (but no doubt not the only) problem is that enigma2 doesn't allow terrestrial receiver modules to have their modulation set to QAM256.
    But it's a start I suppose...:408:


    I am able to receive DVB-T2 channels. This being said, the modulation used here is QAM64.


    The only issue for me right now is that the box gets really sluggish, especially on channel zaps between different transponders.

  • kann ich den Sundtek MediaTV an einer DM 800 HD PVR betreiben?

  • Ok dvb-t usb working great with E2 oe1.6 image , but we are discusing about E2 oe 2.0 image this one it's not working ,so do we have any solution for oe2.0 image to work with dvb-t usb .Thanks

  • I have a similar prb, with usb tuner avemedia a867 (fw af9015).


    Running usbtuner i obtain:
    FE Open: Success
    A867 USB DVB-T: Success
    DMX_START failed - Invalid argument


    I cannot see the usb tuner in Enigma "Config tuner" section, only sat.


    If i click on a dvb-t channel i have a crash of enigma2:


    Code
    [eDVBCAService] channel 0x189c8e8 running [eDVBLocalTimerHandler] channel 0x189c8e8 running allocate demux demux not found [eEPGCache] channel 0x189c8e8 running allocate demux demux not found [eEPGCache] no demux!! stop release channel timer allocate demux demux not found Allocating non--decoding a demux for now tuned-in channel failed. FATAL: scan.cpp:227 ASSERTION m_demux FAILED!


    Someone have a solution or more info about this?
    (I dont want change image)


    Regards.

  • hello to all
    my problem is with a greek usb dvb stick called CRYPTO ReDi PC 100 (187f:0201 - Siano Nova B Digital Receiver)
    i want to install it on a dm800hd in oe 2.0 images(no problem in oe 1.6 and usb 4.3b.ipk)
    for instance now i'm running Merlin-3_OE-2.0-dm800-20131004 and i have follow the next steps
    I install via telnet usbtuner_0.7.3x_all.ipk for oe 2.0 and after finding it as an smsusb was trying to install it.At the end was a message saying that i should install firmware because it did not find it
    so i run via telnet the script :#/usr/script/usbtnrsetup.sh download_drivers to download and install the drivers that smsusb needed
    at the end i made a hard reboot to the box but...nothing at the tuner configuration
    do i missing something?
    did i do something wrong?
    i see it as a connected {OK}when i run the script: /usr/script/usbtnrsetup.sh extended_status but at the end nothing
    i stuck on oe 1.6 images and i want to "explore" the oe 2.0
    and the problem is that i don't have other dvb reciever and i use only that
    ANY HELP PLEASE WELCOME!


    P.S i have also a chinese dvb stick using rtl 2832 u drivers but from what i'm reading it's much more difficult to identifying and work on oe 2.0 images for a noob like me!





    sorry i wanted to post a replay in usbTuner (multiple tuners on dm800) v0.7.3 ipk package (all new images) + GUI plugin
    and i posted as a new thread sorry!

  • hello to all
    my problem is with a greek usb dvb stick called CRYPTO ReDi PC 100 (187f:0201 - Siano Nova B Digital Receiver)
    i want to install it on a dm800hd in oe 2.0 images(no problem in oe 1.6 and usb 4.3b.ipk)
    for instance now i'm running Merlin-3_OE-2.0-dm800-20131004 and i have follow the next steps
    I install via telnet usbtuner_0.7.3x_all.ipk for oe 2.0 and after finding it as an smsusb was trying to install it.At the end was a message saying that i should install firmware because it did not find it
    so i run via telnet the script :#/usr/script/usbtnrsetup.sh download_drivers to download and install the drivers that smsusb needed
    at the end i made a hard reboot to the box but...nothing at the tuner configuration
    do i missing something?
    did i do something wrong?
    i see it as a connected {OK}when i run the script: /usr/script/usbtnrsetup.sh extended_status but at the end nothing
    i stuck on oe 1.6 images and i want to "explore" the oe 2.0
    and the problem is that i don't have other dvb reciever and i use only that
    ANY HELP PLEASE WELCOME!


    P.S i have also a chinese dvb stick using rtl 2832 u drivers but from what i'm reading it's much more difficult to identifying and work on oe 2.0 images for a noob like


    me!

    Quote

    everything working with the new italysat-5.1.124-dm800_usb.zip try it!!!