IPCamViewer for Enigma2



  • Live video geht nicht.Es gehen nur bildaufnahmen.Du mußt es in etwa so ändern wie oben.

  • Quote

    Original von sentinel1



    Live video geht nicht.Es gehen nur bildaufnahmen.Du mußt es in etwa so ändern wie oben.


    Hatte es schon bemerkt und dadurch zum laufen gebracht. Trotzdem danke. Spätestens jetzt wäre es durch deine hilfe gelaufen :tongue:

  • jetzt hab ich im Menü etwas geändert und nun bekomm ich beim Start von IPCamViewer immer einen crash:


    ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++, size_w=1280; size_h=720; space=0, fourByThree_w=960, invisible_h=-240
    ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++, size_w=1280; size_h=720; space=0, fourByThree_w=960, invisible_w =320
    +++++++++++++++++++++++++++++++++++ startWithPIP=False
    ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++, size_w=1280; size_h=760; space=0
    ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ recording
    Directory=/media/hdd/IPCamViewer
    Screen <class 'Plugins.Extensions.IPCamViewer.plugin.ViewCamImage'>((), {}): <type 'exceptions.AttributeError'>
    Traceback (most recent call last):
    File "/usr/lib/enigma2/python/mytest.py", line 246, in create
    return screen(self, *arguments, **kwargs)
    File "/usr/lib/enigma2/python/Plugins/Extensions/IPCamViewer/plugin.py", line 276, in __init__
    AttributeError: 'ViewCamImage' object has no attribute 'scrPosX'
    [InfoBarPlugins.execQuick] src: IPCamViewer 'NoneType' object has no attribute 'isTmp'
    stopService
    [eDVBCAService] free slot 0 demux 3 for service 1:0:1:2C2E:251C:FBFF:820000:0:0:0:
    [eDVBCAService] free service 1:0:1:2C2E:251C:FBFF:820000:0:0:0:
    decoder state: play, vpid=-1, apid=-1
    DEMUX_STOP - pcr - ok
    DEMUX_STOP - video - ok
    VIDEO_STOP - ok
    AUDIO_STOP - ok
    DEMUX_STOP - audio - ok
    AUDIO_CONTINUE - ok
    start release channel timer
    [CrashlogAutoSubmit] - autostart
    (exit code 5)
    ]]>
    </enigma2crashlog>
    <pythonMD5sum>
    <![CDATA[


    Ich glaub bei den rot markierten liegt das problem. Seitdem ich das geändert habe kommt der Crash! Aber wie bekomm ich das wieder auf true? Mit neuinstallieren geht das nicht.

    Gruss Fab

    Edited 2 times, last by fab ().

  • Hi Shumifan50 and thanks for your great realese :)
    In your thread, you ask if somebody try your software on a vu+duo and yes, i try it but unfortunately the soft doesn't start and crash my enigma2 :(
    Do you think a wrong config file can stop the start of ipcamviewer ?
    My camera is a Tenvis cam JPT3815.
    I hope you can help me.
    Thanks for your time.
    Karl

  • Re hi Shumifan50,
    so, i've posted my question after trying hours and hours, but after that, i've tried to put your new driver of this thread and enigma stop to crash :) but the window cam closed immediatly :( so i've changed my command line and YYEESSS i've got the picture !!!
    thanks a lot for your software :)


    Karl

  • Quote

    Original von fab


    Hatte es schon bemerkt und dadurch zum laufen gebracht. Trotzdem danke. Spätestens jetzt wäre es durch deine hilfe gelaufen :tongue:



    {command}{Levelone.snapshot}{/img/snapshot.cgi}
    {command}{Levelone.protocol}{http://}
    {camera}{192.168.178.**}{Levelone}{Ort}{Username}{Password}



    ev mal mur die 3 Zeilen eingeben und dann mal ohne Usernamen u. Password

    Ich spare Strom, esse das Fleisch roh und trinke den Kaffee kalt.


    :hurra:


  • Beitrag komplett gelesen? Wurde schon gelöst ;)

  • Quote


    That still looks like the HTML control page - you need the URL that just requests a single .jpg image. You are getting closer to the required url. If you view the page source you should find the ul.

    2 x DM7025SS (Gemini2v4.4), DM600(PCD 7.0), DM800S (Gemini 4.4) TM9100(UR9B2), DM500HD, Triax 88cm dish, Technomate motor.

  • Do you see a single picture or is t continually updating?

    2 x DM7025SS (Gemini2v4.4), DM600(PCD 7.0), DM800S (Gemini 4.4) TM9100(UR9B2), DM500HD, Triax 88cm dish, Technomate motor.

  • Quote

    Original von shumifan50
    Do you see a single picture or is t continually updating?


    just a single picture.

  • I'd recommend to use the camoFS plugin.


    Mamba

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

  • Quote

    Original von mamba0815
    I'd recommend to use the camoFS plugin.


    Mamba


    Mamba, also a special thanks to you. as per your recommend, camoFSis already in use but I want also double check IPCamViewer to compare those two different plugs and decide to implement one of these in future.

  • Ah ... ok. Understood.


    :D

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

  • Edit the following 3 lines in IPCamViewer.conf


    {command}{Levelone.snapshot}{/record/current.jpg}
    {command}{Levelone.protocol}{http://}
    {camera}{192.168.178.**}{Levelone}{Ort}{Username}{Password}

    2 x DM7025SS (Gemini2v4.4), DM600(PCD 7.0), DM800S (Gemini 4.4) TM9100(UR9B2), DM500HD, Triax 88cm dish, Technomate motor.

  • Howzit Shumifan50,


    I've been trying to get your plugin (enigma2-plugin-extensions-IPCamViewer_20 11-01-10_mipsel.zip) to work on my DB 800se together with my Geovision GV800 DVR card (not an IP camera) with 4 cameras attached.


    To accommodate for GV800 DVR not displaying jpeg feeds using their 8.5 software and windows 7,


    I installed Ubuntu 11.10 32bit Desktop with zoneminder, getting zoneminder to work for GV800 is a pretty tough task on it's own but that's done now and with some other settings to zoneminder I can now see a constantly updating jpeg feed on:


    Code
    http://192.168.1.120/cgi-bin/nph-zms?mode=jpeg&monitor=7&user=admin&pass=admin


    When I launch the plugin with my config the spinner just keeps spinning with the below config:


    Code
    {command}{foscam.snapshot}{/cgi-bin/nph-zms?mode=jpeg&monitor=3&user=admin&pass=admin}
    {command}{foscam.protocol}{http://}
    {command}{foscam2.snapshot}{/cgi-bin/nph-zms?mode=jpeg&monitor=7&user=admin&pass=admin}
    {command}{foscam2.protocol}{http://}
    {camera}{192.168.1.120}{foscam}{Kitchen}{admin}{admin}
    {camera}{192.168.1.120}{foscam}{Lounge}{admin}{admin}


    I tried a few other configs none worked.


    Do you think it is possible to use your plugin to display my jpeg feed?

  • The URL must NOT be a constantly updating jpg stream, it must provide a single jpg mage for each request.

    2 x DM7025SS (Gemini2v4.4), DM600(PCD 7.0), DM800S (Gemini 4.4) TM9100(UR9B2), DM500HD, Triax 88cm dish, Technomate motor.

    Edited once, last by shumifan50 ().

  • Hi Shumifan50,


    After trying many different things to get my config working, I am happy to say your plugin works with a Geovision GV800 card running on Ubuntu with Zoneminder with all CCTV cameras visible.


    It took me all week trying other methods including streaming from the server with vlc which worked too but slowly for the dreambox, then by chance I found a post for geovision single jpeg mode and thought I would give it a go and sure enough it works.


    Only one change to my previous URL and config the word "single" instead of "jpeg".


    Like below:


    Code
    http://192.168.1.120/cgi-bin/nph-zms?mode=single&monitor=16&user=admin&pass=admin



    More info here: http://www.zoneminder.com/forums/viewtopic.php?f=9&t=18939

  • Hi Shumifan,


    first thumbs up for your great plugin!!!
    I use the plugin in combination with my door bell. if it rings the camera pops up. Now it would be very nice, if i could send a http request to open the door (from the dreambox remote).
    It would be easy to use one of the PTZ commands, but the request must be send to a different ip...
    {command}{Axis.up}{http://192.168.0.1/opendoor.sh }
    {command}{Axis.snapshot}{/axis-cgi/jpg/image.cgi?resolution=640x480}
    {command}{Axis.protocol}{http://}
    {camera}{http://192.168.0.2}{Axis}{Eingang}{root}{root}


    Is there a way to solve my problem? I´m using just one camera, so i can live with a "hack" e.g. every PTZ command points to 192.168.0.1...
    I tried to read the plugin.pyc but with no luck... :(


    Thanks in advanced


    FTZ