Project Valerie - MediaCenter for Enigma2

  • Ein anderes Problem bei mir ist, dass immer noch einzelne Episoden von Serien nicht in die Datenbank übernommen werden. Auch beim wiederholten Suchlauf tauen sie nicht auf.


    z.B. die Datei "DVD11s01e065.avi" wird über die valerie.info richtig erkannt.
    Die Datei "DVD11s01e066.avi" im selben Verzeichnis wird einfach nicht angezeigt.


    Gibts da schon nen workaround?


    Edit: Die Serie (Caillou) hat besonders viele Episoden (ca. 170) in der ersten Staffel. Bei anderen Serien ist mir der Fehler noch nicht aufgefallen. Vielleicht hat es was mit der großen Zahl an Episoden zu tun.

    Xtrend et9000 mit OpenPLI 4
    SEDUlight
    FreeNAS 9

    Edited once, last by mrMuppet ().

  • Servus,


    @ Tom,
    gut das du mich drauf bringst. Habe auch das Problem mit doppelten Filmen da ich ab und zu mal tausche bzgl. der Qualität und diese bei mir im Dateinamen ist.


    Hat die Umstellung auf /media/net jetzt den Erfolg gebracht oder nicht? Neusync der ganzen Bibliothek ist zwar unschön, aber mir definitiv wert um die doppelten Rauszukicken. Hab bis jetzt immer im Webinterface gelöscht, dauert aber immer etwas, also nicht grad die schöne Art


    muppet,
    Ich glaub nicht das 170 Folgen ein Problem sind, schischu und Don haben damals extra umprogrammiert, weil ich selbst einmal 120Folgen in einer Staffel habe, dass die dreistellige Anzeige klappt

  • Hallo Mrmuppet,


    Ich bin fasziniert....
    Eigentlich hatte ich es die Tage genau so versucht und es ging nicht. Gerade noch mal probiert und es geht?!


    Ich probiere mal weiterr und fahre nachher ein Update. Habe noch die 1253 drauf.

  • Quote

    Original von jogalla
    Hallo Mrmuppet,


    Ich bin fasziniert....
    Eigentlich hatte ich es die Tage genau so versucht und es ging nicht. Gerade noch mal probiert und es geht?!


    Ich probiere mal weiterr und fahre nachher ein Update. Habe noch die 1253 drauf.


    Leider klappt es bei mir doch nicht richtig. einen Tag später, bzw. einen "fast sync" später ist der Film wieder zu failed gewandert.... :-(

    Xtrend et9000 mit OpenPLI 4
    SEDUlight
    FreeNAS 9

  • Quote

    Original von mrMuppet


    Leider klappt es bei mir doch nicht richtig. einen Tag später, bzw. einen "fast sync" später ist der Film wieder zu failed gewandert.... :-(


    Shit Du hast Recht, nach dem nächsten Sync (normal) sind die Filme bzw. Dokus wieder futsch...
    Somit spare ich mir das Update erst mal, der Rest läuft ja so weit.


    Jemand einen Vorschlag?

  • Quote

    Original von jogalla


    Shit Du hast Recht, nach dem nächsten Sync (normal) sind die Filme bzw. Dokus wieder futsch...
    Somit spare ich mir das Update erst mal, der Rest läuft ja so weit.


    Jemand einen Vorschlag?


    Meinem Verständnis nach sollte es aber beim normalen Sync immer so sein, dass die von Hand eingetragenen Filme wieder weg sind. schließlich wird in diesem Fall quasi eine neue Datenbank aufgebaut. Nach dem fast scan dagegen, werden nur neue Filme ergänzt.

    Xtrend et9000 mit OpenPLI 4
    SEDUlight
    FreeNAS 9

  • Quote

    Original von Taishin
    Servus,


    @ Tom,
    gut das du mich drauf bringst. Habe auch das Problem mit doppelten Filmen da ich ab und zu mal tausche bzgl. der Qualität und diese bei mir im Dateinamen ist.


    Hat die Umstellung auf /media/net jetzt den Erfolg gebracht oder nicht? Neusync der ganzen Bibliothek ist zwar unschön, aber mir definitiv wert um die doppelten Rauszukicken. Hab bis jetzt immer im Webinterface gelöscht, dauert aber immer etwas, also nicht grad die schöne Art


    Die Umstellung auf einen Pfad ohne softlink hat zumindest bewirkt, dass die Dateien nicht (vollständig) gelöscht werden. Im Rahmen eines neuen sync-Laufs werden aber noch immer bereits von mir bearbeitete und in der DB gespeicherte Filme wieder von PV geändert.


    Aus diesem Grund habe ich mal das Ergebnis des letzten sync-Laufs hier angehängt.


    1. Ich hatte insgesamt 27 Filme bearbeitet und in der Datenbank erfasst. Nach dem Neustart der Box waren diese auch noch vorhanden.


    2. Die durchsuchten Pfade wurden um einen weiteren Film ergänzt, so dass insgesamt 28 Filme hätten erfasst werden müssen. 27 unter Movies, einer unter failed.
    Ergebnis: unter failed keiner, unter Movies 22, von mir erfasste imdb Verweise auf die richtigen Daten wurden korrigiert. Diverse Einträge zu 'last action hero' oder 'the comedy' sind schlicht falsch.


    Ich glaube nicht, dass es sich hierbei um etwas handelt, was ein Bedienerproblem ist. Bin mit meinem Latein am Ende. PV ist somit zzt. nicht nutzbar, da ich keine Datenbank aufbauen kann.


    Wäre auch schön zu erfahren, ob die Entwickler das Problem kennen!?


    Gruß


    Tom

  • Hi@all,


    hab ein kleines Problem mit PV. Hab alle Folgen von Captain Future manuel hinzugefügt, im Webinterface werden die auch alle angezeigt, sowohl bei dr Dream800se als auch bei der GB800ue. Wenn ich aber im PV auf die Serie gehe bekomme ich keine Folgen angezeigt...
    Wie bekomme ich denn die Einzelfolgen auch im Menü der Boxen angezeigt?

    Files

    • CF1.png

      (254.01 kB, downloaded 608 times, last: )
    • CF2.png

      (431.11 kB, downloaded 627 times, last: )
  • Hab mal zum Spass meine 28 Filme in einen Ordner gepackt und nur diesen als Suchpfad erfasst (wie mit der Testdatei).


    1. Es werden im Rahmen des normalen Sync-Laufs 28 Dateien gefunden.


    2. Unter Movies werden 9, unter failed 16 Dateien gelistet = 25 ?!?


    3. Alle Dateien wieder bearbeitet, so dass 25 unter Movies erscheinen. Nach Bearbeitung 'save to DB'.


    4. Box neu gestartet. Die 25 Dateien unter Movies sind noch da.


    5. Einen fast(!) Sync-Lauf gemacht, um die fehlenden drei Dateien vielleicht doch noch zu erfassen.


    6. Ergebnis = 9 Dateien unter Movies, 16 unter failed


    So langsam gilt hier der Leitspruch "Lieber ausschalten als draufhauen". :einschenken:
    Hab jetzt zwei Tage verschenkt.


    Ich kann mich nur wiederholen, dass ich eine kurze Information der Entwickler sehr begrüßen würde. Da diese bisher nicht erfolgte, gehe ich zzt. davon aus, dass sich niemand um das Problem kümmert - nicht wichtig oder relevant?


    Was mir bezüglich der doppelt erfassten Einträge in diesem Zusammenhang in den Sinn gekommen ist... Unter den Einstellungen für die Syncronisation kann man vorgeben, ob bei einer nicht mehr vorhandenen Datei der Eintrag in der DB erhalten bleiben soll oder nicht. Da der Abgleich zwischen DB-Bestand und den Videofiles wohl nicht richtig funktioniert und alle Dateien als 'neu' eingestuft werden, wird ein neuer Eintrag erstellt und der alte beibehalten, wenn nach o. g. Einstellung die Verweise bzw. Movies von nicht existierenden Dateien nicht gelöscht werden sollen. Im Ergebnis hat man dann zwei Einträge für eine Filmdatei. Ist aber ins Blaue hinein...


    Gruß


    Tom

  • tom.smith!
    Leg' Dir zu jedem der problematischen Filme eine nfo-Datei mit dem IMDB-Code des Films als einzigen Inhalt an und speichere sie im gleichen Ordner in dem die Filmdatei liegt. Die nfo-Datei muss denselben Namen wie die Filmdatei tragen, also nehmen wir an die Filmdatei heißt "Terminator I.ts", dann muss der Name der nfo "Terminator I.nfo" lauten. Erstellen kannst Du die Datei mit einem Texteditor und sie muss mindestens 2 Zeilen lang sein. Genaueres steht im Wiki von Valerie.
    Liebe Grüße!


    G

  • Hallo zusammen


    Ich habe unter project-valerie Einstellungen mein Skin geändert seitdem startet project-valerie nicht mehr bekomme auch kein Green Screen oder Fehlermeldung habe das Plugin unter Erweiterungen deinstalliert und wieder neu installiert leider besteht das selbe Problem ich hoffe ihr könnt mir da weiterhelfen da ich dieses Plugin eines der besten finde :)


    LG Lony

  • Quote

    Original von Lony
    Hallo zusammen


    Ich habe unter project-valerie Einstellungen mein Skin geändert seitdem startet project-valerie nicht mehr bekomme auch kein Green Screen oder Fehlermeldung habe das Plugin unter Erweiterungen deinstalliert und wieder neu installiert leider besteht das selbe Problem ich hoffe ihr könnt mir da weiterhelfen da ich dieses Plugin eines der besten finde :)


    LG Lony


    einfach unter /etc/enigma2/ die datei settings bearbeiten und dort den eintrag pvmc.skin löschen.


    dann durchstarten. sollte dann wieder den standard skin verwenden.

  • Quote

    Original von Mabthera
    tom.smith!
    Leg' Dir zu jedem der problematischen Filme eine nfo-Datei mit dem IMDB-Code des Films als einzigen Inhalt an und speichere sie im gleichen Ordner in dem die Filmdatei liegt. Die nfo-Datei muss denselben Namen wie die Filmdatei tragen, also nehmen wir an die Filmdatei heißt "Terminator I.ts", dann muss der Name der nfo "Terminator I.nfo" lauten. Erstellen kannst Du die Datei mit einem Texteditor und sie muss mindestens 2 Zeilen lang sein. Genaueres steht im Wiki von Valerie.
    Liebe Grüße!


    G


    Hallo Mabthera,


    habe Deinen Hinweis umgesetzt. Zu zwei Testdateien konnte PV die Zuordnung zu imdb vornehmen. Danach habe ich einen DVD-Ordner zum testen in den Suchpfaden (neuer Pfad mit use Folder) ergänzt und den Ordner Video.ts entsprechend dem Filmtitel umbenannt und die imdb-ID ergänzt -> Bsp. Otto_tt1234567_(2012).
    Hat nicht funktioniert. Suche nach ca. 40 Minuten abgebrochen (sollte für insgesamt drei Filme ausreichen), da im ersten erfolgreichen Suchlauf das Ganze innerhalb von Sekunden beendet gewesen ist.
    DVD entfernt und eine weitere 'einfache' Filmdatei zum Suchpfad hinzugefügt. Suche steht jetzt nach
    Syncronisation gestartet
    Lade Konfiguration
    Lade Daten


    Mit webif kann ich mich nicht einwählen... siehe Datei im Anhang


    :rolleyes: ;(


    :330:

  • Nach dem Wiki von PV sollen DVD anhand des Ordners syncronisiert werden:


    Code
    === DVDs === Valerie erkennt Filme die in mehreren Dateien vorliegen anhand des Namens. Eine Ausnahme sind Ordner mit einer DVD Struktur (`*`.vob, `*`.ifo) als Inhalt. Da hier anhand des Dateinamens keine Suche gestartet werden kann, wird in solchen Fällen immer der Ordnername als Suchbegriff verwendet.


    Welcher Ordner ist gemeint? Macht es einen Unterschied, ob man den Ordner mit den beiden Verzeichnissen audio.ts und video.ts mit dem Filmnamen und der imdb-id versieht oder kann/muss es der video.ts-Ordner sein, der dann die .vob-Dateien enthält?


    Des Weiteren ist mir nicht klar, welcher Ordner in den Sync-Pfad aufgenommen werden muss. Habe jetzt den Ordner als Suchpfad erfasst, in dem dann die einzelnen Ordner mit den DVD-Strukturen liegen (Hauptverzeichnis / DVD-Folder / Audio.ts bzw. Video.ts) = Hauptverzeichnis. Richtig?


    Für Infos wäre ich sehr dankbar.


    Gruß

  • Also mit DVDs und PV habe ich mich noch nie beschäftigt, daher kann ich Dir damit nicht weiterhelfen. Ich verwalte nur die selbstaufgenommenen Filme auf meinen NAS mit Valerie und da klappt eigentlich alles prächtig.
    Vielleicht äußert sich Don dazu, der kann Dir sicher helfen.
    Liebe Grüße!


    G

  • Quote

    Original von Mabthera
    Also mit DVDs und PV habe ich mich noch nie beschäftigt, daher kann ich Dir damit nicht weiterhelfen. Ich verwalte nur die selbstaufgenommenen Filme auf meinen NAS mit Valerie und da klappt eigentlich alles prächtig.
    Vielleicht äußert sich Don dazu, der kann Dir sicher helfen.
    Liebe Grüße!


    G


    Hallo Mabthera,


    bis zur Anschaffung des NAS und Umstieg auf einen BD-Player habe ich Filme über meinen DVD-Receiver aufgenommen (Festplatte und DVD-Brenner) und diese dann als DVD archiviert. Bin nun dabei diese Filme auf den NAS zu bringen. Da ich keinen (weiteren) Qualitätsverlust erleiden möchte, wandele ich diese zzt. nicht in mkv-files etc. um. Der Pionieer hat die Filme hinsichtlich der bitrate schon geschrumpft, damit diese auf die DVD passen...


    Gruß


    Tom

  • Kann ich nachvollziehen, leider ist die Dateistruktur von DVD und BD recht tricky. Deshalb bin ich davon sehr rasch abgekommen und archiviere nur mehr transport-streams auf Festplatte.
    Liebe Grüße!


    G

  • Quote

    Original von Atlanos01
    Hi@all,


    hab ein kleines Problem mit PV. Hab alle Folgen von Captain Future manuel hinzugefügt, im Webinterface werden die auch alle angezeigt, sowohl bei dr Dream800se als auch bei der GB800ue. Wenn ich aber im PV auf die Serie gehe bekomme ich keine Folgen angezeigt...
    Wie bekomme ich denn die Einzelfolgen auch im Menü der Boxen angezeigt?


    Keiner eine Idee???



  • Ich handhabe das so:


    1. Ordner erstellen mit Filmtitel und ID gemäß IMDB (bspw. "Terminator 2 - Tag der Abrechnung (1991) tt0103064")


    2. in diesen Ordner den VIDEO_TS-Ordner von der DVD kopieren


    3. Sync in PV durchlaufen lassen und freuen :)

    VU+ Duo4k SE VTi & DM 820 GP - MacBook Pro 15" 2012, AppleTV, AVR-Heimkino mit Marantz SR7007 und Canton Ergo 5.1-Set
    Datengrab: Fantec http://bit.ly/1Gk291p
    Mitglied-Nr. 7.625 von ca. 345.000

    Webseite