Project Valerie - MediaCenter for Enigma2

  • Hi J.R.,


    schön mal wieder von dir zu hören!


    Enigma2 Crashlog hab ich keins. Es wird nur ein Valerie-Log geschrieben!


    Da die Box "nur" einen GUI-Neustart macht ist das wohl auch ok.
    Dachte dass es evtl an knappem Memory liegt, aber ich hab bereits ein Swapfile auf USB-Stick angelegt...
    Oder muss ich das Logging bei der Box erst aktivieren (analog zu PV mit Debug Level auf High)?


    Gruß,
    brilli_willi

  • das Sonderzeichen ' wird in der Filmliste auf dem OSD nicht mehr korrekt umgesetzt. (z.B.: beim Film Big Mama's Haus). Kann das jemand bestätigen?

  • Kann einer der Devs mir erklären, warum meine interne hdd der 8k immer anläuft, obwohl die Daten (media folder) alle auf einem Usb-Stick liegen?

  • Quote

    Original von Stylewarz3
    das Sonderzeichen ' wird in der Filmliste auf dem OSD nicht mehr korrekt umgesetzt. (z.B.: beim Film Big Mama's Haus). Kann das jemand bestätigen?


    als Ergänzung sei noch gesagt, dass die Anzeige des Zeichen ' durch ' ersetzt wird. Umlaute wie ä, ü und ö werden korrekt dargestellt.


    Nicht alle Filme mit dem Sonderzeichen ' werden falsch dargestellt. Der Film Gangster's Paradise z.B. wird korrekt dargestellt. Big Mama's Haus und Carlito's Way nicht!

  • Habe mich heute mal wieder getraut seit langer Zeit nen Update von Valerie zu machen.
    Ich hätte es wohl besser lassen sollen.


    Irgendwie frisst er meine Datenbank nicht mehr. Die hat angeblich keine Einträge mehr.
    Was aber nicht der Fall ist.


    Die Datenbank liegt auf meinem Server. Zugriff ist sichergestellt, vor dem Update hat alles funktioniert.
    Pfade in PV stimmen soweit auch.


    Im Log sehe ich auch nichts, was weiterhelfen könnte.

    ByeBye Dream, hello VU+ ;)

    Edited 2 times, last by Diablo82 ().

  • Hi kati88,


    ein paar mehr Infos wären nicht schlecht... Wann genau läuft die Platte an? Bereits wenn Du PVMC nur aus dem Hauptmenu aufrufst? Oder wenn Du einen Film zum anschauen ausgewählt hast? Oder bei einem Sync? Oder... ?


    Wie sieht es mit den restlichen Ordnern aus? Du hast jetzt nur vom "media folder" gesprochen, der auf dem Stick liegt - aber wir haben ja insgesamt drei Ordner, die man konfigurieren kann. Wie sieht es z.B. mit dem Ordner für die Logfiles aus? Oder dem Ordner für die Datenbank? Auch alle auf dem USB-Stick?


    Gruß, J.R.

    „Wer die Freiheit aufgibt um Sicherheit zu gewinnen, der wird am Ende beides verlieren.“
    Benjamin Franklin

  • Hi Diablo82,


    kannst Du bitte mal die alte PVMC-Version und die neue Version, auf die Du jetzt das Update gemacht hast, nennen? Ein aktuelles Logfile mit Debug-Mode "high" könnte vielleicht auch hilfreich sein.


    Und: hast Du zufällig mehrere mediafiles* Dateien in Deinem Datenbank-Ordner?


    Danke und Gruß, J.R.

    „Wer die Freiheit aufgibt um Sicherheit zu gewinnen, der wird am Ende beides verlieren.“
    Benjamin Franklin

  • Ich hab leider keinen Plan mehr, welche Version ich vorher drauf hatte.
    Kann ich das irgendwo noch rausbekommen?


    Upgedatet habe ich auf die aktuelle release Version 1239.


    Logfile hänge ich dir an, da ist aber wie gesagt nix zu erkennen.
    mediafiles gibts nur einmal.


    Inhalt des Verzeichnisses:


    dreamscene
    episodes
    fastcrawl.bin
    media
    mediafiles.db
    paths.xml
    post_movie.conf
    post_tv.conf
    pre.conf
    sync.xml
    tables.db

  • Quote

    Original von Stylewarz3
    das Sonderzeichen ' wird in der Filmliste auf dem OSD nicht mehr korrekt umgesetzt. (z.B.: beim Film Big Mama's Haus). Kann das jemand bestätigen?


    Hab bei mir gerade mal ein Dummy-File für diesen Film angelegt und das ganze syncen lassen => der Titel wird überall (PVMC-GUI und WebIF, sowie Display der Box, wenn das File zum Abspielen ausgewählt wurde) korrekt angezeigt...


    Kennst Du mal ein paar mehr Infos zu Deinem Setup nennen? Laut Profil hast Du keine ext. Speichermedien - ist das noch aktuell? Und wie sieht die Darstellung im WebIF aus - hast Du da auch dieses Problem?


    Gruß, J.R.

    „Wer die Freiheit aufgibt um Sicherheit zu gewinnen, der wird am Ende beides verlieren.“
    Benjamin Franklin

  • Hi Diablo,


    hmmm - das Log sieht irgendwie komisch aus... Da fehlt die Hälfte... :(
    Also wenn das File genau so mitgeschrieben wurde, dann mach bitte nochmal einen E2 neustart und schick mir bitte nochmal das neue File - nur zur Sicherheit...


    Wie groß ist eigentlich diese mediafiles.db?


    Gruß, J.R.

    „Wer die Freiheit aufgibt um Sicherheit zu gewinnen, der wird am Ende beides verlieren.“
    Benjamin Franklin

  • Ich habe vor dem Log einen kompletten Neustart gemacht (nicht nur GUI).


    Mediafile.db ist 29 byte sehe ich gerade .... sprich PV hat meine Datenbank beim Update wohl einfach mal weggeworfen?!

    ByeBye Dream, hello VU+ ;)

  • Quote

    Original von Diablo82
    Die Datenbank liegt auf meinem Server. Zugriff ist sichergestellt, vor dem Update hat alles funktioniert.
    Pfade in PV stimmen soweit auch.



    Hmmm, bist du dir sicher, daß es so eine gute Idee ist, die Datenbank auf einem Server zu speichern? Rein von der Sache her dürfte das PV auch ziemlich ausbremsen, Stichwort Bilder und Plakate etc. nachladen, da Netzserver doch wesentlich behäbiger sind als ein direkt angeschlossenes Laufwerk (v.a. Zugriffszeit, aber auch die Transferrate, die hier allerdings weniger zum Tragen kommen dürfte).


    Versuch doch mal, deine Datenbank bspw. auf einen USB-Stick zu speichern und diesen direkt an die DM zu stecken und vergleiche mal die Performance.


    Ich hatte meine iTunes-Mediathek mal eine Zeit lang auf einem NAS gespeichert, weil ich das für eine gute Idee hielt, aber das war praktisch unzumutbar! Heute sichere ich nur noch fertige Filme auf einem Netzlaufwerk, von wo sie auf die DM gestreamt werden, weil da die o.g. Probleme praktisch kaum (!) ins Gewicht fallen.


    Es sei denn, man unterbricht die Wiedergabe mal mit "Pause" und will sie - bspw. nach einer Kippenpause - wieder fortsetzen, dann findet er manchmal den "Faden" nicht wieder.


    Ich weiß, mit deinem Problem hat das im Grunde nichts zu tun, aber vll. bewirkt das bei dir ja an anderer Stelle was.

    DM800se + GP3 - iMac 11,2 - Sharp LC-46LE820E - Onkyo TVX-SR 608 - Canton Ergo 5.1

  • Da fällt mir grad ein: wie wäre es denn mit einem "Pufferspeicher" für PV für gestreamte Filme? Quasi wie bei der Multi-Mediathek, dort kann man ja auch Filme direkt streamen oder auf der HDD zwischenspeichern und dann von dort wiedergeben. Ich bin mir ziemlich sicher, daß das einen deutlichen Vorteil für die Wiedergabe von NASen & Co. geben dürfte :p

    DM800se + GP3 - iMac 11,2 - Sharp LC-46LE820E - Onkyo TVX-SR 608 - Canton Ergo 5.1

  • KJFewerder


    Die Performance ist sehr gut. Ich betreibe das jetzt schon eine ganze Weile so.
    So groß sind die Dateien ja nicht und ob so ein 1,5 MB Bild von der lokalen Platte oder vom Server gezogen wird, macht von der Performance her nicht wirklich nen Unterschied.


    Ich schätze mal es lag einfach an deinem NAS. So billige NAS Systeme haben nicht wirklich Datendurchsatz, von der lokalen I/O wie auch übers Netzwerk. Da merkst du spätestens wenn deine Filme ruckeln.


    Mein Server macht knapp 70 MBit lesend/schreibend pro Minute via Netzwerk.
    1080p mit 1300kbit DTS Spur laufen flüssig und problemlos, auch beim Spulen.
    Da stößt so manches billig NAS an seine Grenzen.

    ByeBye Dream, hello VU+ ;)

    Edited 2 times, last by Diablo82 ().

  • Jap, die Problematik mit "billigen NASen" ist mir geläufig. Bin grundsätzlich kein Freund von den Dingern! Vor allem nicht als Datenspeicher für den PC. Selbst meine Musik-Datenbank war auf einem NAS schlecht platziert und glänzte durch längere Pausen zwischen den einzelnen Titeln (ca. 1 Sekunde, manchmal länger), beim setzen von ID3-Tags wurde das auch schon mal zur Geduldsprobe, wenn Du mehrere Dateien in einem Rutsch bearbeiten wolltest und gelegentlich blieb die Wiedergabe einfach stehen. Darum habe ich das teil dann wieder verkauft :)


    Einzig als reiner Filmserver sind die Dinger zu gebrauchen, sofern sie die nötige Transferrate bringen, um den Film ohne Ruckeln anzuzeigen, also wenn die DM die Filme schneller laden kann, als sie sie wiedergibt. Da es heute kaum Filme mit mehr als 20MBit Datenrate gibt (TV-Filme, BDs oder 1080p-Filme können mehr haben, spielen dabei aber keine Rolle, da solche ja zu gefühlt 95% eh aus illegalen Quellen stammen und die DM ja eh kein 1080p wiedergibt?!?), was also rund 2,5 MB/s entspricht, die selbst billige Geräte stemmen können sollten, sollte das hierbei also kein Problem darstellen!


    Aber wenn Du in kurzer Zeit auf viele kleine Daten zugreifen willst/mußt, macht sich die deutlich höhere "Zugriffszeit" auf das NAS schnell bemerkbar. Wenn Du jedoch beim Laden der Bilder etc. keine Probleme erkennen kannst, gut so! :p


    War nur so ein Gedanke, falls Du mal etwas experimentieren magst ;)



    Aber als so einen Filmserver würde ich mir ganz gerne doch wieder so ein NAS zulegen.
    Spezifikationen: mind. 2, idealerweise 4 HDD-Trays, die separat funktionieren, also nach und nach selber bestückt werden können und wo jede HDD als einzelnes Laufwerk angesprochen wird, so daß also nur eine HDD läuft, wenn ein Film gestreamt wird. Und möglichst leise! Und die Datenrate sollte natürlich mindestens 10MB/s betragen! (MB/s, nicht MBit/s ;) )


    Kennt jemand so ein Gerät, das er empfehlen könnte?

    DM800se + GP3 - iMac 11,2 - Sharp LC-46LE820E - Onkyo TVX-SR 608 - Canton Ergo 5.1

  • Bzgl Datenbank auf NAS,
    die wird ja eh nur zu Beginn geladen und befindet sich dann im Arbeitspeicher.


    Bzgl deiner Datenbank die wohl in der Tat ein bischen klein ausschaut,
    du hast doch bestimmt noch mehr Logs?


    Weil interessant wäre hier ja was beim ersten Start nach dem Update passiert ist.


    Mit etwas Glück hat er sich nur verirrt und sie vlt wo anders hingespeichert. Auch wenn ich zugeben muss das die warscheinlichkeit doch gering ist.

  • @kjf..


    schau mal unter suche nas..
    da gibts etliche berichte..


    also empfehlen kann man qnap und synology

    2x Dm 8000, Ds409, Qnap TS-459 Pro II, SPF-107H,Onkyo TX NR-509,Teufel Consono 35,PS3,Fritzbox 7270,7390,Wii,XboX1,Down 50 Mbits, Up 10 Mbits

  • Hallo Schischu.....


    da ich Dich mal hier zufassen bekomme.....oder auch nicht....habt Ihr noch vor eine Musikverwaltung in das Project zu integrieren so wie in etwa die Filmverwaltung ausschaut.....Cover anzeige ect.?


    Danke Gruß


    edit....
    oder auch nicht....

    Edited 3 times, last by IPMAN ().

  • @Schicschu
    Mein DB wird wohl vom Update überschrieben worden sein. Habe sie ja nur an dem einen Speicherort liegen. Drin waren über 300 Titel, da sind 29 Byte Database wohl etwas klein zu.


    Ihr solltet vor dem Update ein Backup der DB einbauen oder zumindest nen Hinweis. Das ist hier ja imho schon einigen in früheren Versionen passiert ??


    Das Logfile ist doch random oder? Ich habe zumindest nur das eine im ValerieLog Ordner liegen.
    Wenn du noch ne Idee hast, wo ich noch schauen könnte, seh ich aber gern mal nach.



    KJFewerder
    10 MB pro Sekunde wirst du kaum hinbekommen.
    Ich wage mal zu behaupten, dass ich schon so ziemlich das Optimum herausgeholt habe, in Verbindung mit der Dreambox.
    Die ist ja auf ihre 100Mbit LAN Schnittstelle begrenzt, da sollten 70 Mbit/s Realwert ganz ordentlich sein.


    Laufen habe ich gar kein fertiges NAS sondern nen Linux System auf Desktop/Laptop Hardwaretechnik. Das ist allemal performanter und much more customizeable als nen überteuertes Fertig-NAS.


    Das wird jetzt hier aber zu sehr OT.

    ByeBye Dream, hello VU+ ;)

  • @IPMAN: Also ich persönlich hab nichts von einer Musiksammlung da ich auch keine habe.
    Deswegen bin zumindest ich recht unmotiviert in die Richtung zu gehen.
    Aber man soll nie nie sagen.


    Diablo82: Das ist ärgerlich, die werden in /tmp abgespeichert, heist nach einem Neustart ist das Ding weg.