Project Valerie - MediaCenter for Enigma2

  • Quote

    Originally posted by Loomes


    Warum willst du dem entgegenkommen.
    Ich selbst nutze das für mich ebenfalls da mir der Standard Skin so wie er ist nicht zusagt (schriftart, schritfarben, schriftschatten usw).
    Das ist doch das schöne an E2, das es sich jeder so anpassen kann wie er das gerne hätte.
    Das Problem mit Valerie ist eben das es sich imo im ständigen Fluss befindet und dadurch öfter mal Anpassungen nötig sind, das wird sich ja aber mit der Zeit auch wieder beruhigen.


    Naja Valerei hat ja eigene Skins, wenn man nun die einzelnen Screens alle im globalen e2 skin.xml überschreibt, dann läuft mein eigenes Skin Konzept natürlich auf Eis.


    Mein Skinkonzept beinhaltet ja auch das jeder Screen ein API Level hat, der bei Änderungen erhöht hat, dies hat den Hintergrund das auch bei großen Änderungen ältere Skins kompatible bleiben und weiterhin laufen.
    Aber das funktioniert natürlich nicht wenn jemand im globalen e2 skin.xml meine Screens überschreibt, weil ich schaue nicht in der globale skin.xml nach dem API Level sonder in dem Skin der in Valerie unter Skins ausgewählt wurde.


  • Nein das liegt nicht an dir oder deinem Skin, Fehler ist mittlerweile gefunden, liegt an den Änderungen am 720p default Skin von JackDaniel.
    Als alternative kann ich momentan den blackSwan empfehlen, da ist zwar momentan noch nicht alles Optimal aber solange bis der default wieder geht ist es eine akzeptable Alternative.

  • Quote

    Original von Schischu
    weil ich schaue nicht in der globale skin.xml nach dem API Level sonder in dem Skin der in Valerie unter Skins ausgewählt wurde.


    Naja also wenn ich das prinzip der Skins nicht komplett falsch verstanden habe, jetzt unabhängig von Valerie, dann hat der Screen in der skin.xml IMMER Vorrang vor den eigenen Screens des Plugins.
    Also übernehme ich die original Valerie Screens in meine skin.xml, natürlich auch mit den API angaben und modifiziere sie mir so wie ich möchte, in meinem Fall eben andere Schriftart und paar Kleinigkeiten.


    Und solange ich das aktuell halte und immer wieder dem original Valerie Skin angleiche (was dank dem cvs ja kein Problem ist Änderungen zu verfolgen) gibts da auch keine Probleme.

  • Bei mir ist Valerie mit dem grey-Skin auch immer abgestürzt (Green-Screen), aber blackSwan und der Default liefen beide ganz normal.


    Schischu:
    Wegen 720p/1080i:
    ich werd das heut abend nochmal überprüfen. Aber ich bin mir eigentlich sicher, dass er in der Movie- bw. TV Shows-Liste immer zu 1080i gewechselt ist.


    Noch ein kleiner Vorschlag:
    Ich find's ja super, dass ihr trakt.tv implementiert. Allerdings ist es im Moment so, dass wenn man einen Film über Valerie auch nur startet und nur für 2 Sekunden laufen lässt, der Film als "gesehen" an trakt.tv gemeldet wird. Das ist ziemlich unpraktikabel.


    Bei XBMC kann man einstellen, ab wann ein Film als gesehen gemeldet werden soll (70% oder 85%). Ist im Grunde egal was man da nimmt - wichtig ist nur, dass bei wenigen Minuten gucken das Ganze noch nicht als gesehen gemeldet wird. Ich gucke eigentlich IMMER kurz in einen Film rein um die Qualität zu checken, die Sprache, die Untertitel usw.


    Ist sicher nicht das dringendste Problem - aber ich wollt's trotzdem gesagt haben.


    Ansonsten freu' ich mich über die Anpassung des blackSwan bei der Movies / TV Show Liste.


    Greets
    Zodac

  • Quote

    Bei XBMC kann man einstellen, ab wann ein Film als gesehen gemeldet werden soll (70% oder 85%). Ist im Grunde egal was man da nimmt - wichtig ist nur, dass bei wenigen Minuten gucken das Ganze noch nicht als gesehen gemeldet wird. Ich gucke eigentlich IMMER kurz in einen Film rein um die Qualität zu checken, die Sprache, die Untertitel usw.


    Also im Grunde muss es der Player unterstützen, dann kann es auch eingebaut werden. Weiß nicht ob Schischu Lust hat den ganzen Player umzustricken, fall das nicht supportet wird.

  • Quote

    Original von Schischu
    Dann würd ich mal sagen das in deinem Ozoon Image wieder irgendwas an dem e2 Source geändert wurde.
    Ohne ordenliches Bootlog hab ich da keinerleih Chance draufzukommen.


    Anbei ein paar Log-Files die ich anbieten kann.


    Reicht das schon, oder wo krieg ich mehr her?
    Brauchst du ein dmesg?


    Das Image ist das aktuelle OoZooN auf der 8000nder.


    Gruss, deathrattle

  • Warum muss nur jeder Imagebauer an den Grundliegenden e2 Sachen rumwerkeln...
    deathrattle: Kannst du mir die skin.py hochladen?

  • Das sollte diese hier sein...


    Hab sie aus dem Verzeichnis "/usr/lib/enigma2/python/".


    Danke schonmal fürs nachsehen.

    Files

    • skin.py

      (19.28 kB, downloaded 5 times, last: )
  • Ich teste mal die neue Version und melde mich gleich wieder.



    Edit: Ja geil! Das Plugin läuft wieder. Vielen, vielen Dank fürs fixen und fürs tolle Plugin!

  • Quote

    Original von Schischu


    Nein das liegt nicht an dir oder deinem Skin, Fehler ist mittlerweile gefunden, liegt an den Änderungen am 720p default Skin von JackDaniel.
    Als alternative kann ich momentan den blackSwan empfehlen, da ist zwar momentan noch nicht alles Optimal aber solange bis der default wieder geht ist es eine akzeptable Alternative.


    Hi Schischu, danke für die Info. Gestern abend um 22 Uhr dann die neueste Version installiert....wollte den blackSwan ausprobieren. Danach: nun bleibt der Sync nach ca. 75 % stehen (hatte ich vorher nie)


    Ich probiere es heute abend nochmal....komisch, komisch.


    Sasha888

    Box1 : DM 7080HD Merlin4 OE2.2
    Box2 : VU+ Solo 4K
    Box3 : VU+ Duo2
    Box4 : VU+ Solo2
    NAS : Synology 1813+

  • deathrattle: Freut mich, war eigendlich nur ein Schuss ins Blaue. :-)


    Sasha888 unter /tmp sind Logs hinterlegt, mir zukommenlassen und ich kann die wahrscheinlich sagen warum er hängt.

  • Ich finde keinen Download für die PC-Applikation ?! Wo bekommt man das her ?

    DM5620S + Gemini
    DM8000 HD PVR + DVD + HDD ( 1TB )

  • Hat sich sowieso erledigt.
    Hat aufm A#ll#rus#sia#n Image Green Sreen verursacht und nach dem Neustart ist es aus der PlugIn Liste verschwunden. Den Skin hat es mir auch zerstört.
    Ich mache es nicht mehr drauf. Geht auch ohne.

    DM5620S + Gemini
    DM8000 HD PVR + DVD + HDD ( 1TB )

    Edited once, last by GalileoXXL ().

  • Ich hatte noch eine alte Version drauf, bevor ich ein neues Image drauf geworfen habe. Danach Valerie neu installiert in der neuen Umgebung und dann "Datenbank löschen" angewählt. weil ich keine Leichen wollte. soweit so gut. (oder eben auch nicht :-)


    Will ich jetzt aber neu aufbauen; synchronisieren (extra nur mit 1 Verzeichnis probiert), steht nur:

    Code
    Log:
    Synchronisation gestartet
    Lade Konfiguration
    Lade Datenbank


    und das auch noch nach 5 Stunden.


    Hab dann auch extra mal komplett neu gebootet, kriege aber immer noch die gleiche Info. Muss ich Valerie entfernen und dann den Ordner auf der HDD entfernen? oder gibts da ev. ne andere Lösung für mich?

  • Was mir noch aufgefallen ist:
    Seit ein paar Versionen kann man ja einzelne filme serien manuell löschen und er schreibt diese dann in die blacklist.conf


    Das funktioniert auch, nur leider wird bei einem neuen sync per grün dann die blacklist.conf nicht berücksichtigt und der entsprechende Film ist wieder in der Liste, er steht aber auch nachwievor dann in der blacklist.conf.


  • This works for me,


    <ePixmap name="posterborder" position="45,253" zPosition="6" size="380,353" alphatest="blend" pixmap="/usr/lib/enigma2/python/Plugins/Extensions/ProjectValerie/skins/blackSwan/1280x720/images/blackborders_video_thumbnail-fs8.png"/>



    Change the numbers in red in to these values in /usr/lib/enigma2/python/plugins/extensions/projectvalerie/skins/
    blackswan/1280x720/skin.xml


    Note, there are 2 of these lines to be changed!


    Patje.