Project Valerie - MediaCenter for Enigma2


  • euer Webinf funktioniert, got sei dank :)


    muss mal dumm fragen wo bekomme ich das log her?

  • Hi Satanos,


    wenn Du in das PVMC Web-Interface gehst, dann dort


    "Logs" => "Valerie"


    auswählen und Du bekommst eine chronologische Liste aller PVMC Logs angezeigt.


    Zu beachten ist dabei, dass das neueste Log leider immer am Ende aufgeführt ist - Du musst also ganz runterscrollen.


    Außerdem wäre es wahrscheinlich nicht schlecht, wenn Du den Debug-Modus vorher erstmal auf "High" stellst und dann nochmal einen Enigma2 Neustart machst, damit ein neues Log mit diesem Modus angelegt wird.


    Wie der Debug-Modus umgestellt wird - und noch ein paar weitere Infos - sind hier im Wiki beschrieben:


    http://bit.ly/zqbo1G


    Da aber das PVMC WebIF läuft, müsste man vielleicht auch nochmal einen Blick auf das Enigma2-Log werfen. Was für ein Image hast Du eigentlich?


    Gruß, J.R.

    „Wer die Freiheit aufgibt um Sicherheit zu gewinnen, der wird am Ende beides verlieren.“
    Benjamin Franklin

  • mit der einwilligung von ipman (danke an dieser stelle nochmal) habe ich mal einfach unseren internen converter über den skin laufen lassen und die gröbsten anpassungen für die restlichen auflösungen gemacht.


    somit gibt es jetzt SD, XD und HD


    ABER ...


    das ist bei weitem nicht perfekt und wie ich schon mal geschrieben habe, habe ich nicht vor eine weiteren skin feinzutunen ;-)


    ABER ... die zweite...


    sollte jemand einfach etwas zeit übrig haben dann muss in der xml datei der jeweiligen auflösung einfach nur etwas an den werten geschraubt werden. da die grundlage die aktuelle versin des hd skins ist sollte es ja da keine gröberen fehler mehr geben und man kann sich somit wirklcih nur auf schriftgrößen und positionen konzentrieren.


    mal sehen ob sich jemand findet. sollte der skin in allen auflösungen vorliegen werden wir ihn in den standard aufnehmen.


    greets


    PS: sollte jemand die zeit haben sich aber nciht auskennen würde wir natürlich etwas helfen ;-)


    PPS: alle rechte bleiben bei ipman. es ist und bleibt seine arbeit. ich habe nur etwas nachgeholfen ;-)

  • Habe eben ein Update gemacht (auf rev1238 ) und bekomme jetzt bei jedem Aufruf von Valerie einen Crash (Greenscreen beim Plugin-Aufruf, Fehlermeldung beim Webinterface).


    Logs siehe Anhang.



  • em bei mir geht aber das valerie webinf nur das richtige DM webinf geht nach der installation nicht mehr.
    mach da ein log von valerie sinn?

  • Quote

    Original von Satanos666
    mach da ein log von valerie sinn?


    Hi Satanos,


    na, von Dir kam doch der Hinweis, dass das Problem erst nach der Installation von PVMC aufgetreten ist - von daher könnte auch im PVMC-Log ein Hinweis enthalten sein, der uns weiterhilft... Muss nicht, aber kann - und deshalb hatte ich nach beiden Logs gefragt:


    Quote

    Da aber das PVMC WebIF läuft, müsste man vielleicht auch nochmal einen Blick auf das Enigma2-Log werfen.


    Gruß, J.R.

    „Wer die Freiheit aufgibt um Sicherheit zu gewinnen, der wird am Ende beides verlieren.“
    Benjamin Franklin

  • Hallo zusammen,


    ich hab seit kurzen das Plugin Project Valerie. Bei meinen Filmen funktioniert die Synchronisation eig problemlos, nur bei den Serien klappt das irgendwie gar nicht.
    Als Beispiel Two and a half men. Bei der Synchronisation wird es anscheinend in keiner Datenbank gefunden und dem zufolge auch nicht hinzugefügt, deswegen wollte ich übers Web-Interface die Serien manuell hinzufügen.
    Als erstes erstelle ich eine Tv Show, zu welcher ich dann in dem Fall meine Two and half men Aufnahme hinzufügen kann und speicher zum Schluss natürlich alles.
    Wenn ich nun aber bei Project Valerie unter Serien die zuvor erstellte Tv Show auswähle, stürzt jedesmal GUI ab.


    Wo ist nun der Fehler?


    Vielleicht kann mir jemand helfen, der schon etwas mehr Erfahrung mit PV hat.



    Danke schon mal.

  • Hi Michael,


    wegen dem Crash wird Don vermutlich eher was sagen können - für mich sieht das (aus der Hüfte geschossen) danach aus, als ob da bei der "Season"-Angabe für irgendeine Episode nicht nur eine Nummer drinstehen würde - kann das sein?


    Ich will eher darauf eingehen:


    Quote

    Original von michaelmayer
    Als Beispiel Two and a half men. Bei der Synchronisation wird es anscheinend in keiner Datenbank gefunden und dem zufolge auch nicht hinzugefügt, deswegen wollte ich übers Web-Interface die Serien manuell hinzufügen.


    Also ohne Dich jetzt von Deinem Vorhaben abbringen zu wollen, Deine ganzen Serien via WebIF einhackern zu wollen - aber vielleicht sollten wir uns auch nochmal genauer anschauen, warum Deine Serien nicht auf dem "normalen" Weg erkannt werden? ;)


    Don würde sich vermutlich freuen, das WebIF durch die komplette manuelle Eingabe von x Serien incl. aller Staffeln und Episoden mal auf Herz und Nieren testen zu lassen... :D
    Für mich dient das WebIF aber in erster Linie zum bequemen und gezielten Korrigieren einzelner Fehler - oder halt um unbekannte Inhalte in die PVMC-Datenbank zu bekommen. Der größte Batzen sollte automatisch richtig erkannt werden, denn was bei einer Serie mit mehreren Staffeln schon einige Zeit in Anspruch nimmt, ist bei zig Serien fast schon eine Lebensaufgabe... ;-)


    Ich hab das bei mir gerade mal ausprobiert - Two and a Half Men wird durchaus richtig erkannt, wenn ich die Struktur wie folgt aufbaue:


    .../Serien/Two and a Half Men/Two_and_a_half_men_s01e01.mkv


    Den Ordner "Serien" dann entsprechend als "TV" markiert.


    Jetzt kann es natürlich sein, dass das bei Dir Eigenaufnahmen sind, oder Du Deine Struktur ganz anders aufgebaut hast, oder Du nutzt noch eine ältere Version von PVMC, wo wir Probleme mit einer der Online-Datenbanken hatten, die PVMC benutzt - da wären halt ein paar mehr Infos wichtig - und ggf. auch noch ein Valerie.log von einem Sync-Lauf, damit man im Detail sieht, warum das bei Dir nicht klappt. Wichtig aber: Debug-Mode auf "high" und einen E2-restart, bevor Du den Sync-Lauf startest, wie hier im PVMC-Wiki beschrieben:


    http://bit.ly/zqbo1G


    Gruß, J.R.

    „Wer die Freiheit aufgibt um Sicherheit zu gewinnen, der wird am Ende beides verlieren.“
    Benjamin Franklin

    Edited 2 times, last by Jester-Race ().


  • Dear DonDavici,


    Is it possible to change default image from "BACKDROP" to "LIST"


    Regards

  • Quote

    Original von DonDavici
    arzaz


    ähmmm what do you exactly mean? i am little bit confused.


    I mean, when i click on movie or tv show menu, all movies should be displayed on list mode, and not on backdrop (default mode)


    Regards

  • Quote

    Original von arzaz


    I mean, when i click on movie or tv show menu, all movies should be displayed on list mode, and not on backdrop (default mode)


    Regards


    Sorry DonDavici,


    I mean "POSTER-FLOW, instead off LIST mode

  • Quote

    Original von arzaz


    I mean, when i click on movie or tv show menu, all movies should be displayed on list mode, and not on backdrop (default mode)


    Regards


    Hi....


    go to the view you want to have as full view then the Menu button and view as a standart Select your finished


    gruss

  • doofe Frage mit der Bitte um Nachsicht:


    musste meine Box neu aufsetzen. Neuflash inkl. aller wichtigen Aspekte hat soweit geklappt. Bei Valerie habe ich bis jetzt eine neue, noch jungfräuliche Version eingespielt. Was muss ich jetzt wohin kopieren, um die mühsam erarbeiteten Listen etc. wieder zu bekommen?


    Hatte - weil Valerie auch nicht mehr richtig ging - einfach eine Kopie aller Ordner per telnet bei mir auf den PC gezogen.


    Danke für einen Tipp.
    Gruß


    rheinlaender

  • Hi rheinlaender,


    also im Prinzip willst Du Deine alte DAB wieder einspielen, richtig?


    Dazu sollte es reichen, einfach die folgenden Dateien von Deinem Backup wieder in den valerie config Ordner zu kopieren:

    • mediafiles.db
    • tables.db

    Plus den Ordner mit den heruntergeladenen Grafiken (Poster / Backdrops etc.) - also normalerweise /hdd/valerie/media...


    Suchpfade etc. stehen in der sync.xml - die wirst Du ja auch nicht alle wieder händisch eingeben wollen... Aber ich sehe gerade: hatte das ja alles vor kurzem im Wiki auf den neuesten Stand gebracht - schau mal hier:


    http://code.google.com/p/project-valerie/wiki/Resources


    Die unter "Datenbankdateien" und "konfig-Dateien" gelisteten Files würde ich je nach Bedarf wieder zurückspielen...


    Hmmm - hoffe ich habe jetzt erstmal nix vergessen... :rolleyes:


    Melde Dich, wenn Du nicht weiter kommst!


    Gruß, J.R.

    „Wer die Freiheit aufgibt um Sicherheit zu gewinnen, der wird am Ende beides verlieren.“
    Benjamin Franklin

  • Danke!


    Musste gerade feststellen, dass ich zwar die Potser noch gesichert hatte, aber die beiden entscheidenden db-Files nicht. So ne K....cke


    Na ja, dann mal auf ein fröhliches Neusyncen und Neukonfigurieren von über 1.000 (!) Filmen auf meinem NAS :-((((((


    Trotzdem vielen Dank - ich hab eigentlich alles richtig machen wollen...


    rheinlaender