PzyEMAIL v0.8: pop3, imap und smtp, mit WebBrowser [update 21.06.2015]



  • v0.1:
    Wenn es Probleme gibt, mal in "/usr/lib/python2.6" folgende Dateien prüfen und ggf. einfügen:
    ssl.py, textwrap.py, smtplib.py, poplib.py, mimetypes.py, ConfigParser.py
    -----------------------
    09.06.10: Update v0.1.1
    Da es leider einigen Stress beim Installieren gab, hab ich das ipk noch mal neu erstellt und die fehlenden Paket-Abhängigkeiten gesetzt.
    Dateien müsst ihr ab jetzt nicht mehr per Hand einfügen.
    Damit evtl. fehlende Pakete installiert werden, müsst ihr ein "ipkg update" machen.
    Bitte im telnet installieren mit:


    ipkg update && ipkg install enigma2-pzyemail_0.1.1-20100608_mipsel.ipk


    Danach enigma2 neu starten.
    -----------------------
    09.06.10: Update v0.1.2
    Aller guten Dinge sind 3.
    Controlfile korrigiert. Installation mit "ipkg update", wie bei v0.1.1.
    -----------------------
    10.06.10: Update v0.1.3
    So, da es schon wieder eine Problemmeldung bei der Installation gab, hab ich nun die letzten beiden python-files entfernt und durch die Paketabhängigkeiten ersetzt. Sonst hat sich nichts geändert.
    -----------------------
    13.06.10: Update v0.1.4
    - HD-SD Skin-Erkennung
    - Beim Senden einer Mail wird jetzt immer die Empfängerzeile im "Email-Editor" genutzt, statt der Liste im Adressbuch.
    Mehrere Empfängeradressen einfach durch "," (Komma) trennen.
    - Verbessertes Config-Menü


    Datei nach "/tmp/" und dann:
    "ipkg update && ipkg install /tmp/enigma2-pzyemail_0.1.4-20100613_mipsel.ipk"
    ----------------------
    15.06.10: Update v0.1.4.1
    - "Exit" im Email-Viewer war nur beim Gemini2 möglich. gefixed.
    - Dateipfade werden bei Attachments nicht mehr in den Betreff der Mail übernommen(max. 3 Dateinamen, dann "...";)
    ----------------------
    22.06.10: Update v0.1.5.1
    - Autoupdate der Mails im Hintergrund (0 = Aus, unter "Edit Global Settings" zu finden)
    - Bei neuen Mails wird ein kleines Info-Fenster mit der Anzahl der Mails links oben geöffnet. ("OK"-Taste: pzymail GUI öffnen, "Exit"-Taste: Infoscreen schliessen)
    - Code für Multi-Account-Betrieb überarbeitet
    - Code für die Konfiguration überarbeitet
    - Diverse Ausgaben in der Console beseitigt, wegen der Daten im Crash-Log
    - Unicode-Fehler sollten jetzt abgefangen werden, wenn die Mail falsch erstellt wurde
    ----------------------
    01.07.10: Update v0.1.5.2
    - Sortierung der Mails geändert
    ----------------------
    10.07.10: Update v0.1.6
    - Diverse Status-Meldungen in der Titel-Leiste hinzugefügt
    - Summe der Mails im Infofenster gefixed
    - Neue Funktionen in den "Global Settings": Statistik und Crypted Settings
    - verbesserte Unterstützung von html-Mails
    ----------------------
    01.08.10: Update v0.2
    - LCD-Anzeige bei neuen Mails (auch im Standby)
    - IMAP Unterstützung
    ----------------------
    04.08.10: Update v0.2.0.3
    - IMAP-Bug bei leerer Mailliste beseitigt
    - ">"-Taste wechselt jetzt auch die Listen (für DM500)
    - Infofenster für die gleiche Mail nach der "Exit"-Taste beseitigt
    ----------------------
    20.08.10: Update v0.2.5
    - imaplib ersetzt durch imaplib2 (Verlorene Server-Verbindungen werden jetzt erkannt und wieder aufgebaut)
    - imap login jetzt sicherer über automatisches "login_cram_md5"
    - imap fastsync hinzugefügt (nur aktivieren, wenn ihr nicht gleichzeitig mit pop3 auf das Postfach zugreift!)
    - smtp über ssl hinzugefügt (richtet sich nach imap- / pop3-Einstellungen für den jeweiligen Account)
    - Timeouts und erneutes Verbinden bei verlorenen Verbindungen optimiert für imap, pop3, smtp
    - Subject der zuletzt geladenen Mail (Server oder lokaler Mailordner) ist jetzt in der Titelleiste
    - Absender wird jetzt auch decodiert angezeigt
    - Filbrowser gefixed (Devices) und mit neuen Funktionen ausgestattet (Ordner/Dateien erstellen/löschen, Alles deselektieren)
    - Lokaler Mailordner über Config frei wählbar zum lesen/schreiben eurer Mails (Auswahl über File-Browser möglich)
    (Unterordner mit dem Accountnamen wird beim speichern einer Mail automatisch erstellt, wenn er noch nicht vorhanden ist)
    ----------------------
    21.08.10: Update v0.2.5.1
    - Fehlende Paketabhängigkeiten für imaplib2 ergänzt (Sollte jetzt wieder in allen Images laufen)
    ----------------------
    28.08.10: Update v0.2.6
    - SMTP-Typ und -Port jetzt im Account-Setup einstellbar.
    ----------------------
    28.08.10: Update v0.2.6.1
    - Bug in der Smtp-Konfiguration bei verschlüsselten Settings beseitigt.
    ----------------------
    10.09.10: Update v0.3
    - Absender und Subject scrollen jetzt bei neuen Mails durchs LCD
    - Sollte jetzt auch in Images ohne SSL-Unterstützung mit python 2.5 laufen
    - "Alle / nur neue Mails" - Ansicht (über Menü oder "<"-Taste)
    - Es wird jetzt vor dem Versenden von Mails ein ordentlicher Mailheader erzeugt
    ----------------------
    18.09.10: Update v0.3.3
    - Erweiterter Mailticker zum Einbinden in den Skin (Mailheader werden jetzt auch als Ticker am Bildschirm angezeigt)
    - Standby-Modus abschaltbar
    - Automatisches Schliessen des Mailtickers nach Sekunden oder Durchläufen ( 0 zum Deaktivieren des automatischen Schliessens )
    ----------------------
    18.09.10: Update v0.3.4
    - Bug beim automatischen Schliessen des Infoscreens beseitigt (v.0.3.3)
    ----------------------
    24.09.10: Update v0.3.6
    - mp3 bei neuen Mails möglich
    - diverse kleine Bugfixes
    ----------------------
    09.10.10: Update v0.3.9
    - Tickersteuerung
    - Accountname und Mailtext im Ticker sichtbar
    - auch Video, statt mp3 abspielbar
    - HTML-Filter / Plaintext auf der grünen Taste
    - InfoScreen und InfoScreenMini (zum besseren Skinnen)
    - Update auf HTML2Text v2.39
    ----------------------
    31.10.10: Update v0.4
    - diverse kleine Bugs entfernt
    - imaplib2 aktualisiert
    ----------------------
    20.05.11: Update v0.5
    - Sprachausgabe mit espeak. Version beachten!
    - html2text aktualisiert
    - imaplib2 aktualisiert
    ----------------------
    09.08.11: Update v0.5.2
    - Ab jetzt wird das Versenden von Mails aus anderen Plugins unterstützt.
    ----------------------
    01.02.2014: update v0.7
    - Sprachunterstützung entfernt
    - imaplib2 entfernt
    - nur noch HD-Skin
    - text2html aktualisiert
    - diverse kleine Bugfixes
    - HTML-Webansicht der Mails und WebBrowser im OE2.0 (optional)
    ----------------------
    14.03.2014: update v0.7.1
    - Bugfix für geflodderte Boxen
    - Schnellerer Wechsel im Ticker
    - RunningText eingefügt, alte Renderer entfernt (wird per postinst ins Renderer-Verzeichnis kopiert, aber falls vorhanden, nicht überschrieben)
    - HTML mit Opera Webbrowser auf Vu+ über hbbtv-Plugin (kein Support hier im Board)
    ----------------------
    05.07.2014: update v0.7.4
    - Auf skinbare Struktur umgestellt, jetzt auch FullHD möglich
    - Diverse kleine Änderungen
    ----------------------
    26.07.2014: update v0.7.8
    - Einträge der Account- und Mailliste in skinbare Elemente zerlegt
    - Neue Parameter zum Skinnen bereitgestellt
    - Textausrichtung in der Accountliste optimiert
    ----------------------
    20.08.2014: update v0.7.9
    - Hintergrundaktivität geändert, reduziert/entfernt Spinner beim Abruf mehrerer Accounts
    - skin.xml im Plugin-Verzeichnis
    - Löschen von Accounts gefixed
    ----------------------
    21.06.2015: update v0.8
    - Anpassung an OE2.2
    - Aufruf von Opera für Vu-Boxen erweitert





    :399: >>>>> 26.07.2014 -- v0.7.8: Skin-Parameter wurden geändert, vorhandene Skins benötigen ein Update. <<<<<

  • Hallo


    Das Plugin hört sich gut an. DANKE dafür!
    Habe es installiert aber es funzt nicht. Vielleicht stelle ich mich auch zu doof an..


    Woher nehme ich folgende von dir beschriebenen Dateien:
    ssl.py
    textwrap.py
    smtplib.py
    poplib.py
    mimetypes.py
    ConfigParser.py


    Wenn ich PluginManager strtre kommt folgende Meldung:
    Einige Plugins sind nicht verfügbar:
    Estensions/Pzymail (cannot import name POP3_SSL)


    Ich benutze eine DM8000 mit Gemini5


    Danke

  • Bei mir fehlt auch die ssl.py.
    Wo bekomm ich die her?

  • Die Dateien sind eigentlich in Python enthalten.
    Also entweder aus einem vollständigen Python herauskopieren, oder das angehängte Archiv nehmen.


    Gruss
    pzy-co

  • Quote

    Original von pzy-co
    Die Dateien sind eigentlich in Python enthalten.
    Also entweder aus einem vollständigen Python herauskopieren, oder das angehängte Archiv nehmen.


    Gruss
    pzy-co


    Danke für die Dateien mit denen wird das Plugin im PluginManager angezeigt.


    Was mir aufgefallen ist:
    /etc/enigma2/pzymail.settings --- Diese Datei existiert bei mir nicht


    NACH einer Neuistallation des Pakets wir die Datei pzymail.settings angezeigt!!!!



    Das Oberfläche ragt ein bisschen über die normale TV Oberfläche hinaus.
    Sprich ich sehe das PzyEMAIL v0.1 ein bissi abgeschnitten links und rechts

    Beim Editieren eine GMX Kontos beispielsweise sind die Felder begrenzt.
    Was ich meine ist ich kann z.B. unter User nur 9 Buchstaben eintippen mehr lässt er mich nicht eintippen.
    Genau so ist es bei AccountName: Das Feld ist auch auf 7 Zeichen beschränkt.


    Gruß und DANKE

  • Ich habe auch das Problem mit der Zeichenbeschränkung. Im Gui kann ich so meinen Server nicht eintragen. Wenn ich die daten direkt in der pzymail.settings.xml eintrage, bekomme ich bei Aufruf eine Buntscreen.


    @ tajlor
    Die pzymail.settings.xml wird erst angelegt wenn Du im GUI Daten eingetragen und gespeichert hast.

  • Quote

    Original von Aquino
    Ich habe auch das Problem mit der Zeichenbeschränkung. Im Gui kann ich so meinen Server nicht eintragen. Wenn ich die daten direkt in der pzymail.settings.xml eintrage, bekomme ich bei Aufruf eine Buntscreen.


    @ tajlor
    Die pzymail.settings.xml wird erst angelegt wenn Du im GUI Daten eingetragen und gespeichert hast.


    Mittlerweile habe ich die pzym pzymail.settings.xml auch ;=)



    Wenn ich die pzymail.settings.xml händich editiere wird in der GUI nur "Schmarn" angezeigt, aber das könnte auch mit der erwähnten Verschlüsselung zusammenhängen... ??

  • Du musst die Einträge erst Base64 kodieren und dann eintragen.

    Ich bin nicht faul sondern im Energiesparmodus!

  • Hi,


    Die Settings-Datei wird beim verlassen des Prgs erzeugt.
    Settings editieren funzt so nicht, hängt mit der 'Verschlüsselung' zusammen.


    Beim Account editieren einfach mal die "TEXT"-Taste drücken für's Virtual Keyboard. Dann gibt es auch keine Beschränkung bei der Eingabe.


    Hab nur auf HD-Skins getestet, deshalb vielleicht das Grössenproblem.


    Danke für's fleissige testen und Rückmelden.


    Gruss
    pzy-co

  • LazyT
    -- DANKE so was in der Art habe ich mir schon gedacht!


    pzy-co
    die die "TEXT"-Taste drücken erlaubt wie du gesagt hast mehr Zeichen...


    Quote

    Hab nur auf HD-Skins getestet, deshalb vielleicht das Grössenproblem.


    Ich habe Kerni-HD1 am laufen!!


    Eine Frage noch bezüglich des Abrufens von E-Mails
    Wird eine Kopie der E-Mails abgerufen oder wird das pop3 Konto "leergeräumt"?


    Danke

  • Nein, es wird nichts leergeräumt.
    Es wird nur mit Kopien gearbeitet, ausser ihr löscht eine Mail über das Plugin. Alle Mails bleiben also weiterhin auf dem Server.


    Wenn ihr aber eine Mail mit einem anderen Prg(oder Webinterface) vom Server löscht, verschwindet der Mailheader aus der Anzeige im Plugin, wenn ihr euch das nächste mal einloggt, da es die uidl dann nicht mehr gibt.

  • Hi


    So konfiguriet ist das Plugin!
    Empfangen kann ich aber leider nicht! OK kann an verschiedenen Faktoren liegen ist mir auch klar. Will mich auch nicht zu weit aus dem Fenster lehnen .... der GMX Akkount ist richtig konfiguriert.


    Auch das Senden funzt nicht.
    Zusätzlich hatte ich ein kernel Panik --- green screen als ich versucht habe das Senden abzubrechen :o)

  • Quote

    Original von tajlor
    Hi


    So konfiguriet ist das Plugin!
    Empfangen kann ich aber leider nicht! OK kann an verschiedenen Faktoren liegen ist mir auch klar. Will mich auch nicht zu weit aus dem Fenster lehnen .... der GMX Akkount ist richtig konfiguriert.


    Auch das Senden funzt nicht.
    Zusätzlich hatte ich ein kernel Panik --- green screen als ich versucht habe das Senden abzubrechen :o)


    Ich habe den Typ von Pop3-SSL auf POP3 gestellt. Hier werden Mails abgerufen!
    Nur diese Einstellung wurde geändert alle andere sind gleich geblieben!!

  • Abrufen, auch wenn es nicht per SSL ist, funktioniert wunderbar!
    Hinggen senden nicht!


    Was noch "schön" wäre:


    1. ein log unter /var/log/ implementieren, damit ich nachvollziehen kann was das Plugin macht
    z.b. ein mail.log


    2. Wenn ich auf E-Mail antworten gehe und eine E-Mail verfasse ist die Return-Taste nicht funktionsfähig. Ich muss dazu sagen ich schreibe mit der DreamTastatur.


    Das erwähnte nicht "reinpassen" auf den TV Bildschirm...


    Ansonsten KLASSE PLUGIN!! DANKE

  • Hallo nochmal,


    habe gerade eben mal mit neuen Settings angefangen und einen gmx Account eingerichtet (pop.gmx.net, smtp.gmx.net). Meine Mails über pop3-ssl abgerufen und mir über replyto eine Antwort geschrieben. Diese dann wieder über pop3-ssl abgerufen. Ging hier alles einwandfrei.


    Warum das bei dir / euch nicht funzt ??


    Tastatur habe ich leider keine zum Testen.


    Abbrechen muss man eigentlich auch nichts. Nach dem Timeout wird wieder in das Plugin gewechselt (nur etwas Geduld http://www.i-have-a-dreambox.c…if/bmi_orig_img/icon5.gif)


    Einen kleinen log kann man in der Console mitverfolgen. Mit "init 4" und "Enigma2&" im telnet neu starten.


    Das mit dem "reinpassen" lässt sich schnell beheben, aber bei mir ist sogar noch etwas Luft zum Rand hin. Wieviel kleiner sollte also der Screen sein ?


    mfg
    pzy-co

  • Hallo,


    erstmal vielen Dank für die Arbeit!!


    Habe Oozoon im Flash und Gemini 5.0 über BA auf CF. Das Plugin habe ich im Gemini installiert.


    Habe die fehlenden libs kopiert. Trotzdem kommt bei Aufruf der "Erweiterungen" folgende Meldung:

    Files

    • screenshot.jpg

      (23.78 kB, downloaded 11,017 times, last: )

    Edited once, last by ozz ().



  • HI
    Posteingangsserver: POP3: pop.gmx.net (bei SSL Port 995),
    IMAP: imap.gmx.net (bei SSL Port 993)
    Postausgangsserver: mail.gmx.net (bei SSL Port 465)
    Benutzername: GMX-Kundennummer oder GMX-E-Mail-Adresse
    Besonderheiten: Verwendet SMTP-Authentifizierung oder "POP3 vor SMTP", je nachdem, wie
    Sie Ihren Account eingestellt haben.
    IMAP ist nur in den Tarifen ProMail und TopMail verfügbar.


    Das habe ich aus dem Netz!



    Warum es bei dir über ssl geht, kann ich dir leider auch nicht sagen. Komisch ist, dass es bei mir nicht läuft.... :o) ich habe die gleichen Einstellungen, die du genannt hast.
    Genau so ist auch die Größenausgabe merkwürdig. Bei dir passt es, bei mir nicht, obwohl ich auch ein HD Skin habe.
    Ich kann dir also nicht sagen um wie viel du es kleiner machen sollst. Bei mir fehlt vielleicht 1cm falls man das überhaupt so hinschreiben kann.


  • Die gleiche Meldung hatte ich auch bekommen! Siehe oben...
    Schau noch mal ob du die Dateien in den Ordner /usr/lib/python2.6/ rein kopiert hast.
    Anschließend habe ich das Prog. noch mal drüber installiert.
    Versuch das mal...

  • Hallo,


    habe ich gemacht, sicherhalber alle kopiert, neu installiert, Neustart ---> Fehlermeldung beim Aufruf der Erweiterungen und kein PzyEMAIL zu sehen.
    Es müßte doch reichen, das Modul zu installieren, nun wo finde ich das und wo kommt es hin?


    Gruß, Ozz

    Edited once, last by ozz ().

  • ozz


    Dir fehlt das "python-html"-Paket.


    Hab ich als Abhängigkeit im ipk leider vergessen.
    Kann man aber online über die Enigma2 Paketverwaltung installieren.


    Bitte dabei auch gleich mal nachsehen, ob das "python-email"-Paket installiert wurde.




    tajlor


    Server: pop.gmx.net
    Port: 995 für pop3-ssl, 110 für pop3
    SMTP: mail.gmx.net oder smtp.gmx.net, geht bei mir beides


    IMAP wird nicht unterstützt.


    Werd den Screen einfach mal ein wenig verkleinern, damit es bei allen passt.



    Hast du mal per telnet mitverfolgt, wo es klemmt?