PzyEMAIL v0.8: pop3, imap und smtp, mit WebBrowser [update 21.06.2015]

  • Moin!


    Quote

    Original von zombi
    nein an meinen alten skins wird nix mehr geändert
    Die beiden fullhd von mir sind immer aktuell und da kann man sich auch die screens ansehen und dann in die alten portieren wenn man möchte.
    Alles unter OE2.2 bzw. Dreambox OS ist für mich abgehackt und da mache ich auch nix mehr ,hab auch dahingehend keine Box mehr hier.


    Ich gehe mal davon aus, dass das ein Tippfehler ist!?! ;)

  • Mathematisch ist die Aussage korrekt :D
    Alles unter OE 2.2 <=> OE < 2.2 ;)

    so long
    m0rphU



    :aufsmaul: Kein Support per PN! :aufsmaul:

  • Moin!


    Wenn
    bzw. Dreambox OS
    nicht da wäre, hätte ich es so gelten lassen. ;)

  • Hi,

    Quote

    Original von m0rphU
    Mathematisch ist die Aussage korrekt :D
    Alles unter OE 2.2 <=> OE < 2.2 ;)


    ich glaube er meinte eher das Synonym für amputieren:-)


    ciao

    ---
    7020, Combo, Solo2, Ultimo

  • MiRoMOMO
    Ich meinte es schon so ,
    Ich persönlich habe nur noch die Dreambox 7080hd und somit auch nur noch das neue Dreambox OS oder wie man es auch nennt OE2.2 auf der Box und somit keine ältere Soft wie OE2.0 (also unter OE2.2 ;) ).
    Daher arbeite ich nur noch mit aktueller Soft und erstelle meine Sachen auch dahingehend (hat aber hier im Thread er nix zu suchen weil hier geht es nicht um meine Sachen sondern um die von pzy-co und er macht für die unterschiedlichsten Softstände Seine Plugins.

  • Moin!


    Das weiß ich ja schon.
    Aber als ich es gelesen hatte, hatte ich es genau anders herum verstanden ;)
    Das hatte mich eben amüsiert.

  • Update im 1. Post


    21.06.2015: update v0.8
    - Anpassung an OE2.2
    - Aufruf von Opera für Vu-Boxen erweitert

  • Bei duo2+PLi crasht bei MENU-taste mit:
    ---------------
    File "/usr/lib/enigma2/python/Components/ActionMap.py", line 66, in action
    File "/usr/lib/enigma2/python/Components/ActionMap.py", line 46, in action
    File "/usr/lib/enigma2/python/Plugins/Extensions/Pzymail/plugin.py", line 1513, in KeyMenu
    keys = [ "<", "1", "2", "3", "", "4", "5", "6", "7", "", "8" , "9", "0" ]
    File "/usr/lib/enigma2/python/mytest.py", line 274, in openWithCallback
    dlg = self.open(screen, *arguments, **kwargs)
    File "/usr/lib/enigma2/python/mytest.py", line 284, in open
    dlg = self.current_dialog = self.instantiateDialog(screen, *arguments, **kwargs)
    File "/usr/lib/enigma2/python/mytest.py", line 228, in instantiateDialog
    return self.doInstantiateDialog(screen, arguments, kwargs, self.desktop)
    File "/usr/lib/enigma2/python/mytest.py", line 251, in doInstantiateDialog
    dlg.applySkin()
    File "/usr/lib/enigma2/python/Components/GUISkin.py", line 112, in applySkin
    File "/usr/lib/enigma2/python/Components/GUISkin.py", line 30, in createGUIScreen
    File "/usr/lib/enigma2/python/Plugins/Extensions/Pzymail/plugin.py", line 7256, in applySkin
    ep = parsePosition(value, ((1,1),(1,1)))
    File "/usr/lib/enigma2/python/skin.py", line 178, in parsePosition
    File "/usr/lib/enigma2/python/skin.py", line 126, in parseCoordinate
    TypeError: unsupported operand type(s) for -: 'int' and 'NoneType'
    < 1875.523922> [ePyObject] (CallObject(<bound method NumberActionMap.action of <Components.ActionMap.NumberActionMap instance at 0x5511648>>,('MenuActions', 'menu')) failed)
    ]]>


    ---------------

    [SIZE=7]Selfsat H50M4
    Ultimo4K /2xTwinS2, VTI, PLi, ATV...
    NAS: Qnap221[/SIZE]

  • Hallo pasurimi,


    ich glaube das Problem gab es schonmal mit einem PLi an anderer Stelle, weil dort zusätzlich "parseCoordinate" aufgerufen wird und das mit dem "center" nicht zurechtkam.
    Ändere mal bitte deinen Skin testhalber.


    screen name="ChoiceBoxPlus"
    widget name="list"
    textpos="60,center" zu textpos="60,0"

  • Quote

    Originally posted by pzy-co


    ...textpos="60,center" zu textpos="60,0"


    Super, klappts perfekt :thx:
    Habs beim standardskin (PLi-HD) und auf MX_Graphite getestet.

    [SIZE=7]Selfsat H50M4
    Ultimo4K /2xTwinS2, VTI, PLi, ATV...
    NAS: Qnap221[/SIZE]

  • :hurra:Danke fürs Update!


    Funktioniert 1a.... ;)

    Dream 1: 7020HD SS
    Image: Merlin3 OE2.0/GP3
    Dream 2: 7025 SS
    Image: Merlin2

  • Vielen Dank pzy-co für die Portierung des Plugins nach OE2.2.


    Ich habe ein Problem mit der Darstellung der E-Mails im HTML-Format. (Box: Dreambox 7080HD) Diese ist vezerrt und es erscheinen Striche und Linien quer über dem Bildschirm. In Ausschnitten, soweit diese Querstriche und -linien nicht vorhanden sind, lässt sich der Inhalt der E-Mail erkennen.
    Ansonsten arbeitet das Plugin einwandfrei.
    Ist das bei euch auch so ?

    Dreambox 920 Ultra HD (1x DVB-C FBC)

  • Das ist ein problem des Web-Browsers der Dream das ist bei einigen anderen Dingen im OE2.2 leider auch so.
    Ob man da was machen kann könnte DMM sagen ,nur da nutzt sicher keiner das oder die anderen Plugins wo das vor kommt um das nachstellen zu können. ;(
    Drück da einfach mal auf rot für mouse dann müsste die darstellung sich wieder regulieren und lesbar werden.

  • Quote

    Original von zombi
    Das ist ein problem des Web-Browsers der Dream das ist bei einigen anderen Dingen im OE2.2 leider auch so.
    Ob man da was machen kann könnte DMM sagen ,nur da nutzt sicher keiner das oder die anderen Plugins wo das vor kommt um das nachstellen zu können. ;(
    Drück da einfach mal auf rot für mouse dann müsste die darstellung sich wieder regulieren und lesbar werden.


    Vielen Dank für den Tipp; er funktioniert einwandfrei. Bei der 7020HD ist HTML. Darstellung der E-Mails einwandfrei.

    Dreambox 920 Ultra HD (1x DVB-C FBC)

  • Ja im OE2.0 geht das alles auch wie gewollt im OE2.2 ist was mit dem render="Canvas" nicht ganz so richtig bzw. anderst als in den anderen OE´s
    Es gibt die selben Darstellungsfehler seit einführen des OE2.2 bei anderen Plugins die render="Canvas" einsetzen,siehe hier zb. beim Wetterplugin des GP3.3.
    Das ganze müsste sich DMM ansehen nur nutzen sie sicher keines der Plugins um das überprüfen zu können was da wie schief läuft. ;(

  • Hi,

    Quote

    Original von zombinur nutzen sie sicher keines der Plugins um das überprüfen zu können was da wie schief läuft. ;(


    das sollte kein Hinderniss sein. Installieren, Problem beheben, Deinstallieren.


    ciao

    ---
    7020, Combo, Solo2, Ultimo

  • Wenn DMM dafür Zeit und lust hat schon,nur hab ich dies DMM noch nicht gemeldet weil da andere Sachen zZ. bei Ihnen wichtiger sind so wie man liest .
    Beim PZY-Mail kann man sich ja behelfen und beim GP3.3 könnte mechatron sicher auch was machen.
    Aber da ist auch das Privatleben zZ. im Vordergrund und daher war das erstmal nicht so wichtig.
    Ich denke das kommt durch die scale Funktion bzw. durch die Überblendungen im aktuellen OE2.2 .
    Ich werd das aber einfach gleich mal im DMM Board melden mal sehen was passiert.