Version 0.7ht-pre22 (14.06.2013) Atmolight:(Test-Thread) 500HD/800(se)/7020HD/7025/8000 «Dual Core»

  • So,
    um mal alle Spekulation bezüglich der Hänger auf der DM8000 auf den Grund zu gehen, sollten alle mit dem Problem mal folgendes testen:


    1. Stellt den Modus des Atmolight auf Farbwechselmodus.
    2. Am besten vorher noch einmal die Box neu booten.
    3. Ein Aufnahme (vorzugweise von intern HDD) starten (SD/720p/1080i ruhig mal alles testen)
    4. Schnelles hin und herspringen mit den Zifferntasten (1 und 3, also 15 Sekunden)
    5. Beobachten was passiert!


    In meinem Fall kann ich die Hänger so nach wenigen Minuten reproduzieren!
    Die Box bleibt dann ca 10-15 Sekunden hängen und läuft dann normal weiter!


    Sollte das bei mehreren Leuten so sein, können wir folgendes ausschliessen:
    - es liegt nicht an irgendeiner Softcam
    - es ist egal welche Auflösung (720p/10810i, etc)
    - es liegt auch nicht am Grabbing der Bilddaten!!!
    ...


    Gruss slonnet

    DM8000SS + RGB TFT + Atmolight DMM Experimental OE2.0/GP3
    DM7020HD DMM Experimental OE2.0/GP3
    DM500HD + USB Mod DMM Experimental OE2.0/GP3

  • Quote

    Original von Afaliwen


    Bei mir (8000er) auch. Musste neu Flashen.


    Du hättest wahrscheinlich nicht neu flashen müssen: meine Box bootete soweit, dass ich über Telnet das Plugin deinstallieren konnte.


  • Beobachte bitte mal die Größe des Daemons im Speicher, wenn du diese Tests durchführst. Läuft "top" weiter, wenn die Box "klemmt" (für 15 secs)? Oder klemmt top auch?

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

  • Quote

    Original von mamba0815
    Beobachte bitte mal die Größe des Daemons im Speicher, wenn du diese Tests durchführst. Läuft "top" weiter, wenn die Box "klemmt" (für 15 secs)? Oder klemmt top auch?


    Wo sehe ich denn die Grösse im Speicher des Daemons?


    Habs gerade mal mit dem top Befehl getestet!
    Wenn die Box hängt, hängt auch der top Befehl, sprich es kommen erst wieder neue Werte wenn die Box weiter läuft!


    Getestet habe ich im Farbwechselmodus!


    Gruss slonnet

    DM8000SS + RGB TFT + Atmolight DMM Experimental OE2.0/GP3
    DM7020HD DMM Experimental OE2.0/GP3
    DM500HD + USB Mod DMM Experimental OE2.0/GP3

  • Top gibt dir auch die Grösse des Daemons im Speicher an. Schau mal danach, ob direkt vor dem Klemmer die Grösse massiv ansteigt. Ferner gib nach dem Ende eines Klemmers mal direkt im Terminal "dmesg" ein und poste mal die letzten 20 Zeilen der Ausgabe hier.


    Danke im Voraus!


    Mamba

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

  • Hi,


    anbei mal die Ausgabe unter DMESG bei meiner DM8000 wenn es zu den Hängern kommt. Unter TOP kann ich sehen wie die Leistung kurz massiv ansteigt und sich danach wieder einpendelt. Für ca. 15-20 Sekunden geht dann nix mehr.... :(




    [36739.466000] audio: decoder start 0
    [36739.482000] audio delay 18000 (200 ms)
    [36739.482000] total video delay: 18000 (200 ms)
    [36739.484000] start video0 on dmx 3 pid:ff
    [36739.484000] total video delay: 18000 (200 ms)
    [36739.486000] VIDEO0: start decode
    [36739.583000] bcm4506: signal_strength -125.64dbm
    [36739.588000] bcm4506: signal_strength -125.64dbm
    [36739.938000] bcm4506: signal_strength -127.63dbm
    [36739.943000] bcm4506: signal_strength -127.63dbm
    [36740.160000] ch0: lock
    [36740.160000] RAP first pts 0x1ae7ab190, stc 0x1ae7aa9c6, pcr valid
    [36740.367000] bcm4506: signal_strength -126.79dbm
    [36740.467000] RAP sampling rate info isr
    [36740.468000] eModeChange Isr.. set source_changed_event!
    [36740.801000] VIDEO0: first pts 0x1ae7d42c0
    [36740.951000] enable tsm0
    [36741.413000] bcm4506: signal_strength -126.69dbm
    [36741.550000] bcm4506: signal_strength -126.69dbm
    [36741.571000] bcm4506: signal_strength -126.69dbm
    [36742.437000] bcm4506: signal_strength -126.35dbm
    [36743.546000] bcm4506: signal_strength -125.90dbm
    [36743.554000] bcm4506: signal_strength -125.90dbm
    [36743.564000] bcm4506: signal_strength -125.90dbm
    [36748.279000] stop pcr0 on dmx 3 pid:ff
    [36748.280000] stop video0 on dmx 3 pid:ff
    [36748.281000] VIDEO0: stop decode
    [36748.281000] VIDEO0: set blank to 1
    [36748.282000] audio: decoder stop




    LG,


    Wraith

  • Prima. Danke für den dmesg-Log. Kannste den bitte nochmal genau gleich machen und hier wieder posten? Will sehen, ob die gleichen Ausgaben kommen (z.B. stop decode).

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

  • Hier der Log zum nächsten "Hänger":


    [42555.011000] audio: decoder start 0
    [42555.027000] audio delay 18000 (200 ms)
    [42555.027000] total video delay: 18000 (200 ms)
    [42555.029000] start video0 on dmx 3 pid:2ff
    [42555.029000] total video delay: 18000 (200 ms)
    [42555.031000] VIDEO0: start decode
    [42555.057000] bcm4506: signal_strength -124.21dbm
    [42555.063000] bcm4506: signal_strength -124.21dbm
    [42555.169000] bcm4506: signal_strength -124.21dbm
    [42555.175000] bcm4506: signal_strength -124.21dbm
    [42555.509000] ch0: lock
    [42555.509000] RAP first pts 0xd49df662, stc 0x19fac1354, pcr valid
    [42555.509000] RAP pts error 0 PTS 0x6a4efb31, STC 0xcfd609ac, type 0
    [42555.539000] ch0: lock
    [42555.539000] RAP pts error 0 PTS 0x6a4efb31, STC 0xcfd60f08, type 1
    [42555.571000] bcm4506: signal_strength -124.76dbm
    [42555.573000] ch0: lock
    [42555.573000] RAP pts error 0 PTS 0x6a4efb31, STC 0xcfd614f5, type 1
    [42555.580000] bcm4506: signal_strength -124.76dbm
    [42555.587000] bcm4506: signal_strength -124.76dbm
    [42555.603000] ch0: lock
    [42555.912000] RAP sampling rate info isr
    [42555.912000] eModeChange Isr.. set source_changed_event!
    [42556.596000] bcm4506: signal_strength -123.95dbm
    [42557.157000] VIDEO0: first pts 0x19faefbcc
    [42557.308000] enable tsm0
    [42557.584000] bcm4506: signal_strength -123.58dbm
    [42557.592000] bcm4506: signal_strength -123.58dbm
    [42557.601000] bcm4506: signal_strength -123.58dbm
    [42558.624000] bcm4506: signal_strength -123.90dbm
    [42559.578000] bcm4506: signal_strength -123.64dbm
    [42559.587000] bcm4506: signal_strength -123.64dbm
    [42559.628000] bcm4506: signal_strength -123.64dbm
    [42593.367000] stop pcr0 on dmx 3 pid:2ff
    [42593.367000] stop video0 on dmx 3 pid:2ff
    [42593.384000] VIDEO0: stop decode
    [42593.385000] VIDEO0: set blank to 1
    [42593.386000] audio: decoder stop
    [42593.406000] stop audio on dmx 3 pid:303
    [42593.406000] audio: xpt stop(3)
    [42593.406000] no decoder left in sync handling so disable xpt_sync
    [42593.406000] bcm_audio_channel_stop(3) done
    [42594.119000] start pcr0 on dmx 3 pid:ff index 5
    [42594.121000] start audio on dmx 3 pid:103
    [42594.121000] audio xpt start
    [42594.121000] sync is off so we enable it
    [42594.121000] demux-index 3 pcr0pid ff
    [42594.121000] using 5 as pcr0 pidchannel
    [42594.121000] AC3
    [42594.123000] audio: decoder start 0
    [42594.138000] audio delay 18000 (200 ms)
    [42594.138000] total video delay: 18000 (200 ms)
    [42594.140000] start video0 on dmx 3 pid:ff
    [42594.140000] total video delay: 18000 (200 ms)
    [42594.142000] VIDEO0: start decode
    [42594.223000] bcm4506: signal_strength -125.37dbm
    [42594.228000] bcm4506: signal_strength -125.37dbm
    [42594.499000] bcm4506: signal_strength -123.85dbm
    [42594.725000] bcm4506: signal_strength -125.55dbm
    [42594.731000] bcm4506: signal_strength -125.55dbm
    [42594.856000] ch0: lock
    [42594.856000] RAP first pts 0xeedebe9a, stc 0x6a27396e, pcr valid
    [42594.856000] RAP pts error 0 PTS 0x776f5f4d, STC 0x35139cb9, type 0
    [42594.886000] ch0: lock
    [42594.886000] RAP pts error 0 PTS 0x776f5f4d, STC 0x3513a216, type 1
    [42594.922000] ch0: lock
    [42594.922000] RAP pts error 0 PTS 0x776f5f4d, STC 0x3513a866, type 1
    [42594.950000] ch0: lock
    [42595.260000] RAP sampling rate info isr
    [42595.260000] eModeChange Isr.. set source_changed_event!
    [42595.524000] bcm4506: signal_strength -124.54dbm
    [42595.579000] bcm4506: signal_strength -124.54dbm
    [42595.586000] bcm4506: signal_strength -124.54dbm
    [42595.737000] VIDEO0: first pts 0x6a292c48
    [42595.889000] enable tsm0
    [42596.553000] bcm4506: signal_strength -125.42dbm
    [42597.591000] bcm4506: signal_strength -124.26dbm
    [42597.610000] bcm4506: signal_strength -124.26dbm
    [42597.631000] bcm4506: signal_strength -124.26dbm
    [42673.570000] bcm4506: signal_strength -125.81dbm
    [42673.691000] bcm4506: signal_strength -125.81dbm
    [42673.700000] bcm4506: signal_strength -125.81dbm
    [42707.111000] stop pcr0 on dmx 3 pid:ff
    [42707.111000] stop video0 on dmx 3 pid:ff
    [42707.112000] VIDEO0: stop decode
    [42707.113000] VIDEO0: set blank to 1
    [42707.114000] audio: decoder stop
    [42707.141000] stop audio on dmx 3 pid:103
    [42707.141000] audio: xpt stop(3)
    [42707.141000] no decoder left in sync handling so disable xpt_sync
    [42707.141000] bcm_audio_channel_stop(3) done
    [42707.888000] start pcr0 on dmx 3 pid:ff index 5
    [42707.891000] start audio on dmx 3 pid:103
    [42707.891000] audio xpt start
    [42707.891000] sync is off so we enable it
    [42707.891000] demux-index 3 pcr0pid ff
    [42707.891000] using 5 as pcr0 pidchannel
    [42707.891000] AC3
    [42707.891000] audio: decoder start 0
    [42707.908000] audio delay 18000 (200 ms)
    [42707.908000] total video delay: 18000 (200 ms)
    [42707.911000] start video0 on dmx 3 pid:ff
    [42707.911000] total video delay: 18000 (200 ms)
    [42707.912000] VIDEO0: start decode
    [42707.989000] bcm4506: signal_strength -126.37dbm
    [42707.993000] bcm4506: signal_strength -126.37dbm
    [42708.229000] bcm4506: signal_strength -128.16dbm
    [42708.234000] bcm4506: signal_strength -128.16dbm
    [42708.297000] bcm4506: signal_strength -128.16dbm
    [42708.406000] ch0: lock
    [42708.406000] RAP first pts 0x7e95ce5e, stc 0x1ce7edd0c, pcr valid
    [42708.406000] RAP pts error 0 PTS 0x3f4ae72f, STC 0xe73f6e88, type 0
    [42708.434000] ch0: lock
    [42708.742000] RAP sampling rate info isr
    [42708.742000] eModeChange Isr.. set source_changed_event!
    [42709.331000] bcm4506: signal_strength -125.33dbm
    [42709.423000] bcm4506: signal_strength -125.33dbm
    [42709.431000] bcm4506: signal_strength -125.33dbm
    [42709.796000] VIDEO0: first pts 0x1ce82d1c0
    [42709.947000] enable tsm0
    [42710.357000] bcm4506: signal_strength -127.20dbm
    [42711.382000] bcm4506: signal_strength -127.48dbm
    [42711.426000] bcm4506: signal_strength -127.48dbm
    [42711.449000] bcm4506: signal_strength -127.48dbm
    [42712.408000] bcm4506: signal_strength -126.07dbm
    [42722.151000] eModeChange Isr.. set source_changed_event!
    [42726.075000] stop pcr0 on dmx 3 pid:ff
    [42726.077000] stop video0 on dmx 3 pid:ff
    [42726.104000] VIDEO0: stop decode
    [42726.105000] VIDEO0: set blank to 1
    [42726.106000] audio: decoder stop
    [42726.126000] stop audio on dmx 3 pid:103
    [42726.126000] audio: xpt stop(3)
    [42726.126000] no decoder left in sync handling so disable xpt_sync
    [42726.126000] bcm_audio_channel_stop(3) done
    [42726.302000] start pcr0 on dmx 3 pid:1ff index 4
    [42726.304000] start audio on dmx 3 pid:203
    [42726.304000] audio xpt start
    [42726.304000] sync is off so we enable it
    [42726.304000] demux-index 3 pcr0pid 1ff
    [42726.304000] using 4 as pcr0 pidchannel
    [42726.304000] AC3
    [42726.306000] audio: decoder start 0
    [42726.321000] audio delay 18000 (200 ms)
    [42726.321000] total video delay: 18000 (200 ms)
    [42726.323000] start video0 on dmx 3 pid:1ff
    [42726.323000] total video delay: 18000 (200 ms)
    [42726.325000] VIDEO0: start decode
    [42726.420000] bcm4506: signal_strength -125.95dbm
    [42726.424000] bcm4506: signal_strength -125.95dbm
    [42726.873000] bcm4506: signal_strength -127.48dbm
    [42726.878000] bcm4506: signal_strength -127.48dbm
    [42727.195000] bcm4506: signal_strength -126.01dbm
    [42728.237000] bcm4506: signal_strength -128.04dbm
    [42728.269000] bcm4506: signal_strength -128.04dbm
    [42728.274000] bcm4506: signal_strength -128.04dbm
    [42729.353000] bcm4506: signal_strength -125.40dbm
    [42730.289000] bcm4506: signal_strength -126.64dbm
    [42730.293000] bcm4506: signal_strength -126.64dbm
    [42730.358000] bcm4506: signal_strength -126.64dbm


    Hoffentlich bringt es dir etwas :)

  • Danke!


    Hast du während des Loggens von dmesg ein paar mal den TV-Sender gewechselt?

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

  • Hi,


    zu diesem Zeitpunkt habe ich gezappt. In erster Linie tritt der Fehler auch oft beim zappen auf.


    Was ich bemerkte: Seitdem ich mir das aktuellste Merlin Image draufgepackt habe, scheint es etwas stabiler zu laufen. :) Zumindestens hauen die "Hänger" bei mir nicht mehr ganz so oft auf die Box (Box bleibt für ca. 20 Sek. hängen, es geht dann aber weiter). In erster Linie tritt der Fehler beim zappen auf.


    Was mir jedoch auch noch auffiel: Es bleiben ca. alle 30 min mal die Farben stehen (für ein paar Sekunden) . Die Box läuft dann aber weiter.
    So 2-3 mal täglich kommt es zu den schlimmen "Hängern" bei denen 20 Sek. nichts mehr geht.


    Anbei nochmals meine Daten:


    DM 8000 Merlin 2 Image v. 18.04.13 (Enigma2: 24.04.13)
    Atmolight mit 4 Kanälen.
    Die pre10 habe ich mir installiert (lief bisher von allen anderen pres am besten)


    Wie gesagt, mir kommt es so vor, als ob der Fehler mit dem akuellsten Image weniger auftritt. Kann dies jemand bestätigen ?
    Ich werde dir beim nächsten grossen Hänger (ohne Zappen) mal ein Screenshot von TOP und ein Auszug von DMESG erstellen.


    Sollte ich sonst noch etwas loggen, dann lasse es mich wissen.


    LG,


    Wraith

  • Sourcecode für Atmolight (o.ä.)???


    Kann mir jemand sagen, wo ich den Sourcecode zu der Sache bekomme?


    Ich habe zwar eine Karatelight am TV, aber zusätzlich habe ich im Raum LED-RGB-Flutlichter, die ich per Netzwerk ansteuern kann.


    Was ich machen will ist, diese in die Sache zu integrieren..


    Wäre super nett, wenn jemand helfen kann.

  • Sourcecode gibt mamba0815 nich raus sonst hätten wir ja das problem ja schon behoben was die DM8000 hat ;(

    MFG Ralf631 :D
    DM900 DM8000 mit Scythe Kama 92mm DFS922512M-PWM
    Lüfter und SAMSUNG SN-T083A Brenner und Atmolight
    LCD4linux-Plugin mit zwei Farbdisplays
    110´er Schüssel mit stab100 motor
    DM800
    >DM500+DM7000 in Rente<
    Hyricanpaytv das war ne schöne zeit

  • Wie schaut es denn mit dem Boblight-Plugin von speedyisfast. Mir liegen ein paar Berichte vor, dass die DM8000 dort auch "klemmt". Stimmt das denn wirklich? Wenn der Grabber nicht das Problem erzeugt (wurde hier berichtet), warum sollte das Boblight dann verklemmen? Speedyisfast benutzt die Grabber-"Mechanik" von Atmolight-Plugin. Der Rest ist bis auf keine Ausnahmen aber anders.


    Kann das mal jemand kommentieren? Klemmer mit Boblight definitiv ja/nein?


    Mamba


    PS: Source für das Boblight-Plugin hat speedy offen gemacht.

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

  • Ich mag das Boblight nich da kaum eine farbe passt und ich hab
    da genau so hänger beim normalen betrieb und auch beim spulen gerade getestet ;(

    MFG Ralf631 :D
    DM900 DM8000 mit Scythe Kama 92mm DFS922512M-PWM
    Lüfter und SAMSUNG SN-T083A Brenner und Atmolight
    LCD4linux-Plugin mit zwei Farbdisplays
    110´er Schüssel mit stab100 motor
    DM800
    >DM500+DM7000 in Rente<
    Hyricanpaytv das war ne schöne zeit

  • ich benutze Boblight mit meinem Sedulight am Raspberry schon seit etwa 3 Monate.
    Es funktioniert einwandfrei, selten kommen mal kurze weiße Blitze.

  • Quote

    Original von andy6090
    ich benutze Boblight mit meinem Sedulight am Raspberry schon seit etwa 3 Monate.
    Es funktioniert einwandfrei, selten kommen mal kurze weiße Blitze.


    Hi have you tryed the new boblightd for raspberry ?
    This is optimized and the flashes are gone.


    https://github.com/Speedy1985/boblightd-for-raspberry


    Kind regards Speedy

    if you like this project and want to support me, buy me a beer ;) Thanks!!


  • Boblight-enigma2 is based parts of code from aio-grab and boblight-X11.

    if you like this project and want to support me, buy me a beer ;) Thanks!!

  • Also ich habe eine 8000nder Box und das Bild hängt bei mir auch ab und zu.
    Eigentlich immer nur dann, wenn Boblight läuft.
    Bin mir ziemlich sicher, dass das etwas mit der Hintergrundbeleuchtung zu tun hat. Diese Hänger habe ich sonst nicht, wenn das Licht aus ist.