Version 0.7ht-pre22 (14.06.2013) Atmolight:(Test-Thread) 500HD/800(se)/7020HD/7025/8000 «Dual Core»

  • Quote

    Original von pclevon
    3. - Bemerkte Fehler: INFO-Taste - ( ist wohl noch 0.4 ;) )
    DANN ABER - beim Zurücksetzen auf Standard-Einstellungen -
    Crasht das System mit folgendem Fehler:


    Danke für die Meldung. Irgendetwas übersieht man immer. PlugIn wird sofort gefixt...

  • Sehr interessant das ganze :]


    Sobald das ganze wieder auf atmolight.de verfügbar ist werde ich wohl oder übel mit einsteigen müssen ;)


    BG
    Semi

  • "10.05.2012: Die KarateLight und AtmoLight Geräte sind vermutlich auch zum Ende der nächsten Woche versandbereit."


    Geht bald weiter.

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

    Edited once, last by mamba0815 ().

  • @ mamba0815


    im Karatelight Thread hast du was von Version 0.5 HT geschrieben. Wo kann man denn diese Version runterladen? Ist das bereits die, die lespuk angepasst hatte bzw. den Fehler mit den Standardeinstellungen beseitigt hatte? Diese Version ist doch für OE 2.0?



    Wäre es der Übersichtlichkeithalber nicht Sinnvoll, diese Version auf der ersten Seite zu posten? Danke

  • Die wird dann im ersten Post gepackt, wenn sie getestet wurde. Kommt. Einfach noch etwas warten.

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

  • Hier die Fehler bei der Installation:


    OE2


    Installing enigma2-plugin-extensions-atmolightd (0.5) to root...
    Configuring enigma2-plugin-extensions-atmolightd.
    Found DM8000HD.


    **** Testing Atmolight ...
    Message: No Atmolight device found.


    **** Testing amBX Light ...
    Message: No amBX device found.


    **** Testing Karatelight ...
    Karatelight device (serial #23af) found.
    /etc/udev/rules.d/53-karate.rules created.


    /usr/bin/atmodev.sh: line 131: ipkg: not found
    /usr/bin/atmodev.sh: line 131: ipkg: not found
    modprobe: module cdc_acm not found in modules.dep


    Villeicht berücksichtigen


    Danke


    Gruß


    Harry

  • Ist schon gefixt. Kommt mit der nächsten Version.

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

  • doctorno, keine Mailbox ist voll.

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

  • postfach wieder leer und noch eine andere frage....


    root@dm7020hd:~# opkg remove enigma2-plugin-extensions--atmolightd_0.5_mips32el
    No packages removed.
    root@dm7020hd:~#


    wenn ich das plug in deinst. möchte kommt diese meldung..waskann ich noch tun?? danke schon mal..

  • opkg remove enigma2-plugin-extensions-atmolightd


    sollte ausreichen ;)

    mfg


    OoZooN


    .................................................................


    :403: Two Beer or not two Beer, that's the Question :408:


    aktuelle Nachrichten rund um OoZooN-Images gibt es auf Twitter

  • @all,


    anbei eine Testversion vom Plugin 0.5 (Stand: 20.05., 22:00). Ich habe sehr viel am Code geändert, daher kann es sein, dass nicht alle Funktionen getestet wurden. KL16 wird nun unterstützt. Insbesondere wurde an der Helligkeitssteuerung gearbeitet, am Grabber (braucht praktisch immer unter 10% CPU) und am Kinomodus (3 und 4 sehen viel flotter aus) gearbeitet. Ausserdem wird nun die KL-LDR Funktion unterstützt. Das E2 Frontend wurde (von lespuck) ebenfalls aufgemöbelt und ist nun übersichtlicher.


    OE 2.0 TESTVERSION


    OE 1.6 TESTVERSION


    Bitte um Feedback.


    Ich bin nächste Woche praktisch komplett geschäftlich unterwegs, daher kann ich ggfs. nicht so schnell antworten.


    Mamba


    PS: Release-Notes:

    • UPDATE 20.05.2012: Version 0.5:
      - NEU: Karatelight16 wird unterstützt
      - NEU: externer Lichtsensor bei Karatelight wird unterstützt, im Plugin einstellbar
      - NEU: neue E2 Frontend (Danke lespuck)
      - NEU: OE2.0 wird zusätzlich zu OE1.6 unterstützt
      - NEU: Die Settings werden nach der Neuinstallation auf DEFAULT gestellt, d.h. man muss die persönlichen Einstellungen nach jeder Neuinstallation manuell ändern
      - NEU: Delay einstellbar, der verhindert, dass das Plugin schneller fadet, als der TV das Bild verändert
      - NEU: Grabber-LOAD stark reduziert (<10% Load), funktioniert nur auf Dual-Core Boxen (500hd/800se/7020hd/8k)
      - NEU: DM720HD wird unterstützt
      - NEU: Farbübergänge neu aufgesetzt, d.h. mit Werten > Mitte (==5) kann man die Ausgabe auf den LEDs in 10 Hz Schritten (träge) einbremsen. Werte unter "Mitte" entspricht der bisherigen Beschleunigungsfunktion. Die Stellung "Mitte" entspricht der bisherigen Stellung "ganz rechts" (==9), also bitte daran denken den Steller "Farbübergänge" im Plugin auf diese neuen Werte einzustellen.
      - Bugfix für "zabbbelige linke Seite" implementiert
      - Bugfix: Telnet und ssh geht nicht mehr auf NN 2 Images nach Plugininstallation - gefixt.
      - Bugfix: Renicen bei Hyperthreading-Version nun auf beiden Threads.
      - Bugfix: amBX-Light Bugfix (Daemon lies sich zeiweise nicht staren)
      - Helligkeitssteuerung komplett überarbeitet
      - Kinomodus aufgemöbelt, Modus 3/4 deutlich agiler und dynamischer
      - Installationsscript angepasst, nun wird nur "opkg" statt "ipkg" verwendet
      - Atmodev.sh und init-Script überarbeitet

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

    Edited 2 times, last by mamba0815 ().

  • EDIT: Fehlalarm. Scheint doch zu funktionieren. Sorry!


    EDIT2: Von Zeit zu Zeit schmiert der daemon ab.
    Mache bei Gelegenheit einen Log.

  • kurze Frage ..


    habe meine dm800 gegen ein 7020hd getauscht und natürlich gleich wieder das gute amtlolight plugin installiert.


    das atmolight wird auch erkannt bei der isntallation aber nicht hell.


    ich poste mal das log ...evtl. könnt ihr mir nen tipp geben was ich falsch gemacht habe.


    danke schonmal...


    root@dm7020hd:~# atmodev.sh


    Message: Settings have been reset. Please configure using Atmolight-Plugin.
    **** Testing Sedulight ...
    Message: No Sedulight device found.


    **** Testing Atmolight ...
    /usr/bin/atmodev.sh: line 124: can't create /etc/udev/rules.d/52-atmo.rules: non
    existent directory
    Atmolight device (serial #---------) found.
    /etc/udev/rules.d/52-atmo.rules created.



    ERROR: UDEV not found. You need to use /dev/ttyUSB* instead. Try configure using
    the Plugin.


    **** Testing amBX Light ...
    Message: No amBX device found.


    **** Testing Karatelight ...
    Message: No Karatelight device found.

  • So, die 0.5 läuft hier auf OE1.6 hervorragend!


    Die Perfomance der Box ist auch deutlich besser im Vergleich zur ersten HT Version.
    Merkt man sehr gut beim Zappen durch die Senderliste!


    Der Kinomodus 3/4 ist m.M. am besten, vergleichbar mit dem alten 4/4 Modus.
    Der neue Kinomodus 4/4 dunkelt m.M. nach zu stark ab => wirkt daher wieder zu hektisch.
    Ist es evtl. möglich den Kinomoden feiner abzustufen?

    Den Farbübergang habe ich auf 6/9 gestellt, 5 war mir noch zu hektisch.
    (Bei Farbübergang 1 bekommt man bei entsprechenden Filmmaterial einen Epileptischen :D )


    Den Delay hab ich erstmal auf 2/9 gestellt, ohne zu wissen wieviel das wirklich ist ;)
    M.m. nach wäre hier eine Angabe in ms besser, oder noch besser in Frames.
    Der Delay müsste ja der gleiche sein wie der Libsync Delay am AVR, oder sieht das jemand anders?


    PS: Abgeschmiert ist mir de Daemon bis jetzt noch nicht (bei ca. 2,5 Stunden Laufzeit)


    mfg slonnet

    DM8000SS + RGB TFT + Atmolight DMM Experimental OE2.0/GP3
    DM7020HD DMM Experimental OE2.0/GP3
    DM500HD + USB Mod DMM Experimental OE2.0/GP3

  • naudi: was für ein Image hast du drauf? Es hat kein Udev, d.h. du musst unter "Schnittstelle" das Device auswählen. Ausserdem musst du das richtige Gerät einstellen. Im Moment hast du "Seduboard" eingestellt. Das geht aber mit dem Daemon noch nicht, derzeit gehen nur KL, AL und amBXLight.


    slonnet: 2/9 heisst grob 15..20 ms Delay, je nach Auflösung. Denke 1 oder 2 wird für die meisten Sender passen.

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

    Edited once, last by mamba0815 ().

  • Image ist Open Pli...letzte Version.


    Ok...die Schnittstelle manuell auswählen sollte kein Problem sein ist ja USB 0 oder 1.


    Welchen deamon soll ich für mein Atmolight nehmen ?

  • PLI hat kein UDEV, daher wirst du auf das universal device verzichten müssen und immer das native Device auswählen (was hoffentlich immer die gleiche Nummer trägt).


    Daemon? Das Installationsscript wählt automatisch den richtigen Daemon aus. Da musst du nichts machen.


    Mamba

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

  • kurzes Feedback zur Version 0.5:


    DM8000; Atmolight; OE1.6


    *Installation/Update von 0.4c ohne Probleme
    *Einstellungen angepasst (Kino 3/4; Farbüberg. 6/9; Delay 1/4; alles natürlich individ.)
    *Start/Stop - Standby/Deepstandby alles i.O.
    *Deamon läuft scheinbar stabiler; noch kein Neustart verzeichnet
    *CPU Load etwas weniger als die 0.4c


    kurz um läuft super! :danke: :337:


    Möchte aber dies nochmal rauskramen, fände ich sehr wichtig:


    Quote

    Habe für dich doch ein paar Anfragen/aufgaben smile welche für mich sinnvoll wären mit der Frage der machbarkeit.


    -da ich sehr oft den RadioModus nutze wäre eine Option im Plugin nicht übel den Daemon im RadioModus schlafen zu lassen/oder die Farben zu wechseln
    -seperate Helligkeitssteuerung der einzelnen Kanäle
    -berücksichtigung der Hintergrundwandfarbe
    -bei Timerevents das Atmolight wahlweise auslassen (habe z.B. tägliche Umschalttimer und wenn ich mal nicht da bin ist die Bude erleuchtet) {schützt aber vor Einbrechern großes Grinsen }


    MFG
    blaky

  • 0.5 Funktioniert auf meiner 500HD echt gut bis auf 2 Dinge.
    Wenn ich die Box neu starte ist das Athmolight sehr sehr dunkel, bis ich das Plugin aufrufe. Dann wird blitzartig die richtige Helligkeit eingestellt. Das 2. was mir aufgefallen ist, es geht immer noch kein Pan&Scan. Da scheint der Deamon direkt abzustürzen wenn ich es auswähle. Somit muss man die 4:3 Sender mit 16:9 Inhalten (zb History) immer noch verzerrt schauen. Gibts da nen Lösungsansatz?


    Ansonsten wieder mal echt Top! Dankeschön :)

  • Ich benutze das 0.5 er OE 2.0 auf einer 7020 HD und habe damit einige probleme. Das Karatelight habe ich ganz neu könnte natürlich auch defekt sein, daher frage ich erst mal ob noch andere die probleme haben wie ich, bevor ich ein OE1.6 installiere.


    1. Start/Stop funktioniert nicht richtig. Wenn ich den autostart drinn habe die box komplett neu starte funktioniert es ich kann in den einstellungen die farben wechseln oder auf dynamisch stellen und es ändert sich auch etwas. Wenn ich aber von hand starte oder es mal abschalte funktioniert danach nichts mehr richtig. Muss dann wieder komplett neustarten. Auch wenn ich die Box abschalte bleibt das Karatelight dann einfach an.


    2. Standartwerte führen zum Greenscreen(ist aber wohl bekannt)


    3. Es blitzt immer wieder Hell auf, obwohl sich das Bild nicht ändert(auch wenn ich eine feste farbe auswähle passiert das.