Version 0.7ht-pre22 (14.06.2013) Atmolight:(Test-Thread) 500HD/800(se)/7020HD/7025/8000 «Dual Core»

  • eine Frage noch :-) zu 4 Kanal Atmolight


    N_N_2 seconstage 72 Jahr 2010 :-)


    am PC läuft alles bestens am dreambox nicht


    -----------------------------------



    irgedwie ich habe ich alles richtig instaliert
    hier


    root@dm800:/tmp# atmodev.sh


    **** Testing Atmolight ...
    Atmolight device (serial #23T19A8N) found.
    /etc/udev/rules.d/52-atmo.rules created.


    You can use the Plugin now. Please restart Enigma2 or reboot box.
    Das Plugin ist jetzt betriebsbereit. Starten Sie Enigma2 neu oder booten Sie die Box.


    **** Testing amBX Light ...
    Message: No amBX device found.


    **** Testing Karatelight ...
    Message: No Karatelight device found.


    -----------
    leuchtet gar nichts reboot klar auch schon mehrmals gemacht



    .......


    rote lampe am hardware leutet am anfang des rebootes dann aus und tut sich nichts
    bei mir ist die aus
    danke
    in telenet steht



    root@dm800:~# /etc/init.d/atmolight start
    already running with PID 2189
    root@dm800:~#
    AtmoLight Daemon 0.4a for DM800
    (c) Thomas "LazyT" Loewe 2009-2010
    (c) mods by mamba0815 2010-2011




    hm aber LED sind aus !



    llllllllllllllllllllllll


    es geht nicht
    ich instaliere nochmal von anfang an


    tja hat es nicht geholfen



    root@dm800:~# /etc/init.d/atmolight stop
    Stopping AtmoLightD...
    root@dm800:~# /etc/init.d/atmolight start
    root@dm800:~#
    AtmoLight Daemon 0.4a for DM800
    (c) Thomas "LazyT" Loewe 2009-2010
    (c) mods by mamba0815 2010-2011



    irgendwas stimmt nicht bitte um hilfe


    wo kann ich sehen was nicht stimmt bin am ende mit meinen Latein :-(


    Danke
    na ja dann lese ich alle Postings hier
    bleibt nichts übrig

  • Hallo zusammen,


    melde mich seit langem wiedermal mit einer Frage bzgl. Athmolight.


    Betreibe das AL nun schon sicher 12-18 Monate an einer dm500hd. Hatte das AL von Anfang an an meiner Box und hatte es nie uner Verdacht, Verursacher fü mein "Tunen fehlgeschlagen" Problem zu sein. Jetzt hat sich rausgestellt, dass die Box absolut null Probleme beim Umschalten macht, wenn das Athmolight nicht angeschlossen bzw. installiert ist.
    Sonst hatte ich bei jedem Wechsel von HD auf SD Sendern ein "Tunen fehlgeschlagen" und anch 5 Seunden kam das Bild.


    Ist das generell bekannt? Habe wahrscheinlich die erste 4 Kanal VErsion des AL. Kann es am USB Hub liegen? Auch hängt sich das AL von Anfang an manchmal auf. D.h. das Licht ändert die Farbe nicht mehr und bleibt einfach hängen. Ich muss das 1-2 Mal auf Athmolight aktivieren gehen, damit es sich wieder "fängt" Oder eben on/off schalten...


    Irgendwas scheint also nicht zu funktionieren.


    Könnt ihr da irgendwie helfen?


    danke,
    MArkus

  • 1. Welches Image hast du in Betrieb?
    2. Hast du im Plugin die Schnittstelle auf "/dev/ttyUSBAtm" eingestellt?


    Mamba

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

  • root@dm800:~# dmesg | grep usb
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97


    was bedutet das
    danke


    ..............



    root@dm800:~# /usr/sbin/atmolightd.ng
    root@dm800:~#



    ,,,,,,,,,,,,,,,,,,


    hier tut sich nichts


    ..........


    root@dm800:~# ipkg install kernel-module-ftdi-sio
    Package kernel-module-ftdi-sio (2.6.18-r5.0) installed in root is up to date.
    root@dm800:~#



    root@dm800:~# cat /proc/stb/avs/0/input
    encoder


    .........



    root@dm800:~# ipkg remove kernel-module-ftdi-sio
    Collected errors:
    * Package kernel-module-ftdi-sio is depended upon by packages:
    * task-opendreambox-gemini2
    * These might cease to work if package kernel-module-ftdi-sio is removed.


    * * You can force removal of this package with --force-depends.
    * You can force removal of this package and its dependents
    * with --force-removal-of-dependent-packages



    ...................

  • paschua,


    so einen Fehler habe ich in 2 Jahren Atmolight-Projekt noch nicht gesehen. Mit dem eigentlichen Plugin hat der Fehler nichts zu tun. Es gibt irgendein Problem mit dem Kernel und dem ftdi Modul, oder mit dem Atmolight-Gerät selbst.


    Wann genau kommt dieser "-97" Error? Permanent? Geht, wenn der Fehler aktiv ist, das atmodev.sh Script, d.h. erkennt es immer noch das Atmolight (samt Seriennummer)?


    Probiere auch mal das hier:


    ipkg remove kernel-module-ftdi-sio
    opkg update
    opkg install kernel-module-ftdi-sio
    depmod -a


    Geht es dann?


    Mamba

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

    Edited 2 times, last by mamba0815 ().

  • T: Bus=01 Lev=02 Prnt=03 Port=01 Cnt=02 Dev#= 5 Spd=12 MxCh= 0
    D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
    P: Vendor=0403 ProdID=6001 Rev= 6.00
    S: Manufacturer=c@rstenpresser.de
    S: Product=AtmoLight SMD v04
    S: SerialNumber=23T19A8N
    C:* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=120mA
    I: If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=ftdi_sio
    E: Ad=81(I) Atr=02(Bulk) MxPS= 0 Ivl=0ms
    E: Ad=02(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms



    -------------------------------------------
    -------------------------


    root@dm800:/tmp# tar xzvf atmol*.tar.gz
    usr/
    usr/lib/
    usr/lib/enigma2/
    usr/lib/enigma2/python/
    usr/lib/enigma2/python/Plugins/
    usr/lib/enigma2/python/Plugins/Extensions/
    usr/lib/enigma2/python/Plugins/Extensions/AtmoLight/
    usr/lib/enigma2/python/Plugins/Extensions/AtmoLight/locale/
    usr/lib/enigma2/python/Plugins/Extensions/AtmoLight/locale/de/
    usr/lib/enigma2/python/Plugins/Extensions/AtmoLight/locale/de/LC_MESSAGES/
    usr/lib/enigma2/python/Plugins/Extensions/AtmoLight/locale/de/LC_MESSAGES/AtmoLight.mo
    usr/lib/enigma2/python/Plugins/Extensions/AtmoLight/plugin.png
    usr/lib/enigma2/python/Plugins/Extensions/AtmoLight/plugin.pyc
    usr/lib/enigma2/python/Plugins/Extensions/AtmoLight/__init__.pyc
    usr/lib/enigma2/python/Plugins/Extensions/AtmoLight/images/
    usr/lib/enigma2/python/Plugins/Extensions/AtmoLight/images/led_l.png
    usr/lib/enigma2/python/Plugins/Extensions/AtmoLight/images/lcd.png
    usr/lib/enigma2/python/Plugins/Extensions/AtmoLight/images/led_t.png
    usr/lib/enigma2/python/Plugins/Extensions/AtmoLight/images/led_r.png
    usr/lib/enigma2/python/Plugins/Extensions/AtmoLight/images/led_b.png
    usr/sbin/
    usr/sbin/atmolightd
    usr/sbin/atmolightd.ng
    etc/
    etc/rc0.d/
    etc/rc0.d/K10atmolight
    etc/init.d/
    etc/init.d/atmolight
    etc/rc6.d/
    etc/rc6.d/K10atmolight
    etc/rc3.d/
    etc/rc3.d/S99atmolight
    root@dm800:/tmp# atmodev.sh


    **** Testing Atmolight ...
    Atmolight device (serial #23T19A8N) found.
    /etc/udev/rules.d/52-atmo.rules created.


    You can use the Plugin now. Please restart Enigma2 or reboot box.
    Das Plugin ist jetzt betriebsbereit. Starten Sie Enigma2 neu oder booten Sie die Box.


    **** Testing amBX Light ...
    Message: No amBX device found.


    **** Testing Karatelight ...
    Message: No Karatelight device found.


    -----------------------
    reboot
    ....


    in menu atmo an


    nichts tut sich
    .................



    root@dm800:~# dmesg | grep usb
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97


    root@dm800:~#
    root@dm800:~# atmodev.sh


    **** Testing Atmolight ...
    Atmolight device (serial #23T19A8N) found.
    /etc/udev/rules.d/52-atmo.rules created.


    You can use the Plugin now. Please restart Enigma2 or reboot box.
    Das Plugin ist jetzt betriebsbereit. Starten Sie Enigma2 neu oder booten Sie die Box.


    **** Testing amBX Light ...
    Message: No amBX device found.


    **** Testing Karatelight ...
    Message: No Karatelight device found.


    root@dm800:~#


    -----------


    root@dm800:~# ipkg remove kernel-module-ftdi-sio
    Collected errors:
    * Package kernel-module-ftdi-sio is depended upon by packages:
    * task-opendreambox-gemini2
    * These might cease to work if package kernel-module-ftdi-sio is removed.


    * * You can force removal of this package with --force-depends.
    * You can force removal of this package and its dependents
    * with --force-removal-of-dependent-packages


    --------


    keine Samrdcarreder oder so


    alles hängt an USB HUB aktiven


    ...............



    root@dm800:~# dmesg | grep attached
    root@dm800:~# dmesg | grep attached
    root@dm800:~# lsmod | grep ftdi_sio
    ftdi_sio 35344 1 - Live 0xc008a000
    usbserial 33536 4 pl2303,ftdi_sio, Live 0xc0097000
    root@dm800:~# dmesg | grep attached
    root@dm800:~#


    root@dm800:~# /usr/sbin/atmolightd.ng -c=1


    AtmoLight Daemon 0.4a for DM800
    (c) Thomas "LazyT" Loewe 2009-2010
    (c) mods by mamba0815 2010-2011


    ......



    root@dm800:/# stty -F /dev/ttyUSBAtmo 38400
    stty: can't open '/dev/ttyUSBAtmo': Message too long


    ..........



    root@dm800:/# ls /dev/ttyU* -al
    crw-rw-rw- 1 root root 188, 0 Apr 28 16:06 /dev/ttyUSB0
    lrwxrwxrwx 1 root root 7 Apr 28 16:06 /dev/ttyUSBAtmo -> ttyUSB0
    root@dm800:/#


    ....


    was komisch ist bei befehl atmodev.sh kommt am TV


    das erkannt wird unf möchte meine Fotos vom Stick zegen wo mein swap auch ist ??????????


    ...


    root@dm800:~# /etc/init.d/atmolight stop
    Stopping AtmoLightD...
    not running
    root@dm800:~# ps|grep atmolight
    2137 root 2532 S /bin/sh /usr/sbin/atmolightd
    3386 root 2532 S /bin/sh /usr/sbin/atmolightd
    3612 root 2596 S grep atmolight
    root@dm800:~# ps|grep atmolight
    2137 root 2532 S /bin/sh /usr/sbin/atmolightd
    3386 root 2532 R /bin/sh /usr/sbin/atmolightd
    3648 root 2532 R /bin/sh /usr/sbin/atmolightd
    3650 root 2596 S grep atmolight
    root@dm800:~# ps|grep atmolight
    2137 root 2532 S /bin/sh /usr/sbin/atmolightd
    3386 root 2532 S /bin/sh /usr/sbin/atmolightd
    3671 root 1744 R pidof atmolightd.ng
    3673 root 2596 S grep atmolight
    root@dm800:~# ps|grep atmolight
    2137 root 2532 S /bin/sh /usr/sbin/atmolightd
    3386 root 2532 S /bin/sh /usr/sbin/atmolightd
    3708 root 2596 S grep atmolight
    root@dm800:~#


    -------------


    neuste n n 2 mit seconstage84 gerade geflasht
    alles supi instaliert aber dann wieder


    root@dm800:~# dmesg | grep usb
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97
    drivers/usb/serial/ftdi_sio.c: ftdi_open - failed submitting read urb, error -97


    .........


    na ja habe ich ambx wider reingesteckt i plugin umgestellt reboot und ambx geht ohne probleme


    ............

  • @all:


    Ich würde empfehlen diesen Thread mal genau zu beobachten. ;)


    Klick


    EDIT: oops ... Thread wieder weg?

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

    Edited once, last by mamba0815 ().

  • Dein Link geht nicht


    Gruß MaXAt0M


    1 x DreamBox 900UHD
    1 x DreamBox 7080HDSS
    3 x DreamB0X 520

  • Hmm ... er scheint wieder gelöscht worden zu sein ...

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

  • hallo
    was war in den thread ?
    danke
    joooo alles klar
    vielleicht habe ich da mehr glück :-)
    danke sehr

  • Der Thread ist wieder da. Hier.

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

  • mamba hilfe


    glache probs mit den neuen plugins vom link


    was meinst du denn mamba


    ist mein box irgedwie kaputt oder atmolight kaputt ist 2 jahre alt ( aber am pc nter windof läuft er ) vielleicht sollich es an entwickler zuschicken


    wie soll ich es eingrenzen


    meine ideen sind ausgeschöpft
    danke dir

  • Poste mal im Boblight-Thread deine boblight.conf.

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

  • Es hängt davon ab, wie das Boblight auf den Enigma2-Boxen läuft. Wenn die Performance und die Qualität das hält, was es verspricht, dann macht es herzlich wenig Sinn an 2 Projekten weiter zu arbeiten. Zumal bereits wichtige Erfahrungen aus dem Atmolight-Plugin im Grabber des Boblight-Projektes von Speedy eingeflossen sin, z.B. der Geschwindigkeits-Booster und einige kleinere Sachen mehr.


    Man muss sehen. Einige Sachen kann der Fader des Boblights besser als mein Plugin, andere Dinge finde ich suboptimal.


    Es bliebt also interessant.

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

  • @ mamba0815


    habe heute mal das neue OE 2.0 für die DM8000 installiert und bekomme jetzt das Atmo nicht mehr zum laufen, Irgentwas mit den pyo Dateien ( Extensions/AtmoLight Bad magic number in /usr/lib/enigma2/python/Plugins/Extensions/AtmoLight/__init__.pyo ). Mußt oder kannst du das noch anpassen? Möchte ungern auf`s Atmo verzichten. Habe auch mal Boblight probiert, aber hier auch das selbe. Danke dir schon mal

    Edited once, last by magnum1795 ().

  • Quote

    Original von LazyT
    Anbei die Plugindateien für OE2.0...


    @ lazyT


    danke dir, das Atmo leuchtet wieder wie gewohnt.

  • Danke. Das Plugin selber läuft.


    Leider geht mein AtmoLight aber nicht an.
    Das ftdi-sio Modul ist installiert und das device /dev/ttyUSBAtmo ist ebenfalls angelegt.
    Werd mal weiter testen, was es sein könnte.

  • Quote

    Original von deathrattle
    Danke. Das Plugin selber läuft.


    Leider geht mein AtmoLight aber nicht an.
    Das ftdi-sio Modul ist installiert und das device /tty/ttyUSBAtmo ist ebenfalls angelegt.
    Werd mal weiter testen, was es sein könnte.


    war bei mir auch erst so. Habe dann in etc/opkg/arch.conf diese Zeile hinzugefügt:
    arch mipsel 16 und enigma neu gestartet. Jetzt habe ich das Plugin 0.4a noch einmal installiert (vorher hatte ich manuell den Dreamexplorer installiert, damit kann man problemlos ipkg installieren) und die Daten von LazyT in usr/lib/enigma2/python/Plugins/Extensions/AtmoLight ausgetauscht. Box neugestartet und das Atmo lief jetzt.