Version 0.7ht-pre22 (14.06.2013) Atmolight:(Test-Thread) 500HD/800(se)/7020HD/7025/8000 «Dual Core»

  • >>Bei mir lag es (zumindest mittelbar) an
    >>"AutomaticCleanup (Systembereinigung) Plugin Version 0.2.0"


    Ich frage mal beim Autor nach, was er genau macht.

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

    Edited 2 times, last by mamba0815 ().

  • Hallo,


    habe auch mal auf 0.4c upgedatet.
    Allerdings sehe ich nur 2 Prozesse des atmolightd daemons.


    Bin noch am testen, da ich ja Kernel 2.6.31 und einen ET9K habe, kann ich nix beklagen..

  • franko_,


    mit "top" siehst du nur 2 aktive Prozesse, es sind aber 4, wenn du mit "ps" schaust.


    Tut das Atmolight mit dem .31er Kernel?


    Mamba

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

    Edited once, last by mamba0815 ().

  • Hier der output des ET9K:


    root@et9000:~# top |grep atmo*
    615 1 root R N 35368 11% 8% /usr/sbin/atmolightd.ng -o=/dev/ttyUSB
    1089 1050 root S 2292 1% 0% grep atmo*
    596 1 root S 2228 1% 0% /bin/sh /usr/sbin/atmolightd -o=/dev/t


    root@et9000:~# ps |grep atmo*
    596 root 2228 S /bin/sh /usr/sbin/atmolightd -o=/dev/ttyUSB0 -l=1 -s=
    615 root 35368 S N /usr/sbin/atmolightd.ng -o=/dev/ttyUSB0 -l=1 -s=6 -b=


    root@et9000:~# uname -a
    Linux et9000 2.6.31-3.2 #1 SMP Wed Jul 13 05:08:04 CEST 2011 mips GNU/Linux



    2.6.31 ist ein richtiger Quantensprung zum 2.6.18, läuft richtig gut ...

  • >>"o=/dev/ttyUSB0"


    Du verwendest das native Device, nicht das udev-Device. Wundere dich nicht, wenn dir irgendwann die dynamische Lichter einfrieren. Der Kernel verknotet hin und wieder das Device neu und das kann man mit dem udev-Device (/dev/ttyUSBAtmo) abfangen, sodass der Daemon weiter läuft, als wäre nichts gewesen. Dazu muss dein Image aber udev unterstützen. Die meisten Dreambox Images machen das, z.B. iCVS oder OoZoon.


    Bei dir läuft nur ein Daemon (*d.ng), nicht 2.


    >>Tut das Atmolight mit dem .31er Kernel?
    Gehen bei dir nun die dynamischen Lichter, oder nicht?


    Mamba

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

    Edited once, last by mamba0815 ().

  • Ja, habe keine Probleme damit im Dauerbetrieb (STDBY/Aufwecken) geht alles.


    Wegen dem Udev Support muss ich mal im OpenPLi Forum nachschauen.


    Habe nur eine leere Datei /dev/.udev <- muss das damit verlinkt werden?


    Aber es tut alles so wie es soll, warum Arbeit machen ..

  • Hi,


    >>Ja, habe keine Probleme damit im Dauerbetrieb (STDBY/Aufwecken) geht alles.
    ok. Wenn das Device /dev/ttyUSB0 dauerhaft aktiv ist, dann passt das ja. Ich hatte da andere Erfahrungen (allerdings mit 2.6.1x). Beobachte mal weiter und berichte bitte, ob du Probleme hast (allerdings nicht hier, sondern im dazu passenden Thread im ET9000-Forum).


    >>Habe nur eine leere Datei /dev/.udev <- muss das damit verlinkt werden?
    Udev verklinken musst du nicht. Das macht der udevd alleine, wenn der implementiert ist.


    >>Wegen dem Udev Support muss ich mal im OpenPLi Forum nachschauen.
    Die PLIler setzen wohl auf was anderes (mdev, oder so). Ich verwende kein PLI, daher habe ich damit leider keine Erfahrung.


    Mamba

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

  • Nach einigen tagen testen mit der 04c version, bin ich wieder zurück auf die 04a gegangen, die scheint immernoch auf der 800se am besten zu laufen, die neue version reagiert tick zu schnell, die helligkeit ist ein bisschen dunkler bei gleichen einstellungen, das einzige was richtig geil ist, sind die farben, die sehen echt cool aus.bei szenen wechsel reagiert die neue mit einem flackern, was mit der zeit eher störend ist.also die 04a tut im moment am besten!!hat jemand bessere erfahrungen mit der 800se gemacht??

  • Die Helligkeitssteuerung ist bei der 0.4c identisch mit der 0.4a. Gleiches gilt für die Farbsteuerung. Nimm doch einfach den Helligkeitsregler etwas mehr nach rechts.


    Immer darauf achten, dass der Kinomodus nicht zu hoch ist, denn der ist für actionreiche Kinofilme gedacht. Ich bin mit Kinomodus 1 (= 1 Klick von links) gut gefahren.


    Die 0.4c erlaubt mit hohen Werten für "Farbübergänge" einen sehr "weichen" Übergang zwischen Farbwechsel, nimm einfach mal einen Klick von rechts (=20 Hz).


    Was anders ist bei der 0.4c ist das Grabben des Videodecoders. Das geht ja nun parallel zum Farbberechnen. Leider habe ich keine eigene DM800se, daher kann ich es nicht selbst testen und bin auf fremde Hilfe angewiesen. :-/


    Mamba

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

    Edited 2 times, last by mamba0815 ().

  • habe schon alle einstellungen probiert, auch bei langsamster eintellung, flackert das bild zweimal auf bei szenenwechsel, die helligkeit kommt mir wirklich bissschen schwächer vor als in der älteren version.habe 2 filme geguckt mit der neuen dann zwei wieder mit der älteren, also mit der älteren gibt es nichts auszusetzen.mich würden auch andere user mit ner 800se interessieren, was die dazu sagen

  • Ich will nicht ausschliessen, dass der Grabber für die 800se noch etwas tuning braucht. Leider kann ich das mangels Box derzeit nicht angehen. Schneuf.

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

  • das kann ich mir vorstellen, ist echt schwierig an was zu arbeiten, wenn man entsprechende box nicht hat, aber die 04a läuft schon ganz gut, die 04c ist halt tick schneller als das bild, wie du geschrieben hast, ist es die hdmi verzögerung.die farben dafür sind echt krass, man muss schon die alte einstellung verändern, sonst sehen die schlümpfe schon echt brutal blau aus!!!;-)auf der wand natürlich!!

  • Man müsste also eine Latenzzeit einbauen, um die HDMI-Verzögerung auszugleichen? Weiss jemand der Mitleser, wieviele Millisekunden das ungefähr sein sollten?


    Mamba

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

  • Hallo,


    ich musste leider auch wieder von 0.4c zur 0.4a zurückwechseln ...


    Nach einem fehlgeschlagenen Update von 0.4a auf 0.4c, habe ich die Version 0.4a zuerst deinstallieren müssen, um dann nach einem Reboot die Version 0.4c installieren zu können.


    Die Version 0.4c scheint aber (zumindest bei mir) noch nicht stabil zu laufen, denn nach einem Standby von einem Tag funktionierte das Atmolight erst nach einem Reboot wieder. Die vorherige Prüfung der Devices zeigte, dass das Device 'ttyUSBAtmo' nicht mehr vorhanden war. In der Version 0.4a war das Device 'ttyUSBAtmo' auch über länge Zeit immer noch zugreifbar ...


    Beide Versionen getestet auf einer DM8000HD mit NN 2 v3.2.2


    Danke und Gruß
    Michael

  • also abstürze oder sonstige probleme hatte ich keine, nur halt die verzögerung, plus das auflackern bei szenenwechsel, ich denke das hängt mit der verzögerung zusammen


  • Hat dein Image kein udev? Wenn es keins hat, dann hat das nichts mit dem Plugin zu tun. Der Kernel verknotet von Zeit zu Zeit das usb2ser Device neu. Dann steht das Plugin im Wald. Per udev wird das aber transpartent abgefangen und man merkt den Wechsel nicht.


    Mamba

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

  • Die Verzögerung kommt nicht vom HDMI sondern vom TV. 100Hz/200Hz Technik oder wie all diese Bildverbesserer heißen brauchen Zeit. Bei meinem Samsung exakt 100ms.


    Ich kann die Beobachtungen von adi800 nur unterstreichen. Das Flackern tritt bei mir auch auf. Aber weniger in den äußeren Bereichen als in den inneren.

  • also ob das davon kommt, weiss ich nicht, auf jeden fall kommt das öfter vor, wenn von dunklem bild ins helle gewechselt wird, dann flackert es kurz auf(das neue bild) dann wieder kurz das alte bild bis es ins neue wechselt, das alles innerhalb millisekunden, kommt als flackern vor, wenn man es sieht, auf jeden fall fällt es am meisten in dunklen passagen auf, weil es hell wird und man noch das alte dunkle bild sieht

  • Hmmm .... ich glaube, ich weiss was das sein kann. Vielleicht hat das was mit den interlaced Halbbildern zu tun?


    => Oversampling ...


    Ich bastel' mal was.


    Probiert' in der Zwischenzeit mal, ob es auf ARD HD oder ZDF HD auch das Aufflackern gibt. Wäre das ein wichtiger Hinweis.


    Mamba

    checking for long long... yes
    checking for long double... yes
    +++ Divide By Cucumber Error. Stopping. +++

    Edited 3 times, last by mamba0815 ().