[Update 2.4/04.10.2020 WakeOnLan/Mount/Shutdown Plugin


  • Danke für den Tipp! Hat funktioniert!

  • Hallo,


    folgender Sachverhalt:
    Rechner lässt sich direkt über das Router-Interface über Netzwerk Starten. Im Telnet, unter Benutzung des Befehls wolctl isonline "pcname" kommt immer die Meldung "offline", obwohl der Rechner hochgefahren ist (auch bei ausgeschalteter Firewall). Über die Dreambox lässt sich der Rechner nicht starten.


    1. MAC-Adresse wurde kontrolliert
    2. BIOS Einstellungen wurden kontrolliert
    3. IP-Adresse wurde kontrolliert


    Aus meiner Sicht ist der Rechner und der Router für WOL richtig konfiguriert.


    Noch weitere Ideen, woran es liegen könnte?


    Danke und Gruß!
    grepol

  • ok. hab nochmal alles neu eingegeben,
    wolctl funzt...server online,
    server ist bei mir ein whs acer h341, wenn der in den standby gegeangen ist bekomme ich den nicht mehr wach,
    ich kann an der dream "whs über netzwerk wecken" auswählen, whs wacht aber nicht auf,

  • Quote

    Original von tomalu
    ok. hab nochmal alles neu eingegeben,
    wolctl funzt...server online,
    server ist bei mir ein whs acer h341, wenn der in den standby gegeangen ist bekomme ich den nicht mehr wach,
    ich kann an der dream "whs über netzwerk wecken" auswählen, whs wacht aber nicht auf,


    Hi,


    schau im BIOS nach, ob Wake On Lan eingeschaltet ist.


    Viele Grüße


    Aladin


  • Hi,


    schau auf deinem Server unter Systemsteuerung->Verwaltung->Dienste ob das WakeOnLanService gestartet ist.


    Viele Grüße


    Aladin


  • Hallo,


    der besagte Dienst läuft. Der Rechner wird bei Ansteuerung über das Dreambox Plugin erst gar nicht gestartet. Wie bereist gesagt, über das Webinterface des Routers geht das WOL!

  • wie muss eigentlich im Dreambox Plugin die MAC Adresse eingetragen werden? Mit Bindestrich oder Doppelpunkt?

  • Quote

    Original von grepol
    wie muss eigentlich im Dreambox Plugin die MAC Adresse eingetragen werden? Mit Bindestrich oder Doppelpunkt?


    Hi,


    die MAC-Adresse wird durch Doppelpunkt getrennt.


    zum starten wird der folgende Befehl verwendet:


    wakelan -m <MAC-Adresse>


    Möglichweise hast du das das wakelan Paket auf der Dreambox vergessen zu installieren.


    Wenn der Dienst läuft müsste dein Fileserver über das Plugin nach 5 Minuten heruntergefahren werden. Der Dienst wird zum herunterfahren benötigt. wolctl müsste online anzeigen.


    Viele Grüße


    ALadin

  • Hi,


    jetzt hats funktioniert! Danke!


    Ist eine Erweiterung des Shutdown-Funktion möglich, in der gewählt werden kann, ob der Server in Standby bzw. Shutdown gehen soll?


    Gruß
    grepol


  • Ich ziehe die Frage zurück, da das doch überflüssig ist, weil ein Übergang in den Standby-Modus über die Zeitsteuerung am Server einstellbar ist.

  • so, habe es jetzt soweit geschafft das ich über telnet wakelan macadresse den whs aufwecken kann,
    nur über das tool schaffe ich es nicht, whs aufwecken funktioniert nicht?

  • Hi,


    überprüfe nochmal die Mac Adresse mit wol.conf.


    Falls das nicht hilft, poste die Datei


    /etc/enigma2/wol.xml


    Viele Grüße


    Aladin

  • Hey,


    vielen Dank für das super Plugin. Läuft soweit klasse. Lediglich die Portfreigabe will nicht so wie ich das möchte. Sprich ein Wecken funktioniert nur bei abgeschalteter Firewall an meinem Server. Muss ich eventuell noch einen zusätzlichen Port freigeben?



    Grüße,
    Michael


  • Hi,


    es muß der UDP - Port 25255 freigegeben werden. Der ist aleerdings nur für das Herunterfahren nötig. Für das Aufwecken könnte der UDP - Port 99 eventuell helfen. Bin aber nicht hundertprozentig sicher.


    Viele Grüße


    Aladin

  • bei mir funzt es jetzt auch... :hurra:
    zeitweise fährt oder versucht der whs in den stby zu kommen, zumindest siet das so aus, nach 10 sek. geht es aber weiter, komisch
    am whs ist es auch so eingestellt, dass der nach 10 min. in den stby soll, allerdings versucht er das auch solange die dream läuft,
    gibt es da einen tip...?

  • Quote

    Original von tomalu
    bei mir funzt es jetzt auch... :hurra:
    zeitweise fährt oder versucht der whs in den stby zu kommen, zumindest siet das so aus, nach 10 sek. geht es aber weiter, komisch
    am whs ist es auch so eingestellt, dass der nach 10 min. in den stby soll, allerdings versucht er das auch solange die dream läuft,
    gibt es da einen tip...?


    Hi,


    du brauchst den whs nicht in den Standby zu schicken. Das Herunterfahren wird vom Plugin mit Hilfe der Option Server herunterfahren erledigt.


    Viele Grüße


    Aladin

  • wie jeztz , am whs nicht nach 10 min. in stby aber über die dream wird der whs in stby geschickt?

  • Quote

    Original von tomalu
    am whs ist es auch so eingestellt, dass der nach 10 min. in den stby soll, allerdings versucht er das auch solange die dream läuft,


    Hi,


    ich glaube ich habe diesen Satz falsch verstanden. Ich habe das so verstanden, das du deinen WHS so eingestellt hast, daß er alle 10 Minuten in den Standby geht.


    Mein Plugin fährt den Server nach 5 Minuten herunter, wenn du es über das Menü wünschst oder beim Ausschalten der Box. Aber nicht alle 10 Minuten.


    Viele Grüße


    Aladin

  • :rolleyes:soweit habe ich das schon verstenden, das problem ist nur...
    der whs wird in den stby geschickt wacht aber sofort wieder auf,
    es ist egal ob automatisch herunterfahren aktiviert ist oder nicht,
    bedeutet sobald ein video geschaut wird versucht der whs aller 10 min einzuschlafen fährt aber sofort wieder hoch,
    ich wollte eigentlich auf die 10 min stby am whs nicht verzichten, da dieser nicht nur speicher für die dream ist, wenn also die dream nicht läuft kann der whs nach 10 min. in den stby, wird dann bei zugriff eines windows pc im netzwerk problemlos geweckt,
    jetzt fehlt halt nur noch...immer ein des whs wenn die dream läuft, herunterfahren dann händisch oder wenn dream aus ist nach 10 min voreinstellung,
    ich hoffe das war einigermaßen verständlich... :rolleyes:

  • Hi,


    mein Plugin fährt den Server herunter und nicht in den Standby. Deshalb galube ich das mein Plugin dir nicht helfen wird.


    So wie ich dich verstanden habe, wird der Server nach 10 Minuten nur in den Standby gefahren, wenn die Festplatte auch 10 Minuten lang keinen Zugriff hatte. Und wieder aufgeweckt, wenn ein Zugriff auf die Festplatte erfolgt. Wenn das so ist reicht wahrscheinlich, ein Remote mount in der fstab. Mein Plugin wird eher stören statt helfen.


    Viele Grüße


    Aladin