hfsplus + GP5.0

  • Hallo,


    meine hfsplus wird nicht mehr gemounted. Kann es sein, dass das neue Image keine Treiber für hfsplus hat?


    Mit GP4.6 ging die Platte ohne Probleme.


    Wo kann ich denn die Treiber dazu finden, nachladen ist für mich kein Problem......

  • Quote

    Wichtig:
    ACHTUNG bei einige Festplatten soll es unter den neuen Kernel Probleme geben.


    Könnte dich betroffen haben. Ein Lösung habe ich leider nicht.


    E2 Box: TWO ~ ONE ~ DM8000 ~ DM7080 ~ DM7020HD~ DM9x0 ~ DM820 ~ DM800(SE(v2))~ DM52x ~ DM500HD(v2)~ DM7025(+)
    E1 Box: DM7020 ~ DM7000 ~ DM 5620 ~ DM600 ~ DM500+ ~ DM500 ~ TRIAX 272-S
    Image: OE2.5/OE2.6 Unst./GP4.1 ~ OE2.5 Unst./GP3.3 ~ OE2.2 Unst./GP3.3 ~ OE2.0 Exp./GP3.2 ~ iCVS/GP3 ~ Gemini 4.70
    Sonstiges: DM Tastatur ~ Box: DM100 ~ Router: Fritz!Box 7590 ~ Wlan Stick: Dream Multimedia ~ Server: ALIX.3D3 ~ BananaPI
    Satelliten: WaveFrontier T90
    23,5°E | 19,2°E | 16.0°E | 13,0°E | 10,0°E | 9,0°E | 7,0°E | 4,9°E | 3.0°E | 1.9°E | 0,8°W | 4,0°W | 5,0°W | 8,0°W | 12,5°W | 15,0°W | 22,0°W | 24,5°W | 30.0°W


    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorial sind für den Einstieg sehr empfehlenswert

  • ok danke.


    Ich hatte damals versucht die Platte mit ext3 zu formatieren, doch jedesmal ist mir die dm8000 abgeraucht (zu wenig SWAP).


    Dann habe ich diese Platte einfach am Macbook formatiert und die ging dann auch problemlos an der dm8000, aber in hfsplus.


    Dummerweise ist die Platte voll und ich weiß nicht, wohin ich die Daten kopieren kann, damit ich auf ext3 wechseln kann......


    Da bleibt mir wohl nichts anderes übrig, als zurück auf GP4.6, sehr schade.

  • Ich habe gerade noch einmal mit dem Mount Befehl rumgespielt, aber ich glaube die hfsplus Treiber sind nicht mehr im Kernel.....



    mount ohne Parameter -t hfsplus

    Code
    udf_vrs() - Timer expiry, NO VRS FOUND, break at sector 0x1eff800!
    UDF-fs: No VRS found
    cdfs 2.6.18 loaded.
    ioctl(CDROMREADTOCHDR) failed
    cdfs_toc_read failed


    mount mit Parameter -t hfsplus

    Code
    root@dm8000:~# mount -t hfsplus /dev/sdg1 /media/Storage
    mount: mounting /dev/sdg1 on /media/Storage failed: No such device


  • Was willst du auch mit einer HDD im Macformat an einer Dreambox.
    Das ist ne Linuxkiste, also mach da bitte auch ein Linuxdateisystem drauf.

  • Darüber kann man natürlich streiten. Aber wenn es nie gegangen wäre, hätte ich auch keinen Thread dafür aufgemacht ;)


    Da es mit 4.6 ging heißt es, dass es dafür eine Lösung gibt.


    Vielleicht geht es dann wieder mit GP5.1 :)

  • hallo leifgenosse, meine hfs platte geht auch nicht mehr. die dream ist eine linuxbox und trotzdem geht eine ntfs platte. meine popcorn hour ließt die hfs platte ohne probleme.
    schade, dass so ein weg mit der dream eingeschlagen wird.

    8) Eddie 8)
    Es war einmal bzw. ich war einmal Mod bei HyricanPayTV
    Es war einmal bzw. ich war einmal Admin bei Dreambox-Board

  • macos ist hat ein "randgruppen" os
    man kann den ball auch mal apple zuschieben, warum unterstützen die nicht ext3 ?


    ps: ich arbeite auch mit einem imac 24" ;)

    dau bleibt dau, daran kann der beste dev nichts ändern<br><br>

  • JackDaniel


    Wie ich schon im anderen Thread geschrieben habe, ist es doch eine Kleinigkeit die Treiber für hfs+ wieder zu aktivieren, oder als Modul anzubieten. Im 2.6er Kernel ist dafür alles vorhanden.


    Ich habe eigentlich keine Lust, mir eine komplette Entwicklungsumgebung zu installieren, nur damit ich mir die Treiber zu hfs+ kompilieren kann. Aus diesem Grund bin ich LEIDER wieder bei GP4.6 gelandet......


    Warum habt Ihr das denn rausgenommen?


    Auf jeden Fall ist es kein "Randgruppen OS" ;)

  • Quote

    Warum habt Ihr das denn rausgenommen?


    Schlicht und einfach vergessen.
    Versprochen ist im nächsten Image wieder drin, Treiber für die 5.0 werden vielleicht nächste Woche nachgereicht.

    Meine Todesursache wird wahrscheinlich Sarkasmus im falschen Moment sein!


    Boxen:
    1. One
    2. DM820HDse
    3. DM920


    Satellit:
    Astra 19,2°

  • So die Versprochenen Dateien für hfs und hfsplus.
    Nicht als IPKG da ich mal denke das würde sowieso nicht funktionieren die nacchzuinstallieren.
    Also bite selbständig in die entsprechenden Verzeichnisse auf de Box kopieren und die /lib/modules/2.6.18-7.3-dm8000/modules.dep anpassen.
    Nenene immer diese MAC-Jünger ;)

    Files

    • HFS.zip

      (96.13 kB, downloaded 32 times, last: )

    Meine Todesursache wird wahrscheinlich Sarkasmus im falschen Moment sein!


    Boxen:
    1. One
    2. DM820HDse
    3. DM920


    Satellit:
    Astra 19,2°

  • Hallo Mechatron,


    erst einmal vielen Dank, aber das ist leider der falsche Treiber.


    hfs ist alt. Wir benötigen den hfsplus Treiber.


    Könntest du bitte noch den "hfsplus" Treiber mit anhängen?


    Ich habe soeben noch einmal GP5.0 geflashed, somit kann ich es sofort testen :)


    Eventuell ist dir da nur ein Pack Fehler unterlaufen, da der fuse Treiber in deinem Zip enthalten ist.


    DANKE!

  • Ups... ;)
    Lad's noch mal bitte, war natürlich das falsche Modul drin.

    Meine Todesursache wird wahrscheinlich Sarkasmus im falschen Moment sein!


    Boxen:
    1. One
    2. DM820HDse
    3. DM920


    Satellit:
    Astra 19,2°

  • DANKE!!! Es funktioniert :)


    Nur eine Frage, wo soll ich den Befehl "modprobe hfsplus" unterbringen, damit der Treiber nach dem Reboot wieder zur Verfügung steht? Unter /etc/rc2.d ?


    Ich habe bereits die /etc/fstab entsprechend angepasst.

  • eigentlich sollte das udev selbstständig durchführen...
    Wenn nicht, reichts ja wenn du das modprobe in die /usr/bin/enigma2.sh mit aufnimmst.

    Meine Todesursache wird wahrscheinlich Sarkasmus im falschen Moment sein!


    Boxen:
    1. One
    2. DM820HDse
    3. DM920


    Satellit:
    Astra 19,2°

  • die module werden automatisch nach einem reboot geladen, man braucht diese nicht explizit eintragen :)


    Ich habe nur das Problem, dass sich die Platte nicht automatisch mounted, wenn ich sie an die Box anschliesse.


    Erst nachdem ich "mount /media/storage" eingebe, ist sie verfügbar. /media/storage habe ich in der fstab eingetragen.


    Weißt du, woran das liegen könnte?


    Danke,
    Madman

  • Quote

    Original von mechatron
    Wenn nicht, reichts ja wenn du das modprobe in die /usr/bin/enigma2.sh mit aufnimmst.


    Sorry, aber das enigma2.sh ist so ziemlich der blödeste Platz ein kernelmodul zu laden.


    in /etc/init.d/bootup ist eine schöne for schleife wo alle nötigen module mit modprobe geladen werden - falls man zusätliche benötigt diese einfach dort in die Liste dazu tun.


    LG
    gutemine

    Edited 2 times, last by gutemine ().


  • Jep, hfs hab ich in der Abfrage nicht drin.
    Das automatische Mounten geht dann erst ab der 5.1.


    GuteMine du hast ja sowas von Recht... ;)

    Meine Todesursache wird wahrscheinlich Sarkasmus im falschen Moment sein!


    Boxen:
    1. One
    2. DM820HDse
    3. DM920


    Satellit:
    Astra 19,2°

  • Ich weiß nicht, ob es am Treiber liegt, aber auf jeden Fall wacht die Box nicht mehr aus dem Standby auf, wenn ich sie ca. 1 Tag nicht mehr benutzt habe.


    Dann wird irgendwann Enigma neu gestartet und dann geht es wieder. Leider kein Crash Log, nur das.


    Jemand ne Idee?


    Code
    ATA: ata_busy_wait 0xD0 timeout spinup?!? 4350 msecs left
    ATA: ata_busy_wait 0xD0 timeout spinup?!? 4337 msecs left
    ATA: ata_busy_wait 0xD0 timeout spinup?!? 4324 msecs left
    ATA: ata_busy_wait 0xD0 timeout spinup?!? 4311 msecs left
    ATA: ata_busy_wait 0xD0 timeout spinup?!? 4298 msecs left
    ATA: ata_busy_wait 0xD0 timeout spinup?!? 4285 msecs left
    ATA: ata_busy_wait 0xD0 timeout spinup?!? 4272 msecs left
    ATA: ata_busy_wait 0xD0 timeout spinup?!? 4259 msecs left
    ATA: ata_busy_wait 0xD0 timeout spinup?!? 4246 msecs left