ApacheCtl plugin & php5 für 1.6er img

  • So habe euch mal den Apachen und PHP5 für das Opendreambox 1.6er image neugebacken. (autofs)


    Quote

    Apache Version Apache/1.3.41 (Unix) PHP/5.3.2 mod_ssl/2.8.31 OpenSSL/0.9.8j
    PHP Version 5.3.2


    System Linux dm8000 2.6.18-7.3-dm8000 #1 SMP Mon Mar 22 13:28:38 UTC 2010 7400d0-smp (Rel. 1.6)
    Build Date Apr 3 2010 00:15:02 (auf der Box kompiliert)


    Hostname: Port dm8000:4443 (SSL)
    Hostname: Port dm8000:8080 (Vorsicht/note: httpproxy plugin Port:8080!)


    Wenn Du den Port änderst (tonno) :D musst Du auch in:
    /etc/init.d/apachectl Zeile 74:

    Code
    HOMEURL="http://localhost:8080"


    anpassen und bz2 muss installiert sein.
    (if you change Port in httpd.conf, change this, too)


    Wer von euch die cgi-bin scripte nutzen will muss perl installieren.


    hi folks,
    this is apache and php plugin for Opendreambox 1.6er image,
    install via telnet or BP.
    for full funcionality install perl and bz2


    install:
    copy via ftp to /tmp

    Code
    cd /tmp
    ipkg install enigma2-plugin-extensions-apache-php5-ssl_1.3.41.20-r1.6_mipsel.ipk


    or via BP->Filemanager


    have fun


    Emanuel ;)

  • Öhm welches perl aus dem tar.gz sollte man denn installieren?


    und woher bekomme ich die bz2 ??


    EDIT:
    Also irgendwie Funktioniert da nichts mehr :-)
    Mein Proxyrequest funzt nicht mehr, da bekomme ich ne Fehlermeldung beim starten des apachen ssl


    und über php kann ich keine adresse die sich auserhalb meines Heimnetzwerkes ist ansprechen.


    oder liegt das nur an dem Perl und dem bz2 ?

  • was mir auffiel, das ding versemmelt wieder die dateiattribute ;(


    Code
    /usr/lib/enigma2/python/Plugins/Extensions/ApacheCtl/


    alles unterhalb USER bekommt 700 als attribut, sollte aber 755 sein


    habs probiert, vorm installiern passts, nachm installieren isses auf 700



    mfg

    HIER KÖNNTE AUCH IHRE WERBUNG STEHEN - nein JOKE :hurra:


    DM920 1xCombo S2X-MS/1x Twin S2X-MS mit FAN,LED,Heatsink MOD + HK2k2 Quadmouse
    DM900 1xTwin S2 LED MOD
    DM8000 2xS2 1xC 1xT div. MOD
    TBS5927
    Wavefrontier T90: 39E-36-33/31,5-28,2-26-23,5-21,5-19,2-16-13<-10/9->7-4,8-3/1,9-0,8-4/5-8-12,5W
    Selfsat 30W
    Selfsat 51,5/52E
    85cm USALS Testanlage
    180cm PFA Drehbar:37,5W-68E



  • also bz2 gibt es vom Feet (download über Softwaremanager)
    libperl und perl 2. Dateien

    no brain no pain! :495:
    Auf gar keinen Fall die GP-Wiki lesen!!
    sie könnte Deinen Kopf zu schwer für Deinen Hals machen :D
    :sonne:458859-modellist-gif


    attachment.php?attachmentid=158292 Wir wollen uns für das Update bedanken!!
    attachment.php?attachmentid=204594

  • ich hab aber kein Gemini Drauf von daher kann ich das auch nicht per Softupdate runnerladen.


    Un ich brauch dann zusätzlich nur


    libperl5_5.8.8-r31_mipsel.ipk und perl_5.8.8-r31_mipsel.ipk installieren ??


    Wär nett wenn du mir das bz2 hier ma anhängen könntest

  • ja, und im CVS is die Bz2 ehe drin,


    bzw. da kannst genauso laden im Softwaremanager

    no brain no pain! :495:
    Auf gar keinen Fall die GP-Wiki lesen!!
    sie könnte Deinen Kopf zu schwer für Deinen Hals machen :D
    :sonne:458859-modellist-gif


    attachment.php?attachmentid=158292 Wir wollen uns für das Update bedanken!!
    attachment.php?attachmentid=204594

  • In mienem CVS is die aber leider nicht drin zum runterladen :-(
    aber mal gucken ob ich die vom DMM feed saugen kann


    Aber das problem mit dem Proxyrequest habe ich immernoch und ich kann auch über php keine ips anstrippen die auserhalb meines heimnetzwerkes sind.

  • Gratulation Emanuel, der HTTP-Server funktioniert spitze.


    Obwohl ich mich mit Webservern und so Zeugs gar nicht auskenne, ist es mir gelungen, eine kleine Homepage lokal zu hosten. Ist auch echt nix dabei.
    Apache-Paket installiert, Homepage auf die HDD kopiert, Plugin gestartet - fertig.


    Bzip2 hab ich installiert.
    Perl hab ich am experimental-feed auch nicht gefunden. Da ich von php und cgi Null Ahnung habe, ist es mir auch soweit egal. Hauptsache der HTTP-Server funzt.


    PS: Danke für den Hinweis im ersten Post :366:


    Grüsse
    tonno

  • für perl ist doch das link im ersten post :D

    no brain no pain! :495:
    Auf gar keinen Fall die GP-Wiki lesen!!
    sie könnte Deinen Kopf zu schwer für Deinen Hals machen :D
    :sonne:458859-modellist-gif


    attachment.php?attachmentid=158292 Wir wollen uns für das Update bedanken!!
    attachment.php?attachmentid=204594

  • Code
    Aber das problem mit dem Proxyrequest habe ich immernoch und ich kann auch über php keine ips anstrippen die auserhalb meines heimnetzwerkes sind.


    Hm, es ist jetzt php5 ich bin für php gar kein Experte. php4 gabs nimmer bei php.net.
    php.ini ist auch noch keine drin, vieleicht musst da eine machen.


    Grusss Emanuel ;)

    no brain no pain! :495:
    Auf gar keinen Fall die GP-Wiki lesen!!
    sie könnte Deinen Kopf zu schwer für Deinen Hals machen :D
    :sonne:458859-modellist-gif


    attachment.php?attachmentid=158292 Wir wollen uns für das Update bedanken!!
    attachment.php?attachmentid=204594

  • Quote

    Original von emanuel

    Code
    Aber das problem mit dem Proxyrequest habe ich immernoch und ich kann auch über php keine ips anstrippen die auserhalb meines heimnetzwerkes sind.


    Hm, es ist jetzt php5 ich bin für php gar kein Experte. php4 gabs nimmer bei php.net.
    php.ini ist auch noch keine drin, vieleicht musst da eine machen.


    Grusss Emanuel ;)



    Kann man da den alten apache wie man ihn gehabt hat nicht für 1.6er machen, ohne das ganze neue Gedönse? Der Apache lief doch wunderbar und man hat nur seine Sachen reingeschmissen und funzte :-) Wobei man sagen muss, dass der apache alte
    genausogut läuft auf dem 1.6er wie aufm 1.5er.

  • Problem ist autofs :(

    no brain no pain! :495:
    Auf gar keinen Fall die GP-Wiki lesen!!
    sie könnte Deinen Kopf zu schwer für Deinen Hals machen :D
    :sonne:458859-modellist-gif


    attachment.php?attachmentid=158292 Wir wollen uns für das Update bedanken!!
    attachment.php?attachmentid=204594

  • also ich hab damit überhaupt keine Probleme mit dem alten und dem 1.6er Image.


    Die grunddaten vom alten apache hat doch nichts mit dem Autofs zu tun oder? Also ich mein das so , die alten apache binaries auf das neue Image anpassen.

  • Wenn Du Dir es einrichtest is es auch OK.
    Nur für alle ist das nix, weil wenn jemand das alte 1.5er auf dem cf/stick hat und was an oder absteckt ist der dev automatisch auch anders und muss neu gesucht werden. Und es soll natürlich für alle gehen. Was anderes ist noch ich hatte das /srv (service Verzeichnis missbraucht für den install) und das gibt es auf einmal auf der dream, also konnte ich da nix mehr reinmachen.


    Noch was kannst mir mal so ein PHP Bsp geben, evt. bring ich ja was raus.


    Gruss & Gähn


    Emanuel ;)

    no brain no pain! :495:
    Auf gar keinen Fall die GP-Wiki lesen!!
    sie könnte Deinen Kopf zu schwer für Deinen Hals machen :D
    :sonne:458859-modellist-gif


    attachment.php?attachmentid=158292 Wir wollen uns für das Update bedanken!!
    attachment.php?attachmentid=204594

  • Wenn ich Dateien hoch lade per vsftpd haben sie immer chmod 600.
    Das ist sehr ärgerlich. Besonders wenn es sehr viele Dateien & Dir´s sind.


    ein file_open_mode=0666 in der vsftpd.conf hat auch zu keinem Erfolg geführt. Hat jemand einen Tip?


    Wie kann ich den Apache automatisch starten?
    Gibts dafür ein gutes Plug-in?


    in der infophp.php bekomme ich folgende Fehlermeldung:



    Warning: phpinfo() [function.phpinfo]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CEST/2.0/DST' instead in /server/apache/htdocs/phpinfo.php on line 1


    Wie bekomme ich das gefixt ?


    Vielen Dank im Vorraus....


    Edit:


    PHP
    <?php
    date_default_timezone_set('Europe/Berlin');
    ?>


    behebt den Fehler im Script. Warum ist das in einer php.ini nicht vordefiniert? Wo finde ich die php.ini ???

    Gruß Kermit

    Edited once, last by Kermit ().

  • Quote

    Wie kann ich den Apache automatisch starten? Gibts dafür ein gutes Plug-in?


    im plugin autostart enable schalten

    no brain no pain! :495:
    Auf gar keinen Fall die GP-Wiki lesen!!
    sie könnte Deinen Kopf zu schwer für Deinen Hals machen :D
    :sonne:458859-modellist-gif


    attachment.php?attachmentid=158292 Wir wollen uns für das Update bedanken!!
    attachment.php?attachmentid=204594

  • was mir heute wieder auffiel:


    Code
    root@dm8000:/tmp# /etc/init.d/apachectl status
    ------------------------------------------------------------------
    lynx: error while loading shared libraries: libbz2.so.1: cannot open shared object file: No such file or directory


    gemini 5.1


    kannst das file mit einpacken :)


    mfg

    HIER KÖNNTE AUCH IHRE WERBUNG STEHEN - nein JOKE :hurra:


    DM920 1xCombo S2X-MS/1x Twin S2X-MS mit FAN,LED,Heatsink MOD + HK2k2 Quadmouse
    DM900 1xTwin S2 LED MOD
    DM8000 2xS2 1xC 1xT div. MOD
    TBS5927
    Wavefrontier T90: 39E-36-33/31,5-28,2-26-23,5-21,5-19,2-16-13<-10/9->7-4,8-3/1,9-0,8-4/5-8-12,5W
    Selfsat 30W
    Selfsat 51,5/52E
    85cm USALS Testanlage
    180cm PFA Drehbar:37,5W-68E



  • tach Emanuel,


    der Apache funktoniert super - genial!
    Hab jetzt gemerkt, dass da kein "cURL support" drin ist.
    (Aktuell installiert: enigma2-plugin-extensions-apache-php5-ss l_1.3.41.20-r1.6_mipsel.ipk)


    Weisst Du, was es dazu braucht? ... (wie) kann ich das nachträglich aktivieren oder wäre es möglich, dass du das in dein ApachePlugin dazu kompilierst?


    Grüsse
    Scotty

  • Hi,
    ich freu mich schon auf meinen Indianer, ich bekomm ihn nur noch nicht installiert.
    Hab bzip2 installiert und nen USB-Stick unter media/usb/ gemountet. Wenn ich die Installation starte, bekomme ich die Fehlermeldung:

    Code
    root@dm8000:/media/usb# ipkg install enigma2-plugin-extensions-apache-
    php5-ssl_1.3.41.20-r1.6_mipsel.ipk
    Installing enigma2-plugin-extensions-apache-php5-ssl (1.3.41.20-r1.6) to root...
    find: /dev/sd?1: No such file or directory
    No dev for install found! - exit
    preinst script returned status 1
    Collected errors:
    * Aborting installation of enigma2-plugin-extensions-apache-php5-ssl
    * Cannot find package enigma2-plugin-extensions-apache-php5-ssl.


    Ich dachte der probiert die devices CF/USB/HDD durch. warum versucht der dann auf /dev/sd?1 zuzugreifen?

  • kann mir eine die httpd.conf konfigurieren ?
    sie soll auf 8052 laufen und die Homepage ist auf /hdd/www/