USB DM500 möglich?

  • Guter Ansatz..
    Aber bezüglich 4 bzw. 5 Pins...
    Klar USB hat normal 4 aber schau mal auf nen Mainboard da hat der Pfostenstecker auf einer seite auch immer 5 also für zwei USB 9

    .:Multytenne Twin & KabelBW | 2xDM500HD - USB - Sundtek DVB-C:.


    $ mount /dev/brain /head
    mount: mounting /dev/brain on /head failed: /dev/brain not found

  • Gibts irgend ne Box mit 7405 und USB, dort könnte man es rausmessen oder eventuell im Layout verfolgen, solang nicht alles auf Zwischenlagen liegt.

  • Quote

    Original von purple1
    Klar USB hat normal 4 aber schau mal auf nen Mainboard da hat der Pfostenstecker auf einer seite auch immer 5 also für zwei USB 9


    Das dient auf Mainboards nur als Schutz gegen verpolen. Der 5. hat keine elektrische Funktion.

  • Ich weiß, nur evtl hat man ja einfach den gleichen Pfosten verbaut^^
    War bisher zu faul das Teil auf zu schrauben

    .:Multytenne Twin & KabelBW | 2xDM500HD - USB - Sundtek DVB-C:.


    $ mount /dev/brain /head
    mount: mounting /dev/brain on /head failed: /dev/brain not found

  • Quote

    Original von fatharry
    @ Stivmaster


    Könntest du uns vielleicht detaillierte Fotos vom Board liefern? Würde mir gerne genau ansehen.


    Ich hab sie schon wieder zusammengebaut. Ich hab aber den Deckel noch nicht fest geschraubt, werd später dann ein Paar Fotos machen, allerdings nur von oben.


    Mfg


    Stiv

  • Der Pinout über dem kartenlese ist bestimmt der USb Anschluss.
    Habe da einen USB Adapter angehängt... Nach dem Anschliessen eines Gerätes werden auf der Leitung D+ 2.9V durchgeschaltet.Das Passier bei meiner Dm8000 auch ...
    Das Problem ist nur dass der USB Host nicht antwortet , da fehlen die Treiber im Kernel...


    Kann man diese evtl . nachladen ...???

    Files

    • 69p5dy.jpg

      (335.03 kB, downloaded 5,648 times, last: )
  • Danke fürs durchmessen...
    Wenn der Pin oben rechts wirklich leer da steht und die unteren rechten zwei auf Masse gehn, würde es mich doch extrem wundern, wenn das nicht der USB ist. Das is dann 1:1 der Pfosten wie er auch auf PC-Mainboards zu finden ist...


    Würden nur noch die Treiber fehlen...


    //EDIT
    Hat einer ne Vermutung, was dass links unten sein könnte?

    .:Multytenne Twin & KabelBW | 2xDM500HD - USB - Sundtek DVB-C:.


    $ mount /dev/brain /head
    mount: mounting /dev/brain on /head failed: /dev/brain not found

    Edited once, last by purple1 ().

  • Hi


    Im dreamelite Image kann man die USB Module aktivieren, hab aber mittlerweile das Newnigma drauf.


    Keine Ahnung obs mit dem Dreamelite funktionieren würde?


    Mfg


    Stiv

  • wiesel25:
    Wie hast D+/D- ermittelt?
    Ist es ne Annahme? Es ist gut Möglich das dort die USB-Schnittstellen herausgeführt sind.


    Es werden Kernelmodule benötigt (mit insmod nachladbar)

  • Quote

    Original von Zonk2007
    wiesel25:
    Wie hast D+/D- ermittelt?
    Ist es ne Annahme? Es ist gut Möglich das dort die USB-Schnittstellen herausgeführt sind.


    Es ist nur ne Vermutung von ihm, aber wenn 5v & GND stimmen, dann wäre dass die Standardbelegung der Pins.
    Dafür spricht auch dass nach dem Anschliessen eines Gerätes an D+ 2.9V anliegen.


    Ich glaub ich werd meine am WE ma aufmachen, etwas anschließen und versuchen die Kernelmodule nach zu laden...
    Das wäre echt der oberhammer wenn das nen funktionierender USB is.

    .:Multytenne Twin & KabelBW | 2xDM500HD - USB - Sundtek DVB-C:.


    $ mount /dev/brain /head
    mount: mounting /dev/brain on /head failed: /dev/brain not found

  • Wenn ich mir das Dreamelite wieder drauf mach, und die USB Sachen aktivier, geht das dann auch?
    Bin nicht so fit in Linux, müßte mich da erst einlesen wie das funktioniert mit dem Nachladen. So ne Stecker mit USB, wie er auf Mainboards drauf is, hab ich hier rumliegen, das wär das kleinste Problem.


    Mfg


    Stiv

  • ich hab den Stecker jetz mal reingehängt, und nen USB Stick dran.


    Die .ipk von Zonk hab ich auch installiert. Im Device Manager von NewNigma wird nichts erkannt.
    Der Stick leuchtet so wie wenn ich in an meine 800er Anstecke, allerdings kann ich mir vorstellen, dass da schon die Spannungsversorgung ausreicht, damit er zu leuchten beginnt.



    Mfg


    Stiv

  • Schau mal was der Befehl dmesg an Infos ausgibt. Vor und nach dem Stecken.
    Für nen Usb-Stick dürften noch weitere Kernelmodule nötig sein (Stichwort Storage)

  • mit: Stick


    Code
    display 1 uses vbi path 0set input to 0set fb to 2(-1)HDMI: hotplug handler!HDMI: no device attachedusing 50.00Hz as MonitorRefreshRateSET FORMAT: display[0], format=34set fb to 2(0)bcm_video_analog_port_setup (fmt=7)SET FORMAT: display[1], format=7disable wss on display 0disable wss on display 1bcmfb: creating surface with pixel format 0x07e48888 (BPXL_eA8_R8_G8_B8)enable madVIDEO0: set fallback framerate to 60000VIDEO0: set progressive override mode to 1VIDEO0: set streamtype!set MPEG2sw rave disabled!set ac3 to downmixset aac to downmixDVB: registering new adapter (BCM7405).autodetecting NIMs...Initializing adapter 0 (BCM4505-DVB-S2)bcm4506: found 4505, revision 0(b0)bcm_initAPBCM4506: upload & start firmwareJFFS2 notice: (153) check_node_data: wrong data CRC in data node at 0x0329d000: read 0x2257d5c9, calculated 0xc956bfc6.bcm4506: ap not running - start nowno bcm3445 detectedDVB: registering frontend 0 (bcm4506)...init ALSA!using 50.00Hz as MonitorRefreshRateSET FORMAT: display[0], format=7bcm_video_analog_port_setup (fmt=7)SET FORMAT: display[1], format=7set current avs auto aspect to 4:3set sb to 3(2)disable wss on display 0disable wss on display 1VIDEO0: set blank to 0sync is off so we enable itplayback!total video delay: 0 (0 ms)VIDEO0: start decodeflush video decoderVIDEO0 got pts failed !!!! (ret 0)VIDEO0: first pts 0x0VIDEO0: framerate changed 3VIDEO0: resolution changed (1280 720)VIDEO0: aspect changed 3set current avs auto aspect to 16:9set sb to 3(1)disable wss on display 0disable wss on display 1set current avs auto aspect to 16:9set sb to 3(1)disable wss on display 0disable wss on display 1VIDEO0: set blank to 0VIDEO0: stop decodeVIDEO0: set blank to 0no decoder left in sync handling so disable xpt_synceth0 Link UP.SMCA: invalid ioctl: 0x00005407SMCA: invalid ioctl: 0x00005407VIDEO0: set blank to 0sync is off so we enable itplayback!total video delay: 0 (0 ms)VIDEO0: start decodeflush video decoderVIDEO0: first pts 0x0VIDEO0: set blank to 0VIDEO0: stop decodeVIDEO0: set blank to 0no decoder left in sync handling so disable xpt_syncbcmfb: enable manual blitbcmfb: creating surface with pixel format 0x07e48888 (BPXL_eA8_R8_G8_B8)bcm4506 channel 0 is in normale mode nowbcm4506 channel 0 is sleeping nowset fb to 2(1)set current avs auto aspect to 16:9set sb to 3(1)disable wss on display 0disable wss on display 1set current avs auto aspect to 4:3set sb to 3(2)disable wss on display 0disable wss on display 1set current avs auto aspect to 4:3set sb to 3(2)disable wss on display 0disable wss on display 1set wss 8 on display 0set wss 8 on display 1set input to 0set fb to 2(1)set current avs auto aspect to 4:3set sb to 3(2)set wss 8 on display 0set wss 8 on display 1set ac3 to downmixset current avs auto aspect to 16:9set sb to 3(1)set wss 7 on display 0set wss 7 on display 1set current avs auto aspect to 16:9set sb to 3(1)set wss 7 on display 0set wss 7 on display 1set wss 7 on display 0set wss 7 on display 1set current avs auto aspect to 16:9set sb to 3(1)set wss 7 on display 0set wss 7 on display 1set current avs auto aspect to 16:9set sb to 3(1)set wss 7 on display 0set wss 7 on display 1set current avs auto aspect to 16:9set sb to 3(1)set wss 7 on display 0set wss 7 on display 1set wss 7 on display 0set wss 7 on display 1set current avs auto aspect to 16:9set sb to 3(1)set wss 7 on display 0set wss 7 on display 1set current avs auto aspect to 16:9set sb to 3(1)set wss 7 on display 0set wss 7 on display 1set current avs auto aspect to 16:9set sb to 3(1)set wss 7 on display 0set wss 7 on display 1set wss 7 on display 0set wss 7 on display 1set current avs auto aspect to 16:9set sb to 3(1)set wss 7 on display 0set wss 7 on display 1set current avs auto aspect to 16:9set sb to 3(1)set wss 7 on display 0set wss 7 on display 1set current avs auto aspect to 16:9set sb to 3(1)set wss 7 on display 0set wss 7 on display 1set wss 7 on display 0set wss 7 on display 1set current avs auto aspect to 16:9set sb to 3(1)set wss 7 on display 0set wss 7 on display 1set current avs auto aspect to 16:9set sb to 3(1)set wss 7 on display 0set wss 7 on display 1set current avs auto aspect to 16:9set sb to 3(1)set wss 7 on display 0set wss 7 on display 1set current avs auto aspect to 16:9set sb to 3(1)set wss 7 on display 0set wss 7 on display 1set current avs auto aspect to 16:9set sb to 3(1)set wss 7 on display 0set wss 7 on display 1set wss 7 on display 0set wss 7 on display 1set current avs auto aspect to 16:9set sb to 3(1)set wss 7 on display 0set wss 7 on display 1nfs warning: mount version older than kernelset mute 0 (000) 1bcm4506 channel 0 is in normale mode nowsignal_strength -38.40dbmsignal_strength -28.82dbmstart pcr0 on dmx 0 pid:1ff index 5start audio on dmx 0 pid:203audio xpt startsync is off so we enable itdemux-index 0 pcr0pid 1ffusing 5 as pcr0 pidchannelAC3audio: streamtype set 1audio: streamtype_set: stop ravedecodeaudio: streamtype_set: restart raveset mute 0 (111) 1audio: decoder start 2video delay 0 (0 ms)total video delay: 0 (0 ms)VIDEO0: set streamtype!set H264sw rave disabled!start video0 on dmx 0 pid:1fftotal video delay: 0 (0 ms)VIDEO0: start decodeRAP first pts 0x1d0aec296, stc 0x1575a7ac2, pcr validsignal_strength -28.91dbmch0: lockRAP sampling rate info isreModeChange Isr.. set source_changed_event!audio sampling rate event handler ... NYI!signal_strength -29.02dbmVIDEO0: first pts 0x1575e3396VIDEO0: resolution changed (1920 1080)enable tsm0signal_strength -28.79dbmVIDEO0: progressive changed (0)signal_strength -28.90dbmout of order segment: rcv_next 7953344B seq 79533475 - 79533476ofo requeuing : rcv_next 79533475 seq 79533475 - 79533476root@dm500hd:~#


    ohne

    Code
    display 1 uses vbi path 0set input to 0set fb to 2(-1)HDMI: hotplug handler!HDMI: no device attachedusing 50.00Hz as MonitorRefreshRateSET FORMAT: display[0], format=34set fb to 2(0)bcm_video_analog_port_setup (fmt=7)SET FORMAT: display[1], format=7disable wss on display 0disable wss on display 1bcmfb: creating surface with pixel format 0x07e48888 (BPXL_eA8_R8_G8_B8)enable madVIDEO0: set fallback framerate to 60000VIDEO0: set progressive override mode to 1VIDEO0: set streamtype!set MPEG2sw rave disabled!set ac3 to downmixset aac to downmixDVB: registering new adapter (BCM7405).autodetecting NIMs...Initializing adapter 0 (BCM4505-DVB-S2)bcm4506: found 4505, revision 0(b0)bcm_initAPBCM4506: upload & start firmwareJFFS2 notice: (153) check_node_data: wrong data CRC in data node at 0x0329d000: read 0x2257d5c9, calculated 0xc956bfc6.bcm4506: ap not running - start nowno bcm3445 detectedDVB: registering frontend 0 (bcm4506)...init ALSA!using 50.00Hz as MonitorRefreshRateSET FORMAT: display[0], format=7bcm_video_analog_port_setup (fmt=7)SET FORMAT: display[1], format=7set current avs auto aspect to 4:3set sb to 3(2)disable wss on display 0disable wss on display 1VIDEO0: set blank to 0sync is off so we enable itplayback!total video delay: 0 (0 ms)VIDEO0: start decodeflush video decoderVIDEO0 got pts failed !!!! (ret 0)VIDEO0: first pts 0x0VIDEO0: framerate changed 3VIDEO0: resolution changed (1280 720)VIDEO0: aspect changed 3set current avs auto aspect to 16:9set sb to 3(1)disable wss on display 0disable wss on display 1set current avs auto aspect to 16:9set sb to 3(1)disable wss on display 0disable wss on display 1VIDEO0: set blank to 0VIDEO0: stop decodeVIDEO0: set blank to 0no decoder left in sync handling so disable xpt_synceth0 Link UP.SMCA: invalid ioctl: 0x00005407SMCA: invalid ioctl: 0x00005407VIDEO0: set blank to 0sync is off so we enable itplayback!total video delay: 0 (0 ms)VIDEO0: start decodeflush video decoderVIDEO0: first pts 0x0VIDEO0: set blank to 0VIDEO0: stop decodeVIDEO0: set blank to 0no decoder left in sync handling so disable xpt_syncbcmfb: enable manual blitbcmfb: creating surface with pixel format 0x07e48888 (BPXL_eA8_R8_G8_B8)bcm4506 channel 0 is in normale mode nowbcm4506 channel 0 is sleeping nowset fb to 2(1)set current avs auto aspect to 16:9set sb to 3(1)disable wss on display 0disable wss on display 1set current avs auto aspect to 4:3set sb to 3(2)disable wss on display 0disable wss on display 1set current avs auto aspect to 4:3set sb to 3(2)disable wss on display 0disable wss on display 1set wss 8 on display 0set wss 8 on display 1set input to 0set fb to 2(1)set current avs auto aspect to 4:3set sb to 3(2)set wss 8 on display 0set wss 8 on display 1set ac3 to downmixset current avs auto aspect to 16:9set sb to 3(1)set wss 7 on display 0set wss 7 on display 1set current avs auto aspect to 16:9set sb to 3(1)set wss 7 on display 0set wss 7 on display 1set wss 7 on display 0set wss 7 on display 1set current avs auto aspect to 16:9set sb to 3(1)set wss 7 on display 0set wss 7 on display 1set current avs auto aspect to 16:9set sb to 3(1)set wss 7 on display 0set wss 7 on display 1set current avs auto aspect to 16:9set sb to 3(1)set wss 7 on display 0set wss 7 on display 1set wss 7 on display 0set wss 7 on display 1set current avs auto aspect to 16:9set sb to 3(1)set wss 7 on display 0set wss 7 on display 1set current avs auto aspect to 16:9set sb to 3(1)set wss 7 on display 0set wss 7 on display 1set current avs auto aspect to 16:9set sb to 3(1)set wss 7 on display 0set wss 7 on display 1set wss 7 on display 0set wss 7 on display 1set current avs auto aspect to 16:9set sb to 3(1)set wss 7 on display 0set wss 7 on display 1set current avs auto aspect to 16:9set sb to 3(1)set wss 7 on display 0set wss 7 on display 1set current avs auto aspect to 16:9set sb to 3(1)set wss 7 on display 0set wss 7 on display 1set wss 7 on display 0set wss 7 on display 1set current avs auto aspect to 16:9set sb to 3(1)set wss 7 on display 0set wss 7 on display 1set current avs auto aspect to 16:9set sb to 3(1)set wss 7 on display 0set wss 7 on display 1set current avs auto aspect to 16:9set sb to 3(1)set wss 7 on display 0set wss 7 on display 1set current avs auto aspect to 16:9set sb to 3(1)set wss 7 on display 0set wss 7 on display 1set current avs auto aspect to 16:9set sb to 3(1)set wss 7 on display 0set wss 7 on display 1set wss 7 on display 0set wss 7 on display 1set current avs auto aspect to 16:9set sb to 3(1)set wss 7 on display 0set wss 7 on display 1nfs warning: mount version older than kernelset mute 0 (000) 1bcm4506 channel 0 is in normale mode nowsignal_strength -38.40dbmsignal_strength -28.82dbmstart pcr0 on dmx 0 pid:1ff index 5start audio on dmx 0 pid:203audio xpt startsync is off so we enable itdemux-index 0 pcr0pid 1ffusing 5 as pcr0 pidchannelAC3audio: streamtype set 1audio: streamtype_set: stop ravedecodeaudio: streamtype_set: restart raveset mute 0 (111) 1audio: decoder start 2video delay 0 (0 ms)total video delay: 0 (0 ms)VIDEO0: set streamtype!set H264sw rave disabled!start video0 on dmx 0 pid:1fftotal video delay: 0 (0 ms)VIDEO0: start decodeRAP first pts 0x1d0aec296, stc 0x1575a7ac2, pcr validsignal_strength -28.91dbmch0: lockRAP sampling rate info isreModeChange Isr.. set source_changed_event!audio sampling rate event handler ... NYI!signal_strength -29.02dbmVIDEO0: first pts 0x1575e3396VIDEO0: resolution changed (1920 1080)enable tsm0signal_strength -28.79dbmVIDEO0: progressive changed (0)signal_strength -28.90dbmout of order segment: rcv_next 7953344B seq 79533475 - 79533476ofo requeuing : rcv_next 79533475 seq 79533475 - 79533476root@dm500hd:~#

    sorry für die blöde Anzeige, weiß nicht wie man des besser hinbekommt.Irgendwie schneidet mir Putty da was weg, mal anderes Telnet verwenden.MfgStiv

  • Mal den Ringbuffer mit dmesg -c löschen
    dann das Kernelmodul mit insmod laden
    usb-stick anstecken
    und mit dmesg die Ausgabe ansehen.


    Veilleicht sind auch noch mehr Kernelmodule nötig.

  • Quote

    Original von Zonk2007
    Kernelmodule findet man bei dreamboxupdate,
    ich würds mal mit dem probieren:
    http://dreamboxupdate.com/open…sb_2.6.12-r10_dm500hd.ipk


    denn kannst du vergesen, habe ich schon getestet:


  • root@dm500hd:/tmp# insmod kernel-module-hci-usb_2.6.12-r10_dm500hd.ipk
    insmod: cannot insert `kernel-module-hci-usb_2.6.12-r10_dm500hd.ipk': Invalid module format (-1): Exec format error



    Das kommt mit insmod. Mach ich dass überhaupt richtig? Wie gesagt bin nicht so fit in Linux.


    Habs zuvor mit dem plugin installationt tool gemacht, da kommt meldung ok


    Mfg


    Stiv

  • So geht das nicht.
    Eine IPK-Datei ist ein Paket,welches man installieren muss


    ipkg install paketname.ipk


    Dabei wird das Kernelmodul ins richtige Verzeichnis installiert.


    Anschließend kann man das Modul mit insmod starten (hat aber wahrscheinlich einen anderen namen als die ipk-datei)


    Ab besten nimmt man ein Image, wo die USB-Treiber schon dabei sind. Angeblich gab es ein Beta-Image, wo die Treiber mit drinnen waren. Hab leider momentan wenig Zeit, mich mit der DM500HD zu spielen.