[E2 Plugin] Merlin Music Player + Merlin iDream (Update 07.03.2010)

  • das würde ich jetzt nicht so einfach behaupten. bsp:



    oder


    depends auf python-zlib und python-unittest werden nicht gesetzt. auch nicht auf die libsql

    mfg


    OoZooN


    .................................................................


    :403: Two Beer or not two Beer, that's the Question :408:


    aktuelle Nachrichten rund um OoZooN-Images gibt es auf Twitter

    Edited 2 times, last by OoZooN ().

  • Also ich behaupte das trotzdem mal einfach so: :tongue:


    Ich hab ein frisches System, wo nix drauf ist.


    Code
    root@dm8000:/tmp# opkg install python-sqlite3
    Installing python-sqlite3 (2.6.4-ml8.1) to root...
    Downloading [URL]http://feed.dreambox-tools.info/1.6/dm8000/python-sqlite3_2.6.4-ml8.1_mipsel.ipk[/URL]
    Installing python-zlib (2.6.4-ml8.1) to root...
    Downloading [URL]http://feed.dreambox-tools.info/1.6/dm8000/python-zlib_2.6.4-ml8.1_mipsel.ipk[/URL]
    Installing libsqlite3-0 (3.6.20-r0) to root...
    Downloading [URL]http://feed.dreambox-tools.info/1.6/dm8000/libsqlite3-0_3.6.20-r0_mipsel.ipk[/URL]
    Configuring libsqlite3-0
    Configuring python-sqlite3
    Configuring python-zlib


    Das gleiche Resultat war bei einem Testlauf auch mit einem orig. DMM Image.


    Aber oozoon, Du kannst ja gerne noch depence-Einträge setzen, das würde ja nicht stören.

    4 8 15 16 23 42

    Edited once, last by Dr.Best ().

  • Ich hab mal bei mir im Image und bei DMM in das Control File noch mal geschaut:


    1.5 OE:




    1.6 OE:




    Alles also so, wie es sein soll. ;)

    4 8 15 16 23 42

    Edited 2 times, last by Dr.Best ().


  • Kurze Rückmeldung,


    einlesen mit 1.1 funktioniert wunderbar, es fehlen zwar ca. 160 Titel, aber das kann mit fehlenden mp3-Tags zusammenhängen, will ich nicht ausschliessen. Es wurden ca. 18300 Files gescannt, ohne Fehler.



    Danke, für das super Plugin, (Trotzdem die alte Optik war irgendwie "schöner", aber die Technik zählt vorangig)


    Gruß


  • Leider geht's hier nicht :(
    ich habe keine Ahnung wie ich dem Problem auf die Spur kommen könnte, die Verzeichnisse werden leider nicht alphabetisch gescannt, habe nun einige Subdirs meines Musik Verzeichnisses manuell gescannt (ca. 4000 Lieder), ohne Probleme...
    @ Dr. Best: kann ich feststellen, bei welcher Datei das Problem auftritt? Die zuletzt angezeigte ist es definitiv nicht.


    Danke und Gruss
    Marvi

  • Quote

    Original von Dr.Best
    Marvi:


    Gib mir mal Deine Email-Adresse, schick die mir als PM.


    du hast eine PM.

  • Quote

    Originally posted by satsapper
    can not start the plugin
    i close in a crash file.


    i install all the file`s but nothing help


    Code
    pysqlite2.dbapi2.OperationalError: unable to open database file


    Weird. Try to delete the file iDream.db in /hdd/ or in the folder you have specify in the config. Then start the Player again.


  • Starte mal bitte erstmal Enigma2 in der Console, mache einen Scan, und wenn er stehen geblieben bleibt poste bitte hier die Debug-Ausgabe.


    telnet --> init 5 --> enigma2

  • thanks for the response.


    i deleted idream, no deference.


    i use a mount to my /nlslu2/dream/muziek/


    that is the problem?

  • irgendwie dreh ich heute noch ab:



    eigentlich sollte doch alles installiert sein aber ich krieg trotzden ne fehlermeldung. fällt dir noch was ein? eigentlich dürfte das doch nur was mit der sql datenbank geschichte zu tun haben aber der python sql kram nebst libs ist och installiert.

    Files

    • screenshot.jpg

      (73.14 kB, downloaded 1,310 times, last: )

    mfg


    OoZooN


    .................................................................


    :403: Two Beer or not two Beer, that's the Question :408:


    aktuelle Nachrichten rund um OoZooN-Images gibt es auf Twitter

  • Quote

    Originally posted by satsapper
    i use a mount to my /nlslu2/dream/muziek/


    Hm... is the mount writeable? I did not try to save the database on a mount-folder yet, maybe you should use the harddisk or an usb-drive.

  • OoZooN:
    Ich hab ehrlich gesagt keine Ahung, eigentlich sind alle Pakete vorhanden, die Du brauchst. Hast Du die aktuellste Version des Players von Schwerkraft gezogen?
    Das muss es die Importzeile geben: from sqlite3 import dbapi2 as sqlite


    Was grundsätzliches oozoon: Du würdest Dir viel Mühe und Arbeit ersparen, wenn Du ab OE 1.6 nicht mehr eigene Pakete bastelst, sprich auf ne LEAN Version verzichten würdest. Die 500/800/8000/ haben doch eh massig Speicherplatz, da brauchst doch keine LEAN mehr.

  • also für oe 1.6 sind tatsächlich keine lean's mehr geplant. tut aber hier nicht zur sache. ist die letzte version aus dem cvs und diese importzeile habe ich auch drin:


    Quote

    zeile 56: from sqlite3 import dbapi2 as sqlite


    und eine dbapi2 ist auch in /usr/lib/python2.5/sqlite3 vorhanden.


    ich habe keine ahnung warum er das nicht importieren will. bin ja auch kein programmierer.

    mfg


    OoZooN


    .................................................................


    :403: Two Beer or not two Beer, that's the Question :408:


    aktuelle Nachrichten rund um OoZooN-Images gibt es auf Twitter

  • Quote

    Original von satsapper
    can not start the plugin
    i close in a crash file.


    i install all the file`s but nothing help


    Hy
    When i look to the file, i see thats the merlin player dont find the database. I have this problem also. I fixed this following. I had make on the root a symlink to the harddisk (hdd). After this i have no problem to start the merlin player.


    Regards

  • Quote

    Original von Dr.Best


    Starte mal bitte erstmal Enigma2 in der Console, mache einen Scan, und wenn er stehen geblieben bleibt poste bitte hier die Debug-Ausgabe.


    telnet --> init 5 --> enigma2


    so.. hier mein debug output:


    Code
    Exception in thread Thread-1:
    Traceback (most recent call last):
    File "/usr/lib/python2.5/threading.py", line 460, in __bootstrap
    self.run()
    File "/usr/lib/enigma2/python/Plugins/Extensions/MerlinMusicPlayer/plugin.py", line 164, in run
    audio, isAudio, title, genre,artist,album,tracknr,track,date,length,bitrate = getID3Tags(root,filename)
    File "/usr/lib/enigma2/python/Plugins/Extensions/MerlinMusicPlayer/plugin.py", line 413, in getID3Tags
    return audio, isAudio, title.encode("utf-8", 'ignore'), genre.encode("utf-8", 'ignore'),artist.encode("utf-8", 'ignore'),album.encode("utf-8", 'ignore'),tracknr,track,date,length.encode("utf-8", 'ignore'),bitrate
    UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 36: ordinal not in range(128)
  • Marvi: Ich schick Dir morgen abend eine Version per Mail zu. Mal schauen, was wir erreichen können. ;)

  • Hi Dr.Best,
    hab grad das Plugin über den Plugin browser (OE 1.6) installiert.
    In der Liste wird es als "Partnerbox" angezeigt. Hätte den Player beinahe nicht gefunden :)
    Anbei der Screenshot.