[E2 Plugin] Merlin Music Player + Merlin iDream (Update 07.03.2010)

  • Frage. Bekommt man das nun auf einer 7025 zum laufen oder nicht? Bekomme beim starten die Meldung
    GStreamer Plugin Gstreamer Element
    autoaudiosink not aviable


    mfg

  • Quote

    Original von Dr.Best


    Ich hab ihm ein Hotfix geschickt.


    Ich poste es später hier, bin aber gerade am Fussball schauen und deswegen keine Zeit. ;)



    Hallo,


    habe das gleiche Problem. Bleibt beim scannen einfach stehen mit Anzeige der Datei und ich kann nicht abrechen, sondern nur schließen. Wenn ich IDream neu starte kommt ein leeres scannen-Fenster, welches ich wieder schließen kann usw.


    Nach Enigma Neustart kann ich wieder neuscannen, kommt aber immer wieder der gleiche Fehler. aber bei unterschiedlichen Dateien.


    Gruß


    Frank

  • Quote

    Originally posted by Lucas70
    Frage. Bekommt man das nun auf einer 7025 zum laufen oder nicht? Bekomme beim starten die Meldung
    GStreamer Plugin Gstreamer Element
    autoaudiosink not aviable


    mfg


    Klar funktioniert das Plugin auf der 7025. Du kannst auf der 7025 halt keine m4a Dateien abspielen, aber ansonsten geht das Plugin einwandfrei.


    Warum Du einen die Fehlermeldung bekommst weiß ich nicht, der Player verwendet die normalen Libs zum Abspielen der Musik-Dateien.


    Eventuell ist Dein Image zu alt, oder Du hast ein modifiziertes Image und Dir fehlen Standard-Gstreamer-Plugins, die sonst auf jedem anderen Image installiert sind...kein Plan, sorry. Bei mir auf der 7025 funktioniert es.

  • Quote

    Original von Dr.Best


    Ich lade am besten gleich mal alle hoch... ;)


    Muss ich nur die Dateien vom 4. Post installieren oder auch noch die vom 1. Post?

    The true way is M E R L I N !

  • Quote

    Eventuell ist Dein Image zu alt, oder Du hast ein modifiziertes Image und Dir fehlen Standard-Gstreamer-Plugins, die sonst auf jedem anderen Image installiert sind...kein Plan, sorry. Bei mir auf der 7025 funktioniert es.


    Ist ein Oozoon aber war mein Fehler. Hatte den Media Player nicht installiert und deshalb kam es zu dieser Fehlermeldung.
    Jetzt geht es. Danke
    Was mir aber mal so aufgefallen ist, ist die Sache mit den Songtexten.
    Fand das eigentlich immer genial und freut mich das es wieder drin ist.
    Die Trefferquote liegt bei der jetzt verwendeten Seite aber leider nur bei 50/50
    Teils passt es gar nicht.
    Das war vorher Welten besser, aber ist ja kein Fehler Deinerseits
    Schade das die andere Seite geschlossen wurde.


    mfg

  • Is it possible with a little help for the installation guide in English. For it dos not work for me. Perhaps because I have not understood til installation instruction


    HInweis:
    Zur Installation sind mehrere zusätzliche Pakete neben dem Plugin notwendig.


    1) Merlin2 Image
    Solange das Plugin nicht auf dem Feed liegt müssen die 3 Pakete aus dem Anhang installiert werden, der Rest wieder automatisch vom Online-Feed gezogen


    2) CVS Images von DMM
    Hier muss neben dem Plugin das Paket "python-mutagen_1.18-r0_mipsel" aus dem Anhang installiert werden, der Rest sollte über den Online-Feed von DMM gezogen werden


    3) Sonstige Images
    Da habe ich keinen Plan, was auf deren Feed liegt. Da aber neben dem Paket "python-mutagen_1.18-r0_mipsel" nur Standard-Pakete, welche sich im OE befinden, benötigt werden, sollte diese, sofern der Image-Bauer Eures Vertrauens diese auch zur Verfüfung stellt, automatisch gezogen werden. Wenn die Installation schief läuft wegen fehlendender Abhängigkeiten, einfach melden, dann lade ich die Pakete hier im Thread hoch.[/quote]

  • ich hab da noch ne frage bezüglich python-pysqlite2_2.4.0-ml1_mipsel.ipk


    das scheint ja ein altes paket zu sein. im 1.5 oe gibt es ein python-sqlite3_2.5.1-ml5_mipsel.ipk .


    erfüllt das den selben zweck?

    mfg


    OoZooN


    .................................................................


    :403: Two Beer or not two Beer, that's the Question :408:


    aktuelle Nachrichten rund um OoZooN-Images gibt es auf Twitter

  • Quote

    Originally posted by OoZooN
    ich hab da noch ne frage bezüglich python-pysqlite2_2.4.0-ml1_mipsel.ipk


    das scheint ja ein altes paket zu sein. im 1.5 oe gibt es ein python-sqlite3_2.5.1-ml5_mipsel.ipk .


    erfüllt das den selben zweck?


    In der Tat ist das ein altes Paket, was ich leider erst nach dem Release gemerkt habe. :tongue: Im OE 1.6 ist das beispielsweise gar nicht vorhanden.


    Ich werd hier gleich noch mal eine neue Version releasen, in der das Paket python-pysqlite2 allerdings noch benötigt wird.


    Danach checke ich den Player auf Schwerkraft ein und setze den Depence auf python-sqlite3. Allerdings ist das auch mit einer Sourcecode-Änderung verbunden, so dass Du das nicht einfach selber machen kannst.


    Ich hab DMM ein Paket gesendet, welches der Player zwingend benötigt, wleches nun im OE 1.5 und 1.6 drinnen ist. Wenn Du also den Player bei Dir im Feed anbieten willst würde ich warten, bis ich das Plugin eingecheckt habe, dann hast Du automatisch alle Abhängigkeiten und musst nix per Hand anstoßen.



    Quote

    Is it possible with a little help for the installation guide in English. For it dos not work for me. Perhaps because I have not understood til installation instruction


    Yes, sure.


    If you are using Gemini, go in this thread to page 1 and install the packages in that order:


    libsqlite3-0_3.6.11-r2_mipsel.ipk
    python-pysqlite2_2.4.0-ml1_mipsel.ipk
    python-mutagen_1.18-r0_mipsel.ipk
    enigma2-plugin-extensions-merlinmusicpla yer_1.0-r0_mipsel.ipk

  • dann hoffe ich mal, das du es heute noch über die bühne bekommst weil ich das gerne morgen im image drin hätte ;) :357:

    mfg


    OoZooN


    .................................................................


    :403: Two Beer or not two Beer, that's the Question :408:


    aktuelle Nachrichten rund um OoZooN-Images gibt es auf Twitter

  • Update 27.02.2010
    Merlin Music Player Version 1.1


    Fixes:
    - better error handling for id3tags
    - LCD display fix in songlist for filenames


    New:
    - LCD display support for filebrowser
    - do not check existed songs in database for id3tags again when scanning --> very much faster now to scan for new files in folders
    - play current directory with sub-folders automatically by pressing green button in filebrowser
    - with DM7025 and DM8000 you can watch TV while playing songs. Press "OK" in Merlin Music Player to activate, you can switch channels by pressing next/previous/bouquet up/bouquet down key on RC, Info = EPGInfo. Pressing "OK" displays the current song title. Press "EXIT" to go back to Merlin Music Player widget.



    Viel Spass damit.
    Dr. Best



    EDIT: Anhang entfernt, bitte nehmt die aktuelle Version vom Feed Eures Image-Anbieters.

    4 8 15 16 23 42

    Edited once, last by Dr.Best ().

  • Ich habe auf dem oozoon beta image diese Meldung.



    Quote

    root@dm8000:/# opkg install /tmp/enigma2-plugin-extensions-merlinmusicplayer_1.1-r1_mipsel.ipk Installing enigma2-plugin-extensions-merlinmusicplayer (1.1-r1) to root... Collected errors: * ERROR: Cannot satisfy the following dependencies for enigma2-plugin-extensions-merlinmusicplayer: * libpython2.5-1.0 (>= 2.5.1) * * Cannot find package enigma2-plugin-extensions-merlinmusicplayer.


    Die pythonlib ist aber doch installiert?


    Quote

    root@dm8000:/# opkg list_installed | grep -i libpython
    libpython2.6-1.0 - 2.6.4-ml8.1
    root@dm8000:/#


    Kann da bitte jemand helfen?

  • Das Plugin, so wie es verpackt ist, geht nicht im OE 1.6.
    Siehe meine Antwort auf oozoon's Frage 2 Posts davor. ;)

  • Hi,
    Das mit dem TV-Bild im Hintergrund ist toll!
    Allerdings funktioniert das Zappen mit den Bouquet-Tasten nicht. Das Bild ist beim zappen zwar kurz schwarz, aber es kommt immer wieder der selbe Kanal (ORF1HD).



    EDIT: Jetzt hab ich mal einen anderen Startsender genommen. Sobald ich auf eine Bouquet-Taste drücke, zappt er auf ORF1HD(bei mir Programmplatz1).

  • Quote

    Original von DoctorUltra
    was braucht man denn jetzt alles für Pakete bei Gemini2 470?


    libsqlite3-0_3.6.11-r2_mipsel.ipk
    python-pysqlite2_2.4.0-ml1_mipsel.ipk
    python-mutagen_1.18-r0_mipsel.ipk


    und natürlich den aktuellen Player, mom


    enigma2-plugin-extensions-merlinmusicplayer_1.1-r1_mipsel.ipk

    Gruß


    Mr Plainkey


    MD-BOARD.COM

  • Quote

    enigma2(>2.6git20090615), twisted-web, python-mutagen, python-sqlite3


    warum nicht auch libsqlite3-0, python-zlib, python-core, python-shell und python-unittest, wenn diese vom plugin benötigt werden?

    mfg


    OoZooN


    .................................................................


    :403: Two Beer or not two Beer, that's the Question :408:


    aktuelle Nachrichten rund um OoZooN-Images gibt es auf Twitter

    Edited once, last by OoZooN ().

  • Quote

    Original von Dr.Best


    Ich hab ihm ein Hotfix geschickt.


    Ich poste es später hier, bin aber gerade am Fussball schauen und deswegen keine Zeit. ;)


    Hallo Dr. Best


    ist dieser Fix in der neusten Version enthalten?
    Die habe ich nun installiert und habe leider immer noch den selben Fehler.


    Ich habe versucht einzelne Subdirectories zu scannen, das geht tadellos. Wenn ich allerdings das komplette Verzeichnis scanne, bleibt er nach ca. 10min. stehen. Immer bei einer anderen Datei... Die iDream.db ist dann immer gleich gross wie vor dem Scan, allerdings habe ich eine iDream.db-journal, die ein paar KB gross ist.


    28.02.2010 10:54 456'704 iDream.db
    --->> gleich wie vor dem kompletten Scan (ca. 1000 mp3s)
    28.02.2010 11:07 81'008 iDream.db-journal
    --->> nach dem Hängenbleiben während kompl. Scan nach ca. 10min.


    Danke und Gruss
    Marvi


  • Hallo Marvi


    Der Fix muss meiner Meinung nach in der neuen Version enthalten sein. Ich habe nochmals meine komplette Sammlung mit der neuen Version eingelesen. Und es hat geklappt.
    Jedoch sind saubere ID3 Tags dafür Vorraussetzung. MIr fehlten so circa 300 mp3. Jedoch hatte ich dort oft spezielle Zeichen wie % oder @. Mit diesen funktioniert es nicht.


    Gruss Schnuepfli

  • Quote

    Originally posted by OoZooN


    warum nicht auch libsqlite3-0, python-zlib, python-core, python-shell und python-unittest, wenn diese vom plugin benötigt werden?



    Das wird alles automatisch dann gezogen, also in python-mutagen habe ich beispielsweise eine depence zu python-shell drinnen, python-sqlite3 holt sich automatisch libsqlite3-0, usw. usw.

    4 8 15 16 23 42

    Edited once, last by Dr.Best ().