(eingestellt) GP3 FlashBackup aka Backup für NFI-Images (8000,800,800se,7025,7020, 600, 500+,500HD)

  • EDIT: Thread closed da Entwicklung eingestellt wurde.


    in der database findet sich das ganze noch für die leute die daran weiter basteln möchten. Ansonsten empfehle ich keinem mehr das ganze zu benutzen ! nutzt bitte den gp3 sicherungsmanager oder dflash, das ist mehr als ein nachfolger, eher ne verbesserung im konzept der backuperstellung und im funktionsumfang ebenso.



    -------------------------------------------------------------------------


    so das kind hat einen neuen namen bekommen :tongue:


    was ist nun neu:
    * nun gibt es eine gui
    * sprachunterstützung für die gui (im moment en,de,fr und it, *.po datei ist dabei wer es in andere sprachen übersetzen will)
    * bei de wird das script in deutsch ausgegeben, bei den anderen sprachen auf englisch
    * auswahlmöglichkeit int. hdd,usb,sd,cf und netzwerkmounts über die gui
    * auswahlmöglichkeit der grösse vom swap über die gui


    möchte mich bei allen die mitgeholfen haben recht herzlich bedanken (da es so viele waren lass ich das mit den namen, sonst vergesse ich noch einen) :tongue:


    ps: installation übers bp unter plugins oder manuell (download ist in der database unter Dreambox - Zubehör / Entwicklertools / Plugins/Sonstige Plugin´s )


    update: version 1.1-skin und script fix für 7025


    update: version 1.2 neue scripte wo auch die dm500hd unterstützt wird (danke erim)
    cf muss in /media gemountet sein,oder ein symlink (gelabelt als ->cf,CF oder CF-Karte)
    sd muss in /media gemountet sein,oder ein symlink (gelabelt als sd, SD oder SD-Karte)
    usb muss in /media gemountet sein,oder ein symlink (gelabelt als usb,USB oder USB-Stick)
    hdd natürlich auch in /media und gelabelt als hdd
    oe 1.5 und oe 1.6 kompatibel


    update: version 1.3
    * neue gui
    * neue speicherort auswahl
    * oe 1.5 und oe 1.6 kompatibel


    update: version 1.3.1
    * holländische übersetzung hinzugefügt (thx @ ni_hao)


    update: version 1.3.2
    * about screen hinzugefügt


    update: version 1.4
    * scripte getauscht


    update: version 1.4.1
    * scripte update


    update: version 1.4.2
    * polnische übersetzung hinzugefügt (thx @ kosmacz)


    update: version 1.4.3
    * scripte getauscht


    update: version 1.4.4
    * scripte getauscht (damit sind/sollten die probleme bei der 8000er behoben sein)


    update: version 1.4.5
    * script update
    * debug scripte sind nun geschichte, im debug modus wird nun ein FlaschBackupLog in /tmp erstellt (bei problemen diesen bitte ans posting anhängen)


    update: version 1.4.6
    * *.nfo datei für das nfiflash plugin werden nun erstellt


    update: version 1.4.7
    * script update
    * haftungsauschluss hinzugefügt
    * backupverzeichnis anzeige behoben (achtung für die skinner, es ist was dazu gekommen)


    update: version 1.4.8
    * dm800se support
    * beim "normalen" backup gibt es keine telnet ausgabe mehr
    * automatische update überprüfung nach dem backup
    achtung für die skinner, viele änderungen


    update: version 1.4.9
    * doppelte backup erstellung behoben
    * ssl problem bei der 800se behoben


    update: version 1.5.1
    * doppelte backup erstellung behoben (jetzt hoffentlich entgültig :) )
    * crash wenn ein xd skin verwendet wird
    * crash wenn ein nicht beschreibbarer speicherort ausgewählt wird
    * backupnamen angepasst


    update: version 1.5.4
    * backups <2min sollten nun auch als erfolgreich gemeldet werden
    * wenn ein FlashExpand ausgeführt wurde kein backup möglich



    wenn das plugin über das bp installiert wurde, wird es auch automatisch bei einem update aktualisiert



    keine NewNigma unterstützung das es von den entwicklern so gewollt :face_with_rolling_eyes:


    damit das plugin im gp3 unter addons angezeigt wird müsst ihr unter einstellungen->allgemein->extra plugins benutzen auf ein haben, dann wir es euch unter erweiterungen im paketmanager vom gp3 angezeigt (eventuell mal dort aktualisieren drücken)

  • Quote

    Original von JackDaniel
    ps: installation übers bp unter plugins



    ich finds nicht ...

    100cm Preisnerschüssel + 4 ALPS Quattro-LNB's
    9°E 13°E 19.2°E 23.5°E


    BOX 1: 7025+SS - 160GB - CF 4GB - iCVS+GP3
    BOX 2: 7020S - 80GB - Gemini 4.70 - BlueLine-3 Skin

  • ist gerade in arbeit, rom wurde auch nicht in einem tag erbaut :winking_face:

    dau bleibt dau, daran kann der beste dev nichts ändern<br><br>

  • Auf meiner dm 7025 funktioniert es nicht.


    "SSL konnt(e?) nicht ermittelt werden"


    Er liegt bei mir aber unter /media/hdd/backup/FlashBackup/SSL

  • Lass das File mal auf deine HDD weg. Es sollte der richtige SSL vom Server
    jetzt geholt werden :winking_face:

  • Das alte NFI-Backup läuft ohne probleme durch.
    Nur die neue Version will nicht. :frowning_face:
    Auch wenn ich die "secondstage-dm7025-76.bin" & "secondstage-dm7025-76.bin.md5" manuell nach /media/hdd/backup/FlashBackup/SSL kopiere läufts nicht durch.


    Was mir auch noch aufgefallen ist, das Menü ist auf der 7025 zu breit.
    Da fehlt rechts und links etwas. Kann man die Menübreite noch ändern?

  • Auf der 8k funktioniert es einwandfrei. Vielen Dank für dieses tolle Plugin.

  • ja ist jetzt ein fehler im script, wegen der Umbennung des Verzeichnisses NFI-Backup nach FlashBackup, im Anhang sind die scripte, einfach nach /usr/bin kopieren.


    Konnte es auf der Arbeit nicht testen sollte aber funzen, bitte um Rückmeldung.


    ***edit by JackDaniel: dateien entfernt***

    Edited 2 times, last by Erim ().

  • Quote

    Original von tine1084
    Was mir auch noch aufgefallen ist, das Menü ist auf der 7025 zu breit.
    Da fehlt rechts und links etwas. Kann man die Menübreite noch ändern?


    ist in der nächsten version geändert (kommt sobald die neuen scripte für die 7025 bestätigt sind)

    dau bleibt dau, daran kann der beste dev nichts ändern<br><br>

  • Thank you guys...suggest that NFI-Backup (24.10.2009) plugin is removed from bp...waiting for v1.1 in bp.


    Cheers,

    MfG,


    4 8 15 16 23 42


    Box(s): DM900 UltraHD <2TB SSD> | DM820HD <1TB HDD>
    Image(s): Unstable OE2.5 + GP4.1
    Skin: materials.GP4

  • moin, ich habe das plugin installiert, aber wo finde ich es???? bin ich blind?

  • Quote

    Original von ahd299
    Thank you guys...suggest that NFI-Backup (24.10.2009) plugin is removed from bp...waiting for v1.1 in bp.


    the new version already is in the database for the manual installation :tongue:

    dau bleibt dau, daran kann der beste dev nichts ändern<br><br>