Barry Allen 5.2 Test und Entwicklungsthread - currently closed

  • zuerst wechselst du das directory mit cd:


    cd /media/ba/bin


    Und da muss ein leerzeichen zwischen cd und /media/ba/bin sein


    Und dann führst du den bootmanager aus:


    ./barryallen

  • Quote

    Originally posted by gutemine
    du sollst/brauchst auch ein BA device nicht in die fstab machen, in den OE 1.6 images sind die auf /autofs gemountet.

    Also kann ich die Festplatte, USB Stick und cf aus fstab raus holen. Habe gerade gesehen das sdc1 (USB Stick, jetzt überhaupt nicht in /autofs ist. Hmmm, vielleicht zu viel formattiert...hehe


    Pff ich werde verrückt


    Gutemine, du hast doch auch OoZoon im flash (8k) aber hast du auch USB Stick und CF drinn?

    Boxen: im Betrieb die DM7080HD, DM900HD, DM920HD
    Image: u.a. DP Original (unstable)
    Skin...: Verschiedene

    Edited once, last by ni_hao ().

  • Das Scheint zu gehen

    Files

    • Ba5.png

      (162.8 kB, downloaded 627 times, last: )

    DM820HDSS - DM500HDS

  • Jep geht

    Files

    • Ba6.png

      (161.97 kB, downloaded 596 times, last: )

    DM820HDSS - DM500HDS

  • ähhm was geht denn da bei den dataianhängen ?


    Vu+ Solo VTi 2.3 - 2x DM800 Gemini³ - DM7000 Gemini 4.7
    EeePC 1000HE - N330 Desktop - Alix.3D3 Server
    I <3 OSCAM

  • das selbe wie schon am Nachmittag, Ihr versucht ständig runterzuladen während ich hochlade, damit bricht mein download ab wenn Ihr mich überholt und wird nicht fertig, und dann gibts dutzendeweise halbfertig anhänge.


    Nochmals so wie schon weiter oben geschrieben - wenn der Anhang nicht 7MB gross ist ladet ihn NICHT runter bis ich fertig bin.


    LG
    gutemine

  • ja aber dann kriegts keiner ...

    Edited once, last by gutemine ().

  • Na gut ich hoffe es hat jetzt geklappt ich habe noch eine letzte Variante der 5.1.7 hochgeladen wo man auf der 8k das /dev/input/event1 nicht mehr manuell auswählen muss weil es das default ist.


    Und die alten libraries von der libfreetype habe ich auch rausgeschmissen, vieleicht gehts jetzt besser.


    LG
    gutemine

    Edited once, last by gutemine ().

  • Danke Gutemine, muß eben warten denn habe OoZooN neu geflasht und sofort grünes Schirm... werde jetzt mal ins telnet rein gehen

    Boxen: im Betrieb die DM7080HD, DM900HD, DM920HD
    Image: u.a. DP Original (unstable)
    Skin...: Verschiedene

  • jetzt geht image wieder (vielleicht war OoZooN gerade mit seinem feed beschäftigt). Ich warte erst mal eben mit BA und schau erst an ob image ein wenig geht... Frau will ja gucken jetzt ;)

    Boxen: im Betrieb die DM7080HD, DM900HD, DM920HD
    Image: u.a. DP Original (unstable)
    Skin...: Verschiedene

  • Habe die letzte 5.1.7 jetzt drauf und was BA an geht sieht es gut aus. Bootmanager ist da und Image läuft.


    Nur was ich nicht verstehe ist das BA beim installieren sagte: BA feels at home at sdb1 und nach neu start hat /media/ba sich gemount auf /sdc1.


    Ich habe dann die hdd, cf und usb mounts mal aus meine fstab Datei genommen. Aber dann ist nur sda1 (hdd) und sdd1 (cf) da in /autofs, sehe aber bei mounts daß /media/ba sich gemount hat auf sdc1 und auch mit "df -h" sehe ich /media/ba auf sdc1. Warum sehe ich sdc1 nicht in /autofs?


    GuteMine kannst du mal deine fstab Datei posten bitte, dann kann ich mal vergleichen.

    Boxen: im Betrieb die DM7080HD, DM900HD, DM920HD
    Image: u.a. DP Original (unstable)
    Skin...: Verschiedene

    Edited once, last by ni_hao ().

  • Hi Gutemine.


    I write you in english because you know my german is very bad.


    When I flash my 8000er with a new 1.6 OE img i've got some problems.


    First.- when i install OoZooN 1.6 the same img give me problems..example....


    "...poll: unhandled POLLERR/HUP/NVAL for fd 38(16)
    Traceback (most recent call last):
    File "/usr/lib/enigma2/python/Plugins/Extensions/UpdateCheck/plugin.py", line 252, in dataAvail
    softwareupdateto=parts[10]
    IndexError: list index out of range
    (PyObject_CallObject(<bound method SoftwareUpdateCheck.dataAvail of <class 'Plugins.Extensions.UpdateCheck.plugin.SoftwareUpdateCheck'>>,('Upgrading 0imageupdate on root from 20100305-r0 to 20100307-r0...\nDownloading http://www.oozoon-dreamboxupdate.de/opendreambox/1.6/experimental/dm8000/0imageupdate_20100307-r0_dm8000.ipk\n',)) failed)
    getResolvedKey config.plugins.crashlogautosubmit.sendAnonCrashlog failed !! (Typo??)
    getResolvedKey config.plugins.crashlogautosubmit.addNetwork failed !! (Typo??)
    getResolvedKey config.plugins.crashlogautosubmit.addWlan failed !! (Typo??)
    ]]>
    </enigma2crashlog>
    <pythonMD5sum>
    <![CDATA[..."


    The img reboots itself every 20 seconds. I know that it is not a barry problem but.....perhaps OoZooN can see it here .


    Second.- When i install Original experimental 1.6 OE img and next i install Barry, barry is installed well...
    "...root@dm8000:~# ipkg install /tmp/enigma2-plugin-extensions-barryallen_5.1.7_mipsel.ipk
    Installing enigma2-plugin-extensions-barryallen (5.1.7) to root...
    ================================================================
    It's a Dream !
    ================================================================
    dm8000
    ================================================================
    secondstage loader OK
    ================================================================
    now checking Kernel of Image in Flash
    ================================================================
    Barry Allen stops automount, reboot after installation to get it back
    Barry Allen stops udev, reboot after installation to get it back
    Barry Allen already installed, no Format needed
    You can relax now !
    Configuring enigma2-plugin-extensions-barryallen
    Integrating Barry Allen into Flash Image
    /MB_Images will be created on /media/hdd/MB_Images
    Integrating Barry Allen into WebIF
    Flash Kernel Version: 2.6.18-7.1-dm8000
    Barry Allen feels home at /dev/sdd1
    disabled keep squashfs
    bapostinst is already enabled
    second Image in Flash of 8000 is already disabled
    --------------------------------------------------------------
    Installation or Upgrade of Barry Allen is now finished !
    If this is a new installation, then please reboot NOW
    to check if Barry Allen Plugin shows up in the Plugin List !
    --------------------------------------------------------------
    PS: You can ignore any file_move or Can't open status file
    errors after this, they don't hurt
    --------------------------------------------------------------
    root@dm8000:~#..."


    But when i reboot, barry has disappears. In /media/ba (or /ba) directory it's only a .balog file where it says..."/sbin/init: line 293: /media/ba/bin/barryallen: not found".
    Obviously, there is not /media/ba/bin, because barry isn't there.
    In autofs directory there are two directories /sdb1 & /sdc1, but there is not a /sdd1 directory (...Barry Allen feels home at /dev/sdd1) So it´s impossible boot any img i've got in barry. This occurs both in the official experimental image as OoZooN.


    The only way to works is reflash with a 1.5 OE img and reinstall barry 5.0.35, then all it's OK.


    Can you give me a solution to I can Flash 1.6 OE img and use Barry 5.17?


    Thanks mate and sorry if somebody ask for this before, but my german.......


    ;)


  • Lies nochmals was ich weiter oben geschrieben habe - BA braucht sein device nicht in der fstab und es ist auch egal ob es vor der installation gemountet ist.


    Und es kann durchaus sein das das device bei der installation einen anderen device namen hat als wenn BA es dann nachher mountet. Seit Version 5 hat BA ein device managemetn das völlig dynamisch sich sein device beim booten sucht und findet.


    Insofern ist meine fstab original nur mit /media/hdd


    LG
    gutemine


  • 1)


    There is a bug in the updatecheck plugin if the feed doesn't answer properly. If you remove it with ipgk remove it stops crashing.


    2) This is strange because it works nicely on my 8k with latest experimental in Flash and CF card. What device are you using and could you try with another device ?

  • Hi again and thanks for your answer.


    My device is a 2G pen drive (usb). I've got installed a 2G SD card too, but if a remove the pen drive i'm affraid that barry installs itself at HD and perhaps it can format it...there are many movies in it to format it. Barry always seems to ignore the sd card.


    I wait for your answer...
    ;)

  • Try to remove the SD, under OE 1.6 this still seems to have troubles


    And if you create a noba directory on your hardddisk BA will ignore it completely so no need to worry


    BTW BA never formats harddisks when a movie directory is found on them - but without BA it isntallst to them if nothing else is found :-)

    Edited once, last by gutemine ().

  • hi


    i installed the oozoon beta image 1.6 on my 800hd yesterday, and BA 5.1.7.
    i installed it via dcc, and it installed fine on my usb-stick, without reformating it.
    the bootscreen worked, and it responded to the remote just fine.
    nice work gutemine!


    alfi

  • Thanks for the feedback. So there is at least hope that it works ... sometimes ... someday ;-)


    Ciao
    gutemine

  • Hi !


    Mit romeo-golfs Hilfe haben wir jetzt scheinbar meine eigene Dummheit überwunden, probiert mal den BA Kit 5.1.8, da sollte der Bootmanager auch auf der 500HD jetzt auch wieder wie gewohnt funktionieren - hoffentlich.


    LG
    gutemine

    Edited 2 times, last by gutemine ().