Barry Allen 5.2 Test und Entwicklungsthread - currently closed

  • Wat fürn Niwoh ?
    Ich habe gar kein Barry Allen... :tongue: :tongue: :tongue:


    Panasonic TX50-EXW784
    Panasonic SC-ALL70TEGK / SC-ALL2 wireless 5.1 Soundbar
    dm8000, dm7080, dm800sev2, dm900-dvb-s2-unicable, dm900-dvb-s2-multisat


    http://www.dreambox-tools.info

  • Hehehe...Na dann,haste ja nich viel beigetragen zu meim Problem...*gg*


    ;) ;) ;)

    7025+ 260 GB HDD CF BA GP 4.7

  • I installed 5.1.14 and it works fine except I do not have an access to plugin. It says "plugin execution failed". How can I find out what is wrong with it?

  • Probably your image is too old, do init 4 and then enigma2 in telnet and you then could read the full story

  • Image is fresh and like I sad I get only this:

    Code
    action -> WizardActions ok
    [BARRYALLEN] Pluginexecution failed


    nothing else so cannot really start to find a solution if no errors there.

  • If you are not believing and want to see yourself go the /media/ba/BarryAllen and change the plugin.py content from:



    Code
    def main(session,**kwargs):
    try:
    from Plugins.Extensions.BarryAllen.BarryAllenPlugin import BarryAllenPlugin
    session.open(BarryAllenPlugin)
    except:
    print "[BARRYALLEN] Pluginexecution failed"


    to:


    Code
    def main(session,**kwargs):
    # try:
    from Plugins.Extensions.BarryAllen.BarryAllenPlugin import BarryAllenPlugin
    session.open(BarryAllenPlugin)
    # except:
    # print "[BARRYALLEN] Pluginexecution failed"


    Have fun with your crashdump/Plugin Load error when doing init 4 and then enigma2 in telnet

    Edited once, last by gutemine ().

  • Thanks a lot. This is what I needed. Problem solved. ;)

  • Quote

    Original von Ampersand
    Thanks a lot. This is what I needed. Problem solved. ;)


    was I wrong or was I right ?

  • Nothing was wrong with BA. Image I tested does not have a skin.py file so I had to change code in BA to make it work. With your tip I had a chance to solve it. Thanks ones again.

  • It is not really a question of supported or not supported, BA cann't simply support every possible image combination.


    People trying to use latest BA with 1 year old images not supporting the center,center in the Skin have the same problem ... and should not complain either, this is why BA checks the skin.py. But I will also add a check in the next BA Version to prevent problems if people want to keep their secrets.


    Ciao
    gutemine

    Edited 2 times, last by gutemine ().

  • I understand your point of view. Would be really nice if you added support for encrypted skin.py in future realeases. If not, nevermind, I will not complain about it anyway. Of course is it not possible to support everything but that is really nice you still want to help in cases like mine, even without BA official support. :) Otherwise would not be able to do some OE 1.6 tests.

  • BA 5.1.15 will have such a check, but it will the assume a new image with center, center skin support - if you want old secrets BA cann't help :-)


    But just for this small fix it is not worth to relase 5.1.15, so you have to be patient and edit it manually until then

    Edited once, last by gutemine ().

  • @ gutemine



    Das NFI Flash Plugin erstellt unter media/hdd/backup/nfi-backup das Backup. Später werde ich eine Stickimage erstellen.


    Santaleone

    Santaleone


    DM800HD PVR, DM8000HD, DM7020HD, und alles mit Oozoon

    Edited 2 times, last by santaleone ().

  • wo liegt das Problem wenn immer dieser Fehler kommt beim installieren


    root@dm8000:/tmp# opkg install enigma2-plugin-extensions-shoutcast_experimental-
    cvs20100104-r0_mipsel.ipk
    Installing enigma2-plugin-extensions-shoutcast (experimental-cvs20100104-r0) to
    flash...
    Configuring dreambox-bootlogo
    mount: can't find /boot in /proc/mounts
    postinst script returned status 1
    Configuring enigma2-plugin-extensions-shoutcast
    Configuring newnigma2-bootlogo
    mount: can't find /boot in /proc/mounts
    postinst script returned status 1
    Collected errors:
    * ERROR: dreambox-bootlogo.postinst returned 1
    * ERROR: newnigma2-bootlogo.postinst returned 1
    root@dm8000:/tmp#

  • BA Doku nicht gelesesen ?


    In einem BA image ist /boot kein Mount mehr des Flash weswegen natürlich das remounten nicht funktioniert - was aber nicht wirklich stört. Wenn Doch mit BA Plugin ipks installieren oder Softwareupdate machen - das trägt dummy mounts in die fstab ein damit der Fehler nicht kommt - oder im BA den Dummy Mount mit dem Plugin reinmachen und dann ganz normal im telnet oder wimit auch immer installieren - nachher dann aber das wegmachen nicht vergessen.


    Theoretisch kannst du natürlich auch einfach das # in der /boot mount Zeile der fstab wegmachen - aber dann wird evt. was im Flash verändert von einem BA image.


    PS: LowFAT macht das anders, da wird /boot als tempfs gleich immer drüber gemountet.


    LG
    gutemine

    Edited once, last by gutemine ().

  • Hallo zusammen,
    hatte Ostern etwas langeweile und habe getestet ob mann nicht doch Gemini auf
    der DM500HD zum laufen bringen kann.
    Und es geht, mit aktuellen Ozoon 2.8 Stable Ba 5.1.14 auf eSata Stick.
    Läuft stabil, nur hält die DM500HD sich jetzt für eine DM800HD :rolleyes:
    Nur zu Info.

    Dreambox 8000HD1.2 - 8000HD 1.3
    Image - Merlin ;)

  • ähm das hätte ich dir vorher auch sagen können das es geht, kannst sogar ein OE 1.6 Image von OoZooN in den Flash machen, dann ist es noch flotter :-)

  • Na da habe ich wohl was verpasst :tongue:
    Fragt sich dann nur,warum so viele rumheulen das Gemini nicht geht!
    Na was sollst ,so hatten ich Ostern Beschäftigung. ;)

    Dreambox 8000HD1.2 - 8000HD 1.3
    Image - Merlin ;)

    Edited once, last by futuredreamer ().