Barry Allen 5.2 Test und Entwicklungsthread - currently closed

  • Hi !


    Entwicklung und Test von BA 5.1 ist jetzt vorbei. Die Barry Allen 5.1 Kits sind jetzt im normalen Barry Allen Thread !!!


    Test and Development of BA 5.1 are now over. The Barry Allen 5.1 kit is now in the normal Barry Allen Thread !!!


    Nachdem ich ja schon sagte, dass wir durch die neuen OE 1.6 Images auch beim Multibooten einiges zu tun kriegen, will ich nicht alles alleine machen.


    Ausserdem habe ich entschieden nur die neuen Images mit neuem BA 5.1 zu unterstützen.


    BA 5.1 wird sich also auf images mit dem alten 2.6.12er Kernel nicht installieren (mit Ausnahme der 500HD), für alte Images im Flash bitte weiterhin BA 5.0 verwenden - allerdings kann man mit 5.0 dann weiterhin keine neuen OE 1.6 Image vom BA device booten !


    Umgekehrt - also neue Image im Flash und altes image am BA device geht es mit BA 5.1 (bis auf kleine Einschränkungen durch udev und neuere Treiber) schon.


    Darüber hinaus ist jetzt Chinesisch Neujahr vorbei und die Letzte Warnung zum Thema Klone wurde aus der installation des Kits entfernt, was das jetzt wohl bedeutet müsst Ihr selber rausfinden - ich würde es aber besser nicht tun.


    Was aber schon geht ist mit einem Image mit dem neuen 2.6.18er Kernel alte Images vom BA device zu booten.


    Bitte du beachten das wenn diese alten images udev verwenden das NICHT funktionieren wird, da die neuen images Ihr eigenes udev mitbringen.


    Ich habe dazu als workaround wenigstens implementiert das die Hardddisk trotzdem im Image gemountet wird, dafür muss aber /media/hdd als directory existieren, ein Link wird nicht funktionieren und muss gelöscht und durch ein directory ersetzt werden !


    Von hand und mit fstab mounten sollte in den so gebooteten alten Images natürlich funktionieren, nur halt mit den /dev/sd* device Pfaden des neuen udev.


    Auf der 8000er funktionieren bereits alle 5 Varianten der Installation (auf USB stick, CF, SD Karte, Hardddisk und im unbenutzen Flash).


    Als Image im Flash funktioniert jetzt auch ein DMM experimental image aus dem OE 1.6 Zweig das Ihr von http://www.dreamboxupdate.com runterladen könnt (viel mehr an Auswahl gibt es im Moment eh nicht wenn man von Selbstgebackenem absieht) weil die jetzt auch die USB Treiber beinhalten und genauso stabil und flott die USB devices erkennen.


    Bitte testet ob sonst auch alles funktioniert wie es sollte und vor allem probiert es auch auf der 800er aus und postet ggf. Installationslogs wenn es Probleme gibt.


    LG
    gutemine

  • so dann mach ich mal den Anfang :)


    Auf der dm800 ein 1.6 er DMM Image.
    USB Stick FAT32 formatiert


    BA 5.1 installiert :



    Wurde als dm500HD erkannt :)
    Hat sich leider nur auf der HDD installieren wollen


    OK, wie zu erwarten, keine VFAT Treiber geladen, so wurde der
    Stick nicht erkannt, also



    auf ext3 formartiert und nun :


  • Danke, kann mir jemand von der 800er das cat /proc/cpuinfo posten damit ich die Boxerkennung anpassen kann (weil die 500er hat keine USB devices weswegen es dort immer auf die Harddisk gehen wird solange er sich irrt ) ?


    PS: dafür habe ich das problem mit dem bootmanager gefixed, kommt aber erst mit der 5.1.1 wenn auch die 800er funktioniert.


    LG
    gutemine

    Edited once, last by gutemine ().

  • bitte schön ....


    root@dm800:~# cat /proc/cpuinfo
    system type : BCM97xxx Settop Platform
    build target : dm800
    processor : 0
    cpu model : Brcm3300 V0.0
    cpu MHz : 294.91
    BogoMIPS : 294.91 ( udelay_val : 147456 HZ = 1000 )
    wait instruction : yes
    microsecond timers : yes
    tlb_entries : 32
    extra interrupt vector : yes
    hardware watchpoint : no
    ASEs implemented : mips16
    VCED exceptions : not available
    VCEI exceptions : not available
    RAC setting : I/D-RAC enabled
    unaligned access : 100449
    rdhwr/brdhwr traps : 0 / 0
    root@dm800:~#

  • Ahhh, ich sehe schon, die heissen jetzt alle BrcmXXXX


    Na ja dann mache ich Euch schnell noch vor dem Schlafengehen eine 5.1.1 damit Ihr weitertesten könnt wo auch der Bootmanager wieder funktionieren sollte.


    LG
    gutemine


    PS: FAT Treiber funktioniert im Moment noch nicht richtig, nachdem es BA aber egal ist ob das device gemountet ist (es muss nur ein /dev/sd*1 vorhanden sein) sollte das egal sein wenn der stick zur Installationsvorbereitung wie empfohlen als FAT gemacht wird.


    PPS: Das ist übrigens auch einer der Gründe warum im Moment WW nicht unterstützt ist und LowFAT auch nicht sondern nur klassisches BA

    Edited 4 times, last by gutemine ().

  • in den experimentals ist vfat/fat und co im kernel drin.
    es hapert meist an der fehlenden codepage unterstützung ...


    jenachdem, welche codepages er will,
    müssen diese noch nachinstalliert werden ...


    kernel-module-nls-cp437
    kernel-module-nls-iso8859-1



    greetz


  • ist es nicht einfacher nach "build target" abzufragen ?


    PS: einer der BA's 5.1.1 ist sehr klein, denn kannst du neu machen ;)
    PSS: irgendwie konnte ich die 5.1.1 noch herunterladen und upgraden, aber obwohl der bootmanger ging (mit einem bildhuschen dabei) boote enigma2 in einer schleife.
    Enigma2 will den Sender aufschalten und die Infobar war halb zu sehen, dann ging's wieder von vorne los ... habe dann wieder auf 5.1.0 downgeraded und alles wieder OK :)


    also dann gudde Nacht

  • Bitte probiert den 5.1.2, da sollte das gefixed sein


    Das mit dem Bild Target ist erst neu (ich hatte ja angeregt in /proc/cpuinfo was reinzumachen um die Boxen einfach identifizieren zu können).


    Und das kurze schwarze Rechteck beim bootmanager ist zum debuggen drinnen, das ist in der 5.1.2 auch wieder draussen.


    Und ja das FAT drinnen ist habe ich gesehen - nur funktioniert es eben noch nicht, aber ich werde den tipp mit den codepages ausprobieren.


    LG
    gutemine

    Edited 4 times, last by gutemine ().

  • Joh danke, das kann ich erst heute spät Abend probieren.


    Die dm800 mit dem neuen Kernel ist schon flott :)
    das merkt man auch bei den HD Skins, schade das der FTP server noch nicht läuft.
    Die beiden Codepages habe ich nachinstalliert, mal sehen wenn's nen neuen Stick braucht.


    .. ist aber noch ein bischen Arbeit bei dem 1.6 er Image ;)

  • Ich arbeite eh :-)


    Wobei ich den Flash schon umgestellt habe, die alten Images gehen damit eigentlich auch wenn man von den udev inkompatibilitäten absieht.


    Bugs werden ja auch nur gefunden wenn man es auch benutzt :-)


    LG
    gutemine

    Edited once, last by gutemine ().

  • Quote

    Wobei ich den Flash schon umgestellt habe, die alten Images gehen damit eigentlich auch wenn man von den udev inkompatibilitäten absieht.


    Kann ich bestätigen. Das LT6 läuft eigentlich problemlos mit dem neuen Kernel.
    Hier und da gibt es eine Fehlermeldung beim Pakete installieren. Das betrifft jedoch immer nur die Kernel-Module.


    Gruß, deathrattle

  • Quote

    Original von deathrattle
    Hier und da gibt es eine Fehlermeldung beim Pakete installieren. Das betrifft jedoch immer nur die Kernel-Module.


    Gruß, deathrattle


    Mach mal mkdir /lib/modules/2.6.18-7.1-dm8000 (oder 800) dann sollte ruhe sein

  • Quote

    Original von gutemine


    Mach mal mkdir /lib/modules/2.6.18-7.1-dm8000 (oder 800) dann sollte ruhe sein


    Jo, klappt. Danke für den Tip!

  • hi!


    also ich hab mich darüber getraut!


    altuelles "beta-image" von OoZoon (1.6) zweig im flash und barryallen handisch nach installiert!


    soweit alles OK! jedoch reagiert die FB beim bootmanager nicht, und JA ich habe die amlitung gelesen!


    1 - Boot Optionen:
    1 Auswahl der Devices (Ebene ist falsch beschrieben)
    rc device ist für das Device File der Fernbedienung (dieses ist auf der DM8000 /dev/input/event2, sonst /dev/input/event1, allerdings kann es sich, wenn man z.B. USB Mouse oder Keyboard dran hat, auch weiter verschieben. (dann taucht evtl. auch ein /event5 oder /event6 zum Auswählen auf)



    ich habe auch andere events getestet, und auch andere FB ebenen -> kein erfolg! ich konnte nur noch über DCCE2 mein image wechseln!


    ich bitte daher gutemine aufrichtig um RAT und bedanke mich im vorhinein für die hilfestellung!

  • warum musst du mich um Rat bitten wenn du es mit 2 Reboots leicht selbst rausfinden könntest ????


    Seit nicht immer so FAUL !


    Die OE 1.6 images sind anders, da ist im Moment auf der 8000 /dev/input/event1 auszuwählen, dann geht es.


    LG
    gutemine

  • Habe auch mal mit dem OOzoon 1.6 auf der 8k experimentiert.


    wenn man BA vom OoZooN-Feed herunterläd und installiert nützt das noba-Verzeichnis nichts, er installiert sich trotzdem auf der HDD wenn er nichts anderes findet.

    LG
    Karl

    «Einen Menschen erkennt man daran wie er wird, wenn er was wird»


    __________________________________________________________
    Dreambox 8000HD SSCS HDD +CF 8 Gb, Merlin
    Dreambox 7020HD SC HDD
    Dreambox 500 HD S
    Dreambox 7025 SC HDD +CF 2 Gb
    Dreambox 600 S
    NAS = 2x Synology DS109 3 TByte
    TV= Samsung UE40ES6300
    SAT = 45° Ost - 30° West


    [SIZE=7]Dieser Beitrag wurde schon vor Veröffentlichung 8 mal editiert.[/SIZE]

    Edited once, last by karl2014 ().

  • auf welcher box solltest du schon dazusagen und mir das installationslog posten, sonst kann ich es nicht fixen.


    Und wenn greift das noba nur wenn es noch nicht installiert ist, sobald es mal auf der hdd ist ist es für noba zu spät, dann wird dort nur mehr aktualisiert und du musst BA erst deinstallieren damit das noba greift.


    Ich mach Euch aber erstmal auf die erste seite auch noch eine 5.1.3 wo auch die 500HD unterstützt sein sollte.


    LG
    gutemine

    Edited once, last by gutemine ().

  • ich hatte ja geschrieben 8k !


    Da aber BA sich auf dem Stick auf hdc1 installiert hat und damit meine HDD weg war bin ich wieder aufs alte System zurück und warte ab.


    Eine zeitliche Verbesserung beim Start habe ich nicht bemerkt, also wozu der Streß. ;)

    LG
    Karl

    «Einen Menschen erkennt man daran wie er wird, wenn er was wird»


    __________________________________________________________
    Dreambox 8000HD SSCS HDD +CF 8 Gb, Merlin
    Dreambox 7020HD SC HDD
    Dreambox 500 HD S
    Dreambox 7025 SC HDD +CF 2 Gb
    Dreambox 600 S
    NAS = 2x Synology DS109 3 TByte
    TV= Samsung UE40ES6300
    SAT = 45° Ost - 30° West


    [SIZE=7]Dieser Beitrag wurde schon vor Veröffentlichung 8 mal editiert.[/SIZE]

  • Na ja für ein installationslog ist es jetzt zu spät, aber die hardddisk ist /dev/sda1 und der stick /dev/sdb1 - insofern kann ich das mit hdc nicht ganz glauben.


    Vor allem habe ich auch das OoZooN Beta im Flash und mein BA läuft von CF :-)


    Und doch es bootet etwas 15 sec schneller, wenn ich motivert bin passe ich am Wochenende sowieso mal qWickie für die OE 1.6 Images an und schaue ob ich die 40 sec Marke bei der Bootzeit damit knacken kann :-)


    LG
    gutemine

    Edited 2 times, last by gutemine ().