auto.network oder automounts.xml 8000

  • Bei ihm wird sicher das Problem sein, dass gar keine exportfs vorhanden ist.
    Denn die muss man erstellen mittels dem NFS Server Plugin.


    Z.B auf /media/hdd


    Aber so klappt es dann auch nicht weil alle Clienboxen anders mounte.


    So müsste es dann so sein, die Freigabe.


    /media/hdd/movie

  • Gute Nachricht, der letzte Tipp hat's gebracht: mit /hdd/movie funzt's. Aber warum?


    Im PC-FTP Programm ist der Pfad als /media/hdd/movie angezeigt (siehe Anhang), und auch im DCC ist bei "Experten" unter "Path Recordings"der Pfad als /media/hdd/movie eingetragen und darunter finde ich die Filme auch.


    Falls Du also eine logische Erklärung hättest....


    enigma

    Files

    • Pfad.pdf

      (30.94 kB, downloaded 17 times, last: )
  • Ich nochmal: die gute Nachricht relativiert sich etwas:
    2 meiner 5.1er Boxen sind in anderen Zimmern und waren noch nicht auf den neuen Pfad /hdd/movie umgestellt. Trotzdem kommen sie auch auf die Filme der G3er Box.
    Nächster Versuch: die auf /hdd/movie umgestellte 5.1er Box wieder auf /media/hdd/movie umgestellt (natürlich immer Neustart): geht immer noch.
    2 weitere Versuche: Beide, 5.1 und G3 Box aus. 5.1 an und durchbooten. Dann die G3 Box an und durchbooten. Zugriff funzt. Dasselbe umgekehrt, erst die 5.1 an, dann die G3 an. Funzt immer noch.
    Bei meinen Telnet Experimenten muß in der G3 Box irgendein Bit gekippt sein, und nun funktioniert alles, unabhängig davon, welche Box in welcher Reihenfolge eingeschaltet wird - so wie das eigentlich schon immer sein sollte.


    Ich kann mir keinen Reim darauf machen. Am Wochenende werde ich mal das Image auf die G3 erneuern, G3 installieren, meine auto.network einpflegen, den NFS Server installieren und dann kann ich (hoffentlich) wieder nicht auf die G3 Kiste zugreifen. Das wäre dann die Chance auf neuerliche Problemsuche (es sei denn, jemand Schlaues weiß schon jetzt, wo ich noch untersuchen kann).


    enigma


  • Das ist ja auch der Pfad wo die Platte eingebunden ist.
    Interessant ist aber, wie du deine nfs Freigabe erstellst ;)


    Und gut, dass es irgendwie geklappt hat :D

  • Es stellt sich heraus, daß sowohl /media/hdd/filme als auch /hdd/filme in der auto.network Datei auf der G3er Box funzen.
    Ansonsten hier meine Vorgehensweise für Freigaben (Stand Feb 2014), um von der G3 Box die G2 5.1 Boxen zu mounten (Auszug aus meiner "Loseblatt Sammlung" die als Gedächtnisstütze dient). G3 Box zu G3 Box sollte auch so funktionieren:



    FTP
    Der FTP Server muß eingeschaltet sein, wenn man von „anderen“ Boxen Dateien erhalten will. Im Gemini 3.2 muß dazu unter Blue-Panel – Addons – Gemin Plugins zunächst das gemininfs geladen werden. Anschließend findet man den NFS Server unter Blue Panel – Daemons.
    Nun Freigabe einrichten, falls nicht schon automatisch enthalten: mit „Hinzufügen“ das vorgeschlagene Format übernehmen. Als Resultat kommt dann:
    . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
    Freigabe:/media/hdd
    Zugang für alle (*) oder IP: *
    Parameter:rw,no_root_squash,async,no_subtree_check


    NFS Server läuft
    . . . . . . . . . . . . . . . . . . . . . . . . . . . . .


    Fernzugriff auf andere Dreambox - Mounten
    NFS Server aktivieren (in Gemini 5.1 enthalten, muß aber aktiviert werden – in Gemini 3.2 siehe NFS)


    Unter /etc befindet sich die <auto.network> Datei, die entsprechend editiert werden muß.
    Unter 5.1 ist das Attribut 755, unter Gemini 3 muß es 644 sein.


    Muster: Das Verzeichnis "music" der Synology wird "gemountet"
    # Nach dem "Mounten" findet sich die Musik der Synology unter dem Pfad /root/automount/Syn_Music
    Syn_Music -fstype=nfs,rw,soft,tcp,nolock,rsize=32768,wsize=32768 192.168.178.2:/volume1/music


    Muster: Die Festplatte von 192.168.178.42 = 8000-3 wird "gemountet"
    # Nach dem "Mounten" finden sich die Filme der 8000erBox unter dem Pfad /root/automount/IP42_8000
    IP42_8000 -fstype=nfs,rw,soft,tcp,nolock,rsize=32768,wsize=32768 192.168.178.42:/media/hdd/movie


    NETZWERK BROWSER bei Gemini 3 nicht benutzen – er erzeugt eine .xml Datei, die sich mit der auto.network beißt!


    Bei neuen Images (z.B. bei denen für Gemini 3.2) gibt es den „showmount“ Befehl. Syntax:
    showmount -e Ip-Adresse_des_NFS-Server


    Damit scheint es zu laufen. Falls jemand bessere/zusätzliche Ideen hat, immer her damit.


    enigma