auto.network oder automounts.xml 8000

  • das thema interessiert mich auch sehr, da es doch immer wieder um den netzwerkbrowser und auto.network geht...


    was letzt endlich besser ist bzw. funktioniert steht wohl auf einem anderen blatt.
    ich jedenfalls hab auch die erfahrung gemacht dass die NAS vorher da sein muss bzw. der nfs meiner anderen dm, ansonsten erscheint nichts in media/net
    :(


    mit automount.xml hab ich auch schon schlechte erfahrungen gemacht... hatte bei einem neuen image einfach mein alte vorher gesichert und überschrieben... das funzte aber nicht sonderlich, bzw. nur bedingt.
    komischerweise waren nicht alle mounts dann da usw.
    erst ein komplettes neu-anlegen über den netzwerkbrowser brachte den erfolg, was ich aber schlecht finde, wenn man das jedesmal machen muss.


    mit auto.network geht das ohne probs... ich flashe überschreibe die und starte box KOMPLETT (ist wichtig) neu, dann sind die mounts da.

  • Mich würde nur interessieren, warum bei einigen Usern scheinbar autom. gemountet wird.


    Das hat hier noch nie geklappt.


    Wenn ich einen der nfs-server abschalte, zweimal die Videotaste drücke, taucht der Mountpunkt logischerweise nicht mehr auf.
    Schalte ich den Server wieder ein, bleibt das Verzeichnis verschwunden.
    Hangel ich mich bis zur Bookmarkauswahl, kommt "Verzeichnis bla bla bla existiert nicht" ?(


    Panasonic TX50-EXW784
    Panasonic SC-ALL70TEGK / SC-ALL2 wireless 5.1 Soundbar
    dm8000, dm7080, dm800sev2, dm900-dvb-s2-unicable, dm900-dvb-s2-multisat


    http://www.dreambox-tools.info

    Edited 2 times, last by Oldboke ().

  • Oldboke
    wie meinst du das auf einem der server nfs ausschalten?


    also ich hab auf der dm wo nur die nas dran ist KEINEN nfs-server laufen...wozu auch?


    nur wenn ich auf aunderer dm auf INTERNE platte will muss er dort laufen, das ist klar.

  • Nas und dm7025 sind auf der dm800 gemountet.
    Nas und dm800 sind auf der dm7025 gemountet, so kann jede Box auf jeden Server aufzeichnen / abspielen.


    Panasonic TX50-EXW784
    Panasonic SC-ALL70TEGK / SC-ALL2 wireless 5.1 Soundbar
    dm8000, dm7080, dm800sev2, dm900-dvb-s2-unicable, dm900-dvb-s2-multisat


    http://www.dreambox-tools.info

  • Ich habe in /etc eine auto.hotplug, die ich auch immer vernwendet habe.
    Es gibt dort zwar auch eine auto.network, die habe ich aber NIE verwendet.
    In der auto.hotplug mounte ich zwei NFS-Verzeichnisse von zwei verschiedenen
    NAS.
    In /media/hdd/movie habe ich zwei symbolische Links (per ln -s angelegt),
    die auf die Verzeichnisse in /autofs zeigen, die von den NAS gemountet
    werden. Diese symbolischen Links habe ich dann fuer die Bookmarks
    verwendet.
    Solange man auf die Verzeichnisse zugreift, sind die Mounts aktiv.
    Greift man laenger als 10 Sekunden nicht mehr auf die Mounts zu, werden
    sie wieder freigegeben. Greift man dann wieder zu, werden sie sofort
    wieder automatisch gemountet.
    Mein Vermutung lautet nun, dass die auto.network fuer Mounts gedacht
    ist, die staendig verfuegbar sind und nur beim ersten Zugriff einmalig
    gemountet werden und die auto.hotplug fuer Mounts, die immer nur bei
    Bedarf gemountet werden. Ist aber nur eine Vermutung. Muesste mir mal
    den Code anschauen, um das genauer sagen zu koennen.

    Bitte keine unaufgeforderten PNs schicken, sondern im Forum fragen. Ich schaue NIE ohne Auffordung in meine PN-Box.

  • Für mein (bescheidenes) Verständnis, besteht da kein Unterschied, außer dem voreingestellten Pfad in der auto.master.


    Quote

    Greift man dann wieder zu, werden sie sofort
    wieder automatisch gemountet.


    Wie soll ich auf etwas zugreifen, was als "... existiert nicht" angezeigt wird ?


    Panasonic TX50-EXW784
    Panasonic SC-ALL70TEGK / SC-ALL2 wireless 5.1 Soundbar
    dm8000, dm7080, dm800sev2, dm900-dvb-s2-unicable, dm900-dvb-s2-multisat


    http://www.dreambox-tools.info

    Edited 2 times, last by Oldboke ().

  • Auch mit der auto.network werden die mounts bei Bedarf hergestellt und nach 2 min. ungemountet.
    So wie autofs/automount halt funktioniert.

  • Und so sieht das dann hier aus, wenn ich mein nas kurz abschalte, in ein anderes Verzeichnis wechsle und dann dann versuche auf das wieder eingeschaltete nas zu kommen.


    Panasonic TX50-EXW784
    Panasonic SC-ALL70TEGK / SC-ALL2 wireless 5.1 Soundbar
    dm8000, dm7080, dm800sev2, dm900-dvb-s2-unicable, dm900-dvb-s2-multisat


    http://www.dreambox-tools.info

  • Vielleicht liegt der Unterschied darin, dass ich NICHT direkt das Bookmark auf die autofs
    Verzeichnisse lege, sondern auf einen symbolischen Link, der auf das autofs Verzeichnis
    zeigt?

    Bitte keine unaufgeforderten PNs schicken, sondern im Forum fragen. Ich schaue NIE ohne Auffordung in meine PN-Box.

  • Ihe könnt mich für Verrückt erklären, aber ich bin es gerade
    nochmal alles durchgegagen. :D


    bis zum 8.2 lagen meine Netzwerkmounts auch in der auto.network und alle wurdem
    im Browser unter Netzwerkmounts (/media/net) aufgeführt. Irgendwann danach nix mehr.
    Kein Netzwerkmounts Verzeichniss im Browser mehr ...


    Egal ob sie in der auto.hotplug oder auto.network sind !


    Es geht nur wenn ich die mounts in der /etc/enigma2/automounts.xml drin habe !


    Ich habe es an der dm8000 / exp. OoZooN aktuel vom heutigen Datum.


    Ich habe aber auch vor einiger Zeit den Netzwerkbrowser & Freigabemanger
    installiert gehabt. Die unter System - Netzwerk zu finden sind.


    Was zum Henker ist denn bei Euch, die auch ein exp. OoZoon von heute im Flash haben denn anders frage ich mich jetzt ????


    Ich kann aber auch mit der automounts.xml leben :
    1) Ist immer mit einem Settingsbackup gesichert & wiederhergestellt
    2) nach Zuschalten von Netzwerkclients nur ein E2 Neustart erforderlich
    3) vor Abschalten von Netzwerkclients vorher ein umount durchfühern


    auch wenn nicht alles so optimal ist, wie ich mir das vorstelle.
    So sieht es z.Z aus. Vielleicht auch wieder Zeit mal ganz neu zu flashen & alles Schritt für
    Schritt neu zumachen :)


    Die Erklärung dafür ist dort ==> Support-thread für OoZooN CVS images für die 8000 aus dem enigma2 "experimental" zweig

  • @sienna
    was passiert wenn du die automounts.xml löschst und einen KOMPLETTEN neustart machst?
    bzw. die xml löschen und die auto.network "befüllen" und dann neustart...


    bei mir ging das als der netzwerkbrowser nicht so funzte wie ich wollte.
    die auto.network ging dann wieder alles.

  • Quote

    Ich kann aber auch mit der automounts.xml leben :
    1) Ist immer mit einem Settingsbackup gesichert & wiederhergestellt
    2) nach Zuschalten von Netzwerkclients nur ein E2 Neustart erforderlich
    3) vor Abschalten von Netzwerkclients vorher ein umount durchfühern


    1: Bei auto.network auch (einfach mit ins Backup aufnehmen)
    2: Bei auto.network auch (oder autofs reload)
    3: das bedeutete das aus für den networkbrowser bei mir, denn ohne unmount lässt sich die Box dann nicht mehr bedienen, wenn ich zweimal die Videotaste drücke.


    Zu deinem Problem:
    Hast du den Timeout in der autofs auf 1 gelassen ?
    Das funzt nicht.
    Die automounts.xml musst du natürlich auch löschen


    Panasonic TX50-EXW784
    Panasonic SC-ALL70TEGK / SC-ALL2 wireless 5.1 Soundbar
    dm8000, dm7080, dm800sev2, dm900-dvb-s2-unicable, dm900-dvb-s2-multisat


    http://www.dreambox-tools.info

    Edited once, last by Oldboke ().

  • Quote

    Original von kenatonline
    Vielleicht liegt der Unterschied darin, dass ich NICHT direkt das Bookmark auf die autofs
    Verzeichnisse lege, sondern auf einen symbolischen Link, der auf das autofs Verzeichnis
    zeigt?


    Hast du denn auch mehrere netzwerkmounts und / oder eine HDD ?
    Wenn ich das Verzeichniss nicht wechsel, kann ich mein nas auch stundenlang abschalten und bei Bedarf ist es wieder da.
    War ich zwischendurch aber auf der HDD oder dem anderen Server, dann s.o.


    Panasonic TX50-EXW784
    Panasonic SC-ALL70TEGK / SC-ALL2 wireless 5.1 Soundbar
    dm8000, dm7080, dm800sev2, dm900-dvb-s2-unicable, dm900-dvb-s2-multisat


    http://www.dreambox-tools.info

  • Quote

    Original von diddsen
    @sienna
    was passiert wenn du die automounts.xml löschst und einen KOMPLETTEN neustart machst?
    bzw. die xml löschen und die auto.network "befüllen" und dann neustart...


    bei mir ging das als der netzwerkbrowser nicht so funzte wie ich wollte.
    die auto.network ging dann wieder alles.


    Ich habe inzw. neu geflasht :)


    Und alles wie es soll ...


    Das Problem war ja das ich die automounts.xml gelöscht hatte und auto.network wiederhergestellt hatte und trotzdem nicht ging !


    Egal jetzt wieder alles neu ... Gelegenheit den alten Ballast abzuwerfen.


  • Das ist immer bei mir auf : Timeout = 10


    daran lag es nicht, es ist irgend wie die Kombi automounts.xml mit auto.network, die
    nicht zusammen funktioniert !


    Bin auch deiner Meinung, das automounts.xml nicht so dolle ist :)


    Ja den script für autofs reload habe ich mir jetzt wieder aufgewärmt..

  • Ich hab das auch nochmal getestet und so lange ich das Verzeichnis nicht wechsele, wird mein NAS / 7025 auch wieder autom. gemountet.
    Gehe ich aber in ein anderes Verzeichnis, während einer der Netzwerkmounts abgeschaltet ist, kann ich diesen anschließend nicht mehr erreichen, wenn ich ihn wieder einschalte.


    "Verzeichniss existiert nicht", so lange ich kein autofs_reload mache.
    Warum nennt sich das dann Automount ? ?(


    Panasonic TX50-EXW784
    Panasonic SC-ALL70TEGK / SC-ALL2 wireless 5.1 Soundbar
    dm8000, dm7080, dm800sev2, dm900-dvb-s2-unicable, dm900-dvb-s2-multisat


    http://www.dreambox-tools.info

  • Nochmal nach oben holen.


    Wenn ich in der auto.network den Unterordner mit eintrage, z.B. .../mnt/Share/movie, klappt das auch mit dem späteren Einschalten vom NAS.
    In der Verzeichnisauswahl vom Videothek-Plugin, kann man das NAS auch noch sehen, wenn es abgeschaltet ist.
    Auswählen sollte man es dann aber nicht, weil enigma2 dann abstürzt. Es ist es aber sofort wieder erreichbar, wenn es wieder an ist.


    Panasonic TX50-EXW784
    Panasonic SC-ALL70TEGK / SC-ALL2 wireless 5.1 Soundbar
    dm8000, dm7080, dm800sev2, dm900-dvb-s2-unicable, dm900-dvb-s2-multisat


    http://www.dreambox-tools.info

  • Also, ich glaube hier bin ich richtig...


    Habe auch so meine Probleme mit der Verbindung zweier 7025er. Vielleicht kann mir jemand helfen???


    Bestand: Zwei 7025er mit Ozoon experimental, verbunden via Router im LAN. In auto.network bei beiden folgenden Mount:


    dm7025sz -fstype=nfs,rw,soft,tcp,nolock,rsize=8192,wsize=8192 192.168.178.20:/media/hdd
    dm7025wz -fstype=nfs,rw,soft,tcp,nolock,rsize=8192,wsize=8192 192.168.178.30:/media/hdd


    Die jeweils andere Box ist ausge #'t


    Netzwerkbrowser-Plugin ist installiert, damit arbeite ich aber nicht, nfsserver ist auf beiden Boxen installiert.


    So: 1. Problem und Hauptproblem: Von Box dm7025wz im Wohnzimmer kann ich problemlos Filme von der dm 7025sz im Schlafzimmer sehen. Andersherum ruckelt es aber total, Ton stockt, Pinguin trappelt laufend links oben, teilweise ist das garnicht mehr bedienbar.


    Warum geht es in eine Richtung und nicht in die andere??????


    2. Problem, wie schon oben angesprochen: Gibt es nun eine Möglichkeit, daß man die Mounts so macht, daß es EGAL IST, welche Box zuerst eingeschaltet ist??? Das nervt TOTAL, daß man da immer aufpassen muß. Welche Box muß denn nun zuerst laufen? Die wo die Filme draufliegen, oder die, an der ich die Filme der anderen Box schauen will? Geht das nicht einfacher?


    Vielleicht kann mir da jemand nochmal eine Basis-Info für Nichtprofi geben und mir weiterhelfen...


    Evtl. doch nochmal mit der auto.hotplug versuchen? Netzwerkbrowser deinstallieren?

    Oozoon Images.
    Von den Tagen, die Gott einem Mann gegeben hat, zieht er einem nicht die Tage ab, die man mit Segeln verbringt :499:

  • So richtig auto ist das hier auch nicht, wenn du den Thread gelesen hast.


    Aber Netzwerkbrowser + automounts.xml entfernen, auto.network ohne rsize / wsize kann die Sache nur verbessern. ;)


    Panasonic TX50-EXW784
    Panasonic SC-ALL70TEGK / SC-ALL2 wireless 5.1 Soundbar
    dm8000, dm7080, dm800sev2, dm900-dvb-s2-unicable, dm900-dvb-s2-multisat


    http://www.dreambox-tools.info

  • Quote

    Original von Oldboke
    Ich hab das auch nochmal getestet und so lange ich das Verzeichnis nicht wechsele, wird mein NAS / 7025 auch wieder autom. gemountet.
    Gehe ich aber in ein anderes Verzeichnis, während einer der Netzwerkmounts abgeschaltet ist, kann ich diesen anschließend nicht mehr erreichen, wenn ich ihn wieder einschalte.


    "Verzeichniss existiert nicht", so lange ich kein autofs_reload mache.
    Warum nennt sich das dann Automount ? ?(


    Ich glaube, Du hattest mir im anderen Forum schon den Tip mit dem Script für autofs_reload gegeben (wenn der gleiche Avatar darauhindeutet, daß Du die gleiche Person bist ;-).


    Habe da unter /usr/script das Script Autofs_Reload.sh:
    #!/bin/sh
    #DESCRIPTION=This script will restart the automounter
    /etc/init.d/autofs reload
    echo ""
    exit 0
    hinterlegt, beim Ausführen über Userscripts-Plugin kriege ich aber immer die Meldung "permission denied". Wenn ich das Ganze aber via Telnet per Hand aus dem Ordner etc/init.d/autofs reload mache, dann geht das... woran kann das denn liegen?

    Oozoon Images.
    Von den Tagen, die Gott einem Mann gegeben hat, zieht er einem nicht die Tage ab, die man mit Segeln verbringt :499: