Programm zum NFS-Server suchen?

  • Hallo zusammen,


    gibt es ein Programm zum suchen eines NFS-Servers?


    Ich habe mir einen NFS-Server auf dem Asus-Router WL500GP angelegt bzw. eingeschaltet.
    Als Exportverzeichnis:
    /tmp/mnt *(rw,async,no_root_squash)


    mit showmount -e bekomme ich auch dieses in der Exportliste des Routers zu sehen. Somit würde ich sagen, dass der NFS-Server läuft.


    Jetzt komm ich zum Problem mit der Dreambox.
    Ich habe auf der 7025 mittels BluePanel Automount-Editor versucht den NFS-Server einzugeben.
    Name: asus
    TYP: nfs
    Options: rw,soft,udp/tcp...,nolock (ich glaub, ich hab schon alle Einstellungen probiert)
    IP: Ip des Routers
    Freigabe: /tmp/mnt


    Leider sucht die Dreambox sich tot!!!
    Den Ordner asus finde ich ja unter /net, aber wenn ich da drauf gehe, dann sucht und sucht und sucht die Dreambox.


    In Telnet hab ich den Router auch schonmal angepingt -> Funktioniert.


    Ich weiß jetzt wirklich nicht mehr weiter. Bin auch kein Experte.


    Gruß wolder

  • zum überprüfen ob NFSserver läuft kannst du einfach in ein telnet fenster auf den router nachschauen mittels das commando
    ps


    also telnet die IP-router
    login Name
    passwd Pasword
    ps


    dan bekommst du eine liste zu sehen wo der nfs server zwisschenstehen sollte.


    das die Dreambox aber nur sucht kann da ein Problem sein das kein zugang zum router ist
    weil zugang hat nur der LAN-client in die selbe WORKGROUP
    kannst du auch nachschauen in telnet ob die WORKGROUP die gleiche ist als deine Dreambox


    (sollte unter die mappe /etc zu finden sein aber kann auch bei einige modelle im webinterface eingestellt werden)


    ciao

    bin nicht sicher, ist Anne Will ministerin?

  • Der NFS-Server läuft, sonst würde er mir ja auch keine Exportliste anzeigen.


    Aber der Tip mit Workgroup ist gut!
    Den muss ich heute abend mal kontrollieren.
    Ich hab den beim Asus anders eingestellt, ich weiß nur nicht ob ich das bei der Dreambox auch geändert habe.


    Ich schau heute abend mal nach.


    Gruß wolder

  • Na ja man antwortet ja manchmal pur auf die fragestellung: Programm zum NFS-Server suchen?


    aber Gut


    die Dreambox hat natürlich schon eine Workgroup voreingestellt


    die ist nicht ohne weiteres zu ändern (also ich kenne die methode nicht ausser samba)
    wenn die asus ne andere hat als die dreambox sollte es die gleiche werden
    jetzt die frage wer folgt oder besser wer bekommt die änderung
    die dream
    oder
    die asus
    da nicht immer samba installieren oder samba-server laufen lassen von nöten ist mach ich immer alle Clients in die welche der dreambox schon voreingestellt hat
    also WORKGROUP=Dream auf PC's + NAS sowie Router


    wenn du aber samba auch installiert hast auf der dream ist die /etc/samba/smb.conf zu ändern
    dan schreibst dort die WORKGROUP=ASUS?oderso


    ciao

    bin nicht sicher, ist Anne Will ministerin?

  • Uiiiiii,


    kann man Workgroup in der Dream nicht ändern?!?!


    Ok, dann ändere ich den Router und den PC.


    Danke, daran wirds wohl liegen.


    Gruß wolder


    P.S.: Ich dachte es gibt vielleicht ein Programm, welches das Netzwerk durchforstet und mir den NFS-Server anzeigt und gleichzeitig eventuell verbindet.

  • Quote

    Originally posted by wolder
    Uiiiiii,


    kann man Workgroup in der Dream nicht ändern?!?!


    na ja wenn man samba drauf hat schon...
    aber vielleicht wüsste jemand noch wie das geht OHNE samba, ich nähmlich nicht.
    ciao

    bin nicht sicher, ist Anne Will ministerin?

  • Samba wollte ich nicht installieren, vorallem weil ja noch sooooooo viel Platz im Flash ist. :hurra: :hurra:


    Gruß wolder

  • hmmm - die WORKGROUP hat mit einem NFS-Mount nicht wirklich was zu tun....evtl. wird das mit dem Host-Namen verwechselt...


    Ich traue der showmount-Ausgabe nicht wirklich ;). Die ps-Ausgabe wäre schon hilfreich (läuft ausser nfsd und mountd auch der portmapper...?)


    Auch ein exportfs -v verrät ganz eindeutig was denn aktuell wirklich exportiert wird....


    SAMBA zu installieren um eine Workgroup zu ändern, damit ein NFS-Mount funktioniert dürfte zur Problemlösung nicht viel beitragen ;)

  • Ich hab hier für NFS noch keine Workgroup gesehen.
    Die auto.network editiert

    Code
    nas -fstype=nfs,rw,soft,udp 192.168.2.94:/mnt/Share


    Reboot und dann läuft das hier.


    Panasonic TX50-EXW784
    Panasonic SC-ALL70TEGK / SC-ALL2 wireless 5.1 Soundbar
    dm8000, dm7080, dm800sev2, dm900-dvb-s2-unicable, dm900-dvb-s2-multisat


    http://www.dreambox-tools.info

    Edited once, last by Oldboke ().

  • @NASfan
    Da ich mich mit Linux nicht wirklich gut auskenne, hatte ich mich auf showmount verlassen.
    ps und exportfs -v werd ich mal ausprobieren.


    Ich hab das bisher immer mit dem BluePanel automount-editor gemacht und nicht direkt in der Datei geändert.
    Ist das so ein großer Unterschied?


    Ich werd wohl erstmal die Workgroup im Asus einstellen und dann die Datei ändern.


    Mal sehen, ob es dann funktioniert.


    Gruß wolder

  • Quote

    Original von wolder
    Ich werd wohl erstmal die Workgroup im Asus einstellen ..


    ..wenn Du stattdessen einfach den Router (ich nehme an Olegs FW installiert) neu startet hast Du den gleichen Effekt. Die Änderung der Workgroup hat mit Deinem Problem - wie bereits erwähnt - absolut nichts zu tun.

  • So, hab gestern mal ein bißchen getestet.
    Leider nur kurz, da meine Frau nicht mitspielt!!!


    Ja, ich verwende Olegs FW.


    Mit ps war der portmapper nicht zu sehen.
    Also hab ich ihn eingeschaltet.
    Hat auch nicht geholfen.
    Wenn ich keine Buffergröße in der Dream angelegt habe, dann hat der auch nicht gefühlte stunden gesucht, sondern sofort nix angezeigt.


    Ich denke, es liegt noch am Asus.
    Leider kann ich erst morgen abend wieder testen, wenn die Frau nicht da ist.


    Ich melde mich wieder.


    Gruß wolder

  • Hallo.
    Habe ein Problem mit dream 7025 kannst du mir helfen

  • Quote

    Hallo. Habe ein Problem mit dream 7025 kannst du mir helfen


    und warum schreibst du nicht dein problem hier?
    hellsehen können wir nicht ;)

    gruß Friday :499:


    >>> FixBootVolume <<<


    «Nimm Friday, der macht´s auch mit der Nachbarin.» :D

  • Ich antworte mal auf dein Originalposting; hier ging es ja furchtbar durcheinander.



    > gibt es ein Programm zum suchen eines NFS-Servers?


    Antwort: Nicht wirklich (ausser "showmount -e server"; aber das hab' ich nicht auf der Dream!)


    Und vergiss bitte alles, was du zum Thema workgroup hier gehört hast; das hat NIX mit nfs zu tun (du willst ja nfs und kein samba share, oder??


    > Ich habe mir einen NFS-Server auf dem Asus-Router WL500GP angelegt bzw. eingeschaltet.
    > Als Exportverzeichnis:
    > /tmp/mnt *(rw,async,no_root_squash)
    > mit showmount -e bekomme ich auch dieses in der Exportliste des Routers zu sehen.
    > Somit würde ich sagen, dass der NFS-Server läuft.


    Yes, sieht so aus


    > Ich habe auf der 7025 mittels BluePanel Automount-Editor versucht den NFS-Server einzugeben.
    > Name: asus
    > TYP: nfs
    > Options: rw,soft,udp/tcp...,nolock (ich glaub, ich hab schon alle Einstellungen probiert)
    > IP: Ip des Routers
    > Freigabe: /tmp/mnt


    Dann sollte jetzt in der /etc/auto.network so eine Zeile sein (o.ä.):
    asus -fstype=nfs,rw,soft,udp,nolock IP:/tmp/mnt


    Richtig?
    Versuch doch mal, dein export manuell einzuhängen:


    mkdir /media/mnt
    mount -t nfs -orw,soft,udp,nolock IP:/tmp/mnt /media/mnt


    Geht das? Wenn das schon nicht geht, kann der automounter das auch nicht!
    Wenn nicht: Was kommt als Fehlermeldung?


    > Leider sucht die Dreambox sich tot!!!
    OK, dann kann er nicht mounten.


    > Den Ordner asus finde ich ja unter /net,
    > aber wenn ich da drauf gehe, dann sucht und sucht und sucht die Dreambox.


    Das heist nix; den legt der automounter direkt beim start an. Dazu muss er nicht mounten können.


    > In Telnet hab ich den Router auch schonmal angepingt -> Funktioniert.


    OK, d.h. das du netztechnisch bis da hin kommst; mehr auch nicht.


    > Ich weiß jetzt wirklich nicht mehr weiter. Bin auch kein Experte.
    Benutzt du einen eigenen NS? Wenn nein, kennt Dein Router deine Dreambox?


    Was sagt:
    /etc/init.d/automount status ?


    Andreas

  • Es sollte ja wie anderen meinten gehen ohne wenn und aber
    aber...


    Code
    If the device is isolated, that is, you cannot browse for users on the target machine,
    you will not be able to use an NFS.


    deswegen empfehle ich ja nur erstmals nach zu schauen ob man ja die PC's oder "target machine" (NAS) in ein LAN eingebunden hat
    (das ist ja auch nicht verkehrt wenn man schon windows PC's in LAN betreibt neben linux und verschlechtert ja nix)
    denn "browsable" bedeutet ja nicht nur anpingen!


    [QUOTE]Als Exportverzeichnis:
    /tmp/mnt *(rw,async,no_root_squash)/QUOTE]


    wenn ich mir nfs manpages durchlese sollte das woll root_squash sein und nicht no_root_squash


    wenn ich firmware für diese WL500G Premium anschau sehe ich auch ein unterschied>
    /tmp/mnt ist das nicht auch abhängig der firmware 1.9.2.7-9 (2008-03-14) den da steht /tmp/harddisk


    welche firmware hast du drauf Oleg sagt mir nicht viel


    Ich hoffe nicht alzu viel "noise" eingebracht zu haben.


    ciao

    bin nicht sicher, ist Anne Will ministerin?

    Edited once, last by Tonskidutch ().

  • Quote

    gibt es ein Programm zum suchen eines NFS-Servers?


    Den Netzwerkbrowser hast du auch schon getestet ?


    Panasonic TX50-EXW784
    Panasonic SC-ALL70TEGK / SC-ALL2 wireless 5.1 Soundbar
    dm8000, dm7080, dm800sev2, dm900-dvb-s2-unicable, dm900-dvb-s2-multisat


    http://www.dreambox-tools.info

  • Oldboke
    Mit dem Netzwerkbrowser kann ich ihn nicht finden.
    Geht das denn damit?


    Tonskidutch
    In dem Howto steht immer no_root_squash.
    Mehr weiß ich nicht.


    wudelbrumpf
    Ja, in der auto.network stand die Zeile, die ich in dem Automount erstellt habe.
    Manuell kann ich erst heute abend nachschauen, wenn die Frau nicht zu hause ist und der Kleine im Bett ist.
    (Hoffentlich seid ihr dann online, um mir dann zu helfen.)
    Was ist ein NS?
    Dass mein Router die Dream nicht kennt, kann sein. Hab gerade was von den hosts gelesen. Ich glaub, da muss ich die Dream noch einbinden.


    @all
    Ich habe mir den Router heute mal mit zur Arbeit genommen.
    Mit exportfs zeigt er den Mountpunkt an


    /tmp/mnt (world)


    Jetzt hab ich mir Jftp heruntergeladen, da ein NFS-Client dabei ist.
    Siehe da, er sieht den Mountpunkt. Allerdings kann ich nicht weitergehen.
    /tmp/mnt ist ein Verzeichnis und die Unterordner kann er nicht sehen.
    Kann auch an Jftp liegen.
    Was mich allerdings beruhigt ist, dass der NFS-Server ja läuft....


    Alles weitere kann ich erst heute abend testen.


    Gruß wolder

  • Quote

    Original von Oldboke
    Den Netzwerkbrowser hast du auch schon getestet ?


    ... ein neuer und guter Ansatz!
    Ich gehe allerdings davon aus, dass der Netzwerkbrowser wohl nichts finden wird, weil auf dem gemoddeten Asus-Router nicht alles für NFS notwendige sauber läuft (der portmapper muss z.B. zwingend VOR dem starten von nfs aktiv sein).


    Tonskidutch
    ..die Windows-Workgroup spielt keine Rolle und ob der Anwender seiner Dream root-Rechte auf sein exportiertes Verzeichnis auf dem Server einräumt...bleibt ja nun ihm überlassen ;). Ich tue das z.B. auch....ob nun root_squashing oder nicht - mit dem scheitern des mounts hat das nichts zu tun.


    wudelbrumpf


    ich empfinde Deinen einleitenden Satz

    Quote

    hier ging es ja furchtbar durcheinander

    schon als ziemlich überheblich, zumal Du im Folgenden nicht das Geringste zur Problemlösung beiträgst, weil....
    1. dass die Workgroup keine Rolle spielt bereits geklärt war
    2. die showmount-Ausgabe eben keine Garantie für eine korrekte und ansprechbare exports ist
    3. die Einträge im automount-Editor richtig sind, wenn die exports so stimmt wie im ersten Beitrag gepostet
    3. der automounter mit an Sicherheit grenzender Wahrscheinlichkeit korrekt läuft, da - ebenfalls aus dem ersten Post erkennbar - /media/net/asus angelegt ist
    4. der manuelle Mount erst Sinn macht, wenn klar ist, dass auf dem Server alles korrekt läuft (Stichworte: ps und exportfs -v) und dieser deshalb als Problem ausscheidet. Bisher deutet jedoch alles auf den ASUS hin....und das hat wolder in seinem letzten Posting ja bereits selbst auch so gesehen.
    5. das hier

    Quote

    mkdir /media/mnt
    mount -t nfs -orw,soft,udp,nolock IP:/tmp/mnt /media/mnt


    Geht das?

    natürlich nicht gehen wird, da bereits die gepostete Syntax falsch ist (zwischen -o und dem Beginn der Optionen hat ein Leerzeichen zu stehen. Der Fragesteller selbst hat darauf hingewiesen, dass er sich "mit Linux nicht wirklich gut auskennt" ... ;)


    .....so, nun habe ich meinen Kropf geleert und überlasse euch die weitere Gestaltung....um nicht weiter zum Durcheinander beizutragen.


    Cu


    *edit: da noch ein Posting dazwischen gekommen ist (man sollte nicht telefonieren während man postings schreibt) mag manches relativiert/bestätigt sein.


    *edit2: ich hatte vor ein paar Jahren mal mit der WL-HDD rumgespielt. Da war die Datenpartition nach /tmp/harddisk gemountet. Ich habe gerade im 500g-Forum mal nachgeschaut, ob sich da was geändert hat, weil hier ja von /tmp/mnt/ geredet wird.
    Ergebnis:/dev/discs/disc0/part1 wird standardmäßig nach /tmp/mnt/disc0_1 gemountet; symlink auf /tmp/harddisk. Wenn wie vorgesehen auch Swap-Partition und zwei daten-Partitionen angelegt werden, liegt die Datenpartition auf /tmp/mnt/disc0_3. Unklar ist nach der Beschreibung, ob /tmp/harddisk oder /tmp/mnt/disc_03 angesprochen/exportiert werden muss.
    Dies nur als Ansatz für die weitere Fehlersuche - ggf. auch die fstab kontrollieren!

    Edited 2 times, last by NASfan ().

  • Jep Nasfan
    In /tmp/mnt sind auch noch disc0_3 und disc_1_1 drin.
    Da ich auf beide zugreifen wollte, hab ich nur das Verzeichnis /tmp/mnt angegeben, um dann auf beide discs zuzugreifen.
    Oder muss man explizit das letzte Verzeichnis mounten?
    Kann die Dream dann nicht auf die Unterverzeichnisse zugreifen?


    Gruß wolder