Font Magnifier (V0.6.1) - Schriftgrößen per FB ändern (DM 800/800SE/8000)

  • Update Version 0.0.3:

    • Kanalliste: Schriftgröße Sendungsinformationen (von 10..40 Pixel)
    • Kanalliste: Schriftgröße der Liste (von 10..40 Pixel)


    update version 0.0.3:

    • channel list: font size for current television program (from 10..40 pixels)
    • channel list: font size for list entries (from 10..40 pixels)


    Als nächstes kommen Untertitel (0.0.4). Dann lerne ich wie man ipk's baut und danach schauen wir mal weiter :)


    Quote

    Original von Nobby1704
    Geht es auch bei der 7025?


    Das kann ich Dir nicht beantworten. Du kannst es ja probieren, die skin.xml und EpgList.py werden vorher als *.bak gesichert. Aber ich garantiere für nichts...

  • :top: Und so sieht die angepasste kanalliste mit fontgrösse 21/24 jetzt aus:

    Files

    [SIZE=7]Selfsat H50M4
    Ultimo4K /2xTwinS2, VTI, PLi, ATV...
    NAS: Qnap221[/SIZE]

    Edited once, last by pasurimi ().

  • Quote

    Original von mohamedyh
    Version 0.0.3 Does not work with DM8000, GP4.5, and Vali-KingSize Skin 4.0


    Thanks for the crashlog. I will try to analyze this problem. Where can I get Vali-KingSize Skin 4.0 - I only found 4.2 (which needs experimental tree).
    Edit: I found 4.0. I will test it in the evening.

  • Quote

    Original von artman_hacker
    where is the ipk file ? :rolleyes:


    The version will be released as an ipk-file. Be patient please.

  • Quote

    Original von BigReaper
    mfgeg:
    Ich schau mal nach. Wenns geht bau ichs ein.
    Edit: Mit der Größe sollte gehen. Farbe versprech ich erstmal nicht. Aber im Moment muss ich etwas pausieren... Dreambox ist (leider) nicht alles ;)


    Die Farbe für Subtitle ist auch im Skin. Könnte man also auch anpassen:
    [php] <!-- Subtitle effects -->
    <subtitles>
    <sub name="Subtitle_TTX" font="Regular;30" shadowColor="#40101010" shadowOffset="3,3" />
    <sub name="Subtitle_Regular" font="Regular;30" foregroundColor="#DCDCDC" shadowColor="#40101010" shadowOffset="3,3" />
    <sub name="Subtitle_Bold" font="Replacement;30" foregroundColor="#DCDCDC" shadowColor="#40101010" shadowOffset="3,3" />
    <sub name="Subtitle_Italic" font="Regular;30" foregroundColor="#DCAAAA" shadowColor="#40101010" shadowOffset="3,3" />
    <!-- omitting foregroundColor attribute will enable auto-assignment of color -->[/php]

  • Update Version 0.0.4:

    • Untertitel: Schriftgröße jeweils für Teletext, Normal, Fettschrift und Kursiv (von 20..80 Pixel) (seit Version 0.0.4)


    Jetzt auch als ipk-Datei :)


    update version 0.0.4:

    • subtitles: font size for each of teletext, regular, bold and italic (from 20..80 pixels) (since version 0.0.4)


    Now as an ipk-file :)

  • Ist die 04 jetzt für Untertitel oder Teletext oder was bedeutet Untertitel?
    Danke für das Plugin. Super gemacht

  • Quote

    Original von rallebum
    Ist die 04 jetzt für Untertitel oder Teletext oder was bedeutet Untertitel?
    Danke für das Plugin. Super gemacht


    Ich habe im Skin Schriftgrößen für vier verschiedene Arten von Untertitel gefunden. Ich vermute das je nach Sender eine andere Quelle für die Untertitel genommen wird. Da ich es aber nicht besser wusste, habe ich einfache alle 4 Schriften eingebaut. Bitte fleissig testen. Jetzt ist erstmal Pause, außer es gibt noch dicke Fehler. Vali King Size HD muss warten (ich glaube der Skin weicht stark von anderen Skins ab).

  • danke für das überaus sinnvolle Plugin. Für mich als Sehbehinderten ein absolutes Muss. Fehlt eigentlich nur noch die Filmliste mit Beschreibung-

    -DM 8000 HD PVR
    -1TB WD1002FBYS
    -Pio 506XDE
    -Pio VSX-LX70
    -Logiitech Harmony 900

  • Quote

    Original von Oberspacken
    danke für das überaus sinnvolle Plugin. Für mich als Sehbehinderten ein absolutes Muss. Fehlt eigentlich nur noch die Filmliste mit Beschreibung-


    Das freut mich sehr :) Filmliste ist auf jeden Fall notiert. Ich weiß aber nicht wie sich das mit den anderen Video-Plugins verhalten wird... Ich schau mir das mal an, aber jetzt ist erstmal Weihnachtspause. Das Plugin ist für mich als Anfänger im Plugin schreiben schon sehr groß geworden. Ich muss mich erholen ;)

  • Quote

    Original von BigReaper
    Das freut mich sehr :) Filmliste ist auf jeden Fall notiert. Ich weiß aber nicht wie sich das mit den anderen Video-Plugins verhalten wird...


    Andere VideoPlugins wie z.b. [v0.94] Enhanced MovieList with VLC stream support (10 available languages) werden von der Änderung einfach nicht betroffen, da dies andere Skin-Elemente verwendet wie die Original MovieListe aus dem CVS.


    Quote

    Original von BigReaper
    aber jetzt ist erstmal Weihnachtspause.Das Plugin ist für mich als Anfänger im Plugin schreiben schon sehr groß geworden. Ich muss mich erholen ;)


    Weihnachtspause hast du dir verdient geniesse die besinnliche Zeit !!
    Und als Anfänger machst du das ja ganz gut....ich habe leider immer noch keinen Durchblick bei Python. ;)

  • Für mich eines der besten Plugins die es gibt ;)


    Mache mal deine verdiente Pause,


    wünsche dir und allen anderen Usern eine besinliche und
    angenehme Weihnachtszeit.



    Gruss
    Helmut 15

    Dreabox One Ultra HD 2x DVB S2X

  • hallo,


    Ich habe die V0.0.4 drauf, habe aber die FUNKTION Kanalliste: Schriftgröße der Liste nicht.
    Kann mir bitte jemand sagen warum meine Channellist so aussieht und wie ich wieder eine normale Liste bekomme?

  • Quote

    Original von til-ki
    hallo,


    Ich habe die V0.0.4 drauf, habe aber die FUNKTION Kanalliste: Schriftgröße der Liste nicht.
    Kann mir bitte jemand sagen warum meine Channellist so aussieht und wie ich wieder eine normale Liste bekomme?


    Quote

    Original von lolik
    das gleiche ist bei mir auch bei deinstallation, musste noch mal flashen



    bin nr1 nach ca 5 jahren, lol
    gruß


    Hallo ihr beiden,
    Das Plugin ist eigentlich sehr "defensiv". Das heisst wenn es etwas nicht findet in der Dreambox, zeigt es den Punkt auch nicht an. Das es Dir jetzt die Kanalliste zerlegt hat ist "schade".
    Du musst nicht neu flashen.
    Das Plugin legt aber bevor es etwas ändert Sicherheitkopien der Originaldateien an. In Deinem Fall sollte es /usr/lib/enigma2/python/Components/EpgList.py.bak sein.
    Du kannst
    /usr/lib/enigma2/python/Components/EpgList.py löschen und
    /usr/lib/enigma2/python/Components/EpgList.py.bak umbenennen in /usr/lib/enigma2/python/Components/EpgList.py. Danach Enigma neustarten.
    Noch eine Sache: Welches Image verwendet ihr? Könntet ihr mir /usr/lib/enigma2/python/Components/EpgList.py und /usr/lib/enigma2/python/Components/EpgList.py.bak posten? Ich versuche es bei der nächsten Version besser abzufangen.

  • Hallo BigReaper,
    Leider zu spät, musste ich auch neu Flashen :(
    Tritt der selbe Fehler wieder auf, wenn ich das plugin erneut installiere?
    Habe GP 4.6 drauf.



    lolik,
    Du bist in den 5 jahren aber sehr aktiv gewesen :tongue:

  • BigReaper


    Ich hätte da einen kleinen Vorschlag.
    Damit man die *.bak Dateien nicht selbst umbenennen muss, wenn den doch nochmal so was schief läuft, könnte man:


    - Im Plugin eine Funktion einbauen die alle, (oder auch einzelne) *.bak Dateien zurückschreibt.


    ODER


    - im IPKG beim Control "postrm" Script die *.bak Dateien wiederherstellen.


    (e.v. nicht nur ein ".bak" hinten anstellen, sondern z.b. ".FMbak" (FM für Font Magnifier) weil ".bak" macht ja schon jeder der mal ein File patcht....und da könnte es schon mal Probleme mit anderen Patch's geben.)