rtorrent 0.8.6 (Stable Release) + rutorrent WebUI 2.8

  • have fun and credits go to dillinger ! (this one has a very nice "utorrent" style webinterface)

    see also:
    //edit@ibrahim: no links to websites with illegal contents please

  • Hi,
    i'm having this issue on 0.8.6 that i wasn't getting on 0.8.5:

    root@dm800:/# /etc/init.d/rtorrentd start
    /etc/init.d/rtorrentd: line 50: su: not found
    /etc/init.d/rtorrentd: line 56: su: not found
    cannot find readable config /.rtorrent.rc. check that it is there and permissions are appropriate

    can someone help?


  • hi thank u for share
    and do u have a new version ? such a long time passed ,if u have ,pls give me a url ok ,thank u angain

  • Hi,
    can someone compile a new version of

    libtorrent, rtorrent, rtorrent-webui

    for the DM800


  • Quote

    Originally posted by stepan_kv
    rtorrent 0.8.9 (Stable Release) + rutorrent WebUI 3.3 (OE 1.6)

    Web url changed to http://ip_dreambox:8081/rutorrent/

    Thanx to dillinger (linux-sat.tv)

    Thanks for your answer/help. Installed and working.

    Can't start rutorrent,

    "Your web server does not support PHP. Correct this and try again."

    Can i get some further help? As FAIK lighttpd is configured OK for PHP.


  • Hi there,
    I'm still having a problem on ruTorrent UI

    Bad response from server: (500 [error,getplugins]) <?xml version="1.0" encoding="iso-8859-1"?> <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en"> <head> <title>500 - Internal Server Error</title> </head> <body> <h1>500 - Internal Server Error</h1> </body> </html>

    I have tried a lot of configurations with:

    On /www/logs/lighttpd.error.log i can read:

    2012-01-09 23:22:10: (mod_fastcgi.c.3703) handling it in mod_fastcgi
    2012-01-09 23:22:18: (mod_fastcgi.c.2568) unexpected end-of-file (perhaps the fastcgi process died): pid: 784 socket: unix:/tmp/php-fastcgi.socket-3
    2012-01-09 23:22:18: (mod_fastcgi.c.3356) response not received, request sent: 1131 on socket: unix:/tmp/php-fastcgi.socket-3 for /rutorrent/php/getplugins.php?, closing connection

    That is the only error i can find.

    Can someone help on this issue?


  • Seit einiger zeit, nach irgendeinem Update, funktioniert transmission nur noch etwa 5 min. Danach brechen die Downloads ab, bzw es lädt nichts mehr. Rtorrent ist leider auch nicht wirklich eine gute Alternative.

    Ich frage mich allerdings ob ich etwas verpasst habe, denn die torrent Themen sind stets rar gesät, und aktuelle Diskussionen gibt es dazu auch kaum.

  • Unfortunately, I can not run "screen" as daemon for the new "rtorrent". I get the following error message:

    screen: error while loading shared libraries: libncurses.so.5: can not open shared object file: No such file or directory

    I have tried both "screen" from the packages here. Always with the same error message. I have also installed ncurses.

    Maybe someone can help me?
    Thank you in advance.