KiddyTimer V1.3

  • Hallo zusammen!


    Habe schon lange nach so was gesucht, und mich wahnsinnig darüber gefreut.


    Beim starten des Plugins kommt folgender Fehler.
    "Cannot import name MultiPixmap"


    Meine Konfiguration:
    Dreambox 7025
    Gemini Projekt 2: Release: 3.0.0


    Danke

  • dein anliegen ist jetzt aber nicht wirklich ernst gemeint, oder?


    das gemini 3.0 ist über 2 jahre alt. mach dir keine gedanken, da dort neue plugins noch drauf laufen.
    mach dir erst mal ne aktuelle software auf die box und dann frage nach support.

    mfg


    OoZooN


    .................................................................


    :403: Two Beer or not two Beer, that's the Question :408:


    aktuelle Nachrichten rund um OoZooN-Images gibt es auf Twitter

  • Ja ihr wisst doch eh


    "Never change a running system" *G*


    Hab jetzt auf die letze Version geupdated und siehe da es läuft.


    Danke für den Hinweis.


    PS: ein Hinweis zur Kompatibilität wäre schon hilfreich gewesen.


    Trotzdem Danke, danke, Danke, danke


    Lg Marco

  • entschuldige, aber Dein Image ist wesentlich älter, als das Plugin (das ist erst wenige Monate alt). Und ich denke, dass niemand verlangen kann, dass ich für ein Plugin, das unter Gemini 4.3 entwickelt wurde, prüfe, wie weit das in die Vergangenheit rückwärtskompatibel ist...


    Ich habe einen entsprechenden Hinweis in den ersten Post reineditiert...


    Tode

  • Hmm... Du meinst: Wenn der Timer abgelaufen ist, und man dann den Stecker zieht, dann kann man danach wieder weiterkucken ? Das könnte sein, weil da die Shutdown- Routinge nicht aufgerufen wird...


    Aber ich bin sowieso grade dran, das ein wenig zu überarbeiten. Da werde ich das mal prüfen... und einfach den Zwischenstand regelmässig wegspeichern lassen, und nicht nur beim Shutdown.... Evtl. kann ich dann auch einen "Steckerziehschutz" einbauen: Wird die Box nicht sauber runtergefahren, dann wird beim nächsten Hochfahren so lange das Fernsehen gesperrt, bis man die Pin eingibt... Quasi als Strafe für den "Cheat- Versuch". Muss mal schauen wie aufwändig das ganze ist.


    Gruss
    Tode

  • neue Version 0.6 im ersten Post mit neuen Funktionen... Ausserdem dürfte das umgehen per ausschalten eigentlich nicht mehr gehen...


    Gruss
    Tode

    Edited once, last by Tode ().

  • Hallo Tode,


    erstmal ein gesundes neues Jahr und alles Gute für 2010.


    Weichnachten ist zwar vorbei, aber vielleicht darf ich mir ja trotzdem eine Ergänzung zu Deinem Plugin wünschen?


    Ich fände es toll, wenn ich über das Extension Menü das Plugin spontan für x Minuten ativieren könnten. Bei mir ist das Plugin nicht immer aktiv, aber wenn meine Kids z.B. "nur noch diese Sendung sehen wollen, bittteeee..." dann würde ich es gern für die Restlaufzeit der Sendung spontan aktivieren können. Derzeit muss ich immer in die Einstellungen, die erlaubte Zeit des aktuellen Tages anpassen und Plugin aktivieren. Schöner wäre ein Menüpunkt "Enable Kiddytimer for x minutes", mit der Möglichkeit, die Restlaufzeit dann einzugeben.


    Herzliche Grüße,
    ecky2

  • Ok... Halte ich für einen legitimen Wunsch...


    Mit der letzten Version sind das schon ein Paar schritte:


    1. Blau (oder lang blau um Gemini)
    2. Zahl auswählen, auf dem das Kiddytimer liegt
    3. Aktivieren
    4. Im gleichen Menu die Zeitspanne um x Minuten verlängern / verkürzen..



    Ist natürlich etwas umständlich... Ich schau mal, ob ich Deinen Wunch schnell umsetzen kann...


    Gruss
    Tode

  • Was lange währt.


    ecky2: Habe Dein gewünschtes Feature in die aktuelle 0.8 eingebaut.


    Viel Spass damit. Neue Version im ersten Post.


    Tode

  • hallo zusammen,
    ich finde das plugin auch super.
    leider habe ich das problem, dass ich die uhr nicht verschieben kann und bei version steht 0.6 drann.
    ich habe eine dreambox 800 mit gemini 470 drauf und habe mir KiddyTimer V0.8 vonb hier installiert.
    kann mir jemand sagen warum bei mir die version 0.6 dran steht und warum ich den smily nicht bewegen kann.


    herzlichen dank


  • Hallo Tode,


    vielen Dank, dass finde ich ja super!!!


    Leider funktionierts noch nicht richtig:
    Unter Gemini 4.5 die aktuelle Version aus dem ersten Post (V0.8 ) installiert. Im Einstellungsdialog wird Version 0.7 angezeigt. Beim Versuch die neue Funktion "Aktiviere für x Minuten" zu aktivieren, erhalte ich einen Crash. Crashlog ist anbei.


    Dann das ganze unter Gemini 4.7 installiert, wieder das gleiche Paket V 0. 8 verwendet. Unter Gemini 4.7 wird jedoch die Version 0.6 installiert. Zumindest wird dies im Einstellungsdialog des Plugins so angezeigt und die neue Funktion "Aktiviere für X Minuten" fehlt.


    Natürlich habe ich nach der Installaiton Gemini und auch die Box neu gestartet. Habe Update von 0.6 auf 0.8 versucht sowie vorheige Deinstallation der 0.6 - gleiches Ergebnis.


    Der Crash bei 4.5 beim verwenden der neuen Funktion kommt übrigens genau nach der Bestätigung der neuen Fernsehdauer.


    Ich hoffe das hilft. VG, ecky2

  • Hallo Tode,


    Ich bin auch ein Fan von Deinem Plugin, finde ich eine super Idee, habe aber ein Problem in Verbindung mit dem Elektro-Plugin von Morty.


    Ich lasse die DM um 11:45 vom Elektro starten und autom. in den Standby gehen, wenn mein Kleiner dann um ca. 13:30 die Box aus dem Standby holt ist jedoch immer die Stunde die ich ihm gönne schon abgelaufen.


    Könntest Du das eventuell überprüfen bzw. gib mir bitte Info falls Du genaueres benötigst.


    Danke im Voraus und


    Grüße
    chris

  • Vielleicht ist beim Erstellen des Paketes was schiefgegangen. Ich habe im ersten Post mal ein aktuelles Paket von Dreamboxupdate hochgeladen. Wäre schön, wenn Ihr es mal mit diesem probieren könntet, denn die Probleme kann ich bei mir nicht nachvollziehen. ggf. könnt Ihr auch das Plugin erst noch mal deinstallieren.


    Wenn In der Version im Setup- Screen noch 0.6 steht, dann ist definitiv mit dem Update zumindest eines Files was schiefgegangen...


    Wenn eine Neuinstallation mit dem neu angehangenen Paket auch nichts bringt, dann sagt Bescheid, dann schau ich mir das nochmal an, aus den Crashlogs werde ich momentan nicht so richtig schlau...


    Gruss
    Tode

  • chris: Da muss ich mal schauen... vermutlich arbeitet das Elektro an den Funktionen vorbei, die ich überwache, so dass mein Plugin nicht mitbekommt, dass die Box ja eigentlich im Standby ist.


    Ich kann Dir aber nicht sagen, wann ich dazu komme...


    Gruss
    Tode

  • Hallo Tode,


    Danke für die rasche Rückmeldung!
    Laß Dir ruhig Zeit damit, ist zwar für mich ein must have neben dem Elektro aber ich bin schon froh darüber dass sich jemand annimmt das in seiner freizeit zu entwickeln.


    OT on
    Ich hoffe Du kommst auch mit dem Jugendschutz-Plugin gut voran, dass fehlt mir sehr auf der 7025 ....
    OT off


    Grüße
    chris

  • neue Version 0.8a: Crash unter bestimmten Umständen ist gefixt, wenn Funktion "KiddyTimer für x Minuten aktivieren" gestartet wird, ohne dass Kiddytimer vorher aktiviert war.


    Danke fürs reporten


    Gruss
    Tode

  • Unter Gemini 4.7 lässt es sich aber noch immer nicht installieren. Das passiert, wenn ich es versuche und anschließend habe ich die Version 0.6 statt 0.8a drauf:

    Code
    root@dm7025:~# ipkg install /tmp/enigma2-plugin-extensions-kiddytimer_0.8a_all.ipk
    Installing enigma2-plugin-extensions-kiddytimer (2.7cvs20100210-r2) to root...
    Downloading http://download.blue-panel.com/gemini/7025/0470/feed/20100210_base/enigma2-plugin-extensions-kiddytimer_2.7cvs20100210-r2_mipsel.ipk
    Configuring enigma2-plugin-extensions-kiddytimer
    Collected errors:
    Multiple packages (enigma2-plugin-extensions-kiddytimer and enigma2-plugin-extensions-kiddytimer) providing same name marked HOLD or PREFER. Using latest.


    Wieso zieht er sich da eine Version 2.7 des Kiddytimers irgendwoher???


    PS:


    habe unter /var/lib/ipkg/ in der Datei base diesen Eintrag gefunden:


    Hat scheinbar was mit der Paketverwaltung zu tun. Irgendwas stimmt da wohl nicht..



    Ich habe den Eintrag rausgeschmissen und dann auch endlich die Version 0.8a installiert bekommen. Unter Gemini 4.7 bekomme ich aber einen Crash, wenn ich den Setup-Dialog des Plugins mit Abbrechen verlasse. Crashlog anbei.