Wir basteln ein Enigma2 für PC

  • !!! Nichts für Waischaiar !!! :D


      *dieses Enigma2 ist für Pluginprogrammierer und Skinbauern gedacht.
      *es hat noch keine Bild- und Tonausgabe.
      *v4l-Tunertreiber sind nutzbar
      *Senderscan funktioniert
      *Umschaltung der Skinauflösung funktioniert
      *es ist aktuell (20100609)


    Es geht los:
    Zuerstmal besorgt Ihr euch hier das neuste install.sh und benutzt es!
    Es sorgt dafür, das das meiste Zeug das Ihr braucht, auf dem PC installiert wird.
    Fehlerpostings, die darauf zurückzuführen sind, dass das Script nicht verwendet wurde, werden ignoriert. Ich hab einfach keine Lust und Zeit solche unnötigen Probleme zu lösen.
    Außerdem solltet Ihr unbedingt für eine der e2-Boxen (500hd,7025, 800 oder 8000) ein Image damit gemacht haben, bevor Ihr hier weiter macht, da einige der Bestandteile von dort gebraucht werden.
    :aufsmaul:Fragt also nicht wo Ihr das Zeug her bekommt, wenn Ihr diesen Rat ignoriert. Macht es einfach! :aufsmaul:


    Ok, wenn Ihr soweit seit, dann legt ein Arbeitsverzeichnis an kopiert die beiden Dateien aus dem Anhang dort hin und führt das Script aus.
    Das wird sicher noch nicht ohne Fehler durchlaufen, weil euch einige Sachen fehlen werden, die im verlaufe dieses Threads noch zu Script dazu kommen werden (ich weiß ja nicht was so auf einem normalen PC schon drauf ist). :D


    Mehr gibt's dann, wenn die ersten Fehlerberichte eintreffen :D


    So und da ist der erste Fehlerbericht.


    Code
    checking for FRIBIDI... configure: error: Package requirements (fribidi) were not met:
    No package 'fribidi' found


    Generell wenn irgend was fehlendes angemeckert wir erst mal:
    aptitude search blablabla


    also im Fall von fridibi

    Code
    aptitude search fridibi


    da kommt dann sowas:

    Code
    p centericq-fribidi - transitional package for centerim-fribidi
    p centerim-fribidi - A text-mode multi-protocol instant messeng
    i libfribidi-dev - Development files for FreeBidi library
    i libfribidi0 - Free Implementation of the Unicode BiDi al
    p motor-fribidi - C/C++/Java Integrated Development Environm
    p python-pyfribidi - FriBidi Python bindings
    v python2.4-pyfribidi -
    v python2.5-pyfribidi -


    Wir benötigen immer die dev-Version. Also installieren wir das pagage libfribidi-dev:

    Code
    sudo apt-get install libfribidi-dev






    Bedient über PC-Tastatur:
    Kurz und lang drücken funktioniert natürlich auch.



    20090721
    F1/F2-Bug beseitigt
    PS3-HDD Patch von Homey[GER]


    20090912
    An aktuelle Änderungen im enigma2 angepasst
    Diff Datei in zwei Dateien geteilt, eine für SourcePatches und eine für Binarys, um Patches für euch zu erleichtern.


    20091010
    An aktuelle Änderungen im enigma2 angepasst


    20100605
    An aktuelle Änderungen im enigma2 angepasst


    20100609
    An aktuelle Änderungen im enigma2 angepasst




    Danksagung:
    Ich betanke ( :D )mich bei:
    ismail.demir
    Homey[GER]
    tonno



    Quellen:
    [1]Enigma2 auf dem PC
    http://www.dream-multimedia-tv…?page=Thread&threadID=112
    [2]SDL_ffmpeg
    http://www.dranger.com/ffmpeg/

    !! IMMER ALLE DREI DATEIEN DOWNLADEN !!

    Files

    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorials sind für den Einstieg sehr empfehlenswert


    Nur wer die Weisheit mit Löffeln gefressen hat, kann auch klugscheißen. :klugscheiss:
    Alte asiatische Weisheit (wahrscheinlich Plagiat): Ohne Fleiß kein Scheiß. (Ich übernehme keine Garantie für Fehlerfreiheit der Übersetzung)
    "Alle großen Männer sind bescheiden." Gotthold Ephraim Lessing
    "Ich bin nur einsvierundsechzig"adenin
    "Es reicht nicht, Sachen falsch zu verstehen. Man muss sie richtig falsch verstehen."adenin
    "Friends: You Have 0 Friends"facebook

  • Klingt lustisch :baby:


    Mal auf meine PS3 installieren, das wär ja was. Ne PS3 mit Enigma² :-)


    Wie schaut's denn da treibertechnisch? Würden Treiber zB von meinem USB Tuner funktionieren wenn der auf ner DM800 schon läuft? Muss ich wohl antesten ...


    Und für fernbedienung wäre vielleicht mein LIRC Projekt interessant um einen externen IR Sensor benutzen zu können, nutz ich ja auch schon mit meiner DM800. Dann könnte man auch easy nen Zapper benutzen ;)


    Quote

    Es hat noch keine Bild- und Tonausgabe.


    Was heisst noch? Besteht da Hoffnung oder wo hakt es. Wenn's nicht an Treiber- oder Hardware scheitern sollte, dann kann ich mich zB an ein paar Zeilen Code im Enigma² erinnern, wo die DEMUX Devices usw. ausgewählt werden für die TV Wiedergabe, da ist's hardcoded auf Dreamboxen mit so "IF (BOXTYPE == DM8000) then BLABLABLA" und für jede Box halt eine eigene Demux Routine ... das müsste man zB ändern für PC oder PS3 oder so.


    *edit*
    das hier mein ich:
    http://git.opendreambox.org/?p…841494a34196db8ba1dcf8104


    die dvb.cpp datei und die eDVBResourceManager::allocateDemux() funktion ... ansonsten klappt das nicht mit der TV Wiedergabe, das muss aufjedenfall angepasst werden.



    *edit*


    hmmm schade, weit bin ich nicht gekommen.



    python hab ich aber auf meiner Ubuntu PS3 installiert und images backen usw hab ich auch schon dort gemacht ... hmmm ...


    ich hab sowas:
    /usr/include/python2.4/
    /usr/include/python2.5/


    da sind aber nur 2-3 dateien drin (pyconfig.h/arrayobject.h/ufuncobject.h)

  • Quote

    Original von Homey[GER]
    Mal auf meine PS3 installieren, das wär ja was. Ne PS3 mit Enigma² :-)


    Wie schaut's denn da treibertechnisch? Würden Treiber zB von meinem USB Tuner funktionieren wenn der auf ner DM800 schon läuft? Muss ich wohl antesten ...


    Klick guck hier mal rein. wegen DVB-S2 Tuner an PS3 .


    klingt auf jedenfall sehr intressant wenn mal E2 auf PS3 laufen würde Tuner über USB oder von ner anderen Box.


    http://playstation3-homebrew-multimedia.blogspot.com/
    http://www.youtube.com/ps3multimedia
    http://code.google.com/p/ps3-ffdecsa/

  • es haben sich 1 Benutzer bedankt - oder so!

    Quote

    ACTA? -> ad acta!

  • Homey[GER]
    :amen: adenin Kapitel 1 Vers 6:

    Quote

    Fehlerpostings, die darauf zurückzuführen sind, dass das Script nicht verwendet wurde, werden ignoriert. Ich hab einfach keine Lust und Zeit solche unnötigen Probleme zu lösen.


    Bild und Ton ist ein nur Problem das aktuelle SDL_ffmpeg einzubauen, wenn ich mal Zeit hab. :D

    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorials sind für den Einstieg sehr empfehlenswert


    Nur wer die Weisheit mit Löffeln gefressen hat, kann auch klugscheißen. :klugscheiss:
    Alte asiatische Weisheit (wahrscheinlich Plagiat): Ohne Fleiß kein Scheiß. (Ich übernehme keine Garantie für Fehlerfreiheit der Übersetzung)
    "Alle großen Männer sind bescheiden." Gotthold Ephraim Lessing
    "Ich bin nur einsvierundsechzig"adenin
    "Es reicht nicht, Sachen falsch zu verstehen. Man muss sie richtig falsch verstehen."adenin
    "Friends: You Have 0 Friends"facebook

  • Ich hab das Script doch benutzt/installiert:(


    Hab doch hier alles drauf um Images zu backen usw. und es klappt auch mit Images backen ohne Fehler oder sonst was. Oder wie wär ich sonst dazu in der Lage Images zu backen, meine eigenen Treiber und plugins zu basteln !?


    Naja, dann halt nich :( Sorry fürs nerven

  • ok, ja nerv weiter.
    Versuch mal einen Link von /usr/include/python2.5 nach /usr/include/python .


    Was ist das für ein Linux?
    Da muss ja irgend ein Fehler sein, das der Path nicht da ist.

    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorials sind für den Einstieg sehr empfehlenswert


    Nur wer die Weisheit mit Löffeln gefressen hat, kann auch klugscheißen. :klugscheiss:
    Alte asiatische Weisheit (wahrscheinlich Plagiat): Ohne Fleiß kein Scheiß. (Ich übernehme keine Garantie für Fehlerfreiheit der Übersetzung)
    "Alle großen Männer sind bescheiden." Gotthold Ephraim Lessing
    "Ich bin nur einsvierundsechzig"adenin
    "Es reicht nicht, Sachen falsch zu verstehen. Man muss sie richtig falsch verstehen."adenin
    "Friends: You Have 0 Friends"facebook

  • nene, macht ihr erst mal ich schau später irgendwann nochmal vorbei. Kann schon verstehen das ihr bessere Dinge im Kopf habt als solche N00b Probleme ;)


    PS: Auch nen Link bringt leider nix, selbe error. Ubuntu 7.10 für die PS3 ist es. Hab ich von hier: http://cdimages.ubuntu.com/ports/releases/gutsy/release/. Ich check das aber selber dann nochmal die Tage was da los ist und warum ich da kein python ordner habe. Hab nur gesehen das Python halt schon installiert ist in meinem Paket Manager ... aber wohl nicht da wo es hin soll. On /python2.5/ hab ich ja auch nur eine datei drin (pyconfig.h), bezweifle das das alles ist was ich brauch ...


    *edit*


    google is mein freund und nie böse über n00b fragen :D


    Code
    The path is for python header files (files ending in .h). The desklet you are building apparently wants these files. They are contained in the package [B]python2.5-dev[/B], which is not installed by default. You would need to install it with Synaptic (or Adept if you are using Kubuntu/KDE).
    [...]
    Unfortunately, it does not install the directory as /usr/include/python, but as /usr/include/python2.5 [...]you could make a link in /usr/include to satisfy the requirement


    Hab nur python2.5 drauf, aber nicht python2.5-dev ;)


    *snüff*

    Code
    sudo apt-get install python2.5-dev
    Failed to fetch http://ports.ubuntu.com/ubuntu-ports/pool/main/p/python2.5/python2.5-dev_2.5.1-5ubuntu5_powerpc.deb 404 Not Found


    *edit*
    oh mann, das kann dauern. Macht ihr mal ohne mich weiter. Mein Gutsy gibts gar nicht mehr und wird nicht mehr supported und all die Feeds sind auch weg. Muss wohl erstmal Ubuntu Gutsy(7.10) auf Ubuntu Hardy(8.04) oder Ubuntu 9.04 (Jaunty) updaten damit ich wieder was damit machen kann. Das kann aber wochen dauern also klink ich mich erstmal aus hier. Sorry fürs rumnerven :( war aber kurz davor es hinzubekommen, nur am python scheiterte es :) aber python kann ich so nicht updaten, keine feeds und manuell geht auch nicht weil da noch 500 andere dinge für geupdated werdenmüssen (depencies) und ohne Feeds ist das schlecht ...

  • bei mir wird mit folgende fehlermeldung abgebrochen.


    zusätzlich habe ich noch den libfreetype6-dev und fribidi installiert.


    nun weiß ich nicht wie ich den fribidi umbiegen soll. :rolleyes:




    [php]ismail@LINUX:~/e2-pc$ fribidi --version
    fribidi 0.10.9
    interface version FRIBIDI_INTERFACE_VERSION
    Unicode version 5.0.0


    Copyright (C) 2001,2002,2005 Behdad Esfahbod <fribidi@behdad.org>.
    Copyright (C) 1999,2000 Dov Grobgeld
    fribidi comes with NO WARRANTY, to the extent permitted by law.
    You may redistribute copies of fribidi under the terms of
    the GNU Lesser General Public License.
    For more information about these matters, see the files named COPYING.


    Configured with following options:
    ismail@LINUX:~/e2-pc$ ./make_enigma2_pc.sh
    checking for pkg-config... /usr/bin/pkg-config
    checking pkg-config is at least version 0.9.0... yes
    checking for FREETYPE... yes
    checking for FRIBIDI... configure: error: Package requirements (fribidi) were not met:


    No package 'fribidi' found


    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.


    Alternatively, you may set the environment variables FRIBIDI_CFLAGS
    and FRIBIDI_LIBS to avoid the need to call pkg-config.
    See the pkg-config man page for more details.


    >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>\n
    <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<\n
    make: *** Keine Regel, um »clean« zu erstellen. Schluss.
    make: *** Keine Targets angegeben und keine »make«-Steuerdatei gefunden. Schluss.
    \n\n
    Fertig!
    zum installieren: sudo make install
    zum starten: sudo enigma2
    ismail@LINUX:~/e2-pc$[/php]

  • Warum hat denn der bei dir den pfad richtig erkannt:

    Quote

    checking for Python include path... /usr/include/python2.6


    und bei mir nicht und nur "/usr/include/python/" :(


    Auch egal, ich installier grad Ubuntu 9.04 und dann geht das ganze nochmal von vorne los :)

  • das frag ich mich auch.


    vllt deswegen, weil du zwei schlangen hast ;)



    edit: ich hab aber den 2.6er version :)

  • ja ich war so frei eben und wollt mal einfach python deinstallieren und dann neueste version drauf tun. Eine Warnmeldung kam da zwar und er sagte mir das noch xxx hundert andere plugins deinstalliert werden und ob ich das wirklich will ... YES I WANT ...


    danach ging nix mehr und ich hab quasi mein komplettes linux gelöscht und alle programme die ich so hatte und benötigte. das einzigste was noch übrig war in meinem startmenu war COMMAND LINE Tool, alles andere war weg. war irgendwie alles abhängig von python :tongue:


    Jetzt machen wir's besser. Neues Linux rauf und dann neueste python usw.


    Dann klappt das auch mit meiner PS3, hoff ich ma :)

  • upps, die schlangen haben sich wohl nicht vertragen und haben sich selbst gefressen ;)


    always change a running system if doesnt work :D

  • Generell wenn irgend was fehlendes angemeckert wir erst mal:
    aptitude search blablabla


    also im Fall von fridibi
    aptitude search fridibi
    da kommt dann sowas:

    Code
    p centericq-fribidi - transitional package for centerim-fribidi
    p centerim-fribidi - A text-mode multi-protocol instant messeng
    i libfribidi-dev - Development files for FreeBidi library
    i libfribidi0 - Free Implementation of the Unicode BiDi al
    p motor-fribidi - C/C++/Java Integrated Development Environm
    p python-pyfribidi - FriBidi Python bindings
    v python2.4-pyfribidi -
    v python2.5-pyfribidi -


    Wir benötigen immer die dev-Version. Also:
    sudo apt-get install libfribidi-dev

    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorials sind für den Einstieg sehr empfehlenswert


    Nur wer die Weisheit mit Löffeln gefressen hat, kann auch klugscheißen. :klugscheiss:
    Alte asiatische Weisheit (wahrscheinlich Plagiat): Ohne Fleiß kein Scheiß. (Ich übernehme keine Garantie für Fehlerfreiheit der Übersetzung)
    "Alle großen Männer sind bescheiden." Gotthold Ephraim Lessing
    "Ich bin nur einsvierundsechzig"adenin
    "Es reicht nicht, Sachen falsch zu verstehen. Man muss sie richtig falsch verstehen."adenin
    "Friends: You Have 0 Friends"facebook

  • upps, da hab ich ja ganz was anderes installiert :(

  • Jupp, immer die *-dev versionen. Vielleicht mit ins erste Posting aufnehmen, erspart nervige n00b fragen von leuten wie mir :)


    Naja, mein neues Ubuntu is jetzt drauf :D


    also bin ich jetzt wieder bei schritt 1, dein erstes install.sh von developer OE installieren was ja schonmal geklappt hat ;)


    Nur hab ich jetzt schon wieder totales chaos hier *lol*


    Da offtopic, siehe hier

  • Homey[GER]
    Hmm, in der NEUSTEN install.sh wird aber die libfribidi-dev installiert. :aufsmaul:
    Hast Du die neuste verwendet, bei deinen ersten Versuchen?

    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorials sind für den Einstieg sehr empfehlenswert


    Nur wer die Weisheit mit Löffeln gefressen hat, kann auch klugscheißen. :klugscheiss:
    Alte asiatische Weisheit (wahrscheinlich Plagiat): Ohne Fleiß kein Scheiß. (Ich übernehme keine Garantie für Fehlerfreiheit der Übersetzung)
    "Alle großen Männer sind bescheiden." Gotthold Ephraim Lessing
    "Ich bin nur einsvierundsechzig"adenin
    "Es reicht nicht, Sachen falsch zu verstehen. Man muss sie richtig falsch verstehen."adenin
    "Friends: You Have 0 Friends"facebook

  • Soweit bin ich doch noch gar nicht (und war ich auch noch nie) :D


    Ich bin mal bis zu Python gekommen, da fehlte mir aber python-dev.


    Dann hab ich alles kaputt gemacht und bin jetzt im Moment noch hier:

    Quote

    Zuerstmal besorgt Ihr euch hier das neuste install.sh und benutzt es!


    Aber nacher oder morgen nutz ich dann die aktuelllste und berichte was mein fribididu macht :hurra:

  • Quote

    Original von Homey[GER]
    Aber nacher oder morgen nutz ich dann die aktuelllste und berichte was mein fribididu macht :hurra:


    Ich würde mich an seiner Stelle im abgelegensten Sektor der Festplatte verstecken.

    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorials sind für den Einstieg sehr empfehlenswert


    Nur wer die Weisheit mit Löffeln gefressen hat, kann auch klugscheißen. :klugscheiss:
    Alte asiatische Weisheit (wahrscheinlich Plagiat): Ohne Fleiß kein Scheiß. (Ich übernehme keine Garantie für Fehlerfreiheit der Übersetzung)
    "Alle großen Männer sind bescheiden." Gotthold Ephraim Lessing
    "Ich bin nur einsvierundsechzig"adenin
    "Es reicht nicht, Sachen falsch zu verstehen. Man muss sie richtig falsch verstehen."adenin
    "Friends: You Have 0 Friends"facebook