[solved] NFS / Aufnahme / dm800

  • Hi,
    am Ubuntu 8.04 Server habe ich NFS aktiviert.
    in exports steht bei mir
    /mnt/MM2 192.168.1.21(rw,async,no_subtree_check)
    Dann in automount.conf (DM800) habe ich
    MMUSRV -fstype=nfs,rw,soft,tcp,nolock,rsize=8192,wsize=8192 192.168.1.100:/mnt/MM2
    Damit kann ich MMUSRV schon im Dreambox erreichen und sogar gelagerte Filme abspielen. Den movie-Verzeichniss gibt es auch. Jedoch wenn ich was aufzunehmen versuche, dann passiert ueberhaupt nichsts. Bei Timer steht zwar "done" leider auf NFS-Freigabe nichts zu sehen. Gar keine Fehlermeldung.
    In Kernel Modules habe ich bei USB CD/DVD - Ja.


    Was mache ich falsch? Habe ich noch was vergessen/uebersehen?


    Fuer jede Hilfe bedanke ich mich im Voraus.


    Gruss.

  • Welche Berechtigungen hast du /mnt/MM2 gegeben lokal auf dem Ubuntu?
    Kannst vom der Dreambox eine Datei oder ein Verzeichnis via den automount anlegen?


    Und der Aufnahmepfad ist auch auf dein PC gelegt, für die Aufnahmen?

  • danke Mfgeg fuer schnelle Antwort.

    Quote

    Originally posted by mfgeg
    Welche Berechtigungen hast du /mnt/MM2 gegeben lokal auf dem Ubuntu?
    Kannst vom der Dreambox eine Datei oder ein Verzeichnis via den automount anlegen?


    um ganz sicher zu sein habe ich gerade nochmal
    sudo chmod a+rw /mnt/MM2 gemacht, leider keine Aenderung



    Quote


    Und der Aufnahmepfad ist auch auf dein PC gelegt, für die Aufnahmen?


    robert@MMU804SRV:~$ ls /mnt/MM2
    lost+found movie
    hast du das gemeint?
    Wenn ich ueber EPG aufnehmen dann bei Location steht bei mir autmount oder MMUSRV.

  • Den Pfad für Timeshift kannst du über Menü - Einstellungen - System - Timeshift Verzeichnis
    einstellen.


    Wenn du normale Aufnahmen meinst geht das mit 2 mal Video-Taste der FB drücken, den alten
    Bookmark auf /media/hdd löschen und einen neuen hinzufügen der auf deinen Automount
    zielt. Zum Springen ins obere Auswahlfenster drückt man die Bouquet Taste der FB. ;)

  • gerwazy


    Wie alt ist dein Image? Schon n'en älterer Image wenn du noch mit der automount.conf arbeitest. Ein neues wäre sicher nicht verkehrt.


    Aber hast du schon versucht eine TS Datei auf die Freigabe auf dem Rechnder zu schieben, nur so. Z.B. mit dem TuxboxCommander? Nur um wirklich sicher zu sein, dass du schreiben kannst.

  • Quote

    Originally posted by mfgeg
    gerwazy


    Wie alt ist dein Image? Schon n'en älterer Image wenn du noch mit der automount.conf arbeitest. Ein neues wäre sicher nicht verkehrt.


    Aber hast du schon versucht eine TS Datei auf die Freigabe auf dem Rechnder zu schieben, nur so. Z.B. mit dem TuxboxCommander? Nur um wirklich sicher zu sein, dass du schreiben kannst.


    da hast du leider in beiden Saetzen recht... Gemini 3.70. Am Wocheende werde ich es aktualisieren.
    Wenn ich mit Telnet was kopiere dann steht permission denien also doch Berechtigungen. Wenn ich mc starte und versuche was auf MMUSRV zu kopieren kriege ich folgende Fehlermeldung.
    Cannot chown target file. Operation not permitted.
    Danach wird kopiert aber als Owner steht danach (MMUSRV) nobody.


    Was konnte ich jetzt machen?

  • Wenn es an den Berechtigungen liegt, würde ich einmal die exports des Servers ändern.
    Vielleicht ist die Option all_squash noch etwas für den Server.

  • Quote

    Originally posted by mfgeg
    Wenn es an den Berechtigungen liegt, würde ich einmal die exports des Servers ändern.
    Vielleicht ist die Option all_squash noch etwas für den Server.


    Vielen, vielen dank ! ! !
    no_root_squash did the trick! :)