[gelöst] dma Probleme mit CF (Master) und DVD (Slave) über IDE

  • nabend,



    Meine Hardwarekonfiguration:
    7025+ mit einem Pioneer Slotin Brenner als Slave und einer CF Card am IDE als Master.
    Image im Flash: 4.2, inkl. BA Plugin (Problem tritt auch bei frischem 4.0 -4.2 und CVS Images ohne BA auf)


    Wenn ich - egal mit welchem Image gebootet - eine Audio CD einlege, hängt sich die Box total auf. Es wird leider kein crashlog geschrieben.


    Ich konnte es auf den Mount-Vorgang zurückführen: ich habe bei den udev scripten den DVD Brenner mal ausgeklammert und händisch den mount der AudioCD durchgeführt und identisches Verhalten festgestellt. DVD und ISO CDs laufen problemlos.


    Nachdem ich probehalber DMA für das slotin LW deaktiviert habe (hdparm -d0 <CDROM>), stürzte die Box beim Einlegen einer AudioCD nicht mehr ab und ich konnte die CD mounten... Es hängt also mit aktiviertem DMA zusammen: wenn DMA dann Absturz.


    Seltsamerweise ist die CF nicht auf DMA konfiguriert. Schalte ich dma ein, hängt sich meine 7025+ wieder komplett auf... identisch zum AudioCD Problem.


    Wo kann ich dma permanent einrichten ? in der bootup schalte ich es derzeit mit hdparm -d0 ... aus. Ist es da richtig aufgehoben ?


    ABER:
    Nun kann ich wohl AudioCDs hören - aber bekomme wohl Probleme beim DVD brennen... woran mag es liegen, dass es mit AudoCD nur im PIO Modus funktioniert ??



    Gruß, p


    (Master = CF übern IDE Adapter; Slave = DVD Brenner)


    Datenraten CF (SanDisk EXTREME III 2GB):
    Slave
    CF ohne Jumper als Slave und DVDRom am Master Port des Kabels
    DVDRom als Master
    20,65 MB/sec cached read
    12 MB/sec read



    Master
    CF mit Master Jumper am Master Port des IDE Kabels (am Ende)
    DVDRom als slave
    35,7 MB/sec cached read
    19,38 MB/sec read

  • Quote

    Original von p0wah
    Meine Hardwarekonfiguration:
    7025+ mit einem Pioneer Slotin Brenner als Slave und einer CF Card am IDE als Master.
    19,38 MB/sec read


    kannst du uns mal verraten, warum du den CF Slot nicht benutzt? Masochist? ;)

  • gerne :)


    1. hatte einen CFzuIDE Adapter rumliegen
    2. wollte den Slot nicht unbedingt belegen
    3. habe dem IDE Port mehr Transferraten zugeschrieben, da CF ja über USB 2.0 dran ist (oder? nugut... USB2 macht30MB/sec....) ...


    Das Problem stellt sich bei mir aber auch mit der Karte im CF Slot dar (ich hatte sie vorher da drin): ein nicht um DMA deaktiviertes Image schmiert nach dem Einlegen einer Audio CD ab...



    Wie sind denn die üblichen Transferraten über den CF Slot ?


    Gruß, P

  • Quote

    Original von p0wah
    3. habe dem IDE Port mehr Transferraten zugeschrieben, da CF ja über USB 2.0 dran ist (oder? nugut... USB2 macht30MB/sec....) ...


    wer sagt das? Ist auch egal weil falsch. Meine Transcend CF ist genauso schnell wie meine Festplatte, zwischen 13 - 17MB/s. Bus Speed ist bei beiden über 30MB/s.

  • mal ne frage nebenbei - wie hast du den brenner mit 2 sattuner installiert bekommen??? hast mal bilder?

  • Quote

    Originally posted by nillebor
    mal ne frage nebenbei - wie hast du den brenner mit 2 sattuner installiert bekommen??? hast mal bilder?


    naja... ich habe das DVD Kit zurecht geschnitten damit die Blende passt. Dummerweise fiel mir dann erst auf, dass die Tuner zu lang sind. Nun steht das Slotin DVD Rom 2cm raus. Es sollten irgendwann mal kürzere Tuner kommen - da kann man dann nochmal drüber nachdenken....


    In einen externen Brenner per USB würde ich jetzt eher investieren, da man so robustere DVDRoms mit vernünftiger Lade bekommt (als diese klapprigen SlimeLines).

  • Über den USB 1.1 wäre ein externes DVD zum brennen nicht gerade ideal, ausser du hast vieeeel Zeit.


    Ide rausführen ist da schon überlegendswerter.

  • stimmt...


    ich vergaß, dass der USB Port nur Version 1.1 ist.


    Aber mal die Frage an die Profis gerichtet:


    Wo schalte ich sinnvoll dma permanent fürs DVD-Laufwerk aus ?


    und noch viel wichtiger / interessanter:


    Warum führt DMA fürs DVD-LW zum Absturz beim Einlegen eine AUDIO CD (DVD und ISO CD geht ohne murren)?


    Warum führt DMA für die CF Card zum Absturz, wenn man es einschaltet ?

  • ja, wenn müssen alle devices DMA fähig sien, und das kannn nicht jede CF

  • nochmal fürs protokoll :) :


    Auch die Verwndung der CF im VORGESEHENEN Slot ergibt einen Absturz, wenn ich eine AudioCD in mein DVDRom einlege.


    Oder habe ich mit der CF im Slot den Vorteil DMA = ON ? DANN würde ich das wieder umbauen :)



    Dennoch weiterhin die Frage: wo DMA permanent ausschalten fürs DVDRom?

  • UDMA abschalten kannst du damit:
    hdparm -d1 -X34 /dev/xxx


    xxx musst du mit der entsprechenden Gerätedatei ersetzen. Damit aktivierst du nur den MultiwordDMA Modus. Klappt das auch nicht, kannst du:
    hdparm -d0 -X12 /dev/xxx
    versuchen. Dieser Einträge musst du in: /etc/init.d/bootup einfügen. Die CF solltest du wirklich nur im CF Slot betreiben, da du dort vielleicht den DMA wenigstens für die CF nutzen könntest.
    Hier noch ein wenig Info zu hdparm:
    http://www.linux-praxis.de/lpic2/lpi201/2.204.3.html

  • hi,


    danke für die seite - die ist sehr hilfreich.


    Ich habe nun einige Tests gemacht. Intern am IDE erhalte ich beste ergebnisse ohne DMA - aber leider auch eine seltsame Meldung 'hdparm: memory exhausted':


    CF IDE0, Master; CDROM IDE0, SLAVE:
    root@dm7025:~# hdparm -d0 -X34 /dev/discs/disc0/disc
    root@dm7025:~# hdparm -tT /dev/discs/disc0/disc
    /dev/discs/disc0/disc:
    Timing buffer-cache reads: 128 MB in 3.78 seconds = 33.86 MB/sec
    Timing buffered disk reads: 64 MB in 3.07 seconds = 20.84 MB/sec
    hdparm: memory exhausted


    (Mit der CF am IDE0 und mit DMA=on schmiert die Box immer ab)



    Deswegen liegt die CF Karte wieder im CF Slot und ich erhalte mit DMA folgenden Speed:


    CF IDE1, Master; CDROM IDE0, Master:
    root@dm7025:~# hdparm -d1 -X34 /dev/ide/host1/bus0/target0/lun0/disc


    /dev/discs/disc0/disc:
    setting using_dma to 1 (on)
    setting xfermode to 34 (multiword DMA mode2)
    using_dma = 1 (on)
    root@dm7025:~# hdparm -tT /dev/discs/disc0/disc


    /dev/discs/disc0/disc:
    Timing buffer-cache reads: 128 MB in 3.62 seconds = 35.40 MB/sec
    Timing buffered disk reads: 64 MB in 7.12 seconds = 8.99 MB/sec




    Geht man nach den Leseraten sollte m.E. der IDE Variante Vorzug gegeben werden. DMA sollte aber den Proz entlasten - und mit Euren zaghaften Empfehlungen ist somit diese Konfiguration erstmal mein Favorit.




    Ohne interne HDD mit meiner Konstellation habe ich jetzt folgende Änderung an der /etc/init.d/booutp gemachtn und das Einlegen von AudioCDs führt nun nicht mehr zum Absturz:


    # sleep after 10min
    #hdparm -S 120 /dev/discs/disc0/disc
    # accustic management
    #hdparm -M 128 /dev/discs/disc0/disc
    #echo 44 > /proc/progress


    #DMA
    hdparm -d1 -X34 /dev/ide/host1/bus0/target0/lun0/disc
    echo 32 > /proc/progress
    hdparm -d0 -X66 /dev/ide/host0/bus0/target0/lun0/cd
    echo 34 > /proc/progress