Enigma crasht/Loopt beim booten/ Scart-Problem

  • Hallo @all,


    ich habe ein Problem mit meiner DM8000+GP42+GPfix+SSL73, 2xDVB-C
    interne HD, CF mit Swap, Plugins: Autotimer, GoogleMaps, EPGRefresh, LEDcontrol, Elektro, Fritzcall


    Problem: Bei etwa jedem 3. Bootvorgang (variiert) Loopt die Box ziemlich am Ende des Ladebalkens.
    Das Display ist aus und schreibt mir dann die Festplatte mit Crashlogs voll bis ich die Box ausschalte.


    Habe ein Crashlog und ein Bootlog angehängt, um evtl ein Problem vor dem Enigma-Start zu erkennen.
    Ich sehe da leider nicht durch und bitte um Hilfe. Vielleicht findet ihr einen Ansatz.


    Danke und Grüße
    Jörg

  • hmm bin ja nicht der crashlog profi, aber lösch mal das elektro plugin zum test :rolleyes:

    dau bleibt dau, daran kann der beste dev nichts ändern<br><br>

  • Bei mir wars der Mailchecker - Provider machte Mist.
    Löschen der Mailconf.xml in /etc brachte Hilfe.
    Auch ich hatte nach jedem Boot-vorgang so 8 - 10 Logs auf der Platte.


    Bin auch gar kein Expterte in Punkto Crashlogs aber vielleicht ist wa wirklich etwas mit deinem Scart-Anschluss nicht in Ordnung (Kabel / Pin ...?)


    Code
    File "/usr/lib/enigma2/python/Screens/Scart.py", line 25, in showMessageBox
    self.msgBox = self.session.openWithCallback(self.MsgBoxClosed, MessageBox, _("If you see this, something is wrong with\nyour scart connection. Press OK to return."), MessageBox.TYPE_ERROR)
    File "/usr/lib/enigma2/python/mytest.py", line 278, in openWithCallback
    dlg = self.open(screen, *arguments, **kwargs)
    File "/usr/lib/enigma2/python/mytest.py", line 284, in open
    raise RuntimeError("modal open are allowed only from a screen which is modal!")



    Jacques

    | 920 ULTRA HD | 7080 HD| 8000 HD | 2 x 7020 HD V2 | 2 x 800 HD SE V2 | 525 S2 |
    |GP 4.1 & GP 3.2 & GP 3 @ DREAMOS & DMM-Experimental | on all Boxes
    | Hdd : | 2 x 4 TB || 1 TB | Qnap - 8 TB |... and some more space everywhere

    WaveFrontier T 90 : | Hotbird 13 ° | Astra 19,2° | Astra 23,5° | Astra/Eurobird 28,2°/28,5° |
    ........... and happy ;)


    Hier werden Sie geholfen : Gemini Project WIKI sowie Video Tutorials

    Edited once, last by Jake_Worf ().

  • Hallo,


    danke schon mal für die Antworten: MailCheck habe ich nicht aktiviert.
    Naja, das Elektro-Plugin soll ja gerade diesen Neustart machen, wenn die Box läuft passiert ja nichts. Werde das Plugin aber mal wegwerfen und paarmal neu Starten. Testen schadet nichts :-).


    Das mit dem SCART habe ich auch gesehen, aber was soll da das Problem sein. Der TV ist aus und ja ich nutze nur Scart, leider :-(.


    Gruß
    Jörg

  • Gib uns aber bitte Bescheid ! Und denk an die Sache mit de Scart-Anschluss.


    Auch in deiner Bootup sind diesbezüglich Einträge.


    Jacques

    | 920 ULTRA HD | 7080 HD| 8000 HD | 2 x 7020 HD V2 | 2 x 800 HD SE V2 | 525 S2 |
    |GP 4.1 & GP 3.2 & GP 3 @ DREAMOS & DMM-Experimental | on all Boxes
    | Hdd : | 2 x 4 TB || 1 TB | Qnap - 8 TB |... and some more space everywhere

    WaveFrontier T 90 : | Hotbird 13 ° | Astra 19,2° | Astra 23,5° | Astra/Eurobird 28,2°/28,5° |
    ........... and happy ;)


    Hier werden Sie geholfen : Gemini Project WIKI sowie Video Tutorials

  • Hi joergm6,


    du scheinst irgendwie ein Problem mit deiner Konfiguration zu haben.
    Enigma schmiert in der Scart.py ab. Da ich keine 8000 habe, kann
    ich dazu nicht viel sagen, außer, dass er über deinen Scart meckert :rolleyes:


    EXCEPTION IN PYTHON STARTUP CODE:
    ------------------------------------------------------------
    Traceback (most recent call last):
    File "/usr/lib/enigma2/python/mytest.py", line 558, in <module>
    runScreenTest()
    File "/usr/lib/enigma2/python/mytest.py", line 462, in runScreenTest
    session.scart = AutoScartControl(session)
    File "/usr/lib/enigma2/python/mytest.py", line 393, in __init__
    config.av.vcrswitch.addNotifier(self.recheckVCRSb)
    File "/usr/lib/enigma2/python/Components/config.py", line 129, in addNotifier
    notifier(self)
    File "/usr/lib/enigma2/python/mytest.py", line 397, in recheckVCRSb
    self.VCRSbChanged(self.current_vcr_sb)
    File "/usr/lib/enigma2/python/mytest.py", line 404, in VCRSbChanged
    self.scartDialog.showMessageBox()
    File "/usr/lib/enigma2/python/Screens/Scart.py", line 25, in showMessageBox
    self.msgBox = self.session.openWithCallback(self.MsgBoxClosed, MessageBox, _("If you see this, something is wrong with\nyour scart connection. Press OK to return."), MessageBox.TYPE_ERROR)
    File "/usr/lib/enigma2/python/mytest.py", line 278, in openWithCallback
    dlg = self.open(screen, *arguments, **kwargs)
    File "/usr/lib/enigma2/python/mytest.py", line 284, in open
    raise RuntimeError("modal open are allowed only from a screen which is modal!")
    RuntimeError: modal open are allowed only from a screen which is modal!
    ------------------------------------------------------------


    PS: Zu langsam, Jacques warst mal wieder schneller ;)

    Viele Grüße,
    Oliver
    _________________________________________________
    Glücklicher Besitzer einer DM 8000 HD

    Edited once, last by soliver ().

  • @ Oliver : Der Jacques hat ja auch heute keine Lust zum Arbeiten sondern treibt sich lieber im Forum rum oder wühlt im Internetz.

    | 920 ULTRA HD | 7080 HD| 8000 HD | 2 x 7020 HD V2 | 2 x 800 HD SE V2 | 525 S2 |
    |GP 4.1 & GP 3.2 & GP 3 @ DREAMOS & DMM-Experimental | on all Boxes
    | Hdd : | 2 x 4 TB || 1 TB | Qnap - 8 TB |... and some more space everywhere

    WaveFrontier T 90 : | Hotbird 13 ° | Astra 19,2° | Astra 23,5° | Astra/Eurobird 28,2°/28,5° |
    ........... and happy ;)


    Hier werden Sie geholfen : Gemini Project WIKI sowie Video Tutorials

    Edited once, last by Jake_Worf ().

  • Hallo Jacques, Oliver,


    so, nun bisschen probiert, ein Boot dauert ja immer...... [grauer Bart wachs]


    Am Elektro-Plugin liegt es nicht (rausgeschmissen).


    Ich würde sagen, es liegt irgendwie an der Scart Ansteuerrung. Aber was soll man da falsch machen? Habe zum Test auch mal auf die StandartAV Einstellung (Seitenverhältnis=Automatisch) gestellt, gleiche Fehler.


    Beim Enigmastart kommen ja irgendwann drehende Zahnräder, dort wird kurz der 4:3 Modus aktiviert, dann wieder zurück auf 16:9 und kurz darauf ist "feierabend".


    Ist das ein Enigma-bug oder doch Hardware? Bis zum Fehler wird aber alles schön am TV angezeigt und meisten gehts ja auch problemlos, also nicht generell defekt.


    Muss ich mich an Dream wenden, oder hat noch eine ne Idee?


    jetzt habe ich Hunger.... Grüße
    Jörg

  • da versucht der code wahrscheinlich einfach zu füh eine Message box auszugeben obwohl enigma2 noch nicht voll läuft um es auch zu tun


    kommentiere einfach die genannte zeile in der Scart.py aus und gut ist es.


    Eine something wrong message hilft dir eh nicht viel.


    Dann kannst du es immer noch bei DMM eintüten das es so nicht funktioniert wie sie sich das vorstellen, sondern man die messagebox mit einem Timer über board werfen müsste damit sie erst später ausgegeben wird.

    Edited 5 times, last by gutemine ().

  • Kopier mal die Datei im Anhang nach /usr/lib/enigma2/python/mytest.py

    Files

    • mytest.py

      (15.78 kB, downloaded 12 times, last: )

    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorials sind für den Einstieg sehr empfehlenswert


    Nur wer die Weisheit mit Löffeln gefressen hat, kann auch klugscheißen. :klugscheiss:
    Alte asiatische Weisheit (wahrscheinlich Plagiat): Ohne Fleiß kein Scheiß. (Ich übernehme keine Garantie für Fehlerfreiheit der Übersetzung)
    "Alle großen Männer sind bescheiden." Gotthold Ephraim Lessing
    "Ich bin nur einsvierundsechzig"adenin
    "Es reicht nicht, Sachen falsch zu verstehen. Man muss sie richtig falsch verstehen."adenin
    "Friends: You Have 0 Friends"facebook

  • Hallo


    GuteMine
    ob ich die richtigen Stellen in der scart.py zum auskommentieren finde???????
    Mit dem frühen Anzeigen einer Msg kann auch sein, denn beim FritzCall-Plugin nerven mich eigentlich seine Verbindungsmeldungen und die könnten etwa in dem Zeitraum kommen. Werde es mal nachher deaktivieren.
    Muss jetzt aber weg, melde mich dann heute Nachmittag nochmal.


    adenin
    Habe die mytest.py mal ausgetauscht und würde sagen es passiert jetzt öfters


    SET FORMAT: display[0], format=7
    bcm_video_analog_port_setup (fmt=7)
    SET FORMAT: display[1], format=7
    set current avs auto aspect to 16:9
    set sb to 3(1)
    set wss 7 on display 0
    set wss 7 on display 1
    EXCEPTION IN PYTHON STARTUP CODE:
    ------------------------------------------------------------
    Traceback (most recent call last):
    File "/usr/lib/enigma2/python/mytest.py", line 561, in <module>
    runScreenTest()
    File "/usr/lib/enigma2/python/mytest.py", line 465, in runScreenTest
    session.scart = AutoScartControl(session)
    File "/usr/lib/enigma2/python/mytest.py", line 393, in __init__
    config.av.vcrswitch.addNotifier(self.recheckVCRSb)
    File "/usr/lib/enigma2/python/Components/config.py", line 129, in addNotifier
    notifier(self)
    File "/usr/lib/enigma2/python/mytest.py", line 397, in recheckVCRSb
    self.VCRSbChanged(self.current_vcr_sb)
    File "/usr/lib/enigma2/python/mytest.py", line 407, in VCRSbChanged
    self.scartDialog.switchToTV()
    File "/usr/lib/enigma2/python/Screens/Scart.py", line 33, in switchToTV
    if self.msgBox:
    AttributeError: 'Scart' object has no attribute 'msgBox'
    ------------------------------------------------------------
    (exit code 5)
    [BP] start Camd=6098

  • die Zeilennummer sagt dir doch eh der crash dump, lesen musst du ihn schon :-)

    Edited once, last by gutemine ().

  • Hallo gutemine,


    ja gelesen habe habe ich das schon, wollte mal ne Runde doof tun :tongue:


    Aber so einfach ist das nicht, habe die(33) mal auskommentiert, dann geht noch weniger und die Box loop schon früher und das immer.
    Da dieses eine IF-Abfrage ist, hatte ich die 2 nachfolgenden auch auskommentiert aber auch nur noch Loops.
    Geht also nicht so.


    Hatte das FritzCall auch mal deaktiviert, es passiert dann auch. Vom Gefühl her würde ich aber sagen, es kommt seltener (nach 6-7 Neustarts), kann aber auch Zufall sein.


    Habe noch mal die mytest.py von adenin kopiert und teste noch mal.


    Gruß Jörg


    Edit: Ich beobachte noch ein bisschen und warte auf GP43 :-)
    Wenn noch Jemand eine Idee hat, darf er sich trotzdem melden.
    Vielen Dank aber schon mal für eure Hilfsversuche...

  • Zeile 25 ist doch das aufrufen der message box das den Anfang vom ende darstellt - und wenn das de einzige zeile in einem if ist (womit dann das auskommentieren nicht gut ist) schreib halt irgend ein dummy wie pass oder print sorry statt dessen eine zeile drüber damit das if nicht leer ist


    LG
    gutemine

    Edited 2 times, last by gutemine ().

  • Neuer Versuch.
    Kopier das bitte nochmal nach /usr/lib/python/Screens/Scart.py.


    Was hast Du an den Scart-Buchsen angeschlossen?
    Ich will das mal nachstellen. Die eigentliche Absturzursache ist wie die MessageBox zu diesem Zeitpunkt aufgerufen wird. Also ein Fehler im enigma2

    Files

    • Scart.py

      (1.08 kB, downloaded 11 times, last: )

    Hilfe gesucht ? schau mal ins Gemini Project WIKI, auch unsere Video Tutorials sind für den Einstieg sehr empfehlenswert


    Nur wer die Weisheit mit Löffeln gefressen hat, kann auch klugscheißen. :klugscheiss:
    Alte asiatische Weisheit (wahrscheinlich Plagiat): Ohne Fleiß kein Scheiß. (Ich übernehme keine Garantie für Fehlerfreiheit der Übersetzung)
    "Alle großen Männer sind bescheiden." Gotthold Ephraim Lessing
    "Ich bin nur einsvierundsechzig"adenin
    "Es reicht nicht, Sachen falsch zu verstehen. Man muss sie richtig falsch verstehen."adenin
    "Friends: You Have 0 Friends"facebook

  • Hallo adenin,


    ok, habe nun noch mal mit der scart.py probiert. Nach dem 4. Start war es wieder soweit, aber Enigma loopt nicht mehr, sondern schreibt, so wie es sein soll, im LCD-Display "Wenn sie diese Nachricht sehen, gibt es ein Problem mit dem Scart Anschluss" o.ä.
    Und das ist ja schon mal gut, so läuft die DB wenigstens :hurra:. Ich kann dann allerdings nichts auf dem TV sehen (bis dahin war die Anzeige am TV OK). Auch die Menüs im LCD-Display werden nicht angezeigt, da steht ja der obige Text. Somit habe ich keine Chance die DB zu bedienen. Ich habe dann mit WebIF nur Enigma neu gestartet, dann ging es wieder.


    Was wird denn da noch getestet, das der eben noch funktionierende Scartanschluss plötzlich wieder abgeschaltet wird???????


    Habe die DB nur mit einem Scartkabel an eine "Philips-Röhre" angeschlossen, mehr nicht. Vom Gefühl her macht dan Scart-Kabel einen guten Eindruck, ziehmich dick und goldene Kontakte, also kein 2€ Kabel (auch wenn es nur von HAMA ist :rolleyes:)


    Ich weis nicht ob es was nützt, hänge mal das mitgelaufene Log an und extra noch ein Log von dem nachfolgenden erfolgreichen EnigmaNeustart.


    Edit: Habe 15mal nur Enigma neu gestartet, dort passiert es nicht. Das Problem gibt es offensichtlich nur, wenn Enigma das erste Mal nach dem Systemstart startet. Ist hier das System noch nicht ganz fertig, während Enigma startet??????


    Gruß Jörg

  • Hallo adenin,


    wollte noch mal kurz berichten wie es jetzt ausschaut.
    Also seit der neuen scart.py ist das LOOPen nicht mehr aufgetreten, aber die Scart-Fehlermeldung im Display 3x.
    Hier hat aber immer ein Klick auf "OK" (Meldung bestätigen) gereicht um das TV-Bild wieder anzuzeigen.
    Werde mal als Nächstes (wenn Zeit ist :-) ) versuchen diese Meldung auszukommentieren und dann mal schauen.


    Edit: Kann man diese Scart-Fehler-Meldung mit einem "timeout" versehen? Wenn ja wie?


    Edit2 12.06.: Weiter berichten: Habe die Meldungszeile auskommentiert. Nun bin ich diese lästige Meldung los. Allerdings wird auf dem TV bei Auftreten des Scart-Problems nichts mehr angezeigt, da die Zwangspause für das Drücken auf "OK" fehlt. Also relativ sicher ein Timingproblem. Einmal in den "Standby" und zurück, das Bild ist wieder da. Und da ich die Box in den Standbymodus boote merke ich von dem Scartproblem jetzt eigentlich nichts mehr.
    Bei einem kurzen Test mit Skin-Wechseln (3x) war nach dem benötigten Enigma-Neustart IMMER das TV-Bild weg. Wie gesagt, bei einem normalen Enigma-Neustart gab es noch nie ein Scart-Problem.
    Das Problem ist kein Gemini Problem, habe mehrere andere auch CVS probiert, mit den gleichen Ergebnissen.


    Grüß Jörg