DM800 und DM8000 mounten

  • Hallo,


    ich nutze zwar kein Gemini-Image, sondern auf meiner 800er und der 8000er das neueste Newnigma, aber ich hoffe, ihr könnt mir trotzdem weiterhelfen, denn im Newnigma-Forum konnte es bislang keiner, obwohl sich die Jungs wirklich bemüht haben.


    Ausgangsposition ist folgende: Ich will die 800er und die 8000er gegenseitig mounten. Dafür habe ich auf beide den NFS Editor installiert und damit die Festplatten freigeben.


    Nach erfolglosen Versuchen mit dem Mountmanager und dem Netzwerkbrowser (dieser findet weder eine der Dreamboxen noch sonst ein anderes Gerät im Netzwerk), habe ich manuell die jeweilige auto.hotplug angelegt.


    Bei der DM800 steht in der auto.hotplug:
    hdd8000 -fstype=nfs,rw,soft,udp,nolock,rsize=4096,wsize=4096 192.168.0.130:/media/hdd/movie


    Und bei der DM8000 folgendes:
    hdd800 -fstype=nfs,rw,soft,udp,nolock,rsize=32768,wsize=16384 192.168.0.22:/media/hdd/movie


    Mein erster Erfolg: Mounten war in beide Richtungen erfolgreich und von der 800 kann ich problemlos die Aufnahmen der 8000er-HDD ansehen.


    Das Problem: Umgekehrt, von der 800er auf die 8000er, funktioniert es leider gar nicht. Hab versucht, die Werte für rsize und wsize zu ändern (wie man an den Werten bei der auto.hotplug der 8000er erkennen kann), aber das hat bisher auch nichts gebracht.


    Dann habe ich hier von einem Script namens netztest.sh gelesen, das ich daraufhin installiert habe, aber nicht aufrufen kann. Es kommt immer eine "netztest.sh not found"-Meldung.


    Ich bin am Ende mit meinem Latein. Was muss/kann ich tun, damit ich mir die Aufnahme auf der 800er-Festplatte auch auf der 8000er ansehen kann?




    Dreambox1


    Typ : DM8000
    DHCP: aus
    IP: 192.168.0.130
    SubnetMask : 255.255.255.0
    Nameserver : 192.168.0.1
    Gateway : 192.168.0.1



    Dreambox2


    Typ : DM800
    DHCP: aus
    IP: 192.168.0.22
    SubnetMask : 255.255.255.0
    Nameserver : 192.168.0.1
    Gateway : 192.168.0.1



    Router


    DHCP-Server : ja
    IP : 192.168.0.1
    SubnetMask : 255.255.255.0
    ISP : Unitymedia

  • Weiss nicht ob es etwas nützt, aber probieren schadet ja nicht =)


    Im Wiki gibt es einige Problemlösungen. Schau einmal


    Interessant könnte auch das Timeout des autofs zu erhöhen. Wie es da im Wiki steht auf der Clientbox. So wie ich dich verstanden habe klappt das mounten ja.


    Oder halt das einmal mit tcp statt mit udp den mount machen.


    Versuch es einmal =)

  • 1. Versuch: rsize und wsize auf 32768 gesetzt. GUI neu gestartet. Ergebnis: Die Aufnahme startet, aber beginnt sofort zu ruckeln.


    2. Versuch: Werte für rsize und wsize bei 32768 gelassen und zusätzlich Timeout in /etc/init.d/autofs auf 60 erhöht (hatte ich vorher schon auf 30 erhöht, aber damit lief's ja nicht). GUI neu gestartet. Ergebnis: Die Aufnahme lief gar nicht erst an.


    3. Versuch: Werte für rsize und wsize bei 32768 und Timeout bei 60 gelassen, aus udp tcp gemacht. GUI neu gestartet. Ergebnis: Die Aufnahme läuft an, ruckelt aber nach einigen Sekunden und ich musste die Box vom Netz nehmen, weil sie sich aufgehängt hatte.


    Ich werde jetzt noch ein wenig weiter mit den Werten tüfteln, denn wenigstens der dritte Versuch hat eine Verbesserung gebracht.


    Vielen Dank an mfgeg. Ich hab schon so viel ausprobiert, dass ich fast den Wald vor lauter Bäumen nicht mehr gesehen habe. So bin ich doch etwas systematischer an die Sache gegangen.


    Wer sonst noch Ideen hat, wie ich von der 8000er auf die HDD der 800er zugreifen kann, ohne dass die Aufnahme ruckeln, bitte nur her damit. Werde alles ausprobieren.

  • Ich denke, ich habe die Lösung gefunden:


    Ich habe irgendwann einmal im IHAD-Forum gelesen, dass man im Gemini die Variable RPCNFSDCOUNT in /usr/script/nfs_server_script.sh auf 1 setzen soll.


    Die Datei scheint es bei Newnigma nicht zu geben. Aber in etc/init.d gibt es die Datei nfsserver und in der hab ich den Wert für NFS_SERVERS von 8 auf 1 gesetzt.


    Nun laufen die Aufnahmen ohne Ruckeln. :hurra:


    Nochmal zusammenfassend alle Einstellungen:


    Eintrag auto.hotplug bei der DM8000:
    hdd800 -fstype=nfs,rw,soft,udp,nolock,rsize=32768,wsize=32768 192.168.0.22:/media/hdd/movie


    Timeout in /etc/init.d/autofs auf 60 gesetzt


    NFS_Servers=1 in etc/init.d/nfsserver



    Vielleicht erspar ich daruch anderen viel Grübelei. :tongue:

  • Bei mir funktioniert das auch nicht, keine Besserung!

  • Quote

    Original von Freakie
    Bei mir funktioniert das auch nicht, keine Besserung!


    Ich muss zu meiner Schande gestehen, dass die hier genannten Einstellungen bei mir auch nicht lange durchgehalten haben. Das Abspielen von Aufnahmen der DM800 auf der 8000er klappt bei mir immer noch nicht. :O


    Ich setze meine Hoffnungen in das neue Newnigma 2.5, mit dem ich immerhin bei der 800er über die NFS-Suche des Netzwerkbrowsers die 8000er gefunden habe. Das hat beim Newnigma 2.4 gar nicht geklappt.


    Hab das Image aber noch nicht auf der 8000er. Werde dann hier berichten, wie's bei mir weitergeht.

  • Hab auf beiden Boxen das Newnigma 2.5 laufen. Damit klappt das Abspielen von Aufnahmen mit beiden Boxen. :hurra:


    Kann also nur jedem, der eine 8000er auf eine 800er und umgekehrt mit Newnigma mounten will, die Version 2.5 zu nehmen. Dann klappt es auch über den Netzwerkbrowser und die NFS-Suche.

  • ich versuch schon ne ganze Zeit meine beiden 800er zu verbinden um auf die HDD der jeweils anderen Box zuzugreifen,habe Gemini 2.4 auf stick
    habe die vielen Treads gelesen und die Tips ausprobiert,funzt aber nicht richtig alles,
    Box"Wohnzimmer" kann auf Box"Arbeitszimmer" zugreifen und Filme abspielen,
    Box"Arbeitszimmer"kann auf Box"Wohnzimmer" zugreifen-bei Filmauswahl kommen Zahnräder und die Box lässt sich nicht mehr bedienen,Stecker ziehen!!


    NFS-Server läuft bei beiden--Arbeitszimmer kein Log!im Wohnzimmer ja!


    -fstype=nfs,rw,soft,tcp,nolock,rsize=32768,wsize=32768 IP-der-Box:/media/hda1 ....eingetragen,bei beiden


    udp funzt gar nicht,rsize/wsize verändert hilft auch nicht,timeout ist auf 60 gesetzt


    zu timeout in usr/script/nfs-server...ist Standart auf 120 bei mir gewesen,habe ich auf 60 geändert oder muss ich um 30-60 erhöhen??


    hat jemand nen Rat,ausser zu Newnigma,moechte schon beim Gemini bleiben,ich hoffe meine angaben sind so ausreichend


    Danke

    DM 800 S,iCVS,BA/Gemini,250GB 2,5"HDD
    DM 800 s,iCVS,BA/Gemini,320GB 2,5"HDD

  • Gemini 2.4 ist auch nicht mehr ganz aktuell, da wirst ud wenig Hilfe kriegen - oder war es ein Tippfehler :-)


    Und wen du vor -fstype keinen namen xxx hintust weis er nicht das er auf /autofs/xxx bzw. im 4.2 auf /media/net/xxx mounten soll

    Edited 2 times, last by gutemine ().

  • Hoppla,4.2 natürlich


    wohn bzw arbeit stehen vor -fstype


    Box"Wohnzimmer"
    arbeit -fstype=nfs,rw,soft,tcp,nolock,rsize=32768,wsize=32768 IP-der-Box:/media/hda1


    Box"Arbeitszimmer"
    wohn -fstype=nfs,rw,soft,tcp,nolock,rsize=32768,wsize=32768 IP-der-Box:/media/hda1


    komisch is nur von arbeit kann ich mit wohn die Filme abspielen ohne Probleme,umgekehrt hängt sich die Box auf


    Box"Wohnzimmer"gibt der NFS_Server auchn Log,andere Box nicht

    DM 800 S,iCVS,BA/Gemini,250GB 2,5"HDD
    DM 800 s,iCVS,BA/Gemini,320GB 2,5"HDD

    Edited once, last by BO4573 ().